00:00:19 <Sparks> #startmeeting Docs Project Meeting - Agenda: http://fedoraproject.org/wiki/Docs_Project_meetings
00:00:19 <zodbot> Meeting started Thu Dec 16 00:00:19 2010 UTC.  The chair is Sparks. Information about MeetBot at http://wiki.debian.org/MeetBot.
00:00:19 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
00:00:19 <Sparks> #meetingname Fedora Docs
00:00:19 <Sparks> #topic Roll Call
00:00:19 <zodbot> The meeting name has been set to 'fedora_docs'
00:00:39 * jhradilek is here.
00:00:42 * Gearoid is here
00:03:00 <Sparks> Looks like this is going to be a short meeting
00:03:22 <jhradilek> Where is everyone?
00:03:37 * sgordon is here
00:03:48 <sgordon> i hope you can all contain your excitement
00:03:51 <Sparks> :)
00:03:57 <sgordon> rudi just walked in so he will prob pop in too i guess
00:04:19 <Sparks> Okay
00:05:03 * Alegrya is here
00:05:59 <jhradilek> Sparks: What is the agenda anyway? There is one for the last week on the wiki.
00:06:32 <Sparks> jhradilek: Same one
00:06:39 <Sparks> jhradilek: We didn't meet last week.
00:06:44 <Sparks> Okay, let's get started
00:06:49 * bcotton sneaks into the back row
00:07:14 <Sparks> #topic Follow up on last week's action items
00:07:29 <Sparks> #action jjmcd to work with the fedora-bookmarks owner to see if we can get the links fixed in F13 and F14
00:07:41 <Sparks> #topic Removing redirects on docs.fp.o
00:07:46 <Sparks> #info When Fedora 13 was released we had just upgraded to the latest version of Publican which changed all of our links on docs.fp.o. The search engines hadn't had enough time to catch up with the new URLs so we added links to act as redirects so the old URLs would still work.
00:11:19 * prabindatta is here
00:12:24 <Sparks> Sorry about that...  my computer decided to reboot.
00:13:05 <Sparks> Okay, so we are going to have to leave the redirects in place until we can fix the bookmarks package.
00:13:09 <Sparks> Any questions?
00:14:04 <Sparks> #topic Publishing Documentation to the desktop
00:14:24 <Sparks> Okay, rudi isn't here so we'll come back to this next week.
00:14:33 <Sparks> #topic Guide Status
00:14:47 <Sparks> Anyone have anything to discuss with their guide?
00:15:07 * bcotton 
00:15:30 <Sparks> bcotton: Go ahead
00:16:46 <bcotton> So I let Sparks talk me into committing to F15 as a goal of sorts for getting the RPM Guide re-released.  If there's anyone who wants to cut their teeth by working on a chapter or two, see https://fedoraproject.org/wiki/User:Bcotton/RPM_Guide_tasks   EOF
00:17:17 <Sparks> bcotton: Nice plug
00:17:25 * bcotton bows
00:17:44 <Sparks> We also need someone to work on the SELinux guides and, I think, the Virtualization Guide.
00:18:39 * prabindatta likes to talk about fedora release bookmark
00:19:00 <sgordon> what exactly is the state of the virt guide currently?
00:19:31 * nb here
00:19:38 * jjmcd too
00:19:39 <Sparks> sgordon: I'm not sure.
00:20:09 <Sparks> prabindatta: Well, now that jjmcd has decided to join us lets talk about that.  One second...
00:20:19 <nb> Sparks, have we talked to the maintainer yet?
00:20:22 <nb> about fedora-bookmarks?
00:20:50 <Sparks> Okay, anything else on the guides before we move onto the bookmark discussion?
00:21:24 <Sparks> #topic Fedora-bookmarks
00:21:37 <Sparks> nb: I think jjmcd was going to work with the developer.
00:21:43 <jjmcd> Let me review the situation as I see it
00:21:56 <jjmcd> We can't directly fix current installs
00:22:11 <jjmcd> However, if we correct the redirect, most people will get what they expect
00:22:26 <jjmcd> And I think we should correct the package
00:22:34 <jjmcd> so that new installs are correct
00:22:44 <nb> jjmcd, what kind of changes are necesary in hte package? just changing urls to other urls?
00:22:45 <jjmcd> Then, we should remember to check the package each release
00:22:53 <jjmcd> nb, yup
00:23:17 * nb considers "just doing it"
00:23:25 <Sparks> jjmcd: Can we take this to some sort of board to see if we can get buy in on actually fixing existing installations?
00:23:26 <prabindatta> yup! I was going to say the same
00:23:31 <jjmcd> The package should point to the associated release
00:23:44 <Sparks> jjmcd: It's going to be wrong for someone.
00:23:51 <Sparks> ...if we just change the redirect
00:23:53 <jjmcd> Sparks, I suppose we could, but based on stickster's comments
00:24:03 <jjmcd> Yes, but not a big surprise to anyone
00:24:26 <jjmcd> If you go to "release notes" and get the latest release notes it shouldn't be a big surprise
00:24:32 <nb> .whoowns fedora-bookmarks
00:24:32 <zodbot> nb: caillon
00:24:47 <Sparks> jjmcd: I just hate to have broken things in the wild
00:24:49 <jjmcd> Sure, it would be nicer if you got to the release notes for your version
00:25:03 <jjmcd> Sparks, I agree, but I suspect we won't get a lot of sympathy
00:25:14 <jjmcd> I suppose we should ask, tho
00:25:33 <Sparks> I'll bet the rawhide version of fedora-bookmarks is already broken
00:25:42 <jjmcd> Sparks, yep
00:25:53 * jsmith is late to the meeting
00:26:15 <jjmcd> Sparks, I haven't spoken to caillon
00:26:29 <Sparks> jjmcd: Can we create a placeholder for the F15 RNs so we'll have an active URL?
00:26:32 <jjmcd> But the actual changes aren't too tough, unless we go with fixing existing
00:26:53 <Sparks> How about this.
00:26:58 <jjmcd> I suspect Publican will expose them if they are there
00:27:02 <Sparks> Can we change the behavior of FF?
00:27:44 <jjmcd> I think it happens with FF install, or firstboot.  So fixing FF doesn't do any beter than fixing bookmarks
00:27:50 <Sparks> I think that is the only browser that does this.
00:28:03 <jjmcd> Seamonkey seems to do the same
00:28:14 <jjmcd> But I don't think it grabs rn's
00:28:15 <Sparks> Oh
00:28:38 <Sparks> I mean if we put the bookmarks somewhere accessible and have FF go directly there instead of the user's directory...
00:28:44 <jjmcd> At least, it seems to have all the same data.
00:28:45 <Sparks> that would solve the problem
00:29:01 <jjmcd> Well, the whole problem is that the user wants to tailor them
00:29:14 <Sparks> true
00:29:50 <jjmcd> I have toolbar folders for beats, bugs, and mysql databases
00:30:19 <jjmcd> I prolly should retest seamonkey on f14, looked at it on f12
00:30:34 <jjmcd> Which is where I had every browser known to man installed
00:30:48 <Sparks> heh
00:30:56 <jjmcd> We have like a dozen browsers
00:31:28 <Sparks> Okay, so we need to figure this out OR just remove the RNs from those links since we are already providing that via Documentation under System.
00:31:34 <jjmcd> I think the behavior is inherited from mozilla
00:31:48 <jjmcd> Something to be said for that
00:31:51 <nb> jjmcd, is it just the first link on http://pkgs.fedoraproject.org/gitweb/?p=fedora-bookmarks.git;a=blob_plain;f=default-bookmarks.html;hb=efda072796e9ff212976eb16f20eddb59462e3d6
00:31:56 <nb> that needs to be changed?
00:32:03 <jjmcd> But we still should fix the redirect
00:32:04 <nb> if so, i think i could do it as a provenpackager
00:32:32 <jjmcd> We should at least ping the owner.  At this point there is an open discussion on the bug
00:33:24 <Sparks> I'm for just removing the link... personally
00:34:03 <jjmcd> I don't see  ahuge problem with pointing to current release notes
00:34:16 <jjmcd> I'm sure that redirect url is other places in the wild
00:34:47 <jjmcd> But the bookmark should either be correct or removed
00:34:57 <Sparks> Except for that's only valid for part of the userbase
00:35:05 <Sparks> +1
00:35:17 <jjmcd> Well, I think that is a bit of a reach
00:35:29 <Sparks> What's a reach?
00:35:46 <jjmcd> If you click on "Release Notes" you might want F12, but just as likely you want the most recent
00:36:03 <jjmcd> Especially if you have the F12 release notes on your system
00:36:12 <nb> i think the most logical thing to do is to use the current release notes
00:36:16 <Sparks> Maybe, but if you are ON F12 then you would probably expect to get F12
00:36:18 <nb> although i support removing the bookmark
00:36:39 <jjmcd> So I wouldn't call it "invalid" for anyone, although for some small group it might not be there preferred destination
00:37:06 <jjmcd> I'm all for giving callion the alternatives ... fix it each release or remove it
00:37:32 <jjmcd> Tho the more I think about it, the less I like "fixing" it
00:37:58 <Sparks> Well, at least we have some options.
00:38:16 <Sparks> Anyone else?
00:38:17 <jjmcd> If you look for RNs on the web, and you have RNs for your release locally, than almost certainly you want the most recent
00:38:38 <jjmcd> ANd the answer then is to fix the redirect each release
00:38:59 <Sparks> Yeah but that won't fix the link if you are upgrading
00:39:19 <prabindatta> +1, fix the link on each release
00:39:22 <jjmcd> Which is why leaving bookmarks alone and fixing the redirect is the right answer
00:39:26 <Sparks> Or restoring your /home
00:39:42 <Sparks> Except for the fact that you haven't fixed the problem
00:39:53 <jjmcd> For probably 90% of the people you have
00:40:00 <Sparks> By fixing the redirect you have fixed it for some and broken it for others
00:40:04 <jjmcd> Changing bookmarks breaks it for the 90%
00:40:26 <Sparks> Removing it fixes it for everyone
00:40:47 <jjmcd> If you have the F12 notes spinning, why use the web to look at them?  If you look at them on the web you almost certainly want the most recent
00:40:48 <Sparks> Since we are already pushing it separately
00:41:38 <jjmcd> Well, removing it only fixes new
00:41:50 <jjmcd> FOr everyone else, we need to fix the redirect anyway
00:42:16 <Sparks> My vote is for removing it and bumping the redirect.
00:42:50 <jjmcd> We gotta bump the redirect each release.  Leaving it or removing it doesn't make a lot of difference to me
00:43:16 <jjmcd> *BUT*
00:43:20 <Sparks> Well, we can actually track how many hits we are getting through that redirect so we should be able to tell when people stop using it
00:43:37 <jjmcd> We should have a bookmark to docs.fp.o
00:44:07 <jjmcd> People will start using it on the run up to a new release
00:44:21 <Sparks> I like it
00:44:38 * prabindatta too
00:44:46 <nb> Sparks, want me to grep the logs real quick?
00:44:58 <nb> that is, if i can get to them......... anything on NFS is fail rightn ow
00:45:04 <nb> but i think they are stored locally on noc01
00:45:22 <Sparks> nb: I think you did a couple of weeks ago.  The number wasn't impressive IIRC
00:45:49 <jjmcd> I wouldn't expect it to be
00:47:44 <Sparks> Okay, so are we in agreement to replace the link in bookmarks from the RNs to Docs AND to fix the redirect to the latest version of the RNs.
00:48:06 <jjmcd> +1
00:48:12 <prabindatta> +1
00:49:17 <Sparks> anyone else?
00:49:37 <jhradilek> +1 :)
00:50:36 <Sparks> #agreed Replace the link in bookmarks from the RNs to Docs AND to fix the redirect to the latest version of the RNs.
00:50:53 <Sparks> jjmcd: Are you going to work on this?
00:51:08 <jjmcd> Well, nb is the guy for the redirect
00:51:20 <jjmcd> but I will work with callion to get the package fixed
00:51:44 <Sparks> nb: Do I need to put in a ticket?
00:51:52 <nb> +1
00:51:55 <nb> Sparks, i can fix it
00:52:00 <nb> where does it redirect from and to?
00:52:04 <nb> and where should it redirect to?
00:52:06 <jjmcd> I guess I *could* fix the redirect, but it would take nb more time explaining to me how to do it than if he did it himself
00:52:22 <jjmcd> nb latest release notes
00:52:29 <jjmcd> So currently F14
00:52:35 <Sparks> #action jjmcd to work with callion to fix fedora-bookmarks to remove Release Notes and add Docs links
00:52:39 <nb> its in ~/puppet/modules/httpd/templates or /files not sure where, but i can do it
00:52:52 <Sparks> #action nb to fix the redirect from the F13 Release Notes to the F14 Release Notes
00:53:09 <Sparks> jjmcd nb: Can you guys work on this after the meeting?
00:53:30 <jjmcd> yeah, but my initial "work" will be to ping the owner
00:53:43 <jjmcd> Prolly email and on the bug
00:53:47 <Sparks> Yes
00:54:06 <Sparks> Cool
00:54:11 <Sparks> Okay, anything else on this?
00:54:24 <jjmcd> Obviously I could trivially make the change, but I wouldn't want some weirdo messing with my package
00:54:34 <Sparks> heh
00:54:53 <Sparks> Especially if that weirdo is you.
00:54:59 <jjmcd> especially
00:55:08 <nb> jjmcd, you can only change it if you are provenpackager or have commit acl for that package
00:55:14 <nb> anyone with puppet access can change the redirect
00:55:15 <Sparks> Okay, moving on.
00:55:18 <jjmcd> good point, nb
00:55:21 <nb> but this can move on anyway :)
00:55:26 <nb> we can talk in -docs about the redirect
00:55:40 <Sparks> #topic Open floor discussion
00:55:55 <Sparks> Okay, does anyone have anything they'd like to discuss in the last 5 minutes?
00:58:52 <Sparks> Okay, thanks everyone for coming out tonight.
00:58:55 <Sparks> #endmeeting