14:00:31 <bcotton> #startmeeting Docs Project Meeting - Agenda: http://fedoraproject.org/wiki/Docs_Project_meetings
14:00:31 <zodbot> Meeting started Mon Nov 21 14:00:31 2011 UTC.  The chair is bcotton. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:00:31 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
14:00:40 <zodbot> bcotton: Error: Can't start another meeting, one is in progress.
14:00:46 <bcotton> #meetingname Fedora Docs
14:00:46 <zodbot> The meeting name has been set to 'fedora_docs'
14:00:54 <bcotton> #topic Roll Call
14:01:25 * pkovar here
14:01:57 * jjmcd 
14:02:19 * gomix here
14:02:21 * jhradilek 
14:02:25 * jsmith is here
14:04:16 <bcotton> #topic Follow up on last week's action item
14:04:23 <bcotton> i don't see a zoglesby around
14:04:31 <bcotton> nor do I see a Sparks
14:05:00 <bcotton> I haven't emailed about the Bug Squashing Party yet, but i'm doing that as we speak
14:05:26 <bcotton> fnadge to start a Style Guide book
14:05:38 <jsmith> Question...
14:05:44 <bcotton> go ahead jsmith
14:05:54 <jsmith> Should we make the Style Guide part of the new Documentation Guide, or a separate item?
14:06:21 <jjmcd> I thought we talked about that last week - maybe I remember wrong
14:06:26 <fnadge> bcotton:  Will post the book later this week
14:06:46 <bcotton> I think the discussion last week was that it should be a separate doc because it (theoretically) should remain static
14:06:49 <bcotton> fnadge: great!
14:07:16 <jjmcd> jsmith, really different audiences with different update incentives
14:07:27 <jjmcd> or more use cases than audiences
14:07:27 <jsmith> OK, makes sense
14:07:40 <jsmith> Just wanted to make sure it had been discussed
14:08:02 * Sparks is here
14:08:26 <bcotton> Sparks: i believe you sent the QA goals to the list, correct?
14:08:40 <Sparks> bcotton: I think I did
14:09:50 <bcotton> Sparks: and you also took the video recording request to the list. we need more action items for you
14:10:12 <Sparks> bcotton: I did and I think both jsmith and stickster both provided solutions.
14:11:03 <bcotton> and pkovar posted a proposed procedure for translation
14:12:01 <pkovar> bcotton: right, there has been a positive feedback, thanks you guys for your support
14:12:25 <bcotton> pkovar: so what do we need to move forward with that?
14:13:25 <pkovar> bcotton:  do you know about anybody who could look into merging members of the FAS group and the new group in Bugzilla?
14:13:45 <pkovar> so we don't need to add those people manually...
14:14:02 <pkovar> in the Bugzilla group of docs-publishers
14:14:30 <bcotton> if no one volunteers here, you might hunt down nb and see what he knows
14:14:55 <pkovar> OK, thanks for the tip
14:15:32 <jjmcd> nb probably knows what is possible
14:16:03 <bcotton> okay, so i'll remind myself to do things:
14:16:18 <bcotton> #action bcotton to email list to schedule Docs Bug Squashing Party
14:16:39 <bcotton> #topic FUDcon Blacksburg
14:16:50 <bcotton> #link http://fedoraproject.org/wiki/FUDCon:Blacksburg_2012
14:17:00 <bcotton> #info Docs is sponsoring two classes at FUDCon Blacksburg: Introduction to Docs and DocBookXML/Publican
14:17:38 * jjmcd and jsmith will have to fatten up our Milan prez
14:18:10 <jsmith> jjmcd: No worries there...
14:18:37 <jjmcd> Always easier to lengthen than to shorten
14:20:23 <bcotton> any thing else about blacksburg?
14:20:34 <Sparks> ?
14:21:03 <Sparks> I'd like to know how many Docs folks are planning on being there.  We will have hacker space for Docs.
14:21:18 * jjmcd plans to be there (obviously)
14:23:22 <bcotton> anyone else going?
14:24:00 <jhradilek> It's too far for me. :)
14:24:21 <jjmcd> jhradilek, I'm planning 3 days travel each way!
14:24:55 <pkovar> not me, unfortunately
14:24:58 <jhradilek> jjmcd: Heh, are you going to walk there? :)
14:25:00 <bcotton> jjmcd: are you walking?
14:25:14 <jjmcd> It's a good day's drive, but it is likely to snow
14:25:21 <jjmcd> So, leaving plenty of time
14:26:21 <bcotton> anything else re: Blacksburg?
14:27:08 * gomix has a ticket !
14:27:14 <jjmcd> COOL!
14:27:32 * gomix meant a trac ticket for subsidy jjmcd ;)
14:27:45 <jjmcd> Oh, well that's part of it
14:29:31 <bcotton> okay, moving on then
14:29:35 <bcotton> #topic Docs QA
14:29:44 <bcotton> #link http://lists.fedoraproject.org/pipermail/docs/2011-September/013736.html
14:29:51 <bcotton> and the goals that Sparks posted...
14:30:00 <bcotton> #link http://lists.fedoraproject.org/pipermail/docs/2011-November/013855.html
14:31:02 <nb> pkovar, ?
14:31:14 <nb> someone wanted to see what i know about something with FAS?
14:32:13 <pkovar> nb: yes, is there an easy way to merge members of the docs-publishers into a new bugzilla user group?
14:32:43 <jhradilek> Are the Docs QA goals in the above email sorted according to priority?
14:32:46 <nb> bugzilla user group?
14:32:58 <nb> what are we wanting that bugzilla group to do?
14:33:16 <pkovar> nb: well a group of default assignees for a bugzilla component, that is
14:33:38 <bcotton> jhradilek: i think that seems like a reasonable priority, but perhaps Sparks can answer that
14:33:47 <nb> why not just make it assigned to docs-publishers-members@fedoraproject.org
14:34:06 <pkovar> nb: is that a mailing list or something?
14:34:26 <nb> all groups have an alias like that
14:34:33 <nb> groupname-members@fpo will go to all members
14:35:11 <pkovar> nb: sounds great, only that we need to have members of the fas docs-publishers group in docs-publishers-members@fedoraproject.org.
14:35:18 <pkovar> can we do that automatically?
14:35:25 <nb> pkovar, it already is
14:35:30 <nb> every group is set up like that
14:35:44 <nb> i.e. docs-members will go to all members of docs group, packager-members goes to all packagers, etc
14:35:48 <pkovar> nb: oh, is it? excellent!
14:36:05 <bcotton> jhradilek: looks like Sparks may have been pulled away from the keyboard. would you mind posting that question to the list for discussion there?
14:36:32 <pkovar> nb: then i guess we only need to set up a new component with docs-publishers-members@fedoraproject.org.
14:37:22 <jhradilek> Sure; I am just asking, becaue from my perspective, point no. 4 should have the the highest priority.
14:37:35 <bcotton> jhradilek: that's a good point
14:37:38 <pkovar> would you guys prefer to have the new component under the fedora trans or docs product?
14:37:58 <bcotton> anything else on QA?
14:37:59 <jhradilek> The remaining three tasks are usually performed shortly later in the cycle.
14:38:13 <jhradilek> s/shortly//
14:39:07 <bcotton> i think we'll just skip directly to the end here...
14:39:13 <bcotton> #topic Open floor discussion
14:39:35 <pkovar> nb: do you have the admin rights to set up a new component in the docs or trans product?
14:40:26 <jjmcd> pkovar, were you thinking of docs.fp.o as a new component?
14:40:45 <jjmcd> actually might not be such a bad idea
14:41:12 <nb> pkovar, docs/owners.git
14:41:13 <pkovar> jjmcd: you mean call it docs.fp.o instead of say docs-publishers?
14:41:39 <jjmcd> Well, what reasons would you have for having a separate class of bugs?
14:41:39 <nb> pkovar, yeah, i can do it, or any docs-publishers can
14:41:48 <nb> pkovar, what do you want it to be?
14:42:23 <jjmcd> I wouldn't expect every document's bugs to show up in one component, there is already a component for each doc
14:42:39 <jjmcd> But a component for the website may or may not make sense
14:42:59 <jjmcd> Not so confident users would use it
14:43:24 <pkovar> pkovar: hrmm, i'll probably ask for more feedback by sending a message to the lists again
14:43:36 <jjmcd> So I'm not entirely clear on the functional need here
14:44:01 <pkovar> the thing is a bug files against a guide component would only go to the guide owners and QA contact
14:44:25 <pkovar> that's not enough, we need the publishers to be emailed
14:44:29 <jhradilek> pkovar: And people who are in the default CC list.
14:44:47 <jjmcd> OK, I see that.  But a new component wouldn't help that at all
14:45:23 <jjmcd> So, perhaps we add docs-publishers to the default cc list for each guide
14:45:27 <pkovar> jjmcd: if translators file bug against this component only to request the docs to be published, why not?
14:45:55 <pkovar> jjmcd: then docs-publishers would be spammed with every bug unrelated to publishing
14:46:09 <jjmcd> Yeah, I see your point
14:46:25 <jjmcd> So perhaps a component for needs-publishing
14:46:44 <pkovar> yep, something like that
14:47:05 <jjmcd> I was concerned that every bug against any guide would be in one bucket and we wouldn't be able to sort out bugs against a particular guide
14:47:39 <pkovar> jjmcd: no, that's not the case. we will keep the separated components for every guide
14:47:57 <jjmcd> But if there was a component specifically against whether something needs to be published or unpublished, that would be a good thing
14:48:00 <pkovar> but in addition to that, we will create a new component just for publishing
14:48:18 <bcotton> my understanding is that the new component isn't for bugs, but more for workflow
14:48:22 <pkovar> jjmcd: yes, that was my thinking too
14:48:35 <pkovar> bcotton: we can say that, yes
14:49:16 <jjmcd> hmmm, makes one think we need to go back to using trac, tho I really like BZ as the to-do list
14:49:59 <pkovar> hrmm, not sure what tool would be easier to use for translators
14:50:35 <jjmcd> I think the idea is that trac is for workflow, but we have moved to BZ for that too, and I'm happy with that
14:50:55 <jjmcd> Typically, tho, doesn't the guide owner generally do the publishing?
14:51:12 <jjmcd> Seems like you want the bug against the guide anyway
14:51:37 <jjmcd> Or are you thinking folks might be inclined to do any needed publishing?
14:51:51 <pkovar> jjmcd: actually it depends... that's why i proposed the solution so that it is uniformed
14:52:05 <jjmcd> Seems like we might occasionally get things done a little sooner
14:52:33 <pkovar> jjmcd:  some people don't care about publishing translations at all, and we need to solve that
14:52:54 <jjmcd> pkovar, I get that
14:52:54 <pkovar> so that translations get actually published at the end
14:53:19 <jjmcd> Another advantage here, makes it less necessary to keep checking tx to see what is done
14:53:47 <pkovar> translators can request the docs to be published as they wish
14:54:19 <pkovar> and at any time
14:54:29 <pkovar> that's a big advantage for them
14:55:15 <jjmcd> So all it would take is a publishing component with a default CC of docs-publishers
14:55:22 <jjmcd> Sounds pretty simple
14:55:37 <jjmcd> ANd a note to L10n
14:55:43 <pkovar> jjmcd: : yes.
14:55:54 <pkovar> sorry, need to go now, will be back later
14:56:47 <bcotton> well that was a good discussion. anything else before we wrap up?
14:58:52 <bcotton> hearing nothing, thanks everyone for attending. those of you who are celebrating Thanksgiving this week, have an enjoyable celebration. Everyone else have an enjoyable week!
14:58:56 <bcotton> #endmeeting