14:04:08 <randomuser> #startmeeting Docs Project Meeting - Agenda: https://fedoraproject.org/wiki/Docs_Project_meetings
14:04:08 <zodbot> Meeting started Mon Oct  6 14:04:08 2014 UTC.  The chair is randomuser. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:04:08 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
14:04:08 <randomuser> #meetingname Fedora Docs
14:04:08 <randomuser> #topic Roll Call
14:04:08 <zodbot> The meeting name has been set to 'fedora_docs'
14:04:20 * Capesteve waves
14:04:22 * jjmcd 
14:04:25 * pbokoc 
14:05:11 <yruseva> meee
14:05:11 <randomuser> #chair jjmcd pbokoc
14:05:11 <zodbot> Current chairs: jjmcd pbokoc randomuser
14:05:36 <pbokoc> fyi we have an event... thing in Brno right now so there might be less responses than usual
14:06:04 <Capesteve> or just s l o w
14:07:53 <randomuser> It might seem slow from here too, but it's a personal issue :P
14:08:09 <randomuser> #topic follow up on action items
14:08:42 <randomuser> We had two declared action items from last week. One was for me to announce the wiki conversion of beats, which i have done
14:09:15 <randomuser> and the other was to 'reshuffle' the multiboot guide content with roger, which we kinda just worked around for nwo
14:09:36 <randomuser> #topic New Writers
14:10:05 <randomuser> Any new writers here, or people that would like to report on the progress of new writers under their tutelage?
14:14:28 <randomuser> OK then
14:14:36 <randomuser> #topic Release Note Beats
14:14:57 <randomuser> We're in the 'conversion to docbook' phase of writing beats
14:16:37 <randomuser> #link https://fedorapeople.org/groups/schedule/f-21/f-21-docs-tasks.html
14:17:00 <randomuser> #info no more wiki changes to beats after today
14:17:16 <randomuser> I moved over a number of them, those beats are closed
14:17:24 <randomuser> (because I despise wiki tables)
14:17:31 <pbokoc> I'll move a few in the evening
14:18:08 <randomuser> I got sidetracked on the systemd beat, and will probably park there for a day or two
14:19:20 <randomuser> #info docs-writers needed for Self Contained Changes
14:19:46 <randomuser> that's still mostly uncovered, and it should all be finalized now
14:20:17 <pbokoc> bara_, yruseva ^ :)
14:20:18 * jjmcd will try to catch his beats this week, will update wiki then convert to docbook immediately, just to keep the wiki fresh
14:20:32 <jjmcd> Now that SET is behind me I have a *little* breathing space
14:20:39 <randomuser> jjmcd, I was hoping you'd say that :)
14:20:55 <randomuser> nobody does those embedded/circuitry/radio packages like you
14:20:57 <jjmcd> Still not pretty but SET was a really big effort here
14:21:23 <jjmcd> Yeah, do we have a tech notes or at least a pair of databases?
14:22:12 <randomuser> jjmcd, not really; we don't have a dvd image anymore, so it would have to go against some livecd or the whole repo
14:22:26 <randomuser> jjmcd, and it buckled horribly on the whole repo
14:22:38 <jjmcd> In the past I've used the whole repo, but it keeps getting bigger
14:23:12 <randomuser> I don't even recall what was wrong with it, but it didn't look easy
14:23:34 <pbokoc> randomuser, actually Server does have a DVD image afaik
14:23:54 <jjmcd> I have some smaller progs for per-beat stuff
14:24:11 <randomuser> pbokoc, this is why I don't like referring to "the DVD image" :P
14:24:38 <randomuser> but yeah, there is no non-productized/spun install media
14:24:47 <pbokoc> well, yeah
14:25:17 <randomuser> ah, there should be a release note on that
14:26:04 <randomuser> #action randomuser to add RN about F21 deliverables
14:26:35 <randomuser> jjmcd, I can try the TNs again if it would help you. It's a little intimidating
14:27:12 <jjmcd> Is the previous database in git?
14:27:32 <jjmcd> With that I can do 95% Might miss a few new packages
14:27:54 <randomuser> I think the git sqlite tree is up to date
14:28:05 <jjmcd> good deal, that's most of it
14:28:46 <randomuser> I keep a local mirror as well, so if you come up with some repoquery-foo I could run it quickly
14:29:11 <jjmcd> I'm just way behind on local copies of the sqlite
14:29:22 <jjmcd> Once I have the db I can get mostly there wth checkBeatr
14:29:36 * randomuser nods
14:29:56 <randomuser> Anything else we should cover re:beats?
14:30:53 <jjmcd> And I totally get the "intimidating" part.  Hardest thing is re-remembering what I did last time
14:31:26 <randomuser> #topic Guide Status
14:31:44 <pbokoc> randomuser, well, I think someone might want to reply to that e-mail from last week about release notes for the release notes :))
14:36:50 <randomuser> heh, yeah, I'll do that
14:36:52 <randomuser> #info randomuser to reply to adamw's request for preliminary release notes
14:36:55 <randomuser> roger got to a point with the multiboot guide where I thought an SME check was needed, and adamw was kind enough to get himself volunteered
14:37:07 <pbokoc> nice
14:37:22 * adamw requested that?
14:37:47 <randomuser> adamw, you did
14:38:05 <randomuser> https://lists.fedoraproject.org/pipermail/docs/2014-September/015823.html
14:38:17 <adamw> oh, that.
14:39:10 <randomuser> adamw, i think the answer from us is "you're already getting what we're putting down as fast as we write it"
14:39:25 <adamw> WRITE MORE
14:39:55 * randomuser elbows his keyboard busily
14:40:21 * pbokoc hides
14:40:55 <pbokoc> jokes aside though, if I recall the e-mail correctly, it wasn't really about writing more, was it? It was about writing _earlier_
14:41:42 <pbokoc> which is a problem, because earlier, there's nothing to write about. We have a list of changes, but with most of them not even their owners know what's actually gonna happen
14:43:39 <randomuser> we can start doing some research before then, but let's talk about starting early.... early in the next cycle
14:43:58 <randomuser> I also created a repo with an empty publican book for the firewall guide
14:44:09 <randomuser> not much more than that, though
14:44:52 <randomuser> oh, I sent a mail to the design team asking for a volunteer to do some helpful artwork for it
14:45:12 <pbokoc> for the firewall guide?
14:45:54 <randomuser> yes
14:46:13 * randomuser is really attached to the post office metaphor
14:46:31 <pbokoc> heh
14:46:57 <Sparks_too> Hey!  I made it!
14:47:01 <randomuser> yay!
14:47:09 * randomuser hides the donuts
14:47:10 <pbokoc> randomuser, if you do get a volunteer and something useful comes out of it, you should write about your success story and send it to the list
14:47:13 * Sparks_too needs to check his calendar... and clock
14:47:22 <randomuser> pbokoc, definitely
14:47:42 <pbokoc> we could use more graphics in a lot of guides
14:48:02 <jjmcd> pbokoc, translating graphics is an issue
14:48:06 <Sparks_too> pbokoc: Graphics can be problemattic
14:48:22 <Sparks_too> pbokoc: Umm...  what jjmcd said
14:49:41 <pbokoc> well, that's true, but we don't get a whole lot of l10n effort anyway, and there are actually ways to make graphics easily translatable afaik
14:49:53 <pbokoc> in certain circumstances anyway
14:50:09 <randomuser> they can be good or bad - just don't rely on the graphics to do the job
14:50:11 <randomuser> I'm going to move on - there's one thing I want to touch on here
14:50:12 <pbokoc> but anyway I suspect this is way too far away to worry about
14:50:20 <randomuser> #topic Commit announces in #fedora-docs
14:50:56 <randomuser> I've asked infra to put a bot in our IRC channel that will send commit summaries
14:51:16 <Sparks_too> +1
14:51:17 * threebean will do asap
14:51:24 <jjmcd> Doesn't everyone get the emails?
14:51:26 <pbokoc> oh yeah... well, why?
14:51:28 <randomuser> we have a relatively low traffic set of repos, and a relatively low traffic channel, so i think it shouldn't be too intrusive
14:51:58 <randomuser> threebean, there's some rate limiting built in there, right?
14:52:04 <Sparks_too> jjmcd: I suspect most people aren't crazy like us and subscribe to docs-commits
14:52:27 <jjmcd> If "summary" means only the commit message then sounds good, but some of those diffs are megabytes long
14:52:30 <randomuser> like, if I send 50 commits in one push, it'll just say ~'immanetize did "message" and more'
14:52:46 <randomuser> jjmcd, message, shorthash, link?
14:52:56 <jjmcd> Yeah
14:53:04 <threebean> randomuser: yes
14:53:13 <jjmcd> Sparks_too, perhaps the entire channel isn't full of crazies, yeah
14:53:48 <randomuser> jjmcd, that's why we have to work on them !
14:53:55 <jjmcd> :)
14:54:39 * jjmcd doesn't like 50 commits in one push, "git push" rolls off my fingers automatically after "git commit -m"
14:54:59 <randomuser> same here
14:55:32 <randomuser> i'm seriously considering a precommit xmllint hook, and a postcommit push hook
14:56:43 <randomuser> ...so, no objections to the bot?
14:57:17 <randomuser> We can at least give it a try, I think, as long as you know who to blame if you don't like it.
14:57:40 <pbokoc> nobody ever does 50 commits at once anyway, we're happy if someone does 5 :)
14:57:46 <randomuser> exactly
14:58:13 <randomuser> #topic open flooer
14:58:16 <randomuser> #undo
14:58:16 <zodbot> Removing item from minutes: <MeetBot.items.Topic object at 0x2b5c2310>
14:58:19 <randomuser> #topic open floor
14:58:25 <randomuser> 45 seconds, go!
14:58:37 <Sparks_too> AHHHHHHHHHHHHHHHHHHHHHHHHHHHHH
14:58:49 <Sparks_too> Whew, I feel better now.
14:59:02 <randomuser> a fitting end to the meeting, thank you
14:59:05 <pbokoc> "open floor" means "start screaming" now?
14:59:24 <pbokoc> I'm ok with this
14:59:29 * Sparks_too refers confused people to a great 80s movie "Summer School".
14:59:33 <randomuser> yeah, but usually we do it verbally to keep the logs clean
15:00:03 <pbokoc> here in Europe we yodel instead
15:00:08 <randomuser> okay, thanks for coming everyone
15:00:11 <randomuser> #endmeeting