14:00:35 <randomuser> #startmeeting Docs Project Meeting - Agenda: https://fedoraproject.org/wiki/Docs_Project_meetings
14:00:35 <zodbot> Meeting started Mon Nov 10 14:00:35 2014 UTC.  The chair is randomuser. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:00:35 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
14:00:35 <randomuser> #meetingname Fedora Docs
14:00:35 <zodbot> The meeting name has been set to 'fedora_docs'
14:00:35 <randomuser> #topic Roll Call
14:00:52 * Capesteve waves
14:01:41 <randomuser> oh, crap, why do I wait until *now* to look at the action items I wrote for myself
14:02:37 * zoglesby is here
14:03:17 <Southern_Gentlem> randomuser, life happens
14:04:00 <randomuser> Southern_Gentlem, yeah, but usually not this early :P
14:05:32 <randomuser> hrm.. quiet today; shall we carry on, zoglesby and Capesteve, or give them a few minutes
14:06:26 <zoglesby> randomuser: I am just here for you
14:06:31 <Capesteve> let me see ......JH is in another meeting
14:06:57 <randomuser> aww, thanks z
14:06:57 <Capesteve> pbokoc: is not at his desk
14:07:11 <pbokoc> oh, hello
14:07:18 <Capesteve> a gost ^
14:07:29 <Capesteve> ghost, sorry
14:07:36 <randomuser> I think we can assume Sparks is afk, looking for a berth to the south
14:07:44 <pbokoc> yeah, I got hit by a truck while driving to work
14:07:52 <randomuser> !
14:07:52 <Capesteve> bad weather again?
14:07:54 <pbokoc> so now I'm gonna haunt Freenode
14:08:05 <zoglesby> randomuser: is he moving?
14:08:07 <Capesteve> pbokoc: sorry to hear that
14:08:17 <Capesteve> pkovar1: yay
14:08:25 <pkovar1> hey
14:08:38 <randomuser> zoglesby, not that I know of, but he isn't here to defend himself - maybe that'll teach him!
14:09:13 <zoglesby> randomuser: okay, we will start the rumor
14:09:24 * randomuser nods solemnly
14:09:44 <randomuser> #topic Action Items Review!
14:10:03 <zoglesby> #info Sparks is moving to Antarctica
14:10:06 <randomuser> first up, zoglesby,  writing about server ?
14:10:11 <randomuser> heh
14:10:15 <zoglesby> I am going to do that
14:10:23 <randomuser> excellent
14:10:38 * jsmith shows up late to the party
14:10:39 <zoglesby> I did not get it done last week, but I got that out of my system
14:10:53 <zoglesby> (that being hours and hours of Call of Duty)
14:10:59 <randomuser> ha!
14:11:16 <randomuser> okay, carrying it forward
14:11:33 <randomuser> #action zoglesby to finalize Server product stuff in RNs
14:11:48 * randomuser also has some notes on server
14:12:07 * rkratky is sorry for being late
14:12:07 <zoglesby> I also need to make some changes to the Big Data stuff that I asked the SIG to add
14:12:31 <randomuser> cool
14:12:43 <randomuser> welcome, rkratky
14:12:58 <randomuser> aaand jsmith - Cloud product?
14:13:12 <jsmith> Didn't get it done last week, working on it this week
14:13:18 * jsmith hangs his head in shame
14:13:36 <randomuser> I like the 'still working on it' part.  No shame there.
14:14:14 <randomuser> jsmith, i'm uncertain if we're considering atomic good-to-go for this release
14:14:30 <jsmith> randomuser: From what (little) I understand, it's a "technology preview"
14:15:00 <jsmith> randomuser: My understanding is that it'll be an official "feature" of F22-ish
14:15:40 <randomuser> jsmith, do you think we should still write about it? if yes, we can maybe recruit someone instead of you doing it all
14:15:57 <jsmith> randomuser: Wouldn't hurt to write about it -- and yet, I'd prefer someone else wrote about atomic
14:16:10 <randomuser> i have the same sentiments
14:16:20 * jsmith doesn't yet grok it well enough to fully articulate it
14:16:23 <randomuser> does anyone here want to explain atomic?
14:17:17 <jsmith> Isn't this where we volunteer Sparks?
14:17:37 <randomuser> no, we can
14:17:56 <zoglesby> https://www.google.com/?gws_rd=ssl#q=define:+atomic
14:18:10 <zoglesby> done
14:18:11 <randomuser> ...we can't. Sparks will be stuck in the doldrums for 4-6 weeks, on his way to the southern pole for winter
14:18:39 <Southern_Gentlem> randomuser, correction summer
14:18:41 <zoglesby> randomuser: no, its summer time in the south
14:18:57 <randomuser> you people and your spheres
14:19:52 <randomuser> how about this - anyone want to ask around in #fedora-cloud, cloud@lists.fp.o, or in #fedora-devel of someone named 'walters' for copy on atomic ?
14:20:13 * randomuser thinks it's ok to ask the cloud sig to explain themselves sometimes
14:20:57 <randomuser> #halp someone needed to ask around in #fedora-cloud, cloud@lists.fp.o, or in #fedora-devel of someone named 'walters' for copy on atomic
14:21:03 <randomuser> #help someone needed to ask around in #fedora-cloud, cloud@lists.fp.o, or in #fedora-devel of someone named 'walters' for copy on atomic
14:21:13 <randomuser> one of those works, I'm sure of it
14:21:36 <randomuser> uhm... still on action items, now mine
14:21:52 <randomuser> I still need to do all of these, I think
14:22:05 * randomuser randomuser to start nightly builds with fail reports for l10n
14:22:17 <randomuser> #action randomuser to start nightly builds with fail reports for l10n
14:22:24 <randomuser> #action randomuser to write about rolekit
14:22:34 <randomuser> #action randomuser to write powershell checksum instructions for IG, maybe more
14:22:44 <randomuser> #action randomuser to add explanation of deliverables to RNs; there is no universal netinstall or DVD image
14:23:18 <randomuser> on that first one - I did *start* at least, and I can say with confidence that es-ES is broken
14:24:12 <randomuser> If someone fluent in Spanish wanted to take a look, it'd probably help quite a bit
14:25:12 <randomuser> #topic New Writers
14:25:24 <randomuser> Any new writers today?
14:26:37 <randomuser> we're late in the meeting and early in the schedule, so I'll probably cut this section short
14:26:52 <randomuser> #topic Release Note Beats
14:27:13 <randomuser> I *think* we covered the majority of the TODOs in the action items section
14:27:57 <randomuser> I don't at all feel like I have to scramble to get the thing done this time around :)
14:28:21 <zoglesby> #action zoglesby to incorporate Big Data SIG changes
14:28:29 <randomuser> pkovar1, would you be able to publish sometime soon?
14:29:21 <randomuser> ...someone needs to, anyway. Whoever gets there first.
14:29:51 <pbokoc> hang on, the RNs aren't published?
14:30:39 <randomuser> yes, not published
14:31:49 <pbokoc> well, that sucks
14:31:58 <randomuser> anything else that needs to be added?  Anyone notice any "This should be covered in the release notes!" stuff on lists lately?
14:32:18 <pbokoc> I can't recall anyone except pkovar being able to publish. We really need a better process
14:33:04 <zoglesby> pbokoc: +1, or we need a version of publican that we can use to publish in a supported version of Fedora
14:33:14 <randomuser> we could all set up the tools - but pkovar's so *good* at it!
14:33:28 <pbokoc> I hear he loves having to do that, too
14:34:20 <randomuser> well, let's move on to talking about publishing, I guess
14:34:28 <randomuser> #topic publican/publishing
14:34:35 <randomuser> NEEDSWORK
14:34:46 <zoglesby> #agree
14:35:00 <zoglesby> also NEEDSTOWORK
14:35:28 <pbokoc> ^ what he said
14:35:50 <randomuser> I feel like there's all square pegs and round holes when trying to set up a publican site
14:36:47 <zoglesby> I really don't want to say it, but we may need to talk about seeting up a repo with builds of the last version of publican we can build with for F20 and F21
14:37:04 <randomuser> it gets a little better when you start moving files around, creating symlinks, manually dropping in css or html files, but the whole idea was that we could just use RPMs for everything
14:37:08 <zoglesby> s/seeting/setting
14:38:11 <randomuser> zoglesby, how would that work, just something crudely approximating `mv %files $files-legacy` in %post ?
14:40:14 <zoglesby> randomuser: Fedora 20 ship with 4.X which we can't use to build the current site, I think we need to backport 3.X in a repo so that we can still publish until this whole issue is resolved
14:40:22 <jsmith> I guess my question is this -- did we ever get complete instructions on what we *should* be doing to setup a new site, etc?
14:40:36 <randomuser> zoglesby, 2.x - publican3 doesn't work either
14:41:30 <randomuser> jsmith, jfearn clarified some things on the list recently, but also mentioned some undocumented requires and new changes that would ambiguously make things easier
14:41:43 <pkovar1> so what was it that you wanted me to publish?
14:41:55 <jsmith> randomuser: ACK
14:42:11 <randomuser> pkovar1, release notes, please.  And sorry to keep doing this to you, your patience is commendable
14:42:32 <zoglesby> my only point is that we keep thinking this issue is going to be fixed soon, and we never get that far
14:42:38 <randomuser> yeah, agreed
14:43:00 <randomuser> this has drug on for too long
14:43:03 <pkovar1> randomuser: ok, np. you want them published now?
14:43:14 <randomuser> pkovar1, at your convenience
14:43:40 <zoglesby> We should not be running years old unsupported version of Fedora just to publish
14:43:55 <pkovar1> randomuser:  i will try to do it today then, are we publishing from master?
14:44:06 <zoglesby> If the new site is still going to take time we need to have a short term solution as well
14:44:10 <randomuser> pkovar1, that will work for now
14:44:19 <pkovar1> randomuser: kk
14:45:05 <zoglesby> randomuser: what was the last version of publican that works on the site?
14:45:13 <pbokoc> I agree with zoglesby. Making publican 2.8 available on F20 would solve a lot of the problems we have now
14:45:14 <randomuser> zoglesby, I've looked at it - I wasn't confident I could repackage and have it coexist peacefully and still work
14:45:15 <pbokoc> short-term
14:45:29 <randomuser> zoglesby, whatever was right before the publican 3 release
14:45:30 <pbokoc> no idea how feasible that is though
14:45:56 <randomuser> oh, and is publican out of el5 completely now?
14:46:30 <randomuser> sorry for the tangent, i have publican-fedora acls now and it complains that publican is missing there
14:46:47 <zoglesby> randomuser: I don't know that we can get them to coexist, but if we can't publish why write?
14:47:00 <randomuser> fair enough
14:47:29 <randomuser> uhm... I'll look at repackaging, that's what you're getting at, right?
14:47:49 <zoglesby> I think we should try and setup and copr repo for 2.X and see what we can get working
14:48:06 <randomuser> who is we specifically?
14:48:19 <pkovar1> one could also create a docker image with 2.8 so that people with p4 don't have to downgrade... ;)
14:48:35 <pkovar1> everyone loves docker these days
14:48:36 <zoglesby> randomuser: you, me, anyone who wants to help
14:49:31 <randomuser> okay
14:49:42 <zoglesby> I know its nontrivial, but the current state of affairs is just sad
14:49:45 <randomuser> #info randomuser is setting up publican2x copr, ask for perms
14:50:19 <randomuser> #topic Guides
14:50:27 <zoglesby> "Fedora the bleeding edge distro that can't even use its own tools to publish docs"
14:51:05 <randomuser> zoglesby, well, if fedora as a whole got behind the docs publishing toolchain, we'd be in a better situation ...
14:51:20 * zoglesby has to run to another meeting
14:51:23 <zoglesby> randomuser: indeed
14:51:26 <randomuser> what do we need for guides?
14:53:20 <pbokoc> writing :)
14:53:41 <randomuser> #info guides need writing
14:54:14 <randomuser> I just went out to start a vehicle - the thing was fully covered in 5mm of clear ice
14:54:18 <pbokoc> I'm gonna have to finish the Anaconda GUI chapter in the Install Guide this week so it can get on install media in time
14:54:50 <randomuser> however did you make that happen anyway, pbokoc ?  I checked, there was nothing on their list about it
14:55:29 <pbokoc> randomuser, it was a feature originally proposed for the RHEL installer, we decided to try it with Fedora first
14:55:55 <pbokoc> also it's about 55F here, hehe
14:56:28 <randomuser> #link http://copr.fedoraproject.org/coprs/immanetize/publican2/
14:56:39 <pbokoc> oh and the communication is mostly over IRC or in person, the guy who made the conversion script and added the help buttons to spokes in from Brno, too
14:56:40 <randomuser> go there and ask for perms
14:56:48 <randomuser> cool
14:57:12 <pbokoc> randomuser, so wait, that will actually allow me to install publican-2.x on F20?
14:57:43 <randomuser> pbokoc, that's the idea, once the work is done
14:57:58 <pbokoc> why didn't we do this a year ago?! :-D
14:58:13 <randomuser> it's hard
14:58:32 <randomuser> #topic Open Floor
14:58:44 <randomuser> I want to get one thing out while we have... a minute
14:59:15 <randomuser> The new leadership restructuring has an "elected positions cover Fedora's subprojects not under the engineering or outreach banners (Documentation, Translation, etc.)"
14:59:27 <randomuser> and I've thrown my name in the hat for it
14:59:35 <pbokoc> cool
14:59:52 <randomuser> so if you want to avoid the fate that will result, you have maybe 12 hours to get someone else nominated :)
15:00:42 <randomuser> and that's our hour
15:00:46 <pbokoc> nah, you're not getting out of that
15:00:51 <randomuser> #endmeeting