14:00:56 <randomuser> #startmeeting Docs Project Meeting - Agenda: https://fedoraproject.org/wiki/Docs_Project_meetings
14:00:56 <zodbot> Meeting started Mon Aug 15 14:00:56 2016 UTC.  The chair is randomuser. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:00:56 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
14:00:56 <zodbot> The meeting name has been set to 'docs_project_meeting_-_agenda:_https://fedoraproject.org/wiki/docs_project_meetings'
14:00:56 <randomuser> #meetingname Fedora Docs
14:00:56 <zodbot> The meeting name has been set to 'fedora_docs'
14:00:56 <randomuser> #topic Roll Call
14:01:03 * Capesteve waves
14:02:37 * jhradilek waves too.
14:02:41 <bexelbie> .hello bex
14:02:42 <zodbot> bexelbie: bex 'Brian (bex) Exelbierd' <bex@pobox.com>
14:03:00 * pbokoc 
14:03:02 <randomuser> Now, depending on who's here and their interest level, it might be a good idea to spend the meeting discussing progress and plans for pintail
14:03:14 <bexelbie> +1
14:03:32 <randomuser> and eschew the agenda completely
14:04:22 <bexelbie> perhaps it is worth editing the standard agenda too /me ducks
14:05:10 <randomuser> go for it
14:06:09 <randomuser> okay, enough rolls
14:06:20 <randomuser> #topic pintail planning
14:06:27 <randomuser> #link https://pagure.io/docs-fp-o/issues
14:06:42 <randomuser> alright, let's start at the top
14:07:42 <randomuser> the wjmoreno and mayorga took over the package review for pintail
14:07:55 <randomuser> williamjmorenor++
14:07:55 <zodbot> randomuser: Karma for williamjmorenor changed to 2 (for the f24 release cycle):  https://badges.fedoraproject.org/tags/cookie/any
14:07:59 <randomuser> mayorga++
14:07:59 <zodbot> randomuser: Karma for mayorga changed to 3 (for the f24 release cycle):  https://badges.fedoraproject.org/tags/cookie/any
14:08:12 <randomuser> and, issue updated
14:08:27 <c0mrad3> .hello dhanvi
14:08:28 <zodbot> c0mrad3: dhanvi 'Tummala Dhanvi' <dhanvicse@gmail.com>
14:08:56 <randomuser> next up is editing existing books to work with pintail - i think we need more detail in this issue
14:10:19 <randomuser> can someone try to build the books with pintail and update the issue ?
14:10:35 <bexelbie> I tried to build the install guide, iirc, before Flock
14:10:44 <randomuser> it would be best to have a checklist of things to use for each guide
14:10:46 <bexelbie> there is a build bug in pintail regarding xml file requirements
14:10:48 <zoglesby> The biggest issue is common content
14:11:07 <bexelbie> if we convert to asciidoc straight out we should avoid that
14:11:13 <bexelbie> which will just leave us with the common content problem
14:11:28 <bexelbie> I am wondering if we can solve common content with git-submodules or git-subtrees
14:11:32 <randomuser> as in the trademark ownership and legal boilerplate?
14:11:36 <bexelbie> it is little changed content so it should work well with those
14:11:56 <randomuser> bexelbie, i think that would add more workflow complexity than we want
14:12:08 <zoglesby> It also will not deal with stuff like $FedoraVersion
14:12:23 <bexelbie> randomuser, I don't think so ... as I believe it is "automagical" from a non-common content updater perspective
14:12:56 * randomuser shrugs
14:13:04 <pkovar> /me is here
14:13:24 <pkovar> /me is with shaunm at gnome docs sprint
14:13:27 <bexelbie> Could we define release specific versions in common content and peg that to the branches?
14:13:31 <randomuser> I'm not conversant on submodules or subtrees, so I assume that it would be a blocker for others
14:13:38 <bexelbie> assuming a sub-module style usage
14:13:46 <bexelbie> I have done some reading .. which makes me dangerous
14:14:05 <bexelbie> the specific issue is that you want this to be content that is not likely to change often while working on the rest of the repository
14:14:21 <bexelbie> and apparently you tie a specific git has to be checked out when you clone the main repository
14:14:29 <bexelbie> then we can just symlink it ... or so the theory goes
14:14:33 <bexelbie> not symlink - sorry
14:14:36 <bexelbie> then we can just use it
14:14:52 <randomuser> imo we should stop representing articles as being appropriate for $version and simply represent them as "current"
14:15:16 <bexelbie> I believe gnome does tagging for versioning .. so the text stays generic but you can know what is good for which version
14:15:24 <bexelbie> apparently they can also use this for audit before a release
14:15:30 <bexelbie> but I know nothing of the details
14:15:56 <pkovar> bexelbie: you mean http://projectmallard.org/1.0/mal_info_revision
14:16:35 <bexelbie> pkovar, maybe?? It was from a hallway-convo with Kat at Flock
14:16:47 <randomuser> can you take this as an action item to flesh out the idea, bexelbie, or shall we move on to the next issue?
14:17:00 <pkovar> bexelbie: certainly ;)
14:17:06 <bexelbie> randomuser, I'll try to build a POC that shows how to do the common content
14:17:12 <bexelbie> is that what you mean randomuser ?
14:17:34 <randomuser> something that generally addresses the problem of building our existing books with pintail
14:17:57 <bexelbie> I am happy to do that too ... but I don't have the cycles (and possibly knowledge) to fix the pintail XML bug
14:18:03 * bexelbie goes to get issue #
14:18:13 <randomuser> if it happens that you come back with a recommendation to do asciidoc conversion and ignore common content, so be it
14:18:15 <bexelbie> https://github.com/projectmallard/pintail/issues/20
14:18:21 <bexelbie> ok
14:18:31 <bexelbie> I will also try to pin down ShaunM for help when he is back from Guadec
14:18:47 <bexelbie> I am going to Write The Docs Europe (but I don't think he is) so I may try to find some outside parties who want to hack on tools there
14:19:25 <bexelbie> #action bexelbie to develop a POC around a pintail build with common content or come back with a list of failure points cleanly documented
14:19:28 <randomuser> hm... i wonder if that specific DTD declaration is required in that section? perhaps we could just change it to one pintail doesn't complain about
14:19:47 <bexelbie> From messing with it, I got the impression it was any DTD
14:19:54 <randomuser> hm
14:19:55 <bexelbie> I think I did some hacking and slashing to get to that point
14:20:02 <bexelbie> but I will revisit it
14:20:48 <bexelbie> This also begs the question of if we should fix publishing for our current books - as raised at Flock
14:21:05 <bexelbie> (though we still need a process/POC and common content regardless)
14:21:42 <randomuser> the info about what needs to be done to the current guides to publish them with pintail will inform the answer to that question
14:22:00 <bexelbie> cool
14:22:15 <randomuser> please take https://pagure.io/docs-fp-o/issue/2 bexelbie, it doesn't know your name yet
14:22:32 * bexelbie tries not to put his name in public places :P
14:22:55 <randomuser> heh
14:23:17 <randomuser> i think i was looking for 'bexelbie'
14:23:22 <randomuser> okay, #3
14:23:38 <bexelbie> it's a long story .. like TOS to TNG Klingons
14:23:45 <randomuser> this is an sgilson pet topic, but he has not engaged
14:24:23 <randomuser> Do we consider development of an overarching content model to be immediately actionable without him?
14:24:58 <bexelbie> I believe we have to step back and define our new content model and not worry about conversion ... once we know the endpoint we can make a decision about conversion
14:25:50 <jhradilek> I have to admit I wasn't paying too much attention to this lately, so ignore me if it is just my ignorance, but what is the "overarching content model" supposed to be?
14:25:55 <randomuser> I'm afraid that theorizing about the content model will consume manhours that could be spent on implementation
14:26:07 <bexelbie> I have ideas about topics, but I don't know that I have the cycles to write them up this week.  Is there someone else who wants to take action on this?  Otherwise I would propose we table it and wait until we know what the tool is going to do to us with the other books.
14:26:38 <bexelbie> s/other/existing/
14:26:44 <randomuser> jhradilek, some kind of strategy for deciding what we should write about and how we should structure the relationships between those choices
14:27:30 <jhradilek> I am having hard time imagining what it could look like.
14:27:36 <randomuser> we're more ad-hoc now, and for the time being it might be best to accept that and move past what could be an ideological roadblock
14:28:09 <randomuser> jhradilek, well, erm... sgilson has a vision
14:29:13 <randomuser> so... any objections to closing 'Insufficient Data' and perhaps revisiting down the road?
14:29:22 <bexelbie> for info, this was mentioned by pfrields at Flock: http://paste.fedoraproject.org/392172/84893614/
14:29:43 <bexelbie> it is keywords searched for with "fedora how to" ... this could show one way of determing what to write
14:30:16 <randomuser> i like it
14:30:49 <pbokoc> "fedora how to wear" :D
14:30:49 <bexelbie> How about we mark the ticket low priority and put that link in it
14:30:52 <pbokoc> dibs on that one
14:31:19 <jhradilek> pbokoc: Too late: http://www.wikihow.com/Wear-a-Fedora
14:31:31 * stickster notes there are definitely some garbage results in there, but lots of good stuff too
14:32:04 <pbokoc> yeah, it seems like a pretty good list
14:32:51 * a2batic is here
14:35:34 <randomuser> sorry, got a call
14:37:22 <randomuser> there's not a priority thing
14:37:32 <randomuser> in pagure, it's either an issue or it is not
14:38:33 <bexelbie> randomuser, weird, the issue list has a priority column
14:38:34 <bexelbie> heh
14:39:09 <randomuser> i think you set up priority attributes of tags at a project level
14:39:16 <randomuser> will revisit later
14:39:27 <randomuser> #4 looks long term, hm
14:40:04 <randomuser> #link https://pagure.io/documentation-guide/branch/new-workflow
14:40:44 <randomuser> we've done some work on this, but it's ironically unpublished
14:41:04 <zoglesby> Not true!
14:41:16 <randomuser> #chair zoglesby
14:41:16 <zodbot> Current chairs: randomuser zoglesby
14:41:29 <randomuser> do continue
14:41:30 <zoglesby> Its published to https://pagure.io/docs/docs-fp-o/ with pintail
14:41:53 <randomuser> ah, very good
14:41:56 <bexelbie> I have updated the repo to support priorities
14:42:24 <randomuser> zoglesby, can you discuss where we are on this topic, and what remains, while I go afk for 96 seconds?
14:43:53 <zoglesby> This is very much a work as we go issue, as we flesh out details on issues, workflows, etc, we need to document them in that repo
14:44:36 <zoglesby> I don't expect this item to be done until we have a finished workflow, but we should be agile with this and publish early and often.
14:44:58 <zoglesby> Doing so will allow everyone to follow along
14:45:59 <bexelbie> +1 I'll try to put my notes there
14:46:00 <zoglesby> Also, everything that is included as of now is very rough and should be edited, nothing is done or locked in at this point.
14:46:24 <zoglesby> A lot of that was stream of consciousness from myself and randomuser
14:47:19 <randomuser> that's exactly the point I was going to make here - the documentation guide, especially now, should be a living document that we're all aware of and maintaining
14:48:05 <randomuser> oh, i should have been changing the topic as we discuss each issue
14:48:40 <randomuser> just a little time left, let's jump to #7
14:48:58 <randomuser> #topic pagure issue #7: create pintail config to build site
14:49:18 <randomuser> this does exist, but I haven't done a build recently
14:49:57 <randomuser> has anyone else? can we consider this initially done, and also WIP indefinitely?
14:50:11 <bexelbie> +1 for initially done
14:50:18 <bexelbie> and mark closed as it is WIP
14:51:10 <zoglesby> I am okay with that
14:51:58 <randomuser> making it so
14:52:59 <randomuser> #topic pagure#12
14:52:59 <randomuser> Set up a staging environment for new pintail instance
14:53:11 <randomuser> I'm going to work on this one this week
14:53:43 <randomuser> we should have or can get a couple instances to play with, or jenkins, or poor man's ci, or whatever is available
14:54:28 <randomuser> ci integration with pagure isn't a thing yet, i think, but we can still get a proof of concept going
14:55:07 <bexelbie> +1
14:55:41 <randomuser> with elasticsearch even
14:56:13 <randomuser> i don't have more detailed plans off the cuff though
14:56:19 <randomuser> #topic Open Floor
14:57:35 <zoglesby> That reminds me that I need to check in a change to the pintail config to disable elasticsearch for now, or it will fail to build
14:57:52 <zoglesby> Unless you install elasticsearch locally that is
14:57:59 * randomuser nods
14:58:22 <randomuser> what about maintaining a branch for local testing, and a separate branch for use in the build environment?
14:59:38 <zoglesby> Well until we have elasticsearch on anything it makes no diff
14:59:58 <randomuser> fair enough
15:00:10 <randomuser> OK, we're out of time now
15:00:16 <randomuser> see you around
15:00:19 <randomuser> #endmeeting