14:00:54 <sayan> #startmeeting fedora_hubs
14:00:54 <zodbot> Meeting started Tue Oct 18 14:00:54 2016 UTC.  The chair is sayan. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:00:54 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
14:00:54 <zodbot> The meeting name has been set to 'fedora_hubs'
14:00:59 * pingou here
14:01:04 <sayan> #topic Roll Call
14:01:09 <sayan> .hello sayanchowdhury
14:01:10 <zodbot> sayan: sayanchowdhury 'Sayan Chowdhury' <sayan.chowdhury2012@gmail.com>
14:01:11 <jcline> .hello jcline
14:01:11 <stickster> .hello pfrields
14:01:13 <zodbot> jcline: jcline 'Jeremy Cline' <jeremy@jcline.org>
14:01:17 <zodbot> stickster: pfrields 'Paul W. Frields' <stickster@gmail.com>
14:02:22 <sayan> #chair pingou stickster jcline
14:02:22 <zodbot> Current chairs: jcline pingou sayan stickster
14:02:27 <abompard> .hello abompard
14:02:28 <zodbot> abompard: abompard 'Aurelien Bompard' <aurelien@bompard.org>
14:02:34 <sayan> #chair abompard
14:02:34 <zodbot> Current chairs: abompard jcline pingou sayan stickster
14:04:32 <sayan> Going first with the PRs
14:05:47 <sayan> jcline: do you have still some update to do on #260?
14:06:10 <sayan> or we can go ahead and update the PR
14:06:14 <jcline> sayan, nope, I addressed the two comments you had. If everyone is satisfied I can rebase it and we can merge it.
14:06:41 <sayan> jcline: yes, just rebase it and then we can merge
14:06:58 <jcline> sayan, excellent
14:07:51 <sayan> we can merge abompard PR too after the jcline's PR merge
14:08:00 <abompard> cool
14:08:59 <jcline> abompard, it looks like you might get a conflict after #260 is merged, just so you know
14:09:14 <fm-hubs> pagure.pull-request.comment.added -- jcline commented on pull-request#260 of project "fedora-hubs" https://pagure.io/fedora-hubs/pull-request/260#comment-11492
14:09:14 <abompard> jcline: doesn't matter, I'll rebase
14:09:32 * stickster is still trying to get better at doing the right pull/rebase/push thing to his forks to make PRs work correctly
14:09:40 <stickster> ^ OT, let's not go into that here :-)
14:09:49 <jcline> abompard, cool. The stuff in the README moved to docs/dev-guide.rst I believe
14:09:58 <abompard> jcline: ah, perfect
14:10:17 <sayan> Yeah
14:10:47 <sayan> Moving to updates
14:11:08 <sayan> #topic IRC Widget
14:11:25 <sayan> #link https://pagure.io/fedora-hubs/issue/2
14:12:10 <sayan> I am right now working on creating users and authenticating them
14:13:21 <sayan> I built integrated redux-auth-wrapper using which we can redirect user if the user is not authenticated
14:13:26 <sayan> s/built//
14:14:04 <sayan> I will be writing the list of task before the next meeting that needs to be done
14:14:23 <sayan> basically breaking each task into small ones so that it is easier to track
14:14:47 <sayan> #action Break the integration of IRC Widget into small issues for easy tracking
14:15:32 <sayan> #topic Badges
14:15:53 * stickster agrees having some tasks broken out would make it easier to follow the meetings and see what needs to be done :-)
14:16:17 <sayan> yes, helps to see where the project is heading and how much is done
14:16:21 <stickster> hey also, sorry if people missed this, but mizmo sent regrets elsewhere... still has sick kids :-(
14:17:05 * sayan sends get well soon greetings
14:17:29 <sayan> Nothing to update on badges from my side
14:17:55 <sayan> #topic Plus-Plus
14:18:36 <sayan> I did not get time to see if the Plus Plus widget needs FAS3 :(
14:19:07 <sayan> #action sayan to check if the Plus Plus widgets needs FAS3
14:19:40 <sayan> #topic #halp widget
14:20:00 <sayan> abompard: what's your update on the #halp widget?
14:20:05 <abompard> so
14:20:13 <abompard> I think the UI is done now
14:20:21 <abompard> I'm quite happy with how it's shaping up
14:20:26 <stickster> sayan: I'm meeting up with a few people this afternoon (EDT) to discuss FAS3 status... I know that's a tangent here, just FYI
14:20:39 <abompard> since the widget is a bit complex, I wrote it in React
14:20:49 <sayan> cool, good to have an update :)
14:20:59 <abompard> I've started working on connecting it to datagrepper
14:21:27 <sayan> abompard: any branch you are working on?
14:21:28 <abompard> the only problem I have is that the search field that mizmo designed queries fields that are not indexed in datagrepper/datanommer
14:21:33 <sayan> that we can check?
14:21:51 <abompard> so I have to grab all recent messages, cache them, and filter afterwaards
14:22:21 <abompard> Yeah, my next step is to format my commits properly and push them to my branch
14:23:03 <abompard> sayan: it's going to be on https://pagure.io/fork/abompard/fedora-hubs
14:23:08 <abompard> I'll try to do that today
14:24:02 <abompard> I've made a couple structural changes in the way the JS is built
14:24:15 <abompard> because the Feed widget is not the only one to use React now
14:24:30 <abompard> so the webpack config changed a bit
14:24:40 <abompard> but it should work.
14:24:59 <abompard> By the way I'm not sure I have access to the dev server to test my code
14:25:38 <sayan> stickster: can you chair the meeting? caretaker has come down
14:26:02 <abompard> Done with my updates on the halp widget
14:26:42 <stickster> sayan: sorry, I'm on the phone at the moment... abompard or pingou, can you do the honors?
14:28:55 <abompard> hmm, never done that, but I can try
14:29:35 <pingou> it's easy :)
14:29:43 * pingou doesn't know the agenda
14:29:57 <abompard> me neither, trying to find the list of widgets
14:30:43 <abompard> alright, who here has widgets to report on? :-)
14:32:04 <jcline> Not I. I've just been working on the FMN SSE server.
14:32:28 * stickster trying to get done here on phone but it's not working, sorry for not being able to jump in
14:35:59 <abompard> Last meeting seemed to end with the widget updates
14:43:46 * stickster finally is off phone
14:44:04 <stickster> and... I see the meeting has somewhat petered out :-D
14:44:35 <stickster> we could use either a standardized agenda, or maybe restructuring to include active tickets, or both?
14:45:07 * stickster reads back
14:45:48 <stickster> #action abompard push commits to a branch on his fork
14:46:31 <stickster> abompard: do you need to consult with mizmo about the search field design to see how to tackle the issue with non-indexed fields?
14:47:21 <abompard> stickster: Hmm, I don't think the indexed fields will be of any use anyway, so I pretty much have to filter in the app
14:47:39 <stickster> Ah, I gotcha
14:47:42 <abompard> the indexed fields are the message dotted topic, the user, the date, etc.
14:47:47 <abompard> nothing from the message itself
14:48:28 <stickster> OK
14:48:56 <stickster> abompard: Hey, do you also need access to the dev server itself to test, or can you do it locally via the Vagrant config provided?
14:48:58 <abompard> I tried querying the Datanommer SQL directly, but that's not any better
14:49:07 * stickster notes the IP address in the README doesn't work :-(
14:49:17 <abompard> I didn't try vagrant, but I will.
14:49:40 <abompard> access to the dev server would be nice anyway
14:49:50 <stickster> perhaps that should be pointing to https://hubs-dev.fedorainfracloud.org ?
14:50:04 <jcline> stickster, my docs pr fixes it :)
14:50:26 <stickster> Thanks jcline! <-- sayan please review that and merge ASAP ;-)
14:50:27 <jcline> abompard, let me know if you run into any trouble with the Vagrant setup
14:50:37 <stickster> #action sayan review docs PR from jcline and get it merged ASP
14:50:39 <stickster> #undo
14:50:39 <zodbot> Removing item from minutes: ACTION by stickster at 14:50:37 : sayan review docs PR from jcline and get it merged ASP
14:50:40 <stickster> #action sayan review docs PR from jcline and get it merged ASAP
14:50:47 <abompard> jcline: okay, I almost totally new to it
14:50:55 <stickster> abompard: agreed, we can get you access I'm sure
14:51:08 <stickster> #action sayan get abompard access to hubs-dev for testing as well
14:51:11 <sayan> sorry for leaving in between, landlord came down for a room check :(
14:51:21 <stickster> abompard: the nice thing is it's easy enough even for me to use :-)
14:51:33 <stickster> sayan: so you had to hide all your contraband?  :-)
14:51:41 * stickster kidding!
14:51:57 <sayan> kind off :-)
14:52:29 <fm-hubs> pagure.pull-request.comment.added -- sayanchowdhury commented on pull-request#260 of project "fedora-hubs" https://pagure.io/fedora-hubs/pull-request/260#comment-11492
14:52:30 <fm-hubs> pagure.pull-request.closed -- sayanchowdhury merged pull-request#260 of project "fedora-hubs" https://pagure.io/fedora-hubs/pull-request/260
14:52:54 <sayan> ^^ done
14:52:56 <jcline> abompard, perfect. Hopefully you'll find all the things I took for granted and neglected to document.
14:53:14 <abompard> :)
14:53:31 <stickster> NICE
14:54:19 * stickster hands gavel back to sayan
14:55:04 <sayan> abompard: I'll give the access to the dev instance after the meeting
14:55:15 <sayan> vivek_: around?
14:56:22 <sayan> seems like vivek_ and saptaks are not around so skipping the Release widget
14:56:40 <sayan> jcline: which issue are you planning to work on?
14:58:29 <jcline> sayan, my plan was to get the fmn sse stuff sorted and then I guess https://pagure.io/fedora-hubs/issue/172 might be the ticket on the fedora-hubs side?
14:58:43 <sayan> jcline: +1
14:58:47 <jcline> It seems like that issue needs clarification though.
14:59:49 <sayan> jcline: skrzepto needs to update on that
15:00:28 <sayan> IIRC he did some work on the integration
15:01:42 <jcline> sayan, okay. I feel like I've got a pretty good handle on what needs to happen on the FMN side and it'll be a couple weeks (I'd guess) before that's all ready to go.
15:02:09 <sayan> jcline: sure
15:03:09 <sayan> #topic Open Floor
15:03:16 <sayan> Anything any body wants to share?
15:04:03 <sayan> Going ahead and ending the meeting
15:04:03 <jcline> sayan, I can do some more research on my own, but am I right in thinking the hubs "stream" is updated by listening to this SSE server? It looks like maybe https://pagure.io/fedora-hubs/pull-request/231 mocks it out for now?
15:04:19 <sayan> jcline: yes hubs stream uses it
15:04:37 <jcline> Okay, cool
15:04:38 <sayan> but it has some generated messages
15:05:12 <sayan> jcline: with proper integration, we get proper message :)
15:05:27 <sayan> Ending the meeting in
15:05:30 <sayan> 3.
15:05:31 <sayan> 2.
15:05:33 <sayan> 1.
15:05:35 <sayan> #endmeeting