15:01:28 <sayan> #startmeeting fedora_hubs
15:01:28 <zodbot> Meeting started Tue Nov 22 15:01:28 2016 UTC.  The chair is sayan. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:01:28 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
15:01:28 <zodbot> The meeting name has been set to 'fedora_hubs'
15:01:42 <stickster> .hello pfrields
15:01:43 <zodbot> stickster: pfrields 'Paul W. Frields' <stickster@gmail.com>
15:01:48 <vivek|mob> .hello vivekanand1101
15:01:48 <abompard> .hello abompard
15:01:49 <zodbot> vivek|mob: vivekanand1101 'Vivek Anand' <vivekanand1101@gmail.com>
15:01:53 <zodbot> abompard: abompard 'Aurelien Bompard' <aurelien@bompard.org>
15:01:56 <sayan> .hello sayanchowdhury
15:01:57 <zodbot> sayan: sayanchowdhury 'Sayan Chowdhury' <sayan.chowdhury2012@gmail.com>
15:02:02 <devyani7> .hello devyani7
15:02:03 <zodbot> devyani7: devyani7 'Devyani Kota' <devyanikota@gmail.com>
15:02:10 <mizmo1> .hello duffy
15:02:11 <zodbot> mizmo1: duffy 'Máirín Duffy' <fedora@linuxgrrl.com>
15:02:25 <a2batic> .hello a2batic
15:02:26 <zodbot> a2batic: a2batic 'Kanika Murarka' <murarkakanika@gmail.com>
15:02:28 <sayan> Sorry for that, I haven't slept properly in last couple of days :(
15:03:36 * mizmo1 was up every half hour of last night and is sympathetic :(
15:04:56 <mizmo1> how is everybody doing
15:05:01 <sayan> mizmo1: :(
15:05:10 <sayan> I am kindoff homeless :)
15:05:19 <sayan> #topic Action items from last meeting
15:05:27 <sayan> * sayan to test the halp_widget branch
15:05:29 <sayan> * mizmo to get saptaks better icon artwork for ticket #63
15:05:31 <sayan> * sayan to setup a time with devyani7_ and fix her issues with vagrant
15:05:33 <sayan> * mizmo to blog about the halp widget recursing down to errbot meetbot
15:05:35 <sayan> porting and future plans there (maybe a bit of discussion about
15:05:37 <sayan> matrix.org too)
15:05:39 <sayan> * abompard to investigate errbot config
15:06:10 <mizmo1> i got the artwork uploaded for saptaks here: https://pagure.io/fedora-hubs/issue/63#comment-42812
15:06:22 <mizmo1> and the blog post i promised is here: http://blog.linuxgrrl.com/2016/11/15/fedora-hubs-and-meetbot-a-recursive-tale/
15:06:35 * devyani7 clicks
15:06:41 <devyani7> mizmo++ :)
15:06:41 <zodbot> devyani7: Karma for duffy changed to 1 (for the f25 release cycle):  https://badges.fedoraproject.org/tags/cookie/any
15:06:59 <mizmo1> \o/
15:08:36 <a2batic> mizmo++
15:08:36 <zodbot> a2batic: Karma for duffy changed to 2 (for the f25 release cycle):  https://badges.fedoraproject.org/tags/cookie/any
15:08:37 <abompard> great blogpost mizmo1 :-)
15:08:59 <sayan> No update on the halp_widget, was busy with testing fedimg as AWS is deprecating shorter resource ids
15:09:13 <sayan> #action sayan to test the halp_widget branch
15:09:53 <sayan> I did sit with devyani7 to fix her issues
15:10:03 <devyani7> nod nod
15:10:16 <sayan> We solved a few issues and some are still left
15:10:36 <devyani7> sayan maybe reaction it?
15:10:56 <sayan> devyani7: better to create a issue for it
15:11:29 <sayan> as we know about the npm issue but even though I did a fresh setup via vagrant I could not reproduce it
15:11:42 <sayan> so we need to look into it
15:11:45 <devyani7> um, maybe if one more person reproduces it?
15:11:57 <sayan> devyani7: can you create an issue with the npm error log that you got?
15:12:08 <devyani7> sayan, yup, ok.
15:12:56 <sayan> devyani7: and then we can look into the issue on why your bookmarks is not loading
15:13:15 <sayan> #action sayan to setup time with devyani7 to check issues with hubs setup
15:13:26 <devyani7> sayan, ok.
15:14:11 <sayan> abompard: would you be giving the update while dicussing the ticket?
15:14:58 <abompard> Yeah, I started investigating errbot but I have no reply from the Openstack folks yet.
15:15:20 <abompard> I also spent quite some time on mailman / postorius / hyperkitty (bugs mainly) last week
15:15:29 <abompard> so, not much to report, sorry
15:15:41 <mizmo1> abompard: did you see my pull request for HK? :) ? :)?
15:15:42 * mizmo1 nags
15:16:26 <abompard> mizmo1: I didn't actually, and I got no notification email strangely
15:16:30 <abompard> but I'm going to check
15:17:01 <mizmo1> ah okay
15:17:29 * mizmo1 could have done something dumb, not great with git
15:17:38 <sayan> moving to tickets then
15:17:39 <abompard> that's weird, if gitlab forgets to notify me that's not good, I'll check it more actively
15:17:45 <mizmo1> https://gitlab.com/mailman/hyperkitty/merge_requests/31
15:17:50 <abompard> thanks mizmo1
15:18:11 <mizmo1> npp :) thank you for taking a look!
15:18:49 <abompard> mizmo1: I don't see an update since 2 months ago.
15:18:56 <abompard> but that's off topic, sorry
15:19:05 <abompard> mizmo1: lets talk privately after the meeting
15:19:07 <sayan> I am skipping IRC Widget as I plan to finish the badges widget and then work on the IRC
15:19:20 <mizmo1> abompard: (that one was a few months ago so that seems right)
15:19:52 <sayan> devyani7: is there any update on the bookmarks widget? I guess no as you are having issues with setup
15:20:03 <devyani7> nod nod
15:20:11 <devyani7> but...
15:20:35 <devyani7> was thinking about writing about how to implement the three layer integration
15:20:50 <devyani7> your thoughts?
15:21:18 <mizmo1> devyani7: more context about three layer integration? what do you mean?
15:21:21 <devyani7> mizmo^^
15:22:17 <devyani7> um, the vertical bookmarks bar...
15:22:31 <devyani7> will have 3 layers of bookmark modals
15:22:48 <devyani7> you suggested that, actually :P
15:23:27 <sayan> devyani7: so can you just ellaborate?
15:23:33 <mizmo1> devyani7: what do you mean by three layers of modals?
15:23:49 <mizmo1> devyani7: there should never be any more than 1 modal - we shouldn't ever nest modals, if that's what you mean.
15:24:08 <devyani7> yup, we discussed this.
15:24:18 <devyani7> um, no. No nested modals.
15:24:26 <mizmo1> this ticket right? https://pagure.io/fedora-hubs/issue/11
15:24:37 <mizmo1> no, we shouldn't ever nest modals....
15:24:37 <devyani7> 1.Listed bookmarks <-- less than 5
15:24:38 <sayan> mizmo1: yes
15:24:50 <devyani7> 2. MORE button <-- for more than 5 bookamrks
15:24:55 <mizmo1> devyani7: do you have a log?
15:24:55 <devyani7> the modal window^^
15:25:19 <mizmo1> we should have documented this in the ticket, but it seems maybe there was a misunderstanding.
15:25:23 <devyani7> mizmo1, um, gotta dig a bit. :P i saved it somewhere
15:25:44 <mizmo1> devyani7: okay. it would probably be helpful for you to have updated mockups in that ticket, right? so i can work on that today.
15:26:03 <mizmo1> i think maybe mockups can make things more clear
15:26:22 <devyani7> mizmo1, can I pass the log a bit later. (looking for them) :P
15:26:31 <mizmo1> okay sure!
15:26:32 <devyani7> yup, that will certainly be helpful
15:26:49 <devyani7> all the mockups are for horizontal bar
15:26:52 <devyani7> :)
15:26:54 <mizmo1> when you find it, send it to me at duffy at redhat dot com and i'll do the mockups when i get it
15:27:05 <devyani7> mizmo1, sure thing.
15:27:11 <devyani7> :)
15:27:45 <sayan> okay so IIRC if we click on the More button we plan to show all the bookmarks in a modal?
15:28:04 <devyani7> nod nod
15:28:39 <mizmo1> so, iirc what i'd suggested wasn't nested modals
15:28:42 <mizmo1> but an onion skin approach
15:28:48 <mizmo1> so for example.... show 5-7 bookmarks by default
15:28:50 <sayan> no nod nested modals
15:28:56 <sayan> s/nod/not
15:28:58 <mizmo1> and there's a little \/ arrow you click, that slides out like an accordion
15:29:06 <mizmo1> so you can see say 20 bookmarks
15:29:18 <mizmo1> then a button at the very bottom, you click on 'more' and then you get a modal of the full list
15:29:22 <mizmo1> so it's three layers:
15:29:26 <sayan> mizmo1: onion skin?
15:29:27 <mizmo1> - the small view in the vertical bar (just 5-7 bookmarks)
15:29:38 <devyani7> the hide<--> show logic ! right?
15:29:39 <mizmo1> - the full accordion view in the veritcal bar (20 bookmarks in the vertical bar)
15:29:44 <mizmo1> - the modal with the full list
15:29:46 <mizmo1> sayan: layers of an onion
15:29:51 <mizmo1> yeh
15:29:56 <mizmo1> it'd just slide open
15:30:03 <mizmo1> like an accordion (accordion is the UX pattern name)
15:30:09 <sayan> yeah
15:30:33 <sayan> The maximum number of bookmarks you can have is 20 then?
15:31:09 <mizmo1> something like this http://www.vandelaydesign.com/demos/accordion/
15:31:30 <mizmo1> sayan: probably the max in the sidebar should be 20 before ppl have to go to the modal to view more. i'd not hardcode those values so we could play with them and see what makes sense
15:31:50 <mizmo1> that sample btw isn't exactly what i'm talking about but sort of shows the vertical slide i'm talking about
15:33:01 <sayan> so, in first go you see 5 along with a more button
15:33:04 <mizmo1> devyani7: i think that's what i meant by 3 layers - not that there would be 3 levels of nested modals
15:33:21 <sayan> click one more shows you another `n` number of bookmarks along with a view more
15:33:39 <mizmo1> sayan: exactly
15:33:47 <sayan> and clicking on view more would show a modal with all the bookmarks where you can arrange maybe
15:34:03 <devyani7> mizmo1, yup, I intended to say the same, certainly not nested modals :P
15:34:05 <mizmo1> sayan: probably not arrange, just view
15:34:07 <mizmo1> but it could hvae a button to go into arrange mode
15:34:16 <sayan> mizmo1: Ok
15:34:26 <sayan> mizmo1: I'll just go and update the ticket
15:34:37 <mizmo1> coolio thanks sayan!
15:38:42 <sayan> mizmo1: you will be working on the revamped mockups, right?
15:39:34 <fm-hubs> pagure.issue.comment.added -- sayanchowdhury commented on ticket fedora-hubs#11: "Manage Bookmarks Widget (Modal)" https://pagure.io/fedora-hubs/issue/11#comment-43335
15:39:37 <sayan> moving to the next ticket
15:40:05 <sayan> #topic  Badges Widget for Project/Teams (with Path Support) https://pagure.io/fedora-hubs/issue/17
15:40:33 <sayan> I stumbled upon a bunch of issues last week on this
15:41:00 <sayan> mizmo1: What is Open + Non-mission Team Badges?
15:41:17 <sayan> as given in the mockup https://pagure.io/fedora-hubs/issue/17#comment-2500
15:43:41 * mizmo1 looks
15:44:00 <mizmo1> sayan: those are badges that aren't part of a track / path
15:44:08 <mizmo1> sayan: they are just sort of one-shot badges (does that make sense?) they aren't connected to others
15:44:13 <mizmo1> but are still related to the team
15:44:25 <mizmo1> eg you get a badge for going to the design team FAD... but it's not part of a badge mission
15:44:30 <mizmo1> it's still related to design team though
15:44:56 <sayan> mizmo1: oh! ok. I need to see it how that can be done then
15:45:45 <sayan> mizmo1: also I am fighting to show the team badge rank in a optimized way.
15:46:12 <sayan> mostly because badges does not know who all are the members of a hub
15:46:25 <mizmo1> ah okay
15:46:48 <sayan> so maybe I need to send all the fas usernames extract the data from badges and display it
15:46:49 <mizmo1> yeh that's a tricky one. deifnitely not as high priority as the rest of the widget though so if you wanted to punt it for now that would be ok
15:48:26 <sayan> mizmo1: ok, the rest are done, so I will add some dummy data and push the code for you make the UI
15:48:39 <fm-hubs> pagure.issue.new -- devyani7 opened a new ticket fedora-hubs#275: "package.json needs update, throws error while setting up hubs using vagrant" https://pagure.io/fedora-hubs/issue/275
15:49:32 <mizmo1> sayan: great!
15:50:06 <sayan> Also last week I wrote a script to populate the db with dummy data; though the script is ready there seems do be some issues
15:50:23 <sayan> due to which the db transaction is failing. I'm looking into that
15:53:41 <fm-hubs> pagure.issue.comment.added -- sayanchowdhury commented on ticket fedora-hubs#17: "Badges Widget for Project/Teams (with Path Support)" https://pagure.io/fedora-hubs/issue/17#comment-43336
15:54:23 <mizmo1> any other tickets to discuss?
15:54:35 <fm-hubs> pagure.issue.comment.edited -- sayanchowdhury edited a comment on ticket fedora-hubs#17: "Badges Widget for Project/Teams (with Path Support)" https://pagure.io
15:54:44 <sayan> ^^ updated the ticket
15:54:48 <sayan> yes
15:55:20 <sayan> #topic Current status in release cycle widget https://pagure.io/fedora-hubs/issue/63
15:55:31 <sayan> vivek|mob: any update on this ^^
15:56:50 <sayan> #topic #halp/help widget: Default in the CommOps Hub https://pagure.io/fedora-hubs/issue/98
15:57:12 <sayan> abompard: ^^ update on this one?
15:58:12 <abompard> sayan: it's what I said before, advancement in this tickets require changes in the meetbot plugin which require investigating errbot, etc... cf mizmo1's post ;-)
15:58:38 <abompard> unless i'm missing something
15:59:21 <sayan> abompard: nope :)
15:59:52 <sayan> investigating errbot is what needed
16:00:09 <sayan> btw, mizmo1 great blogpost :)
16:00:39 <mizmo1> ill update the ticket with a link to the blog post
16:00:39 <mizmo1> thanks sayan :)
16:00:44 <mizmo1> is there anything else going on i could blog that would be helpful?
16:01:26 <sayan> mizmo1: yeah, updating the ticket would be good
16:01:33 <abompard> mizmo1: if you hear of people being interesting in contributing, please let us know (and I'm particularly interested). I know it's obvious but eh :-)
16:01:37 <fm-hubs> pagure.issue.comment.added -- duffy commented on ticket fedora-hubs#98: "#halp/help widget: Default in the CommOps Hub" https://pagure.io/fedora-hubs/issue/98#comment-43337
16:01:56 <mizmo1> abompard: will do!
16:01:57 <abompard> mizmo1: (since you end you post with a call for help)
16:01:58 <sayan> abompard: yeah
16:02:27 * sayan is looking for React guys :)
16:02:34 <mizmo1> abompard: the blog post says 11 replies btw and the comments are blank - those are retweets basically and FB mentions
16:02:42 <abompard> okay
16:02:55 <sayan> We are over-time
16:03:02 <mizmo1> i did get some messages too from people asking when it would be ready bc they want it lol
16:03:03 <sayan> Going over and ending the meeting in
16:03:06 <mizmo1> but no volunteers yet
16:03:26 <sayan> 5.
16:03:28 <sayan> 4.
16:03:32 <sayan> 3.
16:03:33 <sayan> 2.
16:03:35 <sayan> 1.
16:03:37 <sayan> #endmeeting