15:01:48 <mboddu> #startmeeting RELENG (2021-04-20)
15:01:48 <zodbot> Meeting started Tue Apr 20 15:01:48 2021 UTC.
15:01:48 <zodbot> This meeting is logged and archived in a public location.
15:01:48 <zodbot> The chair is mboddu. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:01:48 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
15:01:48 <zodbot> The meeting name has been set to 'releng_(2021-04-20)'
15:01:48 <mboddu> #meetingname releng
15:01:48 <mboddu> #chair nirik sharkcz pbrobinson pingou mboddu dustymabe ksinny jednorozec
15:01:48 <mboddu> #topic init process
15:01:48 <zodbot> The meeting name has been set to 'releng'
15:01:48 <zodbot> Current chairs: dustymabe jednorozec ksinny mboddu nirik pbrobinson pingou sharkcz
15:02:12 <nirik> morning
15:02:39 <sharkcz> hi everyone
15:04:04 <mboddu> Lets get started
15:05:06 <mboddu> I dont have anything prepared, so lets go with the flow
15:06:32 <mboddu> #topic #8601 Packages that fail to build SRPM are not reported during the mass rebuild bugzillas
15:06:37 <mboddu> #link https://pagure.io/releng/issue/8601
15:07:07 <mboddu> This is because koji doesn't return failed builds that are failed in srpm phase
15:07:54 <sharkcz> right, it would need collecting all the task id for the submitted rebuild tasks
15:08:56 <sharkcz> or finding the initial tasks otherwise
15:09:02 <mboddu> I dont know why koji doesn't return them, cant we just file a ticket with koji?
15:09:24 <mboddu> I dont see the reason why they shouldn't in failed tasks list
15:09:29 <nirik> I think it doesn't have all the info it needs then...
15:09:41 <sharkcz> they are in failed tasks, but not in failed builds
15:09:42 <mboddu> koji web ui finds them
15:09:45 <nirik> but we could ask/file sure
15:10:02 <mboddu> #action mboddu will file a ticket koji upstream
15:10:22 <nirik> yeah, so its probibly not considering that a part of the build? it's just a task until it starts building?
15:10:35 <sharkcz> I think so
15:10:42 <nirik> it might also be a issue with our fedora-messaging plugin not emiting anything on srpm creation?
15:10:51 <mboddu> Maybe, but even then we can ask them if we grab those failed tasks through api
15:11:14 <mboddu> Or add another api for that...
15:11:59 <sharkcz> or just setup a query like all failed buildsrpm tasks submitted by releng, etc ...
15:12:06 <nirik> I think I recall now:
15:12:40 <nirik> when it's doing the build src.rpm it doesn't know what the NVR is... so if it was a failed build it wouldn't know what build could be retried
15:12:56 <nirik> but I could be misremembering
15:13:06 <sharkcz> i think this is correct
15:15:42 <mboddu> Yeah, I think you are right nirik, but there should be someway in the api to find these builds
15:16:54 <sharkcz> mboddu: I think there is already is api that could return the needed info, let me look ...
15:17:43 <sharkcz> the problem might be that those tasks only have a dist-git url, not a package name, but it could be extracted
15:17:46 <mboddu> sharkcz: Not that I know of, but that would help a lot
15:18:51 <sharkcz> listTasks()
15:19:16 <sharkcz> with a right set of options
15:20:41 <sharkcz> I could write a proof of concept for it I believe
15:22:05 <mboddu> sharkcz: Sure, I can try it as well
15:22:40 <mboddu> I wish they would have listed the state's numeric values and what they stand for... :(
15:22:49 <mboddu> I forgot where I found them last time
15:22:57 <mboddu> Probably dug around the code I guess
15:22:58 <sharkcz> ha, I found a script where I have used listTasks()
15:26:03 <mboddu> Okay, moving on
15:26:18 <mboddu> #topic #7067 Fix package ownership in koji
15:26:23 <mboddu> #link https://pagure.io/releng/issue/7067
15:26:48 <mboddu> I have a question for this:
15:27:13 <mboddu> Just grab the owner from dist-git repo and add that user as the package owner in koji?
15:27:39 <nirik> yeah.
15:28:06 <nirik> then I guess we need something (a toddler?) to keep it in sync when ownership changes
15:29:43 <nirik> or really the thing that syncs packages to koji could also sync owner perhaps?
15:29:44 <mboddu> Actually, we can just add it to https://pagure.io/fedora-infra/ansible/blob/main/f/roles/bodhi2/backend/templates/owner-sync-pagure.j2#_350
15:29:48 <nirik> yeah, that
15:30:01 <mboddu> nirik: Great minds think a like ;)
15:31:44 <mboddu> Actually, we can just update that script to grab the owner and set that owner
15:31:53 <mboddu> I think I can easily write that script
15:32:34 <nirik> but we still need to fix existing (one time)
15:34:03 <mboddu> Nope, we run that script as a cron, so next time when it runs that should fix it
15:34:44 <nirik> it would fix existing ones? ok, I guess I didn't look at it much recently... but great!
15:36:29 <mboddu> Yes, when it runs as a cron, it updates all the package lists
15:37:01 <mboddu> I will create a PR for it
15:37:17 <nirik> awesome.
15:37:25 <nirik> that will help the mass rebuild script at least
15:37:34 <nirik> as well as the koji-gc emails
15:39:37 <mboddu> Yup
15:44:30 <mboddu> #topic Open Floor
15:44:56 <mboddu> nirik: I created https://pagure.io/pungi-fedora/pull-request/1029
15:45:26 <sharkcz> a quick question, does bodhi find commit permissions correctly for newly sponsored people?
15:45:36 <sharkcz> after the FAS migration
15:48:21 <mboddu> Not sure about that, nirik ^ ?
15:49:01 <nirik> I... don't know. ;)
15:49:12 <sharkcz> I have them to logoff/logon and report back
15:49:13 <nirik> for who can file updates?
15:49:20 <sharkcz> ok, will see
15:49:23 <sharkcz> yes
15:49:40 <sharkcz> I added them as contributor to epel8 branch
15:50:10 <sharkcz> and the intiial error was "Builds : treydock does not have commit access to conman"
15:50:26 <sharkcz> but he has pushed a change successfully
15:50:34 <sharkcz> I'll keep you informed :-)
15:52:49 <nirik> ah, the contributor thing I think is in the next bodhi
15:52:52 <nirik> the one in stg now.
15:53:02 <mboddu> Yeah, that might be it
15:53:37 <sharkcz> ok, thanks, will change that to "commiter"
16:00:23 <mboddu> Anything else before I close the meeting?
16:00:31 <sharkcz> nope
16:00:39 <mboddu> Thank you everyone for joining
16:00:44 <mboddu> See you all next week
16:04:18 <nirik> thanks mboddu
16:23:15 <nb> mboddu++
18:00:31 <zodbot> nirik: Error: Can't start another meeting, one is in progress.
18:00:32 <nirik> #chair mboddu nirik smooge pingou mobrien nb
18:00:32 <zodbot> Current chairs: dustymabe jednorozec ksinny mboddu mobrien nb nirik pbrobinson pingou sharkcz smooge
18:00:32 <nirik> #meetingname fedora_infrastructure_ops_daily_standup_meeting
18:00:32 <nirik> #info meeting is 30 minutes MAX. At the end of 30, its stops
18:00:32 <nirik> #info agenda is at https://board.net/p/fedora-infra-daily
18:00:32 <zodbot> The meeting name has been set to 'fedora_infrastructure_ops_daily_standup_meeting'
18:00:33 <nirik> #info reminder: speak up if you want to work on a ticket!
18:00:34 <nirik> #topic Tickets needing review
18:00:36 <nirik> #info https://pagure.io/fedora-infrastructure/issues?status=Open&priority=1
18:00:57 <ssmoogen[m]> here
18:01:09 <dtometzki> hi
18:01:10 <ssmoogen[m]> wait is there a meeting in progress?
18:01:10 <mboddu> I am here
18:01:46 <ssmoogen[m]> mboddu: I don't think you ended the releng meeting
18:01:49 <nirik> zodbot: listmeetings
18:01:49 <zodbot> nirik: ('#ansible-docs', 'freenode'), ('#fedora-meeting', 'freenode'), ('#fedora-meeting-3', 'freenode')
18:01:51 <mboddu> Yeah, right
18:01:53 <mboddu> Sorry
18:01:55 <mboddu> #endmeeting