18:05:11 <stickster> #startmeeting Fedora Insight
18:05:11 <zodbot> Meeting started Thu Mar 25 18:05:11 2010 UTC.  The chair is stickster. Information about MeetBot at http://wiki.debian.org/MeetBot.
18:05:12 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
18:05:19 <pcalarco> ok thx
18:05:22 <stickster> #chair stickster pcalarco rbergeron mchua_afk quaid hiemanshu
18:05:23 <zodbot> Current chairs: hiemanshu mchua_afk pcalarco quaid rbergeron stickster
18:05:37 <stickster> #meetingname Fedora Insight
18:05:38 <zodbot> The meeting name has been set to 'fedora_insight'
18:05:44 * mchua here
18:05:47 <stickster> #topic Roll call
18:05:48 <mchua> thanks to stickster for the ping
18:05:50 * stickster 
18:05:51 <pcalarco> Hi Mel!
18:05:54 <stickster> np mchua!
18:05:56 * ke4qqq is here
18:06:00 * rbergeron is here
18:06:07 <pcalarco> pcalarco is here
18:06:54 * ke4qqq steps away immediately after announcing he is here
18:07:09 <stickster> heh
18:07:23 <stickster> pcalarco: Do you have the baton here?
18:07:26 <rbergeron> gg :)
18:07:31 <pcalarco> sure, thx
18:07:35 * stickster not hinting you should hit ke4qqq or anything ;-)
18:07:44 <pcalarco> okay, so we have some packaging work that needs to be done
18:08:01 <pcalarco> with what is currently on publictest6 and move that over to staging
18:08:04 * rbergeron has cookies for that
18:08:24 <pcalarco> including the new pagemaster module and if not already on there Zikula 1.2.2
18:08:46 <pcalarco> we also have a couple template items open, documented at
18:08:55 <pcalarco> #link https://fedoraproject.org/wiki/Fedora_Insight#FWN
18:09:26 <pcalarco> I have been testing with more content and have opened one new TRAC item for templating
18:10:07 <pcalarco> stickster: I did add the SystemTap article and interview from F12 on pt6 as well; layout is a bit messy
18:10:26 <pcalarco> and that is basically where we are
18:11:05 <pcalarco> and the pagemaster module should go into the fedorahosted repo, I think too
18:11:42 * stickster looks at pages
18:12:13 <rbergeron> are there bz's open for the packaging items that need to be done?
18:12:21 <pcalarco> #link http://publictest6.fedoraproject.org/zikula/index.php
18:12:23 * rbergeron is looking at long list of tickets
18:12:23 <stickster> rbergeron: Yeah, that's what I was looking for on the Insight page.
18:13:02 <stickster> #link https://fedoraproject.org/wiki/Zikula#Module_status
18:13:24 <stickster> We need something on that page that's easier to read -- it's hard to tell what's done
18:13:32 <rbergeron> https://fedoraproject.org/wiki/Fedora_Insight#Packaging
18:13:41 <stickster> https://bugzilla.redhat.com/showdependencytree.cgi?id=504066&hide_resolved=1
18:13:44 <rbergeron> what's the difference between these two lists (/me needs to go do a diff)
18:14:00 <rbergeron> oh, big list of stuff
18:14:32 <rbergeron> pcalarco - you said there was "new" pagemaster modules?
18:14:46 <stickster> mchua: OK, who can help us sort out a priority list of things to do here?
18:14:47 <rbergeron> are the new packaging items you refer to in the list on https://fedoraproject.org/wiki/Zikula#Module_status
18:15:06 <pcalarco> the items on the Zikula page are most logistics, the items on the FI page are most templating/theme with a tiny bit of logistics
18:15:08 <stickster> Sounds like first and foremost is making sure we're using the right code (and all of it) wherever it's needed.
18:16:13 <pcalarco> yes, so packaging the version of pageamster on pt6 that Simon hand-installed into the repo, and then moving that over to staging?
18:16:25 <stickster> Yes.
18:16:45 * hiemanshu is here now
18:16:50 <stickster> I really think that it's not a good idea for us to be installing things on the test system *without* packaging at the same time
18:16:53 <pcalarco> Hi hiemanshu!
18:16:55 <rbergeron> hi hiemanshu :)
18:17:00 <hiemanshu> hello rbergeron pcalarco
18:17:01 <stickster> Because otherwise it's unclear what's done and what's not
18:17:39 <stickster> pcalarco: Is anyone packaging pagemaster right now?
18:17:54 <hiemanshu> stickster: I was looking at doing that
18:17:56 <pcalarco> hiemanshu: you did a bit of this, right?
18:17:58 <stickster> And what version are we supposed to be looking at?
18:18:04 <hiemanshu> stickster: the one from the svn
18:18:12 <stickster> hiemanshu: How far did you get?
18:18:29 <hiemanshu> stickster: Should have it done tomorrow my time
18:18:34 <stickster> Wow, cool.
18:18:44 <hiemanshu> thats in about 6-8 hourts
18:18:46 <hiemanshu> hours**
18:18:58 <stickster> #action hiemanshu packaging pagemaster, expects to be done tomorrow his time (Fri 2010-03-26)
18:19:18 <hiemanshu> stickster: FYI Friday for me starts in 12 mins
18:19:22 <stickster> heh
18:19:30 * rbergeron passes hiemanshu $drinkofchoice
18:19:34 <rbergeron> :)
18:19:41 <hiemanshu> rbergeron: beer in my hand now :)
18:20:18 <stickster> I still see a bunch of packages on that BZ dependency list too. My name is on one of them! And I see a few other people there, not all of them here... abadger1999, sparks, J5
18:21:05 <hiemanshu> Some of them got into infra repo as well
18:21:08 <stickster> I wonder if we're supposed to be looking at later versions for all these
18:21:10 <hiemanshu> but into fedora
18:21:20 <stickster> I know there was massive change in upstream as a result of our licensing stuff.
18:21:35 <hiemanshu> stickster: I am picking up working stuff from pt6
18:21:44 <stickster> pcalarco: Did itbegins give you any idea when he'd be around for consultation next?
18:21:47 <hiemanshu> so if a specific version works, no upgrade without testing
18:22:11 <pcalarco> stickster: no, did not hear from Simon; he just moved to London, so is likely busy
18:22:13 <stickster> hiemanshu: OK, tanks
18:22:16 <stickster> *thanks
18:22:50 <stickster> crud, topic's out of date #topic Zikula modules
18:22:55 <stickster> #topic Zikula modules
18:23:09 <stickster> pcalarco: What specifically do we need to deal with next?
18:23:22 <rbergeron> stickster taking the words out of my mouth
18:23:32 <hiemanshu> stickster: FWN theming
18:23:39 <pcalarco> after the module gets moved over, the next is moving over the database from pt6 to staging
18:23:44 <rbergeron> is there a prioritized list of things to do that we can tackle or delegate for work over the next week?
18:24:01 <stickster> rbergeron: I think "delegate" is not going to work here unless someone's already signed up.
18:24:04 <rbergeron> well
18:24:08 <rbergeron> you're corret :)
18:24:16 <rbergeron> i mean ping people on who are already on the boat :)
18:24:21 <stickster> mos' def
18:24:42 <hiemanshu> pcalarco: I am going to take care of that as well, since I have access to the servers
18:24:57 <pcalarco> hiemanshu: groovy, thx
18:25:06 <rbergeron> because if people are looking at a big list - i think it woudl be nice to know which ones are more important :)
18:25:24 <pcalarco> then for me its the theming tickets on the Fedora Insight wiki page
18:25:33 <pcalarco> #link https://fedoraproject.org/wiki/Fedora_Insight#FWN
18:25:33 * rbergeron , for the record, isn't signed up for anything :)
18:25:38 <hiemanshu> no blockers there though
18:25:45 <hiemanshu> rbergeron: you aren't worth it "{
18:25:47 <hiemanshu> :P
18:25:49 * hiemanshu runs
18:25:52 <stickster> #info Next big ticket item is doing the theming shown in tickets here: https://fedoraproject.org/wiki/Fedora_Insight#FWN
18:26:03 * rbergeron will withhold cookies for that! :)
18:26:07 <pcalarco> well, they are blockers for me to use this thing constructively for FWN
18:26:33 <hiemanshu> Well those tickets are mine too
18:26:35 <pcalarco> I perhaps should have labelled them so; still learning TRAC
18:26:54 <stickster> hiemanshu: I worry that you've got all the action items here! Sounds like a lot of work.
18:26:57 <stickster> How can we get you some help?
18:27:08 <hiemanshu> pcalarco: sprint this weekend? I am up for it
18:27:15 <pcalarco> sure, I can
18:27:25 <hiemanshu> stickster: get a larger boat and push more people into it
18:27:27 * stickster can probably help Saturday but Sunday will be hard
18:27:29 <stickster> hiemanshu: :-)
18:28:14 <hiemanshu> stickster: and dont worry about them, I'll handle em all
18:29:02 <pcalarco> hiemanshu: it might be of value to get a couple people conversant with theme changes/templating
18:29:41 <pcalarco> right now we have too many single points of failure, methinks
18:29:42 <hiemanshu> pcalarco: we spoke about it remember :)
18:29:50 <mchua> Do we all know what target dates we're aiming for, for these various milestones we're discussing? (pt6 --> staging --> production)?
18:30:08 <stickster> And when the Infrastructure freezes lift?
18:30:14 <stickster> There's a pretty small window of opportunity there.
18:30:28 <pcalarco> mmcgrath mentioned that we would need to get this to production with milestone for F13 before freeze
18:30:36 <pcalarco> don't know when that is
18:30:57 <stickster> http://fedoraproject.org/wiki/Release_Infrastructure_SOP#Change_Freeze
18:31:04 <mmcgrath> pcalarco: our final freeze starts 2 weeks before the final release.
18:31:25 <mmcgrath> we're also frozen right now though until 1 day after the beta release.
18:32:01 <stickster> So the freeze lifts April 7, and a new freeze starts April 27.
18:32:04 <pcalarco> mmcgrath: thanks!
18:32:20 <stickster> #info Infrastructure Beta freeze lifts April 7, and Final freeze starts April 27.
18:33:04 <stickster> That gives us a little under three weeks -- we need to figure out what we're prepared to have staged on the 7th, and go to production by, say, a week or two later.
18:33:37 <stickster> We have theme issues that it sounds like hiemanshu may have straightened out this weekend.
18:33:59 <hiemanshu> stickster: we can test it on pt6, then I'll package it right away
18:34:14 <hiemanshu> so that shouldn't be a problem
18:34:19 <stickster> The packaging issues are hazier, to me at least -- hiemanshu, you can't be doing all of those too, can you?
18:34:34 <hiemanshu> stickster: I am the packager for the theme
18:35:05 <stickster> hiemanshu: Sorry, by that second part I meant, packaging of any remaining Zikula modules. You can't be doing all of those too, can you?
18:35:18 <hiemanshu> stickster: most of them are *done*
18:35:20 <stickster> Ah
18:35:29 <stickster> OK, I keep missing that salient fact in all this
18:35:29 <hiemanshu> IIRC only pagemaster remains
18:35:42 * stickster is stuck on that BZ dependency tree, which is somewhat false then.
18:35:54 <hiemanshu> stickster: most of them are in infra repo
18:35:54 * stickster promptly clears it from his view for now!
18:35:57 <hiemanshu> not in fedora
18:36:21 <stickster> We do need to fix that, but that's going to require some further deep-diving on versioning.
18:36:25 * stickster puts that aside.
18:37:14 <stickster> mchua: pcalarco: Is there work we can do independently on assigning roles and making sure that FWN beat writers and other content creators have power to do useful content writing, editing, and publishing? Or has all that been done too?
18:37:45 * stickster worries he's behind on some of this, so apply cluebat please.
18:37:54 * mchua is definitely behind on much of this, cluebat can haz?
18:37:56 <pcalarco> mchua: the roles so far are pretty much writers and editors so far
18:38:04 <stickster> ha
18:38:06 <stickster> no bat for you mchua
18:38:44 <pcalarco> at least for FWN; I think we should have different editors for other content types
18:38:51 * rbergeron is behind on all of it so ;)
18:39:02 <pcalarco> so not all content editing goes through one person
18:39:24 <stickster> pcalarco: I agree.
18:39:59 <pcalarco> and the editors can work together to establish conventions and such for consistency across FI
18:40:26 <stickster> *nod
18:40:35 <stickster> pcalarco: Have those editors been identified?
18:40:54 <stickster> Or is it basically people like rbergeron, you, (maybe me), and one or two other people already involved
18:40:55 <stickster> ?
18:41:10 <pcalarco> stickster: not to date; opportunities there
18:41:20 <stickster> pcalarco: Who knows how to assign those roles?
18:41:47 <pcalarco> stickster: I think this could be driven out of Marketing
18:41:53 * stickster trying to drive toward "actionable stuffs" so we're not spending this hour just playing catch up
18:42:14 * hiemanshu has the urge to raise his hand, but steps back
18:42:16 <stickster> rbergeron: Can you identify some people to fill those roles, and then figure out and document how to assign them?
18:42:23 <stickster> hiemanshu: You're doing quite enough already, thank you :-)
18:42:27 <stickster> We need to spread the load a bit here.
18:42:36 * rbergeron is scrolling back up - just ran out of battery
18:42:38 <stickster> ah
18:42:40 <rbergeron> but, yes
18:42:56 <hiemanshu> rbergeron: if you need help, ping me, I can walk you through
18:42:57 <rbergeron> is there a timeline for making the decision?
18:43:03 <rbergeron> or getting owners
18:43:04 <stickster> I think the writers have in large part already self-identified. Several people on Marketing, and of course the FWN beat writers
18:43:07 <rbergeron> i should say
18:43:44 <stickster> rbergeron: If you think it's possible to do this by the end of the weekend, that would be good. We want to "rocket" through some of this since we're up against an April 7th opening of the Infra freeze.
18:43:59 <rbergeron> hiemanshu: yes, let's get together and talk - maybe tomorrow or saturday?
18:44:18 <rbergeron> probably tomorrow? isn't it midnight there? :)
18:44:21 <hiemanshu> rbergeron: tomorrow same time?
18:44:26 <rbergeron> yes, that works. :)
18:44:30 <hiemanshu> rbergeron: dont worry about that, $dayjob until 5 AM :P
18:44:34 * rbergeron nods
18:44:43 <stickster> #action rbergeron Identify several editors for both Marketing and FWN, learn how to assign these roles in Zikula, and document that appropriately -- by end of weekend (Sun 2010/03/28)
18:44:52 <rbergeron> stickster: yes, that should work - if i think it's going to be a problem i'll know straight after talking to hiemanshu
18:45:01 <stickster> OK
18:45:23 <rbergeron> do we have a wiki page with any framework there at all that i should be looking at?
18:45:30 * stickster not sure what other next steps are. pcalarco, hiemanshu, rbergeron, mchua: ?
18:45:36 <rbergeron> other than just FI itself :)
18:45:43 <pcalarco> stickster: I will volunteer for editing FWN content for FI
18:46:23 <rbergeron> so there is no other packaging issues other than getting pagemaster in?
18:46:33 <hiemanshu> rbergeron: AFAIK no
18:46:34 <pcalarco> next step I think is documenting the workflow as itbegins has designed this; I can take responsibility for that
18:47:33 <stickster> pcalarco: That's the FWN workflow, right?
18:47:43 * stickster preparing to wield #action again but wants to get it right :-)
18:47:57 <pcalarco> sticksetr: both FWN pubtype and general content, which are both defined
18:48:16 <stickster> So when you document that workflow, what's actually happening?
18:48:28 <stickster> Are you writing a wiki page, or is this something you do in Zikula itself?
18:48:42 <pcalarco> I will document what steps for each, with screenshots on a wiki page
18:48:57 <pcalarco> screenshots from Zikula
18:49:59 <pcalarco> the general content pubtype for pagemaster is simpler than general
18:50:08 <pcalarco> than FWN rather
18:52:35 <stickster> OK
18:52:42 <stickster> Sorry for delay, had an OOB contact there
18:53:03 <rbergeron> OOB?
18:53:06 <rbergeron> oh
18:53:09 <stickster> #action pcalarco will document steps for both the FWN pubtype workflow, and for the general content workflow, both of which are already created in Ziula
18:53:12 <stickster> #undo
18:53:13 <zodbot> Removing item from minutes: <MeetBot.items.Action object at 0x2b03af35ed50>
18:53:15 <stickster> #action pcalarco will document steps for both the FWN pubtype workflow, and for the general content workflow, both of which are already created in Zikula
18:53:19 <stickster> out-of-band
18:53:20 * rbergeron was thinking some sort of x-files outofbody type experience
18:53:24 <stickster> haha
18:53:38 <stickster> OK, what else can we accomplish in the next week to move forward with all due speed?
18:54:00 * hiemanshu has nothing
18:55:04 <stickster> Okey dokey
18:55:11 <stickster> pcalarco: I leave the gavel in your hands
18:55:20 * stickster has nothing else to add but wants to help where he can
18:55:56 <pcalarco> so I think what I hear is that rbergeron and hiemanshu will get together tomorrow, and we will have a sprint this Saturday
18:56:15 <hiemanshu> pcalarco: saturday and sunday
18:56:15 <stickster> pcalarco: Can you and I agree to meet up on ~Wed to make an agenda for this meeting next week, same time & place?
18:56:24 <pcalarco> does this time work for everyone for weekly meetings?
18:56:35 * stickster is OK with it, waits to hear from everyone else
18:56:35 <pcalarco> yes\
18:56:51 * hiemanshu is happy with it
18:57:02 * rbergeron nods
18:57:04 <stickster> mchua: rbergeron: quaid: anyone_else: ?
18:57:08 <stickster> sorry rbergeron :-)
18:57:15 <rbergeron> it's okay :)
18:57:20 <stickster> Well, that's definitely a quorum at least
18:57:23 <stickster> Let's do it.
18:57:30 <pcalarco> yay!
18:57:37 <stickster> #action stickster to get with pcalarco and anyone else interested Wednesday evening for agenda-making
18:57:39 * rbergeron hands stickster the gavel from pcalarco temporarily
18:57:52 <stickster> #topic Next meeting
18:58:00 <pcalarco> what time UTC Wed?
18:58:14 <stickster> #agreed Next meeting, same time/channel -- 1800 UTC Thu 2010-04-01
18:58:17 <stickster> (no foolin') :-)
18:58:20 <stickster> pcalarco: Hm
18:58:52 <stickster> How about... around the Docs meeting? say, 6:45pm US Eastern time (2245 UTC)?
18:58:54 <pcalarco> 2400 UTC/8:00 pm Eastern?
18:58:59 <stickster> oh
18:59:06 <stickster> Yyyyyy...
18:59:07 <stickster> yes.
18:59:08 <stickster> I could do that.
18:59:09 <pcalarco> is that too late?
18:59:12 <stickster> Nope
18:59:14 <pcalarco> ok great
18:59:20 * hiemanshu will miss it
18:59:36 <hiemanshu> 2400 UTC = 5:30 AM
18:59:37 <stickster> pcalarco: #fedora-mktg OK?
18:59:45 <pcalarco> stickster: yes
19:00:04 * rbergeron is looking at a lot of times and wondering if this is the agenda meeting or the meeting meeting
19:00:14 <hiemanshu> rbergeron: agenda meeting
19:00:15 <stickster> #agreed pcalarco & stickster (at least) to meet 0000 UTC 2010-04-01 (8pm Eastern Wednesday 2010-03-31) for agenda making
19:00:18 <rbergeron> ah
19:00:29 <stickster> Wednesday agenda, Thursday Insight meeting
19:00:33 <stickster> cool?
19:00:36 * mchua will be taking a pass through FI stuff between now and next meeting to catch up - I'm far too behind, apologies folks.
19:00:38 * rbergeron is down with that
19:00:38 <pcalarco> aye
19:00:40 <mchua> +1
19:00:44 <stickster> pcalarco: It's all yours, take us outta here!
19:00:59 <pcalarco> okay, antyhiny else for the group?
19:01:08 <stickster> nada
19:01:09 <hiemanshu> I have to run, ASOT starting now
19:01:14 <stickster> Thanks hiemanshu!
19:01:15 * mchua has to jet as well
19:01:16 <pcalarco> I think we are done, then, thanks all!
19:01:19 <mchua> thank you pcalarco!
19:01:48 * stickster waiting for the bell...
19:01:58 <pcalarco> thanks to everyone who came!
19:01:59 <pcalarco> 4
19:02:00 <pcalarco> 3
19:02:00 <pcalarco> 2
19:02:01 <pcalarco> 1
19:02:02 <hiemanshu> #endmeeting