16:00:47 <pwhalen> #startmeeting Fedora IoT Working Group Meeting
16:00:47 <zodbot> Meeting started Wed Nov 23 16:00:47 2022 UTC.
16:00:47 <zodbot> This meeting is logged and archived in a public location.
16:00:47 <zodbot> The chair is pwhalen. Information about MeetBot at https://fedoraproject.org/wiki/Zodbot#Meeting_Functions.
16:00:47 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
16:00:47 <zodbot> The meeting name has been set to 'fedora_iot_working_group_meeting'
16:00:47 <pwhalen> #chair pwhalen pbrobinson coremodule
16:00:47 <zodbot> Current chairs: coremodule pbrobinson pwhalen
16:00:47 <pwhalen> #topic roll call
16:00:55 <pwhalen> Good morning folks, who's here today?
16:01:01 * coremodule is here
16:01:07 * runcom is here
16:01:08 * pbrobinson o/
16:01:27 <pwhalen> aha, coremodule you're welcome to take over :)
16:01:33 <idiez> hello there
16:01:37 <coremodule> lol
16:01:41 <sarmahaj> hello !
16:01:50 <pwhalen> welcome idiez runcom sarmahaj!
16:02:36 <coremodule> #topic 1) ==== Working Group process and admin  ====
16:02:36 <coremodule> #link https://docs.fedoraproject.org/en-US/iot/
16:02:55 <coremodule> What do we have for docs/admin today?
16:02:58 <pbrobinson> the docs could do with some review for f37
16:03:58 <pwhalen> Agreed. Remove any remain references to armhfp as well.
16:04:29 <coremodule> #info Docs for F37 need to be looked at, any remaining references to armhfp should be removed as well.
16:04:32 <pbrobinson> well f36 will still be supported but we should at least have notes around it being EOL
16:05:23 <pwhalen> it will still work, but stable is now f37
16:06:04 <pbrobinson> the armhfp stable will remain on f36 and we'll do updates there until f36 EOL
16:07:10 <coremodule> #info Information regarding F36 armhfp should be left alone we no longer support F36.
16:07:43 <coremodule> Anything else here?
16:08:16 <pwhalen> nothing from me
16:08:32 <pbrobinson> coremodule: it should be updated to reflect that f36 is the last supported release of armhfp
16:10:11 <coremodule> #info The docs should reflect that F36 is the last release to support armhfp.
16:10:20 <coremodule> #topic 2) ==== Fedora 37 status ====
16:10:21 <coremodule> #info Fedora-IoT-37-20221121.0
16:10:21 <coremodule> #link https://openqa.fedoraproject.org/tests/overview?distri=fedora&version=37&build=Fedora-IoT-37-20221121.0&groupid=1&groupid=5
16:11:46 <pbrobinson> we finally have a signed release as of last night, I will sync it shortly
16:11:57 <pbrobinson> updates are running as per normal
16:12:06 <pwhalen> \0/
16:12:54 <coremodule> thanks pbrobinson
16:13:02 <pwhalen> coremodule: did you have a chance to look at the zezere failure?
16:14:09 <coremodule> No, I haven't looked at it. I restarted the tests, but if they don't work, I'll see what I can do today.
16:14:51 <pwhalen> thanks.
16:16:04 <coremodule> Okay, moving to F38
16:16:05 <coremodule> #topic 3) ==== Fedora 38 status ====
16:16:05 <coremodule> #info Fedora-IoT-38-20221005.0
16:16:05 <coremodule> #link https://openqa.fedoraproject.org/tests/overview?distri=fedora&version=38&build=Fedora-IoT-38-20221005.0&groupid=1&groupid=5
16:16:22 <pbrobinson> so from a feature PoV....
16:16:24 <pwhalen> compose is still failing
16:17:01 <pbrobinson> yes, I think it's getting there, pwhalen did you have any update on the anaconda issues? I think that moved forward a little this week?
16:17:38 <pwhalen> just that the osbuild team is looking at the anaconda issue
16:18:27 <pbrobinson> what other bits are still failing
16:18:37 <pbrobinson> are the raw images passing or failing?
16:18:48 <pwhalen> I've not looked further since filing the issue, but there are some others i need to report as well.
16:18:49 <pbrobinson> there's also the double date naming issue
16:19:12 <pwhalen> The last attempt failed before getting to the disk images, meant to ask you about that
16:19:19 <pbrobinson> #action pwhalen to follow up with osbuild issues
16:19:38 <pwhalen> :) will do
16:19:51 <pbrobinson> the disk images should be able to run in parallel to the iso installer ones now, at least in theory
16:20:30 <pwhalen> but the disk images were passing previously, the iso was failing but should now work.. we just havent had a successful compose since
16:20:40 <pbrobinson> in the old compose it went ostree -> installer -> raw images as the raw images used installer+kickstart to create the raw images
16:21:10 <pbrobinson> but in osbuild the raw images are generated directly from ostree -> raw images
16:21:48 <pbrobinson> right, so we need to look why the compose was failing, I don't think it should just be because "rawhide" as main composes aren't failing
16:23:12 <pwhalen> I'll attempt another compose today, dig a little more
16:23:29 <pbrobinson> right, let me get f37 synced and then it's all yours
16:23:34 <pwhalen> it failed on the runroot task, but not looked at the details
16:23:35 <pwhalen> ok
16:23:54 <pbrobinson> so moving on
16:24:14 <pbrobinson> I got to the bottom of the IMA issue, there was a missing patch on a sigul build
16:24:41 <pbrobinson> so we should have a fix there deployed soon and that should fix signing for new 37+ builds
16:25:00 <pbrobinson> the signatures are actually in the rpms, just not in the right location :-/
16:25:42 <pbrobinson> idiez: FYI for you too ^^
16:25:45 <pwhalen> thanks for the update there
16:26:28 <idiez> pbrobinson: yep!
16:26:59 <pbrobinson> and I should have a new update on the FDO package probably tomorrow, just finishing up an update there
16:27:53 <pwhalen> looking at F38 changes, I see - 'Enable bootupd for Fedora Silverblue & Kinoite'
16:28:05 <pbrobinson> and for F-38 features, I think other than those pwhalen and I spoke about simplified provisioning for F-38
16:28:10 <pwhalen> sounds like we want that too
16:28:29 <pbrobinson> I think he and runcom can own that as a feature and I can assist them in the whole process
16:28:47 <pwhalen> agreed.
16:29:00 <runcom> yeah
16:30:46 <pwhalen> pbrobinson: the bootupd change? I assume we're doing that too, be good to add us to the change
16:31:16 <pbrobinson> yes, good point, I had meant to bring that up, I think it makes sense but I've not read it up yet
16:31:41 <pbrobinson> runcom: thoughts on bootupd?
16:31:56 <pwhalen> #info F38 change: Enable bootupd for Fedora Silverblue & Kinoite
16:31:56 <pwhalen> #link https://fedoraproject.org/wiki/Changes/FedoraSilverblueBootupd
16:32:03 <runcom> I'm +1 on it, we've been discussing with timothee in the past too
16:32:57 <pbrobinson> I don't think we're ready for containers and I don't believe the owners of the feature have actually engaged with the iot wg other than throwing a bug over the fence
16:33:22 <runcom> which one?
16:33:57 <pbrobinson> https://bugzilla.redhat.com/show_bug.cgi?id=2129654
16:34:25 <runcom> have we changed topic to that?
16:34:40 <runcom> thought we were still at bootupd
16:35:03 <pbrobinson> sorry
16:35:19 <runcom> lol (I was just confused)
16:35:30 <pbrobinson> the topic was generically f38 and I thought we'd finished with bootupd and agreed it was good
16:35:47 <runcom> my bad too - wasn't sure
16:36:11 <pbrobinson> also my bad, should have better transitioned the topic :)
16:39:02 <pbrobinson> so, where were we?
16:39:37 <runcom> bootupd++ , containers--
16:40:23 <pbrobinson> runcom: what's your thoughts on the containers stuff? I don't think it's ready for IoT as yet
16:40:56 <runcom> I think it could be an f39 thing assuming it matures enough in f38 (+ delta updates)
16:41:09 <runcom> so yeah, I don't think it's IoT just as yet
16:41:26 <pbrobinson> right, and I think we need to test it on something like the rpi zero2w as well
16:41:50 <pbrobinson> or devices of similar spec 512-1gb RAM etc
16:44:00 <pwhalen> agreed
16:44:12 <pwhalen> anything else for F38?
16:44:58 <pbrobinson> not from me, I think that's quite a bit for this week
16:45:08 <pwhalen> #topic 4) ==== Open Floor ====
16:46:13 * pwhalen has nothing else for this week
16:47:24 <pwhalen> thanks for joining everyone!
16:47:26 <pwhalen> #endmeeting