19:01:13 <jwb> #startmeeting
19:01:13 <zodbot> Meeting started Fri Dec 13 19:01:13 2013 UTC.  The chair is jwb. Information about MeetBot at http://wiki.debian.org/MeetBot.
19:01:13 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
19:01:22 <jwb> #meetingname Fedora kernel
19:01:22 <zodbot> The meeting name has been set to 'fedora_kernel'
19:01:31 <jwb> #meetingtopic Fedora Kernel
19:01:37 <jwb> #topic init
19:01:42 <jwb> hi all.  who's around?
19:02:08 * jforbes is here
19:02:16 * nirik is lurking around
19:03:22 <jwb> wonderful.  we have most of the usual suspects.  let's get rolling because it's friday and i'm sure people have better things to do (or not do!)]
19:03:29 <jwb> #topic release overview
19:03:46 <jwb> jforbes, you want to walk us through f18-f20?  leave out the 3.12 rebase for nwo
19:04:28 <jforbes> Well, there is not too much to say then, F18 through F20 are all sitting on 3.11.10 and that was the last of the 3.11 kernels.  There have been a few one off fixes, but no new builds since then
19:05:03 <jwb> yeah.  i guess that's about it :)
19:05:29 <jwb> rawhide is sitting at 3.13-rc3(ish) and will be progressing as usual
19:05:48 <jwb> overall 3.13 has been pretty quiet.  a few issues here and there but i think we have a handle on most of them
19:06:00 <jwb> jforbes, we still having trouble getting karma on f18?
19:06:33 <jforbes> yes, there are a couple of testers, not too many
19:06:46 <jwb> figures :\
19:06:55 * nirik needs to do karma runs again, sidetracked with f20 stuff. ;)
19:07:21 <jforbes> Well, at this point, there is nothing pending, it just takes much longer for F18 to get the karma
19:07:24 <jwb> #info F18-F20 all on 3.11.10(ish)  Rawhide on 3.13-rc3(ish)
19:07:36 <jwb> ok, let's move to something more interesting
19:07:36 <davej> on the upside, the incoming bugs for 18 seems to have really dropped off to almost 1-2 a week
19:07:43 <jwb> davej, yeah, agreed
19:08:04 <jwb> davej, which brings up an interesting question on the rebase...
19:08:10 <jwb> #topic 3.12 rebase
19:08:22 <jforbes> Rebase!
19:08:32 <jwb> ok, so our stabilization branch is at 3.12.5 now, and we're looking to rebase F20-F18
19:08:38 <jforbes> The F20 rebase is committed and building.
19:08:41 <jwb> i have two main questions/concerns
19:08:43 <davej> when does 18 eol again ?
19:08:48 <jwb> davej, 1mo after F20 GA
19:08:50 <jforbes> 1 month from Tuesday
19:08:52 <davej> ok
19:09:14 <jforbes> But 3.11 we are so long into 3.12 at this point I think it is safe to do the rebase there
19:09:37 <jwb> jforbes, overall i agree but my first question is should we hold off on getting 3.12.y into F20 stable updates until a bit after GA because of network installs?
19:09:57 <jwb> slightly concerned that there's been no network install testing with a 3.12 kernel yet
19:10:02 <davej> we usually do a 19 rebase first, then a week or so later an 18. that doesn't really give us a lot of time.
19:10:18 <davej> we could do them in parallel of course
19:10:19 <jforbes> jwb: I don't see why it should matter. The install media still runs 3.11.10
19:10:21 <jwb> davej, right.  which leads to my question 2) do we bother with f18 at all?
19:10:34 <jforbes> davej: I figured do them in parallel, it will take an extra week for F18 to get the karma
19:10:43 <jwb> jforbes, nirik: doesn't PXE boot grab from updates?
19:10:46 <davej> jwb: I'd vote for 'critical security only' at this point tbh.
19:10:57 <jwb> davej, that's where i'm leaning as well
19:11:00 <nirik> it can... depends on what you pass it.
19:11:14 <jforbes> I am okay with that too. There is no reason that F18 has to get 3.12
19:11:17 <nirik> might be fewer testers around over holidays too.. or more, hard to say. ;)
19:11:46 <jwb> jforbes, for f20, we'd likely do the normal manual karma thing we do now with a rebase anyway, right?  which would leave it in updates-testing for a while?
19:11:57 <jforbes> jwb: Yes
19:12:05 <jwb> ok.  i guess that will probably be sufficient
19:12:15 * nirik is looking forward to it so someone can/will make a bbb image. :)
19:12:24 <jforbes> F19 and F20 will both get that. Otherwise they risk making it to stable before ever hitting updates-testing
19:12:30 <jwb> hm.  fedup is another thing that pulls from updates
19:12:40 <jwb> jforbes, yeah
19:13:02 <jwb> basically my only concern is having our F20 GA overshadowed by unknown install issues with 3.12 via PXE and fedup
19:13:03 <jforbes> So my plan was to get F20 into updates-testing today, F19 on Monday.
19:13:22 <jwb> so as long as we let 3.12 sit in updates-testing for a while, i'm good with it
19:13:33 <jwb> where a while probably means "past tuesday" ;)
19:14:03 <jwb> gotta say, the timing of this release has been the worst in a while :\
19:14:10 <jforbes> jwb: I am less concerned with fedup, it will always be an issue, and my understanding on PXE is it will boot the install image which has 3.11, but it will install the 3.12 kernel to the machine
19:14:21 <jwb> jforbes, right
19:15:20 <jforbes> So the installer itself should always run as tested.  If for some reason 3.12 doesn't work on that machine, they would have to reinstall without updates checked
19:15:38 <jwb> true.  ok, so i think we agreed on 1) no 3.12 for f18, 2) f20 and f19 get 3.12 in updates-testing now and sit via normal manual karma
19:15:40 <jforbes> But again, that will always be an issue
19:15:42 <jwb> seem right?
19:15:52 <jforbes> Seems right
19:15:57 <jwb> cool
19:15:59 * nirik nods. sounds reasonable
19:16:02 <jforbes> Well, F19 probably Monday
19:16:12 <jwb> #info F18 will not get a 3.12 rebase.  critical security fixes only until EOL
19:16:27 <jwb> #info F19-F20 will get 3.12 rebase in updates-testing very soon
19:16:43 <jwb> so how did we think the stabilization branch worked out?
19:16:58 <jwb> i think it went well from a staging perspective, though i'm not sure it did much for testing?
19:17:07 <jforbes> Also of note, rawhide-nodebug will go back to tracking rawhide. I an going to give a 1 week warning as soon as it hits there F20 testing
19:17:26 <jforbes> I think it went well, a lot of people asked for the info, though I guess I don't know how many actually used it
19:17:36 <jwb> #info rawhide-nodebug will go back to tracking rawhide
19:17:53 <jwb> #action jforbes to give 1 week warning for nodebug when 3.12 hits updates-testing
19:18:11 <jwb> jforbes, yeah.  i think it's something to keep in our pockets for the future.
19:18:42 <jwb> ok, anything else on the rebase?
19:18:44 <jforbes> jwb: the branch is there, it is fairly easy to do.
19:18:48 <jforbes> Nothing else on the rebase
19:19:19 <jwb> #topic Removal of kernel-doc
19:19:45 <jwb> so in the Base WG meetings, we've been lamenting the fact that building documentation in packages brings in a lot of weird and bloated BRs
19:19:50 <jwb> (BuildRequires)
19:20:12 <jwb> for the kernel, we bring in asciidoc and xmlto.  that leads to a dep chain that adds almost 100 extra packages
19:20:22 <jwb> stuff like avahi-libs ??
19:20:22 <nirik> icky
19:20:53 <nirik> honestly, I always just google stuff and get a website with those docs... I don't have any machines with the doc package installed.
19:20:58 <jwb> right now, we don't even build kernel-doc in rawhide unless it's a release build
19:21:07 <jforbes> I wouldn't miss kernel-doc
19:21:27 <jwb> so i wrapped the deps in %if with_doc.  here's a scratch build root.log: http://kojipkgs.fedoraproject.org//work/tasks/8704/6288704/root.log
19:21:30 <davej> yeah, I don't think I've ever even installed it.
19:21:32 <jwb> vs. today's rawhide build:
19:21:37 <jwb> http://kojipkgs.fedoraproject.org//packages/kernel/3.13.0/0.rc3.git4.1.fc21/data/logs/x86_64/root.log
19:21:41 <davej> (of course I have 500 kernel trees around so..)
19:22:03 <jwb> the important numbers are: DEBUG util.py:266:  Install  20 Packages (+38 Dependent packages) vs. DEBUG util.py:264:  Install     138 Package(s)
19:22:20 * nirik is find with showing it the door.
19:22:28 <jwb> good.  i think that's what i'm going to do
19:22:37 <jwb> perf still brings in gettext, but that dep chain is much smaller
19:22:46 <davej> I think it makes more sense for something like an enterprise distro than something fast moving like fedora
19:22:55 <jwb> and we'll have one less conditional in the spec file to worry about
19:23:06 <jwb> davej, yeah, agreed
19:23:31 <davej> whether that means it's worth keeping (and disabled) in the spec or not for future rhels..
19:23:49 <jwb> davej, could do that i suppose.  wouldn't be hard
19:23:51 <jforbes> davej: well, it will bit rot either way
19:23:58 <davej> jforbes: true
19:24:00 <jforbes> eventually those deps will change
19:24:34 <jwb> #info kernel-doc subpackage brings in asciidoc and xmlto, which bloat the BuildRequires for the kernel significantly
19:24:44 <jwb> #action jwb to drop kernel-doc subpackage
19:25:50 <jwb> as the Base WG pokes at things, we might have more stuff like this come up but i think kernel-doc is the low-hanging fruit for now
19:26:15 <jwb> also, the alternatives to dropping are either a) pre-built docs b) separate SRPM for kernel-doc
19:26:42 <jwb> i don't really see a need for a. and there's no way i'm uploading a kernel tarball just for b
19:27:03 <jwb> everyone good with this?
19:27:08 <jforbes> I am
19:27:09 <davej> sure
19:27:12 <jwb> sweet
19:27:19 <jwb> ok, let's open it up
19:27:22 <jwb> #topic Open Floor
19:27:35 <jwb> anyone have something for us?
19:27:52 <davej> I could do a brief trinity update ?
19:28:08 * nirik has a bug to mention to see what he should do to move it along.
19:28:27 <jwb> davej, yeah, please do
19:28:37 <jwb> nirik, we'll come back to you
19:28:41 <jwb> #topic Trinity
19:28:57 <davej> so I added some code last week to do some more interesting things with mmap().  Previously we created a bunch of mmaps on startup, and all child processes just used those. Now the children are creating their own mmaps, and reusing them in subsequent syscalls.
19:29:09 <davej> as a result, surprise surprise: bugs are being found.
19:29:38 <davej> I think I've seen 5-6 cases that it's found (nearly all hugepage related) so far. and it's probably going to continue as I improve the code.
19:30:18 <davej> we've had a bunch of VM related oopses in bz before with no real idea what caused them, things like this should hopefully trigger them a lot sooner so we can get reproducable test cases
19:30:45 <davej> and that's been the last two weeks for me pretty much.
19:31:53 <jwb> #info MMAP rework in trinity is surfacing a number of new bugs.  Hopefully this helps clear up some weird MM bugs we've seen in the past
19:32:28 <jwb> davej, until i met you, i had never met someone that uses their computer soley for the purpose of making it do the _wrong_ thing
19:32:32 <jwb> so... kudos!
19:33:02 <jforbes> jwb: Well, it does the wrong thing whether he wants it to or not, so he just decided to use his powers for good
19:33:02 <davej> heh
19:33:28 <davej> it's a curse.
19:33:47 <jwb> jforbes, true
19:34:14 <jwb> davej, you were also looking at reworking some of the socket stuff too, right?
19:34:51 <davej> yeah, I got sidetracked on that a little because I walked into a bluetooth bug (that I've now worked around, but I still don't understand. Need to figure it out at some point)
19:35:05 <jwb> ok.  so still work in progress
19:35:08 <jwb> cool
19:35:16 <davej> if you setsockopt(SO_LINGER) on a bt socket, even if you disable linger, it hangs when you try and close it
19:35:59 <davej> but the work to map a socket back to the protocol that it was created by is done, which opens up a bunch of possibilities
19:36:43 <davej> I kinda left it at that state while I got distracted by the vm stuff
19:36:54 <davej> next week I'll do a tarball release I think.
19:37:04 <davej> it's been a while since the last one, and it's a nice stopping point
19:37:15 <jwb> #info probably upstream trinity release next week
19:37:29 <jwb> nice.  anything else on trinity?
19:37:45 <davej> not from me I think
19:37:51 <jwb> ok
19:37:56 <jwb> #topic Open Floor
19:37:59 <jwb> nirik, what's up?
19:38:01 <nirik> so, should I mention https://bugzilla.redhat.com/show_bug.cgi?id=1021036 on linux-kernel? or any ideas who I should bother to try and fix that module?
19:38:16 <nirik> it's 'ideapad_laptop'
19:38:55 <nirik> I have it blacklisted, but I ran into yet another person today with this laptop that didn't know how to get wireless working. :)
19:39:17 <jwb> hm
19:39:23 <davej> isn't that one of mjg59's things?
19:40:20 <davej> huh, no. dwmw2.
19:40:26 <nirik> dwmw2 is listed as the author in modinfo, but no idea... I guess I could ask him....
19:41:00 <jwb> nirik, is that with 3.13?
19:41:03 <nirik> yeah
19:41:07 <davej> yeah, I'd drop him a mail.
19:41:20 <jwb> could CC him on the bug too
19:41:54 <nirik> whatever works. ;)
19:42:30 * jwb wonders how he missed this bug
19:43:32 <nirik> I can add him to cc and try and ping him on it.
19:43:37 <nirik> not a big deal...
19:44:01 <jwb> googling makes it seem like a common issue, so hopefully it's just a matter of getting it to not bind on those devices
19:44:32 <nirik> yeah.
19:45:28 <jwb> ok, anything else?
19:46:00 <jwb> let's close the meeting then
19:46:04 <jwb> thanks for coming everyone
19:46:07 <jwb> #endmeeting