14:00:13 <mattdm> #startmeeting Prioritized_bugs_and_issues
14:00:13 <zodbot> Meeting started Wed Jul 19 14:00:13 2017 UTC.  The chair is mattdm. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:00:13 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
14:00:13 <zodbot> The meeting name has been set to 'prioritized_bugs_and_issues'
14:00:15 <mattdm> #meetingname Fedora Prioritized bugs and issues
14:00:15 <zodbot> The meeting name has been set to 'fedora_prioritized_bugs_and_issues'
14:00:17 <mattdm> #topic Roll Call
14:00:19 <mattdm> #chair jreznik mattdm mcatanzaro dustymabe sgallagh roshi
14:00:19 <zodbot> Current chairs: dustymabe jreznik mattdm mcatanzaro roshi sgallagh
14:00:25 <mattdm> who is here today?
14:00:33 <sgallagh> .hello sgallagh
14:00:34 * roshi is here
14:00:34 <zodbot> sgallagh: sgallagh 'Stephen Gallagher' <sgallagh@redhat.com>
14:00:36 <mattdm> jkurik is out so jreznik is taking his place
14:01:43 <jreznik> one moment
14:03:11 <mattdm> sgallagh: jkurik has some tool that the list is apparently generated from
14:03:15 <mattdm> do you know what that is?
14:03:38 <sgallagh> Wasn't it just a saved Bugzilla search?
14:03:52 <jreznik> .hello jreznik
14:03:54 <zodbot> jreznik: jreznik 'Jaroslav Reznik' <jreznik@redhat.com>
14:03:54 <mattdm> sgallagh: it's something more than that because https://fedoraproject.org/wiki/Fedora_Program_Management/Prioritized_bugs_and_issues says it is auto-generated
14:04:09 <mattdm> #topic This Meeting
14:04:15 <mattdm> #topic Purpose of this meeting
14:04:17 <mattdm> #info The purpose of this process is to help with processing backlog of bugs and issues found during the development, verification and use of Fedora distribution.
14:04:19 <mattdm> #info The main goal is to raise visibility of bugs and issues to help contributors focus on the most important issues.
14:04:26 <mattdm> #info jkurik is not here this week so we are making some of this up :)
14:05:11 <jreznik> thanks mattdm for starting this meeting, my docking station is dying, so fighting with it at the moment :(
14:06:12 <mattdm> #info Currently we have 2 proposed bugs for evaluation and, like, a zillion already approved
14:06:18 <roshi> lol
14:06:22 <roshi> that's how it goes
14:06:24 <mattdm> #info six. a zillion is six.
14:06:41 <roshi> def get_random:
14:07:02 <roshi> return 4 # rolled on d20, so it's random
14:07:03 <mattdm> #topic Evaluation of #1336435: Require all other updates to be installed before allowing to start system upgrade
14:07:03 <roshi> :p
14:07:20 <mattdm> roshi: is there a way to escalate this to being a F27 blocker?
14:07:25 <roshi> link to the bug?
14:07:37 <roshi> should look into something like the ircformat for the blockerbugs
14:07:46 <mattdm> #link https://bugzilla.redhat.com/show_bug.cgi?id=1336435
14:08:00 <mattdm> roshi: jkurik has a system. i am making things up :)
14:08:04 <sgallagh> mattdm: We could propose it as a new blocker criterion to the QA team
14:08:13 <sgallagh> But that seems a little heavy-handed for a new feature request
14:08:30 <sgallagh> .bz 1336435
14:08:39 <sgallagh> .bug 1336435
14:08:39 <zodbot> sgallagh: Bug 1336435 – Require all other updates to be installed before allowing to start system upgrade - https://bugzilla.redhat.com/1336435
14:08:41 <roshi> /me reads
14:08:45 <sgallagh> I can never remember which one works
14:08:51 <mattdm> yeah. and I haven't heard of any disasters this time around
14:09:03 <mattdm> apparently dnf now warns, and it's in the isntructions for dnf
14:09:09 <mattdm> so this is basically a gnome-software RFE
14:09:58 <mattdm> Proposal: Accept as prioritized bug, and ask GNOME Software developers to have ready for F27 beta
14:10:25 <sgallagh> Do we even have confirmation that the GNOME folks think this is likely to happen?
14:10:28 <roshi> so
14:10:39 <mattdm> I talked to hughsie about it and he didn't think it was a terrible idea
14:10:42 <sgallagh> ok
14:10:52 <mattdm> and mcatanzaro is in favor
14:10:57 * sgallagh really hopes we get to the Atomic Workstation world sooner rather than later
14:11:01 <roshi> we can't make this a blocker as explained in comment 17 - because it's a RFE
14:11:10 <mattdm> roshi: yeah, that's fair
14:11:14 <sgallagh> roshi: Well, we can write new criteria though
14:11:16 <roshi> +1 to accepting as prioritized bug though
14:11:31 <roshi> we could, but once this is fixed, I don't know what we'd need it for
14:11:36 <sgallagh> As long as we're willing to actually block on this functionality being missing
14:11:41 <roshi> besides, how would you test it?
14:11:48 <sgallagh> roshi: ensuring it continued to work?
14:11:49 <mattdm> roshi: "is feature there"? :)
14:12:11 <mattdm> i can imagine it coming up again if GNOME SOftware gets replaced by UberGNOME UltraSoftware at some point or whatever
14:12:19 <roshi> since this is gnome software, it's harder to dig in and see exactly what it's doing for the transaction at hand
14:12:24 <mattdm> then we have lost the institutional knowledge of "we need to do this"
14:12:24 <sgallagh> roshi: If the machine to be upgraded isn't fully up-to-date, it should either prevent upgrade or do the first update silently as part of it
14:12:26 <roshi> it's sufficiently abstracted away
14:12:45 <sgallagh> Of course, the other problem is that this doesn't necessarily fix upgrade problems
14:12:55 <mattdm> (and I think opinion tends towards "just do it")
14:12:58 <sgallagh> Because we only really test the packages that were available at the time we release.
14:13:07 * roshi doesn't see the point in a criterion for "Software must update before it upgrades"
14:13:21 <sgallagh> Who's to say whether an update after that would break upgrades again?
14:13:21 <mattdm> ok, I'm fine with that. let's move on
14:13:25 <roshi> but +1 to getting this fixed
14:13:32 <sgallagh> I'm not convinced yet
14:13:38 <sgallagh> I'm actually -1 at the moment.
14:13:43 <jreznik> well, with the attitude in the bug, I'd not block on this but +1 for priority bug
14:13:49 <roshi> should make it automagically do the right thing for folks that use the GUI to install/upgrade
14:14:10 <sgallagh> I don't think that it's necessarily a priority, especially since it really isn't a guarantee that the updated state is necessarily improved.
14:14:29 <mattdm> I think the problem is that it could easily *suddenly* become a priority if we get into a situation where we *know* the update needs to happen
14:14:43 <roshi> I could be wrong, but my assumption is that if you use the GUI to update, you're less likely to know to update things beforehand
14:14:44 <mattdm> and then we'll be scrambling for workarounds or begging for gnome software update at the last minute
14:14:55 <mattdm> roshi: yes, it's not intuitive at all right now
14:15:38 <sgallagh> mattdm: Right, but I'm not sure the requested feature actually fixes the problem
14:15:54 * mattdm looks at clock
14:16:01 <sgallagh> Because an update can easily lead to upgradepath issues where FN+1 has older packages than FN
14:16:10 * mattdm looks over at new puppy
14:16:27 <jreznik> and I agree with the bug that this should happen transparently if it's needed... aka user does not have to take care, app will do it... just such update+upgrade could be huuuge
14:16:41 <mattdm> sgallagh: but that's already a blocker, right?
14:17:02 <sgallagh> No, it's not
14:17:23 <sgallagh> Because we can't possibly block on any package in the distro that might happen to be downgrading.
14:17:24 <jreznik> mattdm: you don't want to know my dog story from the morning :D I don't want to let you surprise your family when they will be back and no puppy at mattdm's household :D
14:17:34 <sgallagh> And it doesn't help if that situation arises after we lift Freeze either
14:19:25 <roshi> overall I think this is a good feature for Software (as I understand the problem at least)
14:19:52 <roshi> it doesn't fix issues with the upodates themselves, but it does reduce the chances of a bad upgrade due to out of date packages
14:20:11 <mattdm> hmm okay. so, maybe I'll just talk to richard again and see about timeline, without us putting it on the prioritized bugs list?
14:20:14 <sgallagh> I don't disagree with that
14:20:22 <roshi> not sure what else to do with this one
14:20:38 <sgallagh> I just don't think it's useful to spend our limited Prioritized Bugs capital on something that I'm not convinced is a fully-baked idea.
14:20:45 <mattdm> sgallagh: yeah, that's compelling
14:21:08 <mattdm> let's move on to the next one and come back to this next time around and maybe I'll have more info
14:21:14 <sgallagh> Sounds good
14:21:30 <mattdm> #topic Evaluation of #1390198: a gnome-shell crash
14:21:32 <roshi> works for me
14:21:35 <mattdm> .bz 1390198
14:22:07 <roshi> .bug 1390198
14:22:07 <zodbot> roshi: Bug 1390198 – [abrt] gnome-shell: st_bin_dispose(): gnome-shell killed by SIGABRT - https://bugzilla.redhat.com/1390198
14:22:07 <mattdm> seems like a somewhat popular crash
14:22:11 <mattdm> roshi thanks :)
14:22:19 <roshi> np
14:22:29 * roshi loves some zodbot arcana
14:22:29 <mattdm> i'm not sure how widespread it is, or whether it is just really hurting these reporters
14:22:34 <roshi> .moar bacon mattdm
14:22:34 <zodbot> here mattdm, have some more bacon
14:22:41 * mattdm looks at retrace
14:22:52 <mattdm> #link https://retrace.fedoraproject.org/faf/reports/1376401/
14:23:46 <mattdm> So, on the scale of stuff in FAF, this is not *really* jumping to the top
14:24:34 <mattdm> it's the most popular crash in gnome shell right now, though
14:24:42 <sgallagh> FAF?
14:24:55 <mattdm> sgallagh: "Fedora Analaysis Framework"
14:24:58 <sgallagh> Ah
14:25:00 <mattdm> aka retrace.fpo
14:25:10 <mattdm> but wait no i was wrong not most popular
14:25:26 <mattdm> it's way down the list
14:25:50 <roshi> I haven't seen this bug
14:26:06 <sgallagh> I was hitting this daily on my previous laptop
14:26:09 <roshi> I mean, gnome-shell crashes from time to time, but it's *gnome* :p
14:26:13 * sgallagh checks to see if it's happening on the new one
14:26:24 <mattdm> sgallagh: that particular crash or a different gnome-shell crash?
14:26:33 <roshi> seems like a lot of things can trigger this
14:26:43 <sgallagh> This one
14:26:50 <roshi> shell crashes are a pain, so +1 for a prioritized bug
14:27:10 <sgallagh> Ah, right. I'm back to X on my new laptop and this seems to be a Wayland issue
14:27:37 <sgallagh> (I have unrelated Wayland issues due to Nouveau driver bugs on this laptop)
14:27:47 <mattdm> I'm just concerned that this is not a good use of prioritizedbug process because why *this* gnome shell crash and not https://retrace.fedoraproject.org/faf/problems/bthash/?bth=24dfac78b5811609cc921a56206be5e5712d0b53&bth=875f0b20640058256982870549e7116b4bd844ff&bth=98eb77b940053cea676d5a754820666f68617965&bth=b107dd390cfdb04a5b280cfc7937a736e74b0f65&bth=b919fcd92d2863beb49a459f99ea2ced13bbc6aa ?
14:28:09 <mattdm> which is to say https://bugzilla.redhat.com/show_bug.cgi?id=1427029
14:28:59 <sgallagh> Yeah, I think I'm fine with just letting the Workstation team follow their normal triage process.
14:29:15 <sgallagh> Though maybe a ping over there to make sure it's on their radar wouldn't hurt
14:29:16 <roshi> just make i3 the default :p
14:29:18 * roshi ducks
14:29:36 * mattdm thinks the resolution might be "ask gnome shell team about their process for triaging crashes that show up in FAF"
14:29:48 <jreznik> mattdm: +1
14:30:03 <mattdm> sgallagh: are you in the westford office today? :)
14:30:20 <sgallagh> Not at the moment, but if necessary it's a short drive.
14:30:31 <jreznik> actually I think faf report could be input for this meeting (if it isn't now)
14:30:40 <mattdm> jreznik++
14:30:40 <zodbot> mattdm: Karma for jreznik changed to 1 (for the f26 release cycle):  https://badges.fedoraproject.org/tags/cookie/any
14:30:40 <roshi> makes sense
14:30:54 <mattdm> #action jreznik to take that idea to jkurik :)
14:31:06 <jreznik> good!
14:31:41 <mattdm> sgallagh: do you want to discuss gnome-shell crash prioritization with owen, or should I?
14:31:56 <mattdm> (Owen in particular because he's the owner of these bugs.)
14:32:06 <sgallagh> mattdm: Go ahead. I'm a bit swamped this week
14:32:23 <mattdm> #action mattdm to talk to otaylor about gnome-shell crash bug prioritization process
14:32:36 <mattdm> hold on a sec...
14:34:47 <mattdm> okay, so now we have some existing bugs...
14:35:30 <mattdm> #topic #1306992 PackageKit accumlates unused RPMs until /var is swamped
14:35:36 <mattdm> .bug 1306992
14:35:36 <zodbot> mattdm: Bug 1306992 – PackageKit accumulate over 18GBytes of RPM packages in /var/cache/PackageKit/metadata and fill my root filesystem with unused RPM files - https://bugzilla.redhat.com/1306992
14:36:25 <mattdm> also
14:36:28 <mattdm> #link https://github.com/hughsie/PackageKit/issues/194
14:36:41 <mattdm> I think right now I'm just going to ping in the upstream issue
14:36:46 <mattdm> anyone have anything else?
14:36:54 * roshi has nothing
14:37:13 <roshi> tbh, these meetings always take me by surprise :p
14:37:17 <sgallagh> no
14:37:45 <mattdm> #topic Bug #1385432: Dracut exhibits numerous AVC denied errors during cleanup, takes long time to power off
14:37:54 <mattdm> .bug 1385432
14:37:54 <zodbot> mattdm: Bug 1385432 – Dracut exhibits numerous AVC denied errors during cleanup, takes long time to power off - https://bugzilla.redhat.com/1385432
14:38:26 <mattdm> there was an update in June
14:38:39 <mattdm> but reports are that problem persists
14:39:18 <mattdm> I'm not sure who to go to with selinux issues these days
14:39:27 <mattdm> I guess the selinux mailing list is a good start
14:40:13 <mattdm> #action mattdm to write message to selinux list
14:40:34 <mattdm> #topic Bug #1413306 - pointer speed on some dell laptops
14:40:41 <mattdm> .bug 1413306
14:40:41 <zodbot> mattdm: Bug 1413306 – Pointer speed on some Dell laptops (XPS 13, Precision 5510...) too slow with recent libinput (inc. 1.6) - https://bugzilla.redhat.com/1413306
14:41:10 <mattdm> this one has an update, and no further reports
14:41:26 <mattdm> mark closed?
14:42:11 <roshi> sure
14:42:25 <roshi> well, should probably test the fix first
14:42:28 <roshi> or look for karma
14:42:53 <mattdm> roshi it has karma but mostly from the usual "works for me!" suspects
14:42:57 <mattdm> nothing about the particular issue
14:43:15 <roshi> ah
14:44:05 <mattdm> I'll make a note in the close message to reopen if it's still a problem.
14:44:17 <roshi> wfm
14:44:27 <mattdm> #topic Bug 1366004: setroubleshoot-server crash
14:44:33 <mattdm> .bug 1366004
14:44:33 <zodbot> mattdm: Bug 1366004 – [abrt] setroubleshoot-server: service.py:647:_message_cb:SystemError: <built-in function isinstance> returned a result with an error set - https://bugzilla.redhat.com/1366004
14:45:08 <mattdm> see now *this* one is getting a lot of crashes
14:45:22 <mattdm> but, humm, not on f26?
14:45:53 <mattdm> oh no wait that too
14:45:56 <mattdm> https://retrace.fedoraproject.org/faf/reports/1518755/
14:47:15 <mattdm> proposal: this is long and complicated and I have no idea what to do about it in the next 15 mintues so maybe wait for jkurik on this one?
14:47:27 <roshi> seems fair
14:47:52 <mattdm> #topic Bug 1146232:  no VM networking; 'default' network in the VM conflicts with 'default' network on the host
14:48:00 <mattdm> .bug 1146232
14:48:01 <zodbot> mattdm: Bug 1146232 – no VM networking; 'default' network in the VM conflicts with 'default' network on the host - https://bugzilla.redhat.com/1146232
14:48:05 <mattdm> hey look this one is CLOSED:ERRATA
14:48:07 <mattdm> whee
14:48:19 <roshi> that was easy
14:48:24 <roshi> let's have more of those :p
14:48:27 <mattdm> leaving us with
14:48:45 <mattdm> #topic Bug #1375468: nautilus crashes on drag and drop
14:48:52 <mattdm> .bug 1375468
14:48:52 <zodbot> mattdm: Bug 1375468 – [abrt] nautilus: nautilus_window_slot_get_allow_stop(): nautilus killed by SIGSEGV - https://bugzilla.redhat.com/1375468
14:49:35 <mattdm> sgallagh: can you ask matthias abou the status of this one?
14:50:37 <sgallagh> I can ask, sure
14:50:43 <mattdm> sgallagh: thanks :)
14:50:57 <mattdm> i need to quick attend to puppy and then run to another meeting
14:51:05 <mattdm> #topic that's all for now
14:51:10 * mattdm runs off
14:51:13 <mattdm> #endmeeting