15:00:09 <bcotton> #startmeeting Prioritized bugs and issues
15:00:09 <zodbot> Meeting started Wed Apr 21 15:00:09 2021 UTC.
15:00:09 <zodbot> This meeting is logged and archived in a public location.
15:00:09 <zodbot> The chair is bcotton. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:00:09 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
15:00:09 <zodbot> The meeting name has been set to 'prioritized_bugs_and_issues'
15:00:17 <bcotton> #meetingname Fedora Prioritized bugs and issues
15:00:17 <zodbot> The meeting name has been set to 'fedora_prioritized_bugs_and_issues'
15:00:23 <bcotton> #topic Purpose of this meeting
15:00:28 <bcotton> #info The purpose of this process is to help with processing backlog of bugs and issues found during the development, verification and use of Fedora distribution.
15:00:34 <bcotton> #info The main goal is to raise visibility of bugs and issues to help  contributors focus on the most important issues.
15:00:39 <bcotton> #link https://docs.fedoraproject.org/en-US/program_management/prioritized_bugs/#_process_description
15:00:43 <bcotton> #topic Roll call
15:01:56 <mattdm> I am here!
15:02:13 <am7c7> I'm here, contributor to one of the bugs
15:02:25 <frantisekz> .hello2
15:02:26 <zodbot> frantisekz: frantisekz 'FrantiĊĦek Zatloukal' <fzatlouk@redhat.com>
15:02:51 <bcotton> welcome to the party everyone!
15:03:10 <mattdm> hello new people!
15:03:26 <bcotton> #topic Nominated bugs
15:03:32 <bcotton> #info 2 nominated bugs
15:03:37 <bcotton> #link https://bugzilla.redhat.com/buglist.cgi?bug_status=__open__&f1=flagtypes.name&f2=OP&list_id=10871664&o1=substring&query_format=advanced&v1=fedora_prioritized_bug%3F
15:03:51 <bcotton> #topic Cpu usage very high until touchpad is touched
15:03:57 <bcotton> #link https://bugzilla.redhat.com/show_bug.cgi?id=1847627
15:04:55 <bcotton> so this is a weird one. there are reports of similar behavior across different OSes (including windows)
15:05:03 <bcotton> which kinda makes me wonder if it's a firmware issue?
15:05:34 * mattdm reading
15:06:24 <mattdm> It'd be interesting to see if we can find some other XPS 13 users to reproduce
15:07:44 <bcotton> there are some similar issues fixed in older kernels
15:07:45 <bcotton> https://bugzilla.kernel.org/show_bug.cgi?id=203995
15:07:53 <bcotton> https://bugs.launchpad.net/bugs/1841396
15:08:14 <am7c7> I'm here for the other bug, but I do have a XPS-13 and could test it. But I never noticed it
15:08:39 <mattdm> I guess in general since I invited people to nominate bugs and we got two rather than two hundred, and because the Dell XPS is a pretty popular linux-enthusiast model, I'm inclined to accept this and see if we can help
15:08:39 <bcotton> am7c7: do you put it to sleep?
15:08:50 <am7c7> yes
15:09:32 <bcotton> yeah, i agree
15:09:48 <bcotton> i can put out a call for testing on the QA list, in addition to am7c7 trying to replicate it
15:09:50 <am7c7> the first thing I always do after wake up is touch the touchpad to remove the screen where it only shows the time
15:10:12 <bcotton> we can always de-prioritize it if necessary
15:10:19 <mattdm> am7c7: hmmm i wonder if the cpu is high at that point and you just don't notice
15:11:27 <am7c7> mattdm, yes I agree. It's possible that it happens. But neither does the fan become noisy.
15:12:43 <bcotton> proposed #agreed BZ 1847627 is accepted as a Prioritized Bug
15:12:47 <am7c7> trying to reproduce now, but doesn't happen yet
15:14:10 <mattdm> +1 accept
15:14:29 <bcotton> #agreed BZ 1847627 is accepted as a Prioritized Bug
15:14:39 <frantisekz> I don't have any Dell laptop around, posting to some list will deffinetly help, two ideas: trying enabling powertop might help (which has it's own shortcomings, but if it helps, we can selectively enable pm just for the touchpad); apart from that, ensuring the firmware is latest and set to uefi-non csm might make a difference too; I'll post that to the bz
15:14:42 <bcotton> #action bcotton to post a call for testing on test@
15:14:56 <bcotton> frantisekz++
15:15:07 <am7c7> yes I would ask which powertop controls are enabled.
15:15:31 <bcotton> #topic screen never reactivates after dimming or blanking
15:15:34 <bcotton> #link https://bugzilla.redhat.com/show_bug.cgi?id=1900890
15:16:31 <bcotton> so if I read this bug correctly, it's limited to the Intel NUC and there's a workaround that fixes it for some people but not others?
15:17:06 <am7c7> I did a lot of work on this, you can ask me anything about it. Current point is that it's NUC, and it doesn't wake up from sleep or lock. gnome-shell is in D state. BIOS is the latest. When I disable the sound chip in the bios, everything works
15:18:39 <am7c7> disabling power saving on the intel_hda_snd thing doesn't work anymore.
15:18:52 <bcotton> hm. that was going to be my next question
15:18:58 <am7c7> With kernel 5.8 everything worked.
15:19:13 * mattdm still reading :)
15:19:36 <bcotton> do you know if it's unique to Fedora or if it happens with other distros too?
15:19:41 <am7c7> sorry there are a lot of false starts/fixes.
15:20:07 <am7c7> No, I don't know. I was hoping that if ubuntu switches to 5.8+ it will affect them too
15:20:11 <bcotton> no worries, that's how debugging goes :-)
15:20:53 <am7c7> I do think it's an Intel problem, after they moved everything to their blobs..
15:21:11 <bcotton> jforbes: are you around?
15:21:22 <jforbes> I am
15:22:05 <bcotton> we're evaluating https://bugzilla.redhat.com/show_bug.cgi?id=1900890 for prioritized bug status
15:22:32 <bcotton> do you have any insight on this? or hunches based off a quick look? :-)
15:26:41 <jforbes> Basically, it is unlikely anyone is going to go back and fix the code that is there for the sound bit. They are more interested in replacing that code with SOF, it was originally scheduled as a feature for F34 and got pushed back
15:26:43 <bcotton> i'm trying to figure out if this is something even within our control to fix :-)
15:27:33 <bcotton> #link https://fedoraproject.org/wiki/Changes/SofDefaultForIntelLpe
15:28:26 <jforbes> If Hans had some free cycles, it might be addressed, but more likely the answer is going to be SOF
15:28:44 <mattdm> jforbes: do you know if the SOF patch is still in rawhide? would the rawhide nodebug kernel be a workaround here?
15:29:19 <jforbes> The drivers are in stable Fedora as well, they just aren't on by default
15:29:31 <am7c7> is SOF open source too?
15:29:59 <jforbes> am7c7: yes, it is in the upstream kernel
15:30:17 <jforbes> We just aren't defaulting to it yet, as it seems all of the kinks aren't worked out
15:30:26 <mattdm> Ah, the how-to-test bit for the feature ben links just says "install f34 kernel" -- are there instructions for turning it on?
15:30:32 <am7c7> ok, I can test it if you want
15:30:47 <jforbes> More importantly, with SOF the firmware is open too
15:30:57 <am7c7> I can wait for F34
15:31:22 <jforbes> I think you would have to blacklist the existing driver and it should automatically load the SOF version since we build both.
15:32:24 <jforbes> https://mailman.alsa-project.org/pipermail/sound-open-firmware/2021-March/004175.html Are the current issues and why it got delayed from F34 to F35
15:32:29 <mattdm> Should I ask hans to add instructions for that to the feature page?
15:33:03 <bcotton> yes please
15:33:04 <jforbes> I suppose it would be worthwhile
15:33:06 <mattdm> ("that" is "blacklist existing driver")
15:33:36 <jforbes> Well, we need to verify with him that blaclist is the best way to accomplish this, there could be some easier way
15:33:48 <bcotton> i think the approach here is to reject is as a priortized bug, but document how people can opt in to SOF on F34
15:34:19 <bcotton> because it's not going to be "fixed "so much as "made irrelevant"
15:34:21 <mattdm> and revisit if that doesn't work
15:34:49 * bcotton nods
15:35:55 <bcotton> proposed #agreed BZ 1900890 is rejected as a priortized bug, as it will be obviated by the SOF Change. We will document how users can opt into that for F34 and expect it to be default for F35
15:36:10 <am7c7> I'm fine with that
15:36:51 <mattdm> +1
15:37:42 <bcotton> #agreed BZ 1900890 is rejected as a priortized bug, as it will be obviated by the SOF Change. We will document how users can opt into that for F34 and expect it to be default for F35
15:37:43 <jforbes> +1
15:38:28 <bcotton> #action mattdm to ask jwrdegoede to document opt-in procedure on the SOF change proposal page
15:38:38 <bcotton> #topic Accepted bugs
15:38:45 <bcotton> #info 0 accepted bugs
15:38:51 <bcotton> #link https://bugzilla.redhat.com/buglist.cgi?bug_status=__open__&f1=flagtypes.name&f2=OP&list_id=10871665&o1=substring&query_format=advanced&v1=fedora_prioritized_bug%2B
15:38:55 <bcotton> well that's easy :-)
15:39:01 <bcotton> #topic Next meeting
15:39:07 <bcotton> #info We will meet again on 5 May at 1500 UTC in #fedora-meeting-1
15:39:15 <mattdm> thanks all!
15:39:15 <bcotton> anything else before we wrap up?
15:39:28 <am7c7> thank you very much
15:40:05 <jforbes> Thanks for sending out that email mattdm
15:40:15 <frantisekz> just a bit ot, I think I've fixed showing prioritized bugs on our blockerbugs app, so it should start displaying them here (on every milestone): https://qa.fedoraproject.org/blockerbugs/
15:40:29 <frantisekz> for a bit more visibility
15:41:04 <bcotton> frantisekz: awesome!
15:43:25 <bcotton> okay, well i guess that settles it
15:43:31 <bcotton> thanks for coming by everyone!
15:43:34 <bcotton> jforbes++
15:43:36 <zodbot> bcotton: Karma for jforbes changed to 3 (for the current release cycle):  https://badges.fedoraproject.org/tags/cookie/any
15:43:42 <bcotton> am7c7++
15:43:45 <bcotton> mattdm++
15:43:56 <bcotton> frantisekz++ (again, just for fun)
15:43:58 <bcotton> #endmeeting