16:02:46 <alebastr[m]> #startmeeting Fedora Sway SIG (2023-02-13)
16:02:46 <zodbot> Meeting started Mon Feb 13 16:02:46 2023 UTC.
16:02:46 <zodbot> This meeting is logged and archived in a public location.
16:02:46 <zodbot> The chair is alebastr[m]. Information about MeetBot at https://fedoraproject.org/wiki/Zodbot#Meeting_Functions.
16:02:46 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
16:02:46 <zodbot> The meeting name has been set to 'fedora_sway_sig_(2023-02-13)'
16:02:53 <alebastr[m]> .hello alebastr
16:02:54 <zodbot> alebastr[m]: alebastr 'Aleksei Bavshin' <alebastr89@gmail.com>
16:02:54 <Fale[m]> .hello fale
16:02:57 <zodbot> Fale[m]: fale 'Fabio Alessandro Locati' <me@fale.io>
16:03:38 <alebastr[m]> jkonecny, anthr76, are you joining us today? :)
16:04:04 <jkonecny[m]> .hello jkonecny
16:04:05 <zodbot> jkonecny[m]: jkonecny 'Jiří Konečný' <jkonecny@redhat.com>
16:04:05 <jkonecny[m]> yes
16:04:06 <jkonecny[m]> 🙂
16:04:27 <alebastr[m]> #topic Spin development status
16:05:50 <alebastr[m]> Now, we're got 80% ready and everything builds in fedora infra. But there's that remaining 20% of polishing and small but visible things and we're slowed down
16:06:03 * alebastr[m] blames $dayjob
16:06:30 <Fale[m]> we also need to get our website published by the Fedora website team
16:06:40 <Fale[m]> (and I guess the sericea logo as well)
16:07:16 <alebastr[m]> Fale: are you still planning to work on adjusting documentation for Sericea?
16:07:46 <Fale[m]> I think we are in a state that we can do the first release and then fine tune it
16:08:21 <alebastr[m]> hm. there's still some leftover silverblue stuff in the doc
16:08:28 <Fale[m]> is it?
16:09:01 <alebastr[m]> most notably, it refers to Workstation way too much. We're not quite Fedora Workstation
16:09:31 <Fale[m]> ok, that can be something I can fix
16:09:55 * alebastr[m] glares at the first paragraph of <https://fedora.gitlab.io/sigs/sway/sericea-docs/fedora-sericea/updates-upgrades-rollbacks/#updating>
16:10:53 <alebastr[m]> so yep, reading the whole doc, marking the sentences that seem unfitting for Sway spin, etc
16:11:16 <Fale[m]> I did a first pass a couple of weeks ago but yeah, another one is probably needed
16:13:47 <alebastr[m]> Thanks!
16:14:37 <alebastr[m]> For the logo we should file a design ticket, right?
16:14:44 <Fale[m]> I think so
16:16:38 <alebastr[m]> and with the website we need to start from figuring out where should it be created
16:17:24 <alebastr[m]> the direction with websites 3.0 is to get rid of variant-specific sites and to merge everything into fedoraproject.org, IIUC
16:18:08 <Fale[m]> do we know when www3.0 will happen?
16:18:10 <alebastr[m]> nope :)
16:18:35 <alebastr[m]> so... anyone wants to figure that out?
16:19:03 <Fale[m]> I found https://communityblog.fedoraproject.org/fedora-websites-and-apps-team-what-have-we-been-up-to/ that at least points to some people involved into it
16:19:10 <Fale[m]> I can look for more info on the topic
16:19:22 <alebastr[m]> Thanks!
16:20:06 <Fale[m]> #action Fale to follow up on the state of Fedora website 3.0 to understand when that is going in production
16:21:21 <Fale[m]> I still see the "splitted" links in https://stg.fedoraproject.org/ so it might not impact that much our work
16:23:16 <alebastr[m]> on the unrelated topic: does anyone know if we should start building modules for f39?
16:27:24 <alebastr[m]> I'm going to assume that we should. Let's see if I break mbs with that
16:28:13 <Fale[m]> f38 has been splitted, so the current rawhide is going to become F39
16:28:43 <majestictwelve[m> I noticed
16:29:05 <alebastr[m]> yep, but mbs is really well maintained and all, so it could be unaware of that
16:30:17 <Fale[m]> :-D
16:30:51 <majestictwelve[m> Yay
16:31:15 <majestictwelve[m> Also trying to get ibus and fcitx5 didn't work out on sway :(
16:31:28 <alebastr[m]> jkonecny: there was a thread in sway list about the instructions not working. Are you going to follow up on that?
16:33:34 <alebastr[m]> majestictwelve: I'll try to see what's wrong there, but I have limited time for oss stuff lately :'(
16:34:08 <majestictwelve[m> I understand
16:34:14 <majestictwelve[m> No rush
16:34:42 <alebastr[m]> It would be awesome if someone who actually uses that could troubleshoot and write a guide how to setup input methods.
16:34:46 <majestictwelve[m> With fcitx5. It killed all input except for the key combos like to quit applications and close sway
16:35:51 <alebastr[m]> sounds like fcitx was intercepting all the input (as expected), but wasn't configured correctly and did not pass it back to the compositor
16:36:01 <majestictwelve[m> True
16:36:40 <jkonecny[m]> alebastr: I want to but wasn't able to get to that
16:39:03 <alebastr[m]> hm. there's a new issue about some missing bits of infra config - https://gitlab.com/fedora/sigs/sway/SIG/-/issues/18
16:43:14 <alebastr[m]> and some remaining ones, like waybar config and autostart. I think at this point we can declare Anthony MIA and find another volunteer for the bar config :)
16:44:05 <Fale[m]> I can work on the infra configs bits, if needed
16:44:22 <alebastr[m]> that would be appreciated, thanks
16:44:43 <Fale[m]> #action Fale will work on https://gitlab.com/fedora/sigs/sway/SIG/-/issues/18
16:47:14 <alebastr[m]> I've been drafting autostart at <https://github.com/alebastr/sway-systemd/tree/xdg-desktop-autostart>, but some things (nm-applet) just don't want to cooperate. I hope I'll manage to figure out this by beta
16:51:45 <alebastr[m]> anything else we need to discuss before I close the meeting?
16:52:19 <jkonecny[m]> not from my side
16:52:38 <jkonecny[m]> unfortunately, I don't have much time to invest these days -- again
16:53:19 <alebastr[m]> that, unfortunately, seems common for the people here
16:53:20 <Fale[m]> not from me
16:54:08 <alebastr[m]> #endmeeting