17:00:17 <jds2001> #startmeeting FESCo meeting 20091218
17:00:17 <zodbot> Meeting started Fri Dec 18 17:00:17 2009 UTC.  The chair is jds2001. Information about MeetBot at http://wiki.debian.org/MeetBot.
17:00:17 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
17:00:21 <jds2001> #meetingname fesco
17:00:21 <zodbot> The meeting name has been set to 'fesco'
17:00:23 <jds2001> #chair dgilmore dwmw2 notting nirik sharkcz jds2001 j-rod skvidal Kevin_Kofler
17:00:23 <zodbot> Current chairs: Kevin_Kofler dgilmore dwmw2 j-rod jds2001 nirik notting sharkcz skvidal
17:00:25 * nirik is here.
17:00:34 <jds2001> ok, so I'm lame
17:00:42 <dgilmore> gday gday gday
17:00:50 <jds2001> I didn't send out an agenda or anything :(
17:00:52 * sharkcz is back in few minutes
17:00:58 * skvidal is present
17:01:57 <jds2001> unfortunately, due to no agenda, no notification went to the feature owners that are up today :(
17:02:31 <jds2001> but we can just go through em, and if there are any questions, let's just defer em to next meeting.
17:03:00 <Kevin_Kofler> Present.
17:03:14 <jds2001> #topic better hostname
17:03:31 <jds2001> .fesco 278
17:03:42 <zodbot> jds2001: An error has occurred and has been logged. Please contact this bot's administrator for more information.
17:03:47 <jds2001> .fesco 278
17:03:57 <zodbot> jds2001: An error has occurred and has been logged. Please contact this bot's administrator for more information.
17:04:05 <jds2001> alrighty, zoddy not working all that well today for url's :)
17:04:14 * jds2001 will look into that later.
17:04:19 <Kevin_Kofler> fedorahosted.org seems not to respond at the moment.
17:04:30 <jds2001> ahh, that would be why.
17:04:40 <nirik> doomed. ;(
17:04:48 <notting> sorry i'm late
17:04:51 <Kevin_Kofler> The joys of technology…
17:05:05 <jds2001> anyhow, there havent been any updates to this
17:05:20 <jds2001> and mclasen said it was pretty much off their radar for right now.
17:05:32 <jds2001> so let's move on.....
17:05:58 <jds2001> #topic change in implicit DSO linking
17:05:59 * sharkcz is back
17:06:17 <jds2001> due to no agenda, this didnt get seen.
17:06:17 <jds2001> https://fedoraproject.org/wiki/Features/ChangeInImplicitDSOLinking
17:06:58 <jds2001> this makes sense to me, +1
17:06:59 <Kevin_Kofler> I'm not convinced this change is a good idea at all. It breaks backwards compatibility, and it might also break API compatibility with upstream due to us removing .la files.
17:07:10 <jds2001> why?
17:07:26 <Kevin_Kofler> I guess this is being done because gold doesn't implement the old behavior for performance reasons, so they're trying to get apps prepared for that.
17:07:29 <jds2001> it removes implicit linking, such that you have to explicitly link against what you use.
17:07:37 <jds2001> if you don't, I'd consider that an upstream bug.
17:07:52 <Kevin_Kofler> Imagine 2 packages, a-devel and b-devel, providing liba.so resp. libb.so.
17:08:04 <Kevin_Kofler> Upstream ships a liba.la which does -la -lb.
17:08:24 <Kevin_Kofler> To avoid a-devel having to drag in b-devel, we delete liba.la (that's even required in our guidelines).
17:08:46 <Kevin_Kofler> Upstream apps which do -la get -la -lb with the upstream .la file and they can use functions from -lb.
17:09:17 <nirik> this will require a mass rebuild right? How far away is gold from usable?
17:09:21 <Kevin_Kofler> With us deleting liba.la, with the old ld behavior, they still could, now they can't (without passing extra ld flags which are certainly not encouraged).
17:09:33 <jds2001> right.
17:09:44 <jds2001> but if a drops it's dep on b
17:09:50 <jds2001> they dont get the functions from b anymore.
17:10:35 <notting> nirik: it doesn't *require* a mass rebuild for any functionality. it just may require packages to change when they rebuild
17:10:42 <Kevin_Kofler> But as upstream liba implicitly links in -lb in its .la file, I'm not sure upstream projects using liba will care.
17:11:05 <nirik> notting: ok.
17:11:22 <jds2001> but what if upstream liba decides to stop doing that?
17:11:26 <jds2001> that's the concern here.
17:11:34 <Kevin_Kofler> Then the apps will adapt.
17:12:00 <Kevin_Kofler> But if it's us removing liba.la, they'll just blame us.
17:12:13 <Kevin_Kofler> The old ld behavior made it work anyway without .la files.
17:12:22 <Kevin_Kofler> Now we'll have to ship .la files or patch upstream projects.
17:12:30 <nirik> if this is a precursor to gold usage, should we just wait for that to do this? (along with any other weird things it needs)
17:13:14 <Kevin_Kofler> Well, I think the idea is that the regular ld still sees the symbols and can tell what libraries need to be linked to.
17:13:25 <Kevin_Kofler> AFAIK gold will just not find them.
17:13:53 <notting> frankly, it makes programs be more correct, so i'm +1 to this.
17:13:57 <Kevin_Kofler> (IMHO that's gold not complying to the ELF spec, but I guess my opinion doesn't matter much.)
17:14:04 <nirik> sure, but this change makes the current ld behave more like gold will?
17:14:20 * nirik looks at the list of affected packages.
17:14:36 <Kevin_Kofler> nirik: Yes.
17:14:47 <Kevin_Kofler> (at least AFAIU)
17:16:34 * nirik wonders if we still have quorum...
17:16:55 * jds2001 somehow doubts it
17:17:06 <Kevin_Kofler> quorum++
17:17:11 <notting> i see me, Kevin_Kofler, nirik, jds2001, and skvidal
17:17:29 <sharkcz> and /me
17:17:35 <jds2001> so we do...if everyone is in favor :)
17:17:37 * dgilmore is torn on this
17:17:57 <nirik> I guess I am a marginal +1 here... it seems like we should be educating upstream about this issue and fixing our stuff. They would have gold breakage down the road anyhow if they didn't fix things.
17:18:04 <Kevin_Kofler> I think current Rawhide already has this, or at least had for a while.
17:18:18 <Kevin_Kofler> It already caused some FTBFSes.
17:19:37 <jds2001> so we have 3 +1 thus far (me, notting, and nirik)
17:20:09 * skvidal reads some more
17:20:14 * dgilmore is unsure of impact and if its really a big win
17:20:25 <dgilmore> but in theory it should be better
17:20:41 <dgilmore> though will mean work for developers to resolve FTBFS
17:20:52 <dgilmore> i guess +1
17:21:13 * skvidal decides to go with the crowd. If it is a mistake, we'll all get screwed
17:21:14 <skvidal> +1
17:21:17 <sharkcz> +1
17:21:20 <skvidal> w00t
17:21:22 <skvidal> passes
17:21:23 <skvidal> move alon
17:21:24 <skvidal> g
17:21:35 <Kevin_Kofler> -1 here just to make this not unanimous. ;-)
17:22:01 <Kevin_Kofler> I'm still worried about the impact of this, no list of FTBFS issues has been provided.
17:22:10 <Kevin_Kofler> But I guess I'm alone there.
17:22:10 <jds2001> #agreed Change in implicit dynamic DSO linking is accepted.
17:22:14 <jds2001> Kevin_Kofler: he did
17:22:14 <skvidal> oh, in that case then I know it's right, if Kevin_Kofler is against it :)
17:22:14 <Kevin_Kofler> So let's move on.
17:22:31 <Kevin_Kofler> "Incomplete list"
17:22:43 <Kevin_Kofler> And it's a bazillion packages already.
17:23:08 <jds2001> anyhow...
17:23:15 <jds2001> #topic open floor
17:23:20 <jds2001> anyone got anything else?
17:23:32 <nirik> so is this the last meeting with the current fesco lineup?
17:23:37 * jds2001 guesses this is my last official FESCo meeting....been great :)
17:24:00 <jds2001> yeah, the results were just announced by stickster
17:24:03 <dgilmore> jds2001: we dont have official results yet
17:24:14 <sharkcz> my last too, it was a good time :-)
17:24:14 <skvidal> we do now
17:24:14 <dgilmore> we need at least a transition meeting
17:24:25 <jds2001> yeah
17:24:26 <Kevin_Kofler> Seeing how many packages are affected, I think the DSO change is an awful idea. But I can't do more than vote -1 as I already did. :-(
17:24:35 <jds2001> i was planning on showing up next week
17:24:36 <notting> what's the schedule for the rest of the year?
17:24:39 <dgilmore> skvidal: i missed that.  we still need a transition meeting
17:24:44 <dgilmore> so yall get 1 more
17:24:44 <jds2001> and at least starting the meeting.
17:24:49 <skvidal> dgilmore: they JUST came out
17:24:51 <nirik> Kevin_Kofler: there are a number, but how hard are they going to be to fix? shouldn't be that bad I wouldn't think...
17:25:05 <notting> jds2001: i am not showing up next week, fyi
17:25:14 <Kevin_Kofler> Next week will be Dec 25.
17:25:22 <jds2001> oops, yeah
17:25:24 <Kevin_Kofler> Who will actually be present?
17:25:27 <nirik> week after will be the 1st.
17:25:43 <skvidal> hahahah
17:25:47 * skvidal is not going to be here either day
17:25:50 <skvidal> tough noogies
17:26:05 * jds2001 really doesnt wanna go two weeks without meeting, and i dont wanna meet on christmas, and will be in no condition to meet on new years :D
17:26:10 <wwoods> dec 25 == oct 31, so I'll be out trick-or-treating
17:26:14 <Kevin_Kofler> I probably won't be there on Dec 25, so far I guess I should be online on Jan 1, but I don't expect quorum on either. ;-)
17:26:41 <nirik> so, jan 8th looks like the next regular meeting time?
17:27:02 <Kevin_Kofler> We'll all be celebrating Grav-mass <http://stallman.org/grav-mass.html>. ;-)
17:27:26 * dgilmore guesses that the first friday in January  should be the next meeting
17:27:56 <jds2001> which would be jan 1 :)
17:28:01 <jds2001> so jan 8 :)
17:28:07 <dgilmore> jds2001: the one after that
17:28:35 <nirik> Kevin_Kofler: ha. Hadn't seen that one.
17:28:40 <skvidal> btw
17:28:45 <skvidal> results from the election
17:28:46 <skvidal> 1. Adam Jackson (ajax)                       1028
17:28:46 <skvidal> 2. Christoph Wickert (cwickert)               934
17:28:46 <skvidal> 3. Peter Jones (pjones)                       820
17:28:46 <skvidal> 4. Matthew Garrett (mjg59)                    753
17:28:46 <skvidal> * * * * *
17:28:47 <skvidal> 5. Robert Scheck (rsc)                        663
17:28:51 <skvidal> 6. Justin M. Forbes (jforbes)                 535
17:28:54 <skvidal> 7. Richard June (rjune)                       415
17:29:01 <skvidal> top 4 are in
17:29:19 <nirik> congrats to all.
17:29:34 <nirik> and thanks for running to those who didn't make it this time.
17:29:50 <notting> nirik: agreed on both counts
17:30:45 <jds2001> same here :)
17:31:25 <jds2001> anything else?
17:31:35 * jds2001 on $DAYJOB concall
17:31:40 <Kevin_Kofler> So who's being replaced?
17:32:02 <notting> "The seats open are currently held by Jon Stanley, Dan Horák, Jarod Wilson, and David Woodhouse (Josh Boyer's original seat)."
17:32:27 <Oxf13> wait, so fesco needs a new leader?
17:32:29 <notting> sharkcz: jds2001: j-rod: dwmw2: thanks for serving on FESCo
17:32:35 <jwb> you now are forced to elect a new chair
17:32:37 <skvidal> Oxf13: yes and we've decided it should be you
17:32:39 <nirik> Oxf13: yeah, we will need a new chair.
17:32:47 <notting> we can do that at the first meeting of the new fesco
17:32:53 * nirik notes we usually do that the first meeting of the new fesco
17:32:53 <Oxf13> skvidal: neat, given that I'm not even in FESCo.  I disapprove of every measure.
17:32:54 <skvidal> notting: with everyone here, yah
17:32:56 <jds2001> yeah....
17:32:58 <skvidal> Oxf13: good, good
17:33:02 <skvidal> Oxf13: that's the spirit
17:33:07 * nirik hands Oxf13 a big rubber "NO" stamp.
17:33:17 <Oxf13> nirik: man, this still has Jeremy's name all over it
17:33:22 <notting> i vote for zodbot for chair
17:33:43 <nirik> ha
17:34:43 <jwb> .chair zodbot
17:34:58 <dgilmore> #chair zodbot
17:34:58 <zodbot> Current chairs: Kevin_Kofler dgilmore dwmw2 j-rod jds2001 nirik notting sharkcz skvidal zodbot
17:35:18 <Kevin_Kofler> h <- meeting chair ^^
17:35:24 <nirik> ha. Anything else, or shall we close down the meeting for today?
17:35:37 <dgilmore> lets close and meet on Jan 8th
17:35:43 * nirik nods.
17:35:46 <Kevin_Kofler> +1
17:36:04 <nirik> #endmeeting