17:01:40 <notting> #startmeeting FESCo (2011-07-25)
17:01:40 <zodbot> Meeting started Mon Jul 25 17:01:40 2011 UTC.  The chair is notting. Information about MeetBot at http://wiki.debian.org/MeetBot.
17:01:40 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
17:01:47 <notting> #meetingname fesco
17:01:47 <zodbot> The meeting name has been set to 'fesco'
17:01:59 * nirik is around.
17:02:00 * sgallagh is back this week (but is still getting caught up)
17:02:03 <notting> #chair notting nirik ajax cwickert mjg59 mmaslano t8m pjones sgallagh
17:02:03 <zodbot> Current chairs: ajax cwickert mjg59 mmaslano nirik notting pjones sgallagh t8m
17:02:15 <t8m> hello all
17:02:17 <mmaslano> hello
17:02:29 <notting> #topic init process
17:02:35 <pjones> hello, world.
17:02:52 * ajax waves
17:03:36 <notting> I don't see cwickert today
17:03:39 <notting> mjg59: around?
17:03:48 <mjg59> Yup
17:05:06 <notting> ok, let's get started. light agenda today
17:05:18 <notting> #topic #563     suggested policy: all daemons must set RELRO and PIE flags
17:05:23 <notting> .fesco 563
17:05:25 <zodbot> notting: #563 (suggested policy: all daemons must set RELRO and PIE flags) - FESCo - Trac - https://fedorahosted.org/fesco/ticket/563
17:05:31 <nirik> I've not done much more on this I'm afraid.
17:05:52 <notting> ok. there was a question whether we were going to have a mass rebuild to add these flags. obviously, at this point, it would have to be after branch
17:05:54 <nirik> would any other folks care to take a stab at a list? or ?
17:06:37 <notting> ajax: were you going to do the macros/flags?
17:06:39 <nirik> or as an alternative: we don't use a list, we just make it optional if the maintainer feels it would be good to do for their package. ;)
17:07:21 <ajax> i did say i would, yes.  been distracted by rhel work, but i can fit that in this week i suppose.
17:07:24 <t8m> nirik, I think we can do a list of a few packages that do have it and are required - the list on the proposed page is fine
17:07:54 <notting> ajax: the standard flags are already fixed, correct?
17:08:12 <nirik> upowerd probibly shouldn't be there (as mentioned last time)
17:08:16 <t8m> for the rest of packages that fall into the categories that are written on the page it would be just recommended but not required
17:08:25 <ajax> notting: LDFLAGS has -Wl,-z,relro now, yes
17:08:33 <t8m> nirik, yeah upowerd can be removed sure
17:09:01 <notting> #action ajax will create standard macros for enabling full RELRO/PIE
17:10:04 <t8m> ajax, please modify the proposal page then to show the macro usage
17:10:10 <ajax> aye cap'n
17:10:28 <notting> do we want to vote on the proposal now, or keep kicking it down the curb?
17:11:14 * nirik removes upowerd
17:11:35 <ajax> i'm fine with the proposal as written
17:11:40 <t8m> +1
17:12:10 <nirik> Should we add a 'if you think this is good for your package, you can optionally enable it' ?
17:12:14 <nirik> or leave it to just the list?
17:12:23 * nirik can edit on the fly if we can get to a draft to approve.
17:12:26 <notting> nirik: that's already in there, isn't it?
17:12:34 <pjones> yeah, I think I can agree we want the feature: +1
17:12:35 <notting> 'If you package meets the following critera you can enable the PIE compiler flags:...'
17:12:48 <mmaslano> nirik: just remove question section, when it's ready
17:12:58 * notting is +1
17:13:00 <mmaslano> +1
17:13:04 <nirik> yeah, I guess so, not super clear tho.
17:13:23 <sgallagh> +1
17:13:26 <nirik> we need to add the macros in once they exist too
17:13:42 * nirik is fine with this as a starting point. Can kick it back to FPC to comment on.
17:13:51 <notting> #agreed draft proposal at https://fedoraproject.org/wiki/User:Kevin/DRAFT_When_to_use_PIE_compiler_flags is approved
17:13:52 <t8m> yes, and a few cleanups here or there - mention the full RELRO f.e.
17:14:11 <notting> would someone like to volunteer to take this to FPC?
17:14:17 * nirik can.
17:14:24 <nirik> I already have a ticket open with them for it.
17:14:41 <notting> #action nirik will take draft proposal to FPC
17:15:00 <notting> do we want to schedule a post-branch mass-rebuild for this? if so, I can take that to rel-eng
17:16:07 * nirik isn't sure.
17:16:20 <nirik> relro is the only thing that needs it right?
17:16:26 <sgallagh> I don't think we need a mass rebuild for PIO, since it's optional
17:16:31 <sgallagh> relro might benefit though
17:17:03 <ajax> a selective rebuild for the packages in the proposal is probably sufficient, really.
17:17:10 <notting> ok.
17:17:16 <notting> #agreed no mass rebuild at this time for this feature
17:17:23 <t8m> but we want it for the partial relro
17:17:29 <t8m> don't we?
17:17:55 <notting> #undo
17:17:55 <zodbot> Removing item from minutes: <MeetBot.items.Agreed object at 0xee9bc8c>
17:18:08 <ajax> t8m: meh
17:18:25 <nirik> yeah, not sure if it's really worth the pain...
17:19:22 <nirik> is there likely to be packages that don't rebuild due to relro?
17:19:47 <pjones> there will probably be a *few*, but I mean very few.
17:20:28 <pjones> Come to think of it, most of the interesting ones probably have unique enough builds that automatically turning it on won't hurt them :P
17:20:46 <ajax> nirik: i would be shocked if the reason they didn't rebuild was because of relro
17:20:56 * nirik is +0 for rebuild. It seems like a lot of work for this... if there were other better reasons I'd be more in favor.
17:20:57 <t8m> nirik, after the fix that puts the relro flag to LDFLAGS only I think there hardly be any
17:21:00 <ajax> it's _possible_ but you have to be playing extremely intimate games with the linker to make it happen
17:21:18 <pjones> ajax: in which case it probably won't get switched on in a rebuild
17:21:26 <nirik> yeah, and those people should be able to fix the mess they got themseleves in.
17:21:31 <pjones> right
17:22:02 * pjones steps away for a minute
17:22:34 <notting> do we need to vote, or can we come to general agreeement?
17:22:57 <t8m> when was the last mass rebuild?
17:23:01 <sgallagh> I vote -1 to a rebuild
17:23:33 <notting> t8m: F-15 in february
17:23:34 <nirik> t8m: last cycle
17:24:06 <t8m> ok then
17:24:19 <t8m> I do not insist on doing it now.
17:24:24 <mmaslano> -1 to mass rebuidl because of this feature
17:24:41 <ajax> -1 for mass rebuild, but i'll do targeted builds for the list in the proposal
17:24:53 <notting> ok
17:24:55 <notting> #agreed no mass rebuild at this time for this feature
17:24:59 <t8m> ajax, please also for the dependencies
17:25:04 <ajax> t8m: sure.
17:25:26 <notting> next item
17:25:28 <notting> #topic #615     Strategy for services that do not have systemd native unit files
17:25:33 <notting> .fesco 615
17:25:35 <zodbot> notting: #615 (Strategy for services that do not have systemd native unit files) - FESCo - Trac - https://fedorahosted.org/fesco/ticket/615
17:25:48 <notting> anything new here?
17:25:51 <Viking-Ice> I had an idea for busy maintainers
17:26:36 * nirik keeps not having time to help out... but encourages others to do so.
17:26:48 <Viking-Ice> as in I could initially convert the service for them ( given that they provide me with list of services they maintain ) and they could perhaps take a day to look over it and package it or get a proven packager to do it for them
17:27:10 <Viking-Ice> do it all in one day swoop
17:27:26 * nirik has no problems with a systemd unit activity day.
17:27:26 * pjones also -1 to rebuild, fwiw.
17:27:36 <nirik> might get some more interest.
17:27:45 <sgallagh> I agree, that would be good to organize
17:27:55 <mmaslano> Test day would be nice
17:28:25 <t8m> seems to be a fine proposal
17:29:02 <Viking-Ice> then I think we should to the activity day per @group
17:29:25 <Viking-Ice> for example try to hold an activity for the ftp servers group
17:29:34 <Viking-Ice> gather those maintainers and get it done
17:29:40 <notting> seems reasonable, althouhg maintainers could be out and 1-day may not be enough. of course, things have likely been in bugzilla for a while
17:29:43 <nirik> Viking-Ice: well, how much time do we have left?
17:29:54 * nirik looks at schedule.
17:29:57 <Viking-Ice> up too beta right
17:30:13 <pjones> notting: sure, but that's a "see if it's enough and organize another one if not" sort of thing
17:30:27 <pjones> also it helps get provenpackagers to help out
17:30:29 <Viking-Ice> this is outside our alpha target and more aimed at beta target ( which could be for example everything on dvd )
17:31:15 <sgallagh> Viking-Ice: I've been out of touch for two weeks. Did we meet our alpha goal of Live Media?
17:31:21 <nirik> Viking-Ice: sure, if you want to do them by group, or if thats too small, we could just do several general ones?
17:31:43 <nirik> alpha freeze is next week
17:32:15 <Viking-Ice> sgallagh, not yet not even our base base-x and core we currently have audidt #617321  iscsi #714688  NFS-Utils #699040 Tigervnc #717227 dnsmasq #694932 openvpn #714710 speech-dispatcherd #697600 smolt #697612 wpa_supplicant #661230 left
17:32:38 <sgallagh> Viking-Ice: Ok, thanks for the update.
17:33:05 <nirik> #info need to get audidt #617321  iscsi #714688  NFS-Utils #699040 Tigervnc #717227 dnsmasq #694932 openvpn #714710 speech-dispatcherd #697600 smolt #697612 wpa_supplicant #661230 done before next tuesday if at all possible.
17:33:06 <Viking-Ice> of that wpa_supplicant is ready as is speech-dispatched along with dnsmasq
17:33:10 <notting> Viking-Ice: although, at least two of those don't start by default
17:34:09 <notting> Viking-Ice: are you willing to set up test days/work days for this?
17:34:34 <Viking-Ice> adamw claimed the systemd test day last release I'll see if I can find the time to do it
17:34:47 <Viking-Ice> allthou that time is on gray area for me to make it
17:35:36 <sgallagh> I don't think we want a Test Day so much as an Activity Day
17:35:44 <sgallagh> Because this isn't really a user issue
17:35:51 <nirik> yeah.
17:36:15 <sgallagh> My kingdom for a FUDCON :)
17:36:34 <Viking-Ice> yup I would rather see an activity day I would think the functionality for this would be tested during the rest of the development cycle
17:36:47 <Viking-Ice> and fixed via update in the process
17:37:26 <sgallagh> Can we pick a day this week (how about Wednesday), declare it a short-notice Activity Day and do a mass update of the pending conversion BZs that they should attend it if possible?
17:38:12 <Viking-Ice> I'm not sure if that's doable in the case of audit
17:38:15 <notting> is it better to do during the alpha stabilization, or between alpha and beta?
17:38:31 <Viking-Ice> I think he's doing necessary code work along with it
17:39:02 <Viking-Ice> personally I would want us to delay the release until we meet the set goal
17:39:34 <Viking-Ice> as in finishing core base and base-x + those service on the livecd
17:40:11 <Viking-Ice> official one that is ( allthou I know that finishing those service on the official live will also finish them on soas and lxde )
17:40:12 <notting> we seem to have not documented that goal
17:40:19 <notting> at least, it's not in the feature page, nor in trac
17:41:11 <Viking-Ice> well you agreed to it here on irc meeting sgallagh proposal which we later extended to include the livecd ( which should be doable everything but openvpn have native units in bz )=
17:41:19 <sgallagh> notting: We may not have documented it, but we definitely agreed to it in here
17:41:35 <nirik> we did? I thought we left the ticket open because we couldn't agree. ;)
17:41:38 <notting> sgallagh: not disputing that, but it's nice to have something to point to
17:41:49 <sgallagh> Fair enough
17:41:54 <Viking-Ice> as in all the service on the livecd that is ( iscsi nfs and autitd are all missing )
17:42:12 <sgallagh> That was originally the intent of the tracking ticket I opened, but it got hijacked for ALL conversions, not just the Alpha ones
17:42:31 <Viking-Ice> sgallagh, hence the wikipage
17:42:38 <sgallagh> right
17:42:46 <notting> Viking-Ice: i assume https://fedoraproject.org/wiki/User:Johannbg/Features/SysVtoSystemd is up to date?
17:42:50 <sgallagh> (Again, I'm coming back from a vacation and still clearing out the cobwebs)
17:43:12 <Viking-Ice> notting, yup allthou the list there does not contain the remaining livecd
17:43:28 <t8m> we agree that the goal is to have the packages in base+livedvd converted
17:43:58 <t8m> we did not agree on what to do for packages that aren't converted - whether to block release or block packages
17:44:10 <t8m> or something else
17:44:20 <sgallagh> right, that was the part we couldn't get a consensus on
17:45:06 <sgallagh> For the record, I'm in favor of blocking packages. The easiest way to accomplish this might be to disable the legacy SYSV support in systemd (evil, but effective)
17:45:10 <Viking-Ice> out of my share ignorance if we start blocking packages wont that fuck up compose for spin kickstart
17:45:21 <notting> we've hit 15+ minutes - keep going?
17:45:34 <sgallagh> notting: +1 to continuing
17:45:34 <notting> sgallagh: given that's not a configuration we'll ship with, i find that pointless
17:45:37 <sgallagh> I think this is important
17:45:49 * nirik is fine with continuing
17:45:53 <t8m> sgallagh, I do not think we want to block nfs, auditd and iscsi
17:46:18 <sgallagh> I withdraw that. It was mostly a joke, poorly delivered.
17:46:25 <mjg59> These all sound like things I'd love to block
17:46:32 <sgallagh> heh
17:46:33 <nirik> I'm ok also with trying an activity day and revisit next week and see if we can get them done by then. If not, perhaps we take some time out of our meeting and just finish up the rest?
17:46:43 <notting> so, of the list above, openvpn, speech-dispatcherd, wpa_supplicant, tigervnc don't actually start by default
17:47:11 <t8m> notting, does it make difference?
17:47:13 <sgallagh> notting: wpa_supplicant does, "kind-of"
17:47:21 <notting> sgallagh: not via the init script
17:47:27 <sgallagh> ok
17:47:41 <notting> t8m: i would say yes from a prioritization standpoint
17:47:54 <nirik> yeah, others first before those.
17:48:10 <Viking-Ice> wpa_supplicant is ready and OK by Dan but not packaged yet speech-dispatcherd has unit file in bugzilla no comments on it tigervnc is being worked on openvpn is heavy hitter to convert ( which means let's dump the legacy sysv init scrip into /usr/libexec/opencvpn and call it from the unit file )
17:48:34 <Viking-Ice> as is iscsi
17:48:49 <Viking-Ice> audit is being worked on and nfs is maintainer problem not technical one
17:48:52 <notting> Viking-Ice: but if you're doing that sort of conversion, what does it buy you?
17:49:03 <mmaslano> Viking-Ice: not sure what will be solved in openvpn
17:49:06 <ajax> purity of essence.
17:49:14 <Viking-Ice> time to come up with proper solution and introduce it in the release cycle
17:49:25 <Viking-Ice> which is way they md guys had to pull back their update
17:49:31 <mmaslano> Viking-Ice: but it doesn't help anything else than your statistics
17:49:49 <Viking-Ice> mmaslano, read what I posted before
17:50:26 * mmaslano is for revisiting next week
17:50:40 <t8m> Viking-Ice, I do not think heavy rewrites of unit files should be encouraged in stable updates
17:50:51 <Viking-Ice> mmaslano, from the packaging guidelines "Packages are strictly forbidden from migrating to systemd within updates to a Fedora release. The migration is only allowed between Fedora releases."
17:51:04 <t8m> Viking-Ice, even if this is not conversion sysv->systemd
17:51:18 <notting> and doing a migration-in-name-only to allow for bigger changes later seems to miss the point
17:51:27 <t8m> notting, exactly
17:51:32 <Viking-Ice> this caused the headache and fixes for the mdraid guys they had to pull back the unit file they shipped for F15 along with updates to their code base
17:51:41 * nirik thinks that sounds like language lawyering the guidelines. ;(
17:52:37 <nirik> anyhow, I think we should prioritize: things that start by default over things that don't... but we should try and get them all done.
17:53:03 <nirik> openvpn and wpa_supplicant aren't as crititcal since they are started by NM for most people.
17:53:05 <Viking-Ice> that leaves what iscsi and audit ?
17:53:15 <t8m> and nfs
17:53:27 <notting> nfslock, at least
17:53:31 <Viking-Ice> I'm not sure the default livecd install nfs
17:54:02 <sgallagh> Viking-Ice: I think you're right. I think it installs the nfs client support only
17:54:04 <notting> desktop doesn't. others might.
17:54:25 <sgallagh> notting: I think our alpha target was just desktop
17:54:29 <notting> sgallagh: client & server are in the same package
17:54:30 <Viking-Ice> yup
17:54:30 <sgallagh> We can worry about NFS for beta
17:54:53 <sgallagh> notting: Are they? I thought the client was a kernel module
17:54:58 <sgallagh> (not the tools)
17:55:18 <pjones> the tools are effectively required.
17:55:24 <sgallagh> ah
17:55:42 <notting> proposal: continue working on conversion, prioritizing services on livecd/livedvd, and services that start by default. Viking-Ice will organize activity days around conversion. revisit status next week
17:55:53 <nirik> +1
17:55:56 <sgallagh> +1
17:56:02 <mjg59> +1
17:56:15 <t8m> +1
17:56:31 <pjones> +1
17:56:34 <mmaslano> +1
17:56:54 <pjones> shall we move on?
17:56:55 <notting> agreed: continue working on conversion, prioritizing services on livecd/livedvd, and services that start by default. Viking-Ice will organize activity days around conversion. revisit status next week
17:57:02 <notting> #agreed continue working on conversion, prioritizing services on livecd/livedvd, and services that start by default. Viking-Ice will organize activity days around conversion. revisit status next week
17:57:18 <notting> #info current status at https://fedoraproject.org/wiki/User:Johannbg/Features/SysVtoSystemd
17:57:23 <sgallagh> notting: action for Viking-Ice?
17:57:37 <notting> #action Viking-Ice will organize activity day around service conversion
17:57:41 <notting> next...
17:57:50 <notting> #topic #650     May DBUS autostart?
17:57:54 <notting> .fesco 650
17:57:56 <zodbot> notting: #650 (May DBUS autostart?) - FESCo - Trac - https://fedorahosted.org/fesco/ticket/650
17:57:57 <notting> proposal: yes
17:58:03 <mjg59> +1
17:58:04 <nirik> Viking-Ice: BTW, thanks for working on all this. It's a sometimes thankless task. ;)
17:58:17 <nirik> +1 to dbus starting by default.
17:58:37 * notting is +1 to his own proposal
17:58:40 <ajax> +1
17:58:41 <sgallagh> Why is this a question? Nearly everything in the desktop relies on it (and many things besides)
17:58:42 <sgallagh> +1
17:58:47 <pjones> +1
17:59:35 <notting> that's 6
17:59:38 <t8m> +1 no problem
17:59:48 <notting> #agreed DBUS may start by default
17:59:59 <notting> #topic #651     Updated installation/live image needed
18:00:03 <notting> .fesco 651
18:00:08 <zodbot> notting: #651 (Updated installation/live image needed) - FESCo - Trac - https://fedorahosted.org/fesco/ticket/651
18:00:38 <notting> this was a request that came into bugzilla for a respin of the live media due to a package kit bug
18:00:38 * nirik thinks we should confirm that PK updates itself first, then we don't need to consider this.
18:00:48 <notting> bug in reference: https://bugzilla.redhat.com/show_bug.cgi?id=723988
18:00:55 * nirik is sad the bug has sat there so long.
18:01:23 <notting> sorry, PK bug is  https://bugzilla.redhat.com/show_bug.cgi?id=716752
18:01:58 <pjones> this certainly doesn't need a respin if yum works properly.
18:02:24 <nirik> proposal: ask PK maintainers to try and push out a fix, confirm PK updates itself first, decline request.
18:02:36 <mjg59> It needs fixing. I agree that a respin isn't the correct answer.
18:02:39 <notting> +1
18:02:47 <ajax> +1 to nirik's proposal
18:02:48 <pjones> nirik: +1
18:02:50 <mjg59> +1
18:02:55 <sgallagh> nirik: +1
18:03:19 <notting> that's 6 with nirik's implied +1
18:03:20 <nirik> +1 to my own proposal
18:03:35 <notting> #agreed ask PK maintainers to try and push out a fix, confirm PK updates itself first
18:03:41 <notting> #agreed no respin at this time
18:03:50 <nirik> would someone take the items there as an action? ;)
18:03:57 <notting> i'll do it
18:04:03 <nirik> thanks
18:04:07 <notting> #action notting to contact PK maintainers
18:04:38 <notting> moving on...
18:04:55 <notting> there was one ticket filed today requesting a feature extension. we can discuss it now, or leave for next week
18:05:12 * nirik is fine either way. It does seem time sensitive...
18:05:19 <sgallagh> notting: Java 7?
18:05:21 <notting> no
18:05:55 <notting> #topic #652  Extension for the F-16 Aeolus Conductor feature
18:05:55 <nirik> #652: Extension for the F-16 Aeolus Conductor feature
18:06:03 <notting> .fesco 652
18:06:04 <zodbot> notting: #652 (Extension for the F-16 Aeolus Conductor feature) - FESCo - Trac - https://fedorahosted.org/fesco/ticket/652
18:06:24 <notting> i'm inclined to ack it, they say they'll have it working by friday
18:06:27 <mjg59> Yeah
18:06:31 <pjones> sure.
18:06:37 <mmaslano> sounds good
18:06:38 * nirik is fine to say they have more time. Since it's isolated.
18:06:46 <sgallagh> +1
18:06:53 <notting> #agreed extension granted
18:06:55 <ajax> +1, why not
18:07:00 <mmaslano> +1
18:07:23 <notting> #topic Next meeting
18:07:36 <notting> any volunteers to chair the next meeting?
18:07:47 <mmaslano> I could do it
18:07:53 <notting> sold!
18:08:05 <notting> #action mmaslano to chair next FESCo meeting
18:08:31 <nirik> cool.
18:08:38 <notting> #topic Fedora Engineering Services tickets - https://fedorahosted.org/fedora-engineering-services/report/6
18:08:54 <notting> anything new to report?
18:09:05 <nirik> I've not had a chance to work on them...
18:09:08 <nirik> will try this coming week.
18:09:42 <notting> ok
18:09:46 <notting> #info no new news
18:09:49 <nim-nim> su
18:10:07 <notting> and that's the agenda.
18:10:10 <notting> #topic Open Floor
18:10:16 <notting> anyone have anything else to bring up?
18:10:40 <ajax> not i.
18:10:50 <notting> #info retiring of orphan packages will take place later today
18:10:55 <nirik> what do folks think about the perl7 feature discussed on list?
18:10:59 <nirik> too late?
18:11:04 <notting> nirik: haven't gotten there yet
18:11:05 <mmaslano> um?
18:11:05 <sgallagh> nirik: Perl or Java?
18:11:13 <nirik> sorry, java.
18:11:18 <sgallagh> (last I checked, Perl hadn't hit version 6 yet :))
18:11:19 * nirik has a cold and mistyped. ;)
18:11:28 <mmaslano> sgallagh: it did...
18:11:40 <sgallagh> mmaslano: Well, I last checked a couple years ago :)
18:12:15 <sgallagh> As much as I'd like to see Fedora be among the first to offer Java 7, I think the timeline doesn't line up
18:12:20 * notting looks over the thread
18:12:21 <sgallagh> It's a big feature to push in late.
18:12:28 <pjones> "if Java 7 isn't released this time around, it won't be in Fedora until the Fedora 17 release rolls around, nearly a year (!) after Java 7 is released." doesn't sound as bad as the author seems to think.
18:12:38 <notting> sgallagh: but unlikely to have any deps that it would break
18:13:02 <notting> if they file an exception request, we can consider it. not sure what else we could do until that happens
18:13:17 <nirik> yeah, true.
18:13:18 <sgallagh> "Unfortunately, I don't have the knowledge to help build it. I'm
18:13:18 <sgallagh> announcing it here in case whoever maintains Java 6 in Fedora, or
18:13:18 <sgallagh> someone else, is interested."
18:13:19 <notting> rbergeron: have they submitted it to you yet?
18:13:30 <notting> sgallagh: dbhole said he'd take over
18:13:35 <mmaslano> I would wait for Java-SIG  reaction
18:13:40 <mmaslano> no-one from them respond
18:13:41 <sgallagh> Ah, didn't read that yet
18:14:22 <t8m> mmaslano, +1
18:14:33 <nirik> yeah, ok, just thought I would mention it.
18:14:37 <sgallagh> I'm with notting. If they file an exception request, we'll consider it.
18:15:20 <pjones> yeah, +1 to wait and let the java sig do their thing.
18:15:47 <notting> #info have noticed request for Java 7 feature on list. waiting on any possible exception request from Java SIG
18:15:55 <sgallagh> Actually, isn't Java parallel-installable?
18:16:18 <notting> should be
18:16:43 <sgallagh> If so, there's no reason it couldn't be offered up mid-stream as a java7 package that would be retired in F17 when it was turned into the standard java package
18:17:19 <notting> i would suspect we'd have both java-1.6.0-openjdk and java-1.7.0-openjdk. but again, would have to see what java sig wants to do
18:18:01 <sgallagh> notting: Well, my point was that if they are parallel-installable, then there's zero breakage risk and we'd probably be okay with approving the exception (when it's requested)
18:19:01 <notting> *nod*
18:19:06 <notting> anything else on this, or other subjects?
18:19:27 * nirik has nothing.
18:19:40 * sgallagh stares blankly
18:19:49 <notting> if nothing new comes up, will close meeting in 30 seconds
18:20:24 <notting> #endmeeting