17:00:23 <mmaslano> #startmeeting FESCO (2011-08-01)
17:00:23 <zodbot> Meeting started Mon Aug  1 17:00:23 2011 UTC.  The chair is mmaslano. Information about MeetBot at http://wiki.debian.org/MeetBot.
17:00:23 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
17:00:32 <mmaslano> #meetingname fesco
17:00:32 <zodbot> The meeting name has been set to 'fesco'
17:00:40 * nirik waves.
17:00:45 <mmaslano> #chair notting nirik ajax cwickert mjg59 mmaslano t8m pjones sgallagh
17:00:45 <zodbot> Current chairs: ajax cwickert mjg59 mmaslano nirik notting pjones sgallagh t8m
17:00:45 <t8m> hello
17:00:55 <mmaslano> #topic init process
17:01:09 <pjones> Hello fine sirs and whatnot.
17:01:15 * notting is here
17:01:21 * ajax waves
17:01:35 <mmaslano> ok, we can probably start
17:02:06 <mmaslano> #topic #517 Updates Metrics
17:02:24 <mmaslano> not sure why we have metrics on agenda...
17:02:31 <nirik> well, this is an old one...
17:02:41 <nirik> no one really took it on to try and get it moved forward.
17:02:43 * sgallagh is here
17:02:50 <nirik> it's from the updates policy days.
17:03:53 <mmaslano> ok, so I remove it from meeting for now. If anyone has comments, we could re-add it on our agenda
17:03:57 <pjones> it was a dark time
17:04:24 <mmaslano> #topic #518 abrt
17:04:26 <nirik> one of the things the Board wanted was a way to measure if an updates policy was working/improving things.
17:05:05 <nirik> ah yeah, this one we were going to revisit.
17:06:02 <mmaslano> abrt team has roadmap: https://fedorahosted.org/abrt/wiki/Features
17:06:23 <mmaslano> it assigned to ajax :)
17:06:29 <mmaslano> any comments to this one?
17:06:44 <mmaslano> .fesco 518
17:06:45 <zodbot> mmaslano: #518 (Abrt) - FESCo - Trac - https://fedorahosted.org/fesco/ticket/518
17:07:02 <nirik> I think they are working on improving, it might be nice to see what they have planned for f16 cycle...
17:07:20 * dvlasenk abrt guy
17:07:32 <dvlasenk> we don't have much feedback
17:07:36 * pjones has come up with a couple of features he'd like that aren't on the roadmap
17:07:56 <dvlasenk> and we know our UI is probably somewhat confusing
17:08:18 <ajax> that roadmap doesn't have any targets set that are in the future.
17:08:38 <t8m> ajax, there are some TBD targets
17:08:39 <dvlasenk> because F15 was our "future" and we reached it
17:08:41 <nirik> dvlasenk: I hate to suggest it, but might post another thread to the devel list asking for things maintainers want.
17:08:53 <nirik> (after updating roadmap. ;)
17:09:07 <pjones> 1) make it so core dumps/faults aren't trapped by abrt for processes invoked with .-relative paths. 2) debuginfofs is still worthwhile even though I haven't had time to work on it ;)
17:09:38 <dvlasenk> (1) shouldn't be happening, does it??
17:09:59 <pjones> I noticed it last week on... probably f15?
17:10:10 <dvlasenk> (2) duly noted, will poke Jiri about it
17:10:28 <t8m> pjones, perhaps the process changed its process title?
17:10:35 <pjones> specifically I noticed that when such a process abort()s, I get a core but I don't get the normal notification of a failure
17:10:49 <pjones> t8m: I'm really sure it didn't.
17:10:58 <mmaslano> bug reports shouldn't be solved on meeting
17:11:12 <t8m> mmaslano, +1 :)
17:11:18 <pjones> mmaslano: fair enough; I hadn't realized they intended it to already work how I suggested.
17:11:41 <mmaslano> pjones: ajax: so, you'd like to see roadmap for F-16?
17:12:26 <pjones> that'd be good, yeah.
17:12:35 <pjones> the thing about roadmaps is that they need to continue being updated :)
17:12:44 <ajax> mmaslano: a bit late for that.  but yes, would be nice to see that remaining work items are being actively scheduled.
17:12:47 <t8m> let's say at least F-16 + F-17
17:12:56 <mmaslano> dvlasenk: do you want update your schedule?
17:13:01 <nirik> The reason for this ticket was that there was a lot of maintainer pushback on wanting abrt to help them more... I think some of those things are solved, but there may still be more.
17:13:05 <mmaslano> dvlasenk: as only abrt team member here?
17:13:07 <dvlasenk> yes
17:13:13 <dvlasenk> yes
17:13:40 <mmaslano> #action dvlasenk will update Abrt roadmap for F-16 and F-17
17:13:44 <notting> nirik: meanwhile, the pushback has settled down
17:14:08 <nirik> yeah.
17:14:31 <mmaslano> any other things to discuss?
17:16:13 <mmaslano> #topic #563 suggested policy: all daemons must set RELRO and PIE flags
17:16:19 <mmaslano> .fesco 563
17:16:21 <zodbot> mmaslano: #563 (suggested policy: all daemons must set RELRO and PIE flags) - FESCo - Trac - https://fedorahosted.org/fesco/ticket/563
17:16:40 <nirik> so, I took this to FPC and they cleaned up my draft and agreed to it pending adding the macros to it.
17:16:59 <mmaslano> nirik: great
17:17:01 <nirik> https://fedoraproject.org/wiki/User:Kevin/DRAFT_When_to_use_PIE_compiler_flags
17:17:20 <nirik> ajax was going to add those macros. Once those are in, we can add them to the page and get it pushed out.
17:17:27 <mmaslano> ajax: Did you have time to work on macros?
17:17:36 <ajax> http://pkgs.fedoraproject.org/gitweb/?p=redhat-rpm-config.git;a=blob;f=redhat-rpm-config-9.1.0-hardened.patch;h=710a2c3aa3543320eb954bb630bc8069e8b01f2c;hb=796b80f2f49f2301d2687fd3c12d12d8d2b2dc59
17:17:50 <ajax> built for f16 and rawhide, update in the queue for f16
17:18:05 <ajax> currently walking through the targeted rebuilds to make sure it's all working, but it seems to be doing the right thing
17:18:18 <nirik> coolness.
17:18:20 <ajax> %define _hardened_build 1
17:18:21 <t8m> great
17:18:32 <nirik> ajax: can you update the draft page with that macro? or would you like me to sometime?
17:18:33 <pjones> we need to make sure that gets documented ... somewhere.
17:18:41 <ajax> nirik: i'll do it
17:18:51 <nirik> cool
17:19:25 <mmaslano> we should sent announcement on list and it will be also part of FPC changes
17:19:59 <nirik> mmaslano: FPC would announce it when they add it into the guidelines...
17:20:15 <mmaslano> nirik: that could be enough, I guess
17:21:12 <mmaslano> #action ajax will update draft page with macro
17:21:32 <ajax> https://admin.fedoraproject.org/updates/redhat-rpm-config-9.1.0-14.fc16
17:22:09 <mjg59> Hi, sorry I'm late
17:23:55 <pjones> mjg59: just for that, I'm going to make you review cc thunking patches.
17:24:00 <mjg59> Already on it.
17:24:14 <mmaslano> mjg59: hi, you are here just in time for the most discussed issue ;-)
17:24:17 <mmaslano> #topic #615 Strategy for services that do not have systemd native unit files
17:24:24 <mmaslano> .fesco 615
17:24:35 <zodbot> mmaslano: An error has occurred and has been logged. Please contact this bot's administrator for more information.
17:25:20 <t8m> zodbot, lol
17:25:31 <nirik> hum. Not sure why it would give that. ;(
17:25:34 <mmaslano> nirik: you are administrator? ;-)
17:25:57 <mmaslano> .fesco 615
17:26:08 <zodbot> mmaslano: An error has occurred and has been logged. Please contact this bot's administrator for more information.
17:26:15 * nirik checks logs
17:26:36 <mmaslano> nirik: it looks like server is down
17:27:00 <mmaslano> nirik: I can't change tickets on fedorahosted ;-)
17:27:19 <nirik> what server is down?
17:27:43 <nirik> might be a network issue somewhere... I can get to fedorahosted just fine here.
17:27:53 <t8m> nirik, fedorahosted.org http cannot be reached from here
17:27:57 <mmaslano> ok, now it changed
17:27:57 <t8m> just now
17:28:00 <mmaslano> .fesco 615
17:28:10 <zodbot> mmaslano: An error has occurred and has been logged. Please contact this bot's administrator for more information.
17:28:20 <mmaslano> sigh
17:28:25 <mmaslano> next ticket: https://fedorahosted.org/fesco/ticket/615
17:29:06 <pjones> maybe we ought to postpone until the bot works again, since it's doing logging and such?  though tbf I have no idea if we can save the log so far this way.
17:29:07 <pjones> argh.
17:29:18 <mmaslano> pjones: good point
17:29:26 <nirik> the bot is fine. There's a routing issue between phx and fedorahosted.org
17:29:47 <nirik> so, the logs will be processed as normal
17:29:52 <mmaslano> nirik: let's continue, thanks
17:30:02 <mmaslano> Viking-Ice: did you have time to prepare activity day?
17:30:07 <pjones> nirik: but are # agreed's and such working right?  will they go to the right tickets?
17:30:26 <nirik> yes.
17:30:40 <nirik> it just can't get titles of urls on fedorahosted.org
17:31:20 <pjones> okay
17:31:52 <nirik> so, I think we wanted to wait on this ticket and see where we were...
17:32:21 <nirik> Viking-Ice: you around?
17:32:54 <nirik> looks like 2 items in @base
17:32:59 <nirik> https://fedoraproject.org/wiki/User:Johannbg/Features/SysVtoSystemd
17:33:28 <mmaslano> there are bz, which should be done: need to get audidt #617321 iscsi #714688 NFS-Utils #699040 Tigervnc #717227 dnsmasq #694932 openvpn #714710 speech-dispatcherd #697600 smolt #697612 wpa_supplicant #661230 done before next tuesday if at all possible.
17:33:42 <nirik> looks like iscsi and nfs are the 2 left in base
17:35:10 <nirik> so, perhaps we could try and get those 2 done today/tonight...
17:35:15 <nirik> then make alpha freeze?
17:35:22 <mmaslano> and dnsmasq
17:35:39 <t8m> nirik, I do not think this is realistic
17:36:01 <mmaslano> nirik: nfs has active maintainer, but it just didn't work
17:36:02 <nirik> mmaslano: I don't think thats on the list... is it?
17:36:17 <mmaslano> nirik: it is, see list ^
17:36:37 * nirik looks, doesn't see it. odd.
17:36:56 <t8m> is dnsmasq really in base?
17:37:17 <mmaslano> and smolt and wpa_supplicat are also not fixed
17:37:29 <notting> t8m: NM brings in dnsmasq
17:37:43 <notting> mmaslano: i'm willing to give wpa_supplicant a bit of a pass, as it's not started by default
17:38:12 <t8m> hmm and dnsmasq if started by NM does not use the init script either probably?
17:38:29 <notting> correct
17:39:20 <nirik> so, do we block on icsi and nfs? or keep going? or something else?
17:40:07 <t8m> I'd propose postponing the decision to beta
17:40:19 <ajax> i don't think iscsi or nfs are so critical to functionality that we need to switch their init scripts for alpha.
17:40:41 <pjones> yeah, if that's all we're concerned with, we're in a pretty good place.
17:40:49 <ajax> if the proposed scripts don't work, waiting a week isn't going to fix it.
17:41:01 <ajax> and there's probably some deeper issue to investigate
17:41:23 <mmaslano> ajax: +1
17:41:35 <mmaslano> for example look at nfs #699040
17:41:45 <mmaslano> maintainer was really working on it
17:41:49 <nirik> yeah, was just reading that...
17:42:23 * nirik is +1 to not blocking alpha on this item at this time.
17:43:28 <ajax> agreed
17:43:30 * mmaslano agree with nirik
17:43:39 <mmaslano> votes?
17:43:39 <sgallagh> +1
17:43:45 * pjones +1 as well
17:43:47 <mjg59> +1
17:43:50 <mmaslano> +1 for not blocking alpha
17:43:53 <notting> sure +1
17:43:55 <t8m> +1
17:44:36 <mmaslano> #agreed not blocking alpha because of #615
17:44:52 <t8m> meanwhile the fedorahosted.org routing issue seems to be resolved (at least for now)
17:44:54 <mmaslano> so, I'll leave it to next meeting
17:45:09 <nirik> t8m: yeah.
17:45:33 <mmaslano> #topic #653 Fixing the feature process: use the feature definition, and
17:45:34 <mmaslano> let FESCo declare changes to be features
17:45:42 <mmaslano> .fesco 653
17:45:43 <zodbot> mmaslano: #653 (Fixing the feature process: use the feature definition, and let FESCo declare changes to be features) - FESCo - Trac - https://fedorahosted.org/fesco/ticket/653
17:46:19 <nirik> well, I think this is fine and all, but doesn't really 'fix' the feature process...
17:46:27 * adamw is here for discussion
17:46:41 <adamw> nirik: okay, i may have overbilled it. =) just take it on its merits as a proposal.
17:47:20 <t8m> I think this should be decided only together with the upcoming feature process redesign
17:47:48 <mmaslano> adamw: we were discussing fix of features with rbergeron
17:48:02 <pjones> I think -1 on this simply because I don't think we should enumerate every power we've got ;)
17:48:13 <pjones> (that is - we already have this ability, why declare it?)
17:48:22 <t8m> pjones, +1
17:48:42 <adamw> er, undocumented powers seem like a bad thing. if it's not documented, how does anyone know you have it?
17:48:54 <mjg59> I dislike this proposal
17:48:57 <pjones> adamw: if we ever ne ed to use it, we will.
17:49:00 <pjones> need
17:49:07 <mjg59> In that we have no power to do anything about anyone who fails to produce a featuer page
17:49:12 <nirik> I suppose I am fine with this change for clarity, but otherwise don't feel too strongly on it.
17:49:34 <mjg59> Other than, what, forcibly revert their code even after they've said they don't feel it's a feature?
17:49:41 <mjg59> I don't think that's a healthy development environment
17:49:45 <t8m> mjg59, +1
17:50:04 <notting> the issue i see with making it a 'must' is we've already had discussions on whether some things that fit some of the guidelines truly are features
17:50:06 <adamw> how's that different from people who start the feature process and don't finish it? you either require them to comply or the change gets dropped, right?
17:50:19 <mjg59> No, the feature gets dropped
17:50:22 <jlk> dropped as a feature
17:50:29 <jlk> the change itself may still happen
17:50:30 <mjg59> The person doing the work chooses whether or not to drop the change
17:50:36 <adamw> ah.
17:51:00 <adamw> well, if you'd prefer to keep everything very voluntary and un-enforced then yes, this change doesn't make sense.
17:51:14 <mmaslano> adamw: anyway I don't know how would you like to control it
17:51:35 <adamw> but it still feels odd to me that we have a careful process dedicated to ensuring changes go through appropriate management, then if people don't comply with the process, we just...let the change happen anyway?
17:51:56 <mjg59> Yes!
17:52:06 <pjones> adamw: even if you don't, what's the point of making this change?  just more rules?  boo.
17:52:13 <mjg59> Because we function as a project where if people want to do something useful and good they should be able to do that
17:52:26 <adamw> mmaslano: the proposed text says 'at FESCo's discretion', which means it would be entirely up to the currently constituted FESCo whether and what to do with the power.
17:52:29 <mjg59> And putting barriers in the way of those people if they're asking for nothing in return is unreasonable
17:52:35 <t8m> I think FESCo already has the power to ask for revert of a disrupting change either the maintainers or provenpackagers
17:52:51 <mjg59> Practically speaking we assume that fesco can already override maintainers if there's a sufficiently compelling reason
17:53:07 <t8m> mjg59, exactly
17:53:10 <mjg59> And "sufficiently compelling reason" means "this has broken the distribution", not "this hasn't jumped throguh the correct process hoops"
17:53:30 <adamw> well, the point of the qa stuff in the feature process is to make sure the feature doesn't break the distribution
17:53:32 <pjones> So, shall we vote on this proposal?
17:53:59 <mjg59> adamw: There's plenty of non-feature related ways to break the distribution
17:54:02 <adamw> sure.
17:54:22 <mmaslano> adamw: I get your point, but I don't think this would help
17:54:26 <mmaslano> votes?
17:54:28 <pjones> -1
17:54:31 <mjg59> We should focus on making sure that we notice (and, where possible, prevent) breakage, not introduce extra process whose sole aim is to prevent breakage by someone typing words into a website
17:54:46 <mjg59> So, yeah, -1
17:54:49 <t8m> -1
17:54:53 <mmaslano> -1
17:54:58 <sgallagh> -1
17:55:11 <notting> i guess i'm -1 by those rules. of course ,our door is always open if people see something causing problems
17:55:12 <nirik> +0 (I dont' see the harm in it personally, but not much gain either)
17:55:56 <mmaslano> #agreed -6, proposal was rejected
17:56:14 <mmaslano> and now new business
17:56:20 <mmaslano> #topic #657 Feature request F16
17:56:26 <mmaslano> .fesco 657
17:56:27 <zodbot> mmaslano: #657 (Feature request F16) - FESCo - Trac - https://fedorahosted.org/fesco/ticket/657
17:56:34 <bioinfornatics> i am here
17:57:01 <t8m> given the percentage of completion, isn't it too late?
17:57:21 <bioinfornatics> no i have work hard today
17:57:26 <bioinfornatics> it is almost down
17:57:30 <bioinfornatics> done
17:57:30 <notting> especially since that percentage is apparently accurate as of a month from now :)
17:57:38 <bioinfornatics> 95% here
17:58:04 <mmaslano> Feature page: https://fedoraproject.org/wiki/Features/D2_programming#Release_Notes
17:58:06 <t8m> bioinfornatics, please correct the page then
17:58:16 <bioinfornatics> yes
17:58:25 <t8m> bioinfornatics, also what's still missing?
17:58:25 <bioinfornatics> it is because today i have work on
17:58:32 <bioinfornatics> just fix spec
17:58:41 <mmaslano> bioinfornatics: what's the impact? how many packages are dependent on your feature?
17:58:41 <bioinfornatics> in 10 min is done i hope
17:58:46 <bioinfornatics> and after unitest
17:59:06 <bioinfornatics> ldc will be upgrade to D2
17:59:17 <bioinfornatics> tango package will be deprecated
17:59:57 <bioinfornatics> if tango project finish upgrade at time (i think not) i cold update tange
17:59:59 <bioinfornatics> tango
18:01:56 * nirik is fine with this as long as it lands soon. It seems reasonably isolated...
18:02:03 * notting is +1 for the same reasons
18:02:08 <mjg59> +1
18:02:14 <t8m> ok then +1
18:02:23 <mmaslano> +1 it doesn't have impact on other packages
18:02:33 <pjones> sure, +1
18:02:48 <bioinfornatics> thanks alot
18:02:51 <mmaslano> #action bioinfornatics will update feature page
18:03:00 <bioinfornatics> done
18:03:26 <mmaslano> #agreed 5 votes for giving exception to D2
18:03:40 <mmaslano> #topic #656 Exception request for pacemaker-cloud
18:03:46 <mmaslano> .fesco 656
18:03:47 <zodbot> mmaslano: #656 (Exception request for pacemaker-cloud) - FESCo - Trac - https://fedorahosted.org/fesco/ticket/656
18:04:50 <notting> if it's already built and already tested, sure, +1
18:04:52 * nirik is ok with this as well. +1
18:04:55 <t8m> +1
18:05:14 <ajax> +1
18:05:24 <mjg59> +1
18:05:48 <mmaslano> +1
18:06:20 <mmaslano> #agreed 6 votes for this feature as exception
18:06:34 <pjones> may as well be +1 as well
18:07:03 <sgallagh> +1
18:07:24 <sgallagh> Also +1 for the previous topic. I got pulled away for a minute
18:08:07 <mmaslano> #topic Fedora engineering
18:08:14 <mmaslano> https://fedorahosted.org/fedora-engineering-services/report/6
18:08:34 <mmaslano> any questions to to engineering services? ^
18:08:38 <nirik> I've not gotten a chance to sit down with the guy who was going to work on reviving things.
18:08:44 <nirik> I hope to this week.
18:09:14 <mmaslano> um and we have this ticket https://fedorahosted.org/fesco/ticket/658
18:09:29 <mmaslano> but I guess this is for services or more likely for rel-eng?
18:09:50 <nirik> yeah, I think we should probibly ask them to file with rel-eng on that one.
18:10:31 <t8m> nirik, +1
18:10:51 <mmaslano> #topic open floor
18:12:12 * nirik has nothing
18:12:29 <mmaslano> aaa I forgot
18:12:36 <mmaslano> who will be chair for next meeting :)
18:14:06 <nirik> I've had a nice break, I can do it again next week... unless someone else wants to.
18:14:17 * t8m will be on holidays next week
18:14:33 <ajax> who's not had a turn yet?
18:15:20 <ajax> also, related to the build flags, i have found at least one instance where the existing macros won't work
18:15:32 <ajax> so... that's sad.
18:15:53 <nirik> bummer. ;(
18:16:16 <t8m> ajax, me, I can take the chair on the 2011-08-15 meeting
18:16:27 <ajax> i can chair next week i think.
18:16:37 * nirik is fine with that too.
18:17:00 <mmaslano> #action ajax is chairman next week and t8m on 2011-08-15
18:17:18 <ajax> i'll be gone the three weeks after the 15th.
18:18:49 <mmaslano> I'll close meeting in 5 minutes...
18:23:28 <mmaslano> #endmeeting