18:02:00 <notting> #startmeeting FESCO (2011-12-19)
18:02:00 <zodbot> Meeting started Mon Dec 19 18:02:00 2011 UTC.  The chair is notting. Information about MeetBot at http://wiki.debian.org/MeetBot.
18:02:00 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
18:02:07 <notting> #meetingname fesco
18:02:07 <zodbot> The meeting name has been set to 'fesco'
18:02:13 <pjones> morning, sunshine.
18:02:16 <mmaslano> hi
18:02:17 <notting> #chair notting nirik mjg59 mmaslano t8m pjones sgallagh mitr limburgher
18:02:17 <zodbot> Current chairs: limburgher mitr mjg59 mmaslano nirik notting pjones sgallagh t8m
18:02:29 <notting> #topic init process
18:02:30 <nirik> Morning.
18:02:43 <notting> pjones: aww, that's sweet. and disturbing!
18:02:44 <sgallagh> Good afternoon :)
18:02:59 * limburgher awake
18:03:26 <mitr> Hello
18:04:30 <notting> well, that looks like quorum
18:04:47 <notting> #topic #718 New meeting time?
18:04:47 <notting> .fesco 718
18:04:49 <zodbot> notting: #718 (New meeting time?) – FESCo - https://fedorahosted.org/fesco/ticket/718
18:04:59 <nirik> did everyone fill out the thingie?
18:05:23 <limburgher> Nearly, I think.  It looks like we should stay put.
18:06:20 <notting> any objections?
18:06:49 <sgallagh> +1 to maintaining the current slot
18:06:59 <mmaslano> +1 nothing against it
18:07:20 * nirik is fine with that.
18:07:26 <mitr> +1, because +1 and 0 is the same thing :)
18:07:26 <limburgher> +1
18:07:26 <nirik> easy to remember at least. ;)
18:07:30 <pjones> sure, why not.
18:07:35 <pjones> +1
18:08:49 <notting> #agreed meetings will continue at the current time
18:08:49 <t8m> hello, I am sorry I am late
18:09:04 <notting> t8m: i assume current meeting slot remains ok?
18:09:34 <t8m> notting, it's not the best, but acceptable
18:09:43 <notting> ok
18:09:49 <pjones> It's too bad whenisgood doesn't allow ranking
18:10:37 <notting> on to new business
18:10:48 <notting> #topic #722 F17 Feature: Multitouch support - https://fedoraproject.org/wiki/Features/Multitouch_support
18:10:52 <notting> .fesco 722
18:10:54 <zodbot> notting: #722 (F17 Feature: Multitouch support - https://fedoraproject.org/wiki/Features/Multitouch_support) – FESCo - https://fedorahosted.org/fesco/ticket/722
18:11:13 <mitr> +1
18:11:22 <nirik> +1 here.
18:11:37 <notting> +1
18:11:39 <pjones> +1
18:11:40 <t8m> +1 no brainer
18:11:54 <limburgher> +1
18:12:03 <sgallagh> Is this going to cause issues with multi-seat support?
18:12:31 <sgallagh> Playing with multiple-input devices always seems to lean one way or the other.
18:12:37 <pjones> sgallagh: I wouldn't think there'd be any issues that we don't already have in terms of which-input-goes-where
18:12:46 <sgallagh> I would :)
18:13:14 <pjones> maybe my expectations of current are just lower.
18:13:32 <sgallagh> Sure, but I know there are active efforts in this direction
18:13:59 <sgallagh> I'd like to know if the Feature proposers are aware of multi-seat efforts and won't be actively contradicting them
18:14:04 <notting> it's supporting multitouch events for single devices
18:14:25 <notting> afaik, you can still only assign the device to one seat
18:14:34 <sgallagh> notting: I thought "multitouch" was essentially simulated by having two devices pointed at the same display with different device ids
18:15:42 <pjones> sgallagh: changes to the evdev driver certainly seem to imply a single device
18:16:19 <sgallagh> pjones: I'm not against this feature at all. I just want to make sure F18 doesn't have the "Unbreak multi-seat support" Feature :)
18:16:50 <notting> we can raise that in the ticket
18:16:53 <sgallagh> Anyway, the Feature is approved, so let's move on (my reservations are noted in the minutes)
18:17:06 <notting> #agreed Multitouch support feature is approved
18:17:13 <mitr> sgallagh: Considering that we are not packaging any users of this, nobody should notice if it is broken :)
18:17:21 <pjones> sgallagh: the detailed description certainly appears to describe multitouch events from a single device.
18:17:34 <pjones> also what mitr said
18:17:39 <notting> that's all for new business
18:17:54 <notting> #topic FES tickets
18:18:13 <notting> https://fedorahosted.org/fedora-engineering-services/report/6
18:18:14 <nirik> nothing new here. ;)
18:18:55 <notting> #topic Open Floor
18:19:02 <notting> anyone have anything?
18:19:21 <limburgher> not i.
18:19:31 <notting> actually
18:19:33 <notting> #undo
18:19:33 <zodbot> Removing item from minutes: <MeetBot.items.Topic object at 0x236574d0>
18:19:41 <notting> #topic Next meeting
18:20:03 <notting> there was discussion that, assuming we keep this slot, we would not meet on either 26 December or 2 January
18:20:11 <limburgher> Right.
18:20:31 <notting> #proposal Next FESCo meeting is on 2012-01-09
18:20:33 <limburgher> That's fine with me, I'm most likely offline 12/16 and probably 1/2.
18:20:36 <limburgher> +1
18:20:43 <mmaslano> +1
18:20:46 <nirik> +1
18:20:47 <mitr> Anyone cares enough about 1/2?
18:20:48 <pjones> +1
18:21:05 <t8m> +1
18:21:06 <sgallagh> I was about to ask: are there any other close second-choices to the meeting time?
18:21:07 <pjones> mitr: it's a RH USA black-out day
18:21:11 <notting> i am +1, as i will not be around both days
18:21:14 <sgallagh> We could reschedule the 1/2 meeting one time
18:21:20 <pjones> meh.
18:21:26 <mitr> +1 then.
18:21:28 <pjones> it's not like we've got a backlog of stuff to talk about
18:21:37 <limburgher> 1/2 might be a black-out day for others, for other reasons.
18:21:41 <limburgher> Right.
18:21:42 <sgallagh> Well, people WILL be rushing their Feature Pages in
18:21:58 <notting> ... we hope
18:22:20 <sgallagh> (I know of at least three that are being worked on right now for my extended team)
18:22:37 <pjones> sgallagh: and they're going to be in good enough shape that they should glide on through, right? ;)
18:22:57 <sgallagh> pjones: An almost definitive maybe.
18:23:49 <notting> looks like it did pass
18:23:56 <sgallagh> +1
18:23:58 <nirik> we could always do a special session the week of the 2nd if there's call for it
18:23:58 <sgallagh> (for the record)
18:24:09 <notting> #agreed No FESCo meetings on 2011-12-26 or 2012-01-02. Next FESCo meeting on 2012-01-09
18:24:25 <notting> any volunteers to chair next meeting?
18:24:56 <limburgher> I will.  How? :)
18:25:26 <mmaslano> limburgher: https://fedoraproject.org/wiki/FESCo_meeting_process
18:25:26 <sgallagh> https://fedoraproject.org/wiki/FESCo_meeting_process
18:25:33 <mmaslano> everything you wanted to know
18:25:41 <sgallagh> but were afraid to ask
18:25:51 <t8m> maybe not completely everything :)
18:25:52 <limburgher> The goggles. . .they<melts>
18:26:03 <notting> #info limburgher will chair 2012-01-09 meeting
18:26:08 <notting> thanks for volunteering!
18:26:16 <notting> back to...
18:26:18 <notting> #topic Open Floor
18:27:10 <NiveusLuna> Okay... what's the rules to speak here?
18:27:22 <notting> it's open floor. if you've got an issue, fire away
18:27:26 <NiveusLuna> Ah.
18:27:42 <limburgher> (Hands NiveusLuna the stick)
18:28:03 <NiveusLuna> Is readable startup output, a la sysvinit / upstart, a priority for F17? This is important to a lot of people.
18:28:55 <nirik> readable? you mean ordered in some way?
18:28:58 <nirik> is there a bug on it?
18:29:13 <NiveusLuna> Yes, and there has been for some time.
18:29:20 <notting> what constitutes readable in your opinion? if it means 'a return to serialized startup of services', no, no plans
18:29:21 <NiveusLuna> Since F15 release, if not earlier, actually.
18:29:39 <nirik> bug number?
18:29:44 <NiveusLuna> No, not serialized. Just some way to get the green OK, red FAILED, yellow WARNING.
18:29:49 <mitr> I'm not quite sure whether a list of ~200 very quick items can ever be really readable
18:29:58 <NiveusLuna> I believe curses-based interfaces were suggested...
18:30:09 <NiveusLuna> lemme find it, been a while since I looked.
18:30:36 <t8m> mitr, perhaps what might be of interest is the latest few entries before the boot gets stuck somehow
18:30:51 <NiveusLuna> .bug 622633
18:30:53 <zodbot> NiveusLuna: Bug 622633 [abrt] crash in tracker-0.6.96-3.fc12: IA__g_str_hash: Process /usr/libexec/trackerd was killed by signal 11 (SIGSEGV) - https://bugzilla.redhat.com/show_bug.cgi?id=622633
18:30:55 <NiveusLuna> .bug 622663
18:30:57 <zodbot> NiveusLuna: Bug 622663 RFE: Implement a clean system for displaying service startup information messages with systemd (possibly curses-based) - https://bugzilla.redhat.com/show_bug.cgi?id=622663
18:31:00 <NiveusLuna> there we go
18:31:06 <nirik> in any case, I'd suggest asking systemd folks about it...
18:31:09 <t8m> mitr, so although the complete output won't be readable on console the last screen might be interestin anyway
18:31:11 <NiveusLuna> Warning, there's what appears to be a very long argument.
18:31:24 <NiveusLuna> You mean Lennart?
18:31:34 <t8m> NiveusLuna, but as you can see it is not a priority of FESCo
18:31:44 <NiveusLuna> *nod*
18:31:46 <pjones> I'd say it's not a priority - for one thing, by default we hide it.
18:32:05 <NiveusLuna> Because of a few ... people... who are scared by a screen saying everything's fine.
18:32:11 <NiveusLuna> Don't get me started on that decision. >_>
18:32:33 <nirik> I'd also suggest perhaps systemd-devel lists are a better place to discuss it.
18:32:41 <pjones> you may agree or disagree, but the status quo is we don't display anything at all.
18:32:42 <NiveusLuna> Okay then. Thank you.
18:33:03 <nirik> that might get more folks involved in the discussion that could design some solution.
18:33:12 <notting> one could conceivably do a plymouth theme that reads from systemd (or a forthcoming journal) and displays things. but i don't think anyone's working on it
18:33:19 <NiveusLuna> I'm aware, pjones. And there was a very long discussion on the bugzilla about it when it was first implemented. But, Red Hat has final say.
18:33:30 <NiveusLuna> I'm done.
18:33:58 * nirik notes this has nothing to do with Red Hat as far as I can see.
18:34:19 <notting> other open floor items?
18:34:42 <pjones> notting: that'd probably be pretty easy, too.
18:36:10 <notting> I will close the meeting in 2 mins if there are no more items
18:36:34 <NiveusLuna> It does, as people are considering leaving Fedora for other distros (like debian) because of readable startup output.
18:36:52 <NiveusLuna> Done for real now, I don't want to drag this on. I got my answer. >_<
18:37:58 <NiveusLuna> I'll just go ahead and part to be sure. Thanks for the info, everyone.
18:38:29 <nirik> NiveusLuna: people switch distros for all kinds of crazy reasons. ;) But the point I was making is that Red Hat the company doesn't have anything to do with this... it's systemd developement community. It would be great if they come up with a good solution to this...
18:38:46 <t8m> too late
18:38:59 <notting> #endmeeting - thanks all