17:00:37 <t8m> #startmeeting FESCO (2012-05-21)
17:00:37 <zodbot> Meeting started Mon May 21 17:00:37 2012 UTC.  The chair is t8m. Information about MeetBot at http://wiki.debian.org/MeetBot.
17:00:37 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
17:00:45 <t8m> #meetingname fesco
17:00:45 <zodbot> The meeting name has been set to 'fesco'
17:00:46 * nirik waves
17:00:49 <pjones> yo.
17:00:53 <t8m> #chair notting nirik mjg59 mmaslano t8m pjones sgallagh mitr limburgher
17:00:53 <t8m> #topic init process
17:00:53 <zodbot> Current chairs: limburgher mitr mjg59 mmaslano nirik notting pjones sgallagh t8m
17:00:57 * notting is here
17:00:59 <t8m> Hello all
17:01:00 <mitr> Hello
17:01:07 <pjones> I'm a chair, and I'm in a chair.  Sweet.
17:01:36 <t8m> pjones, I thought I am a chair :)
17:01:43 <sgallagh> Three chairs for FESCo!
17:01:51 <pjones> (though it is not mechanized)
17:01:54 * sgallagh is here after all, today
17:02:06 <limburgher> I'm Spartacus.
17:02:25 <t8m> So I think we can begin as mmaslano won't make it today.
17:02:32 <notting> i remember reading a study about how sitting was deemed harmful to your health, so maybe we shouldn't have chairs
17:02:44 <limburgher> Pilates balls, perhaps.
17:03:18 <t8m> #topic #854 Please ratify F18 schedule.
17:03:29 <t8m> .fesco 854
17:03:30 <zodbot> t8m: #854 (Please ratify F18 schedule.) – FESCo - https://fedorahosted.org/fesco/ticket/854
17:03:41 <limburgher> So it's down to 1. or 2.
17:03:44 <t8m> So we have two proposals for the schedule.
17:03:54 <sgallagh> Two proposals, neither considered ideal
17:03:57 * nirik is really ok with either option. I don't like the idea of planning to slip tho... so probibly the second one.
17:04:28 <limburgher> I think with the second we might be less likely to slip.
17:04:31 <sgallagh> But I agree, proposal 2 is the better starting point
17:04:39 <pjones> I'd prefer option 2.
17:04:48 <notting> yes, +1 to 2, -1 to 1
17:04:54 <mjg59> +1 to 2
17:04:54 <pjones> I don't think it'll stop slippage, but that's beside the point.
17:04:57 <t8m> sgallagh, well starting point maybe but once it slips it is worse :D
17:05:00 <limburgher> +1 to 2.
17:05:07 <pjones> +1 to 2
17:05:07 <t8m> I don't care either way.
17:05:11 <limburgher> pjones:  Nothing really does, in the end. :)
17:05:17 <pjones> limburgher: exactly
17:05:20 <t8m> so +1 to 1. and 2.
17:05:20 <mitr> Wouldn't it be nice if the GNOME and Fedora schedules were prepared and approved at the same time, if they are so bound together...
17:05:24 <mitr> +1 to 2
17:05:40 <sgallagh> t8m: Well, I meant starting point for discussion
17:05:44 <limburgher> I'd also like a unicorn.
17:06:03 <t8m> So that was fast - it seems that there is not much to discuss as the option 2. got enough votes.
17:06:05 <nirik> yeah, and the kde one too... :)
17:06:15 <pjones> mitr: it'd be nice if we got over this idea that we can't ship without updating it every time
17:06:18 <sgallagh> May I make my point before we declare agreement?
17:06:27 <pjones> you can try.
17:06:34 <mitr> pjones: That to, perhaps.
17:06:41 * nirik ponders again looking at trying to make the 9 month release cycle work...
17:06:58 <sgallagh> Could we take option 2 but move GA and Final Change *up* a week?
17:07:03 <t8m> nirik, heh, that would be nice
17:07:09 <pjones> sgallagh: please no
17:07:17 <mitr> sgallagh: "up" is earlier or later?
17:07:18 <pjones> assuming by "up" you mean earlier
17:07:19 <sgallagh> That way we have a little built-in protection against slippage?
17:07:23 <sgallagh> earlier, yes
17:07:32 <pjones> that's not built in protection against slippage
17:07:35 <pjones> that's /forcing/ slippage to happen
17:07:38 <t8m> :D
17:07:43 <t8m> pjones, +1
17:07:50 <sgallagh> I don't think that makes any sense
17:07:53 <mjg59> Things that are good to do at this point do not include overruling the release team's ideas about how much time they need
17:08:03 <mjg59> If we want to talk about that then let's talk about it for F19
17:08:16 <mjg59> We don't have time to do a proper analysis of this for F18
17:08:36 <sgallagh> So the only options are to move the *entire* schedule forward or backj?
17:08:40 <mjg59> Yes
17:08:42 <sgallagh> That seems... inefficient at best
17:09:05 <pjones> well, we could do something more arbitrary if you've got a proposal, but you're not going to find a lot of support for it, I suspect.
17:09:21 <mjg59> sgallagh: I'm fine with us interfering with the process providing that we've actually ensured that we understand what the pros and cons are first
17:09:30 <sgallagh> pjones: My proposal was merely to shorten the Beta->Final span by one week
17:09:33 <mjg59> sgallagh: But we're not going to gain an adequate understanding of that in this meeting
17:10:06 <pjones> sgallagh: and how do you think that'll turn out other than just being that the first time we hit the final date we have a vote and slip it a week?
17:10:12 <mjg59> sgallagh: So either we refuse to ratify any schedule now while we do that research or we accept the figures that the people who *are* informed gave us
17:10:22 <pjones> sgallagh: what are you doing that would even /suggest/ it would happen any other week?
17:10:23 <sgallagh> pjones: How is that any different from any other release?
17:10:25 <pjones> any other way rather.
17:10:35 <pjones> it's different because in your plan we'll have one more of them.
17:10:38 <mjg59> Plan for failure, don't assume it
17:11:24 <sgallagh> mjg59: That's what I was trying to do. Plan that if we target this date, we at least have an extra week to clean ourselves up before we hit a schedule conflict with LinuxCon Europe
17:11:32 <nirik> so, that would mean 2 weeks between beta release and final change instead of 3?
17:11:54 <t8m> imo that's extremely short time
17:12:09 <pjones> nirik: yeah, it means shortening the incredibly period to 10 workdays instead of 15.
17:12:11 <sgallagh> Yeah, you're probably right.
17:12:23 <mitr> Does LinuxCon Europe really have that much impact on Fedora?  My impression was that it is primarily a kernel-developer meeting, and most our blockers tend to be in the installer, don't they?
17:12:25 <sgallagh> Ok, I withdraw my proposal
17:12:33 <t8m> mitr, +1
17:12:39 <notting> given that the most likely source of slips (sorry, no offense) is undergoing an large rework for this release, i think shortening any time period is a really bad idea
17:12:40 <limburgher> I'm honestly more worried about T-day than LinuxCon.  People can work at conferences, but pull out the lappy at dinner and . . .eesh.
17:12:42 <nirik> yeah, I think our schedule is already really agressive...
17:12:50 <nirik> as is witnessed by us slipping all the time. ;)
17:13:01 <pjones> mitr: I don't know about most; this time we've had a couple of kernel scares as well.
17:13:19 <sgallagh> Well, I've said my piece and been convinced to stick with Option 2. So +1 to Option 2.
17:13:20 <mitr> pjones: Could be, I didn't do the research.
17:13:21 <pjones> mitr: though frankly I think we should at least plan for most to be in the installer in f18, since the ui rewrite will land in that time frame.
17:13:40 <pjones> (not to disparage my coworkers working on it at all, but it's a giant change and we need to expect giant changes to be giant)
17:13:44 <sgallagh> Thank you for allowing me the time to at least talk that out.
17:14:07 <t8m> #agreed The schedule option 2 for F18 release is ratified by FESCo.
17:14:45 <notting> pjones: absolutely, i'm not expecting anaconda redesign to cause a slip because it's bad or a problem, mostly just because it's in the critical path and huge
17:16:09 <t8m> otoh how many anaconda developers are expecting Linuxcon visit?
17:16:35 <pjones> I don't know, but I wouldn't expect clumens or dlehman or wwoods to be hitting up linuxcon europe, so I don't think it'll be a /major/ issue.
17:16:41 <pjones> some of the .cz guys may?
17:16:43 <t8m> and there are some anaconda developers in Brno which might help with the Thanksgiving problem as we don't have this holiday.
17:16:53 <pjones> yes
17:17:37 <t8m> So I don't have any other tickets for discussion.
17:17:52 <t8m> #topic Next week's chair
17:18:12 <t8m> I saw there is holiday next monday in U.S. ?
17:18:24 <nirik> yeah, holiday, so likely no meeting?
17:18:37 * sgallagh will not be in attendance
17:18:48 <pjones> I'd definitely be +1 to not having the meeting next week
17:19:01 <limburgher> Not likely to make it.
17:19:02 <mjg59> Yeah, I'll be out
17:19:17 <notting> same here
17:19:33 <t8m> #info No FESCo meeting on 2012-05-28
17:19:34 <nirik> so who wants to chair the week after? ;)
17:19:52 <mitr> I can do that
17:20:30 <t8m> #action mitr will be the chair on 2012-06-04 meeting
17:20:35 <mitr> Um, sorry, can I take that back?
17:20:40 <mjg59> Heh
17:20:41 <t8m> #undo
17:20:41 <zodbot> Removing item from minutes: <MeetBot.items.Action object at 0x225e7ad0>
17:20:44 <mitr> Planning a PTO sometime in that time
17:20:53 <mjg59> I can do it
17:21:10 <t8m> #action mjg59 will be the chair on 2012-06-04 meeting
17:21:21 <nirik> when are elections over?
17:21:26 <t8m> #topic Open Floor
17:21:42 <nirik> june 8th looks like.
17:21:59 <notting> i will miss the june 4th meeting as well, apologies. will try to comment in any tickets.
17:22:20 <nirik> so, june 11th meeting will be with the new fesco slate. :)
17:22:28 <pjones> sweet, elections end and prometheus comes out the same day
17:22:47 <nirik> coincidence? :)
17:23:17 <pjones> nirik: no, I think ridley scott definitely pays attention to when our elections are.
17:23:20 <sgallagh> I think not
17:23:28 <nirik> :)
17:23:37 <sgallagh> I suspect that pjones is secretly Ridley Scott
17:23:45 <nirik> hopefully the blade runner sequel will be ok.
17:24:06 <t8m> #info FESCo (and other elections) June 1st to 7th
17:24:29 <t8m> Anything non-sci-fi for open floor? :)
17:25:05 <sgallagh> Maybe not FESCo-related, but anyone else seeing issues with the BZ upgrade?
17:25:24 <mjg59> Yes
17:25:24 <notting> assorted defaults changed, yes
17:25:25 <t8m> sgallagh, well the change of the default mail format is very unfortunate
17:25:32 <nirik> sgallagh: there's some issues in fedora infrastructure, yeah.
17:25:35 <notting> and python-bugzilla needs adjustments
17:25:49 <sgallagh> nirik: I reported a bug this morning because new users cannot create BZ accounts
17:25:53 <sgallagh> That's kind of a big one
17:25:55 * nirik has a rhel6 scratch build of git head of python-bugzilla if anyone needs it.
17:26:01 <nirik> sgallagh: oops. ;(
17:26:03 <limburgher> Nothing besides what nirik said, and I like the new email format.
17:26:52 <sgallagh> nirik: Users are hit with an interstitial that implies the detection of a token replay-attack and are denied creation of an account
17:27:15 <nirik> bummer
17:27:24 <pjones> totally read that as "token relay attack".
17:27:47 <limburgher> pjones:  I read that they were dropping that from the 3.5 kernel. :)
17:27:56 * sgallagh grins
17:28:46 <sgallagh> Ok, I have no other business
17:29:55 <t8m> If nobody else speaks up I close the meeting in two minutes.
17:31:51 <t8m> #endmeeting