17:00:50 <mitr> #startmeeting FESCO (2012-10-17)
17:00:50 <zodbot> Meeting started Wed Oct 17 17:00:50 2012 UTC.  The chair is mitr. Information about MeetBot at http://wiki.debian.org/MeetBot.
17:00:50 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
17:00:53 <mitr> #meetingname fesco
17:00:53 <zodbot> The meeting name has been set to 'fesco'
17:00:55 <mitr> #chair notting nirik mjg59 mmaslano t8m pjones mitr limburgher jwb
17:00:55 <zodbot> Current chairs: jwb limburgher mitr mjg59 mmaslano nirik notting pjones t8m
17:00:57 <mitr> #topic init process
17:01:06 * limburgher here
17:01:08 <mitr> Hello all
17:01:10 <nirik> morning everyone.
17:01:19 <mmaslano> hi
17:03:00 <notting> here now, sorry.
17:03:21 * vanaltj also here
17:05:49 * mitr can't see t8m around; pinging jwb, mjg59 and pjones
17:06:10 <mitr> We have quorum and probably little to discuss, let's start...
17:06:14 <mitr> #topic #932 F18 Features - progress at Feature Freeze
17:06:17 <mitr> .fesco 932
17:06:19 <zodbot> mitr: #932 (F18 Features - progress at Feature Freeze) – FESCo - https://fedorahosted.org/fesco/ticket/932
17:06:36 <nirik> so, I guess we have yet another week for the deadline.
17:06:44 <limburgher> Looks like it.
17:07:00 <mmaslano> skip it again
17:07:06 <t8m> hello
17:07:09 * nirik will try and poke ppc64 folks about those low % ones
17:08:13 <mitr> Is anyone particularly concerned about any feature?
17:08:47 <mitr> Moving on...
17:08:52 <mitr> #topic #946 Fedora 18 Beta freeze readiness: is major functionality in place?
17:08:54 <mitr> .fesco 946
17:08:56 <zodbot> mitr: #946 (Fedora 18 Beta freeze readiness: is major functionality in place?) – FESCo - https://fedorahosted.org/fesco/ticket/946
17:09:13 <mitr> Anything?
17:09:31 <nirik> well, fedup wasn't really ready for testing, so we punted another week.
17:09:43 <nirik> if we could try and provide resources to help, I think that would be good.
17:09:47 * nirik is tired of slipping.
17:09:58 <nirik> wwoods: you around? anything we can provide to help with fedup development?
17:10:06 <limburgher> nirik:  If we slip too much more, my daughter's going to be *mad*.
17:10:44 <nirik> only 2 more weeks slip and we can ship on xmas day! :)
17:11:11 <t8m> limburgher, daughter wants a spherical cow for an xmas present?
17:11:16 * limburgher checks if DVDs fit in stocking. . .
17:11:45 <mitr> OK, on to...
17:11:50 <mitr> #topic #950 Cleanup of the default enabled services list
17:11:52 <mitr> .fesco 950
17:11:52 <nirik> anyhow, the best we can do it help provide resources if we cna.
17:11:54 <zodbot> mitr: #950 (Cleanup of the default enabled services list) – FESCo - https://fedorahosted.org/fesco/ticket/950
17:11:55 <limburgher> t8m:  She gets really excited about each release.  I was able to get her room cleaned so she could upgrade to F15.
17:12:10 <mitr> Notes from the last time:
17:12:14 <mitr> "those who have strong opinions will prepare list of services. The next discussion will be at 17 oct meeting
17:12:17 <mitr> We will vote about services, which should stay, which should go. "
17:12:18 * nirik started to work on this a bit, then ran out of time and didn't get anything done. ;(
17:12:28 * notting sees it still sitting on his todo list
17:12:54 * mmaslano has the same problem
17:13:10 <nirik> proposal: punt a week?
17:13:18 <mitr> "punt until there is a list"?
17:13:25 * nirik nods
17:13:29 <mmaslano> yeah, that's better
17:13:33 <nirik> +1 mitr
17:13:33 <mitr> OTOH Lennart has proposed a list...
17:13:37 <limburgher> + mitr
17:13:52 <mitr> I'd still want to -1 anything that hasn't been consulted with the owner of the package
17:14:07 <limburgher> For sure.
17:14:12 <pjones> +1
17:14:19 <t8m> mitr, apart from clear violations of the current packaging policy
17:14:40 <mitr> t8m: That wiki page defines the policy, I'm not sure that it can violate it
17:15:15 <t8m> mitr, I mean if there are currently packages that do not use presets and are enabled in the %post and violate the policy
17:15:33 <nirik> the current list doesn't match the wiki page
17:15:56 <nirik> so, in addition to revising our wiki page/list, we need to make sure systemd honors it. ;)
17:16:45 * mitr counts +5 to punting until there is a "list"
17:17:11 <notting> yeah, +1
17:17:19 <mmaslano> +1
17:17:20 <mitr> I'll also send out a general call for maintainers to take a look at the policy and check that it matches the current state / propose changes, so that we can get this started.
17:17:26 <t8m> +1
17:17:30 <mitr> #agreed Will revisit when there is a list of specific changes
17:17:45 <mitr> #topic #958 Exception for updating ecj across major version boundary in f17
17:17:48 <mitr> .fesco 958
17:17:50 <zodbot> mitr: #958 (Exception for updating ecj across major version boundary in f17) – FESCo - https://fedorahosted.org/fesco/ticket/958
17:18:13 <mitr> It seems we don't have enough information.  Punt?
17:18:21 <nirik> it sounds like this may just be a misunderstanding/not that big a deal.
17:18:21 <t8m> I'm not quite sure this even needs a FESCo ticket?
17:18:37 <vanaltj> I made fesco ticket because of letter of the law policy
17:18:47 <nirik> hey vanaltj
17:18:51 <vanaltj> I don't think it is a big deal.
17:18:53 <vanaltj> hi
17:19:04 * vanaltj == jvanalte in fas :)
17:19:12 <nirik> vanaltj: so, it doesn't require rebuilding deps? it doesn't change the user experence?
17:19:19 <vanaltj> exactly
17:19:33 <t8m> then I don't think the update would break the policy
17:19:36 <pjones> Proposal: do it.
17:19:45 <notting> from reading it, it says it's needed to support java7, which, given that that's the only jdk in f17... i'd just do it. although the tycho thing warrants looking at
17:19:51 <nirik> right, seems fine to me per the policy then.
17:19:54 <limburgher> Nods
17:19:55 <mitr> +1
17:20:08 <limburgher> +1
17:20:10 <mmaslano> +1
17:20:15 <vanaltj> yes, I won't be pushing until/unless I know that hte one sign of problem is solved.
17:20:15 <t8m> but +1 anyway
17:20:27 * nirik doesn't think we need to vote actually... but sure.
17:20:47 <mitr> #agreed ecj major update in F17 is OK (+7)
17:20:54 <vanaltj> great, thanks all!
17:20:55 <mitr> #topic #959 Mediation needed for cobbler in EPEL
17:20:58 <mitr> .fesco 959
17:20:59 <zodbot> mitr: #959 (Mediation needed for cobbler in EPEL) – FESCo - https://fedorahosted.org/fesco/ticket/959
17:21:32 <limburgher> This looks like CWB fodder to me.
17:21:38 <limburgher> CWG, even.
17:21:47 <nirik> proposal: ask them to use epel-devel and ask for mediation in cwg if that fails. close fesco ticket.
17:21:58 <limburgher> nirik: +1
17:22:23 <notting> hm
17:22:44 <mmaslano> is cwg still active?
17:22:51 <notting> well, if we have one person coming to us about updating ecj which is our business, and this resulting from issues with updating cobbler, which isn't our business?
17:22:52 <nirik> mmaslano: the board is trying to reactivate it.
17:23:02 <mmaslano> they prefer fast solution
17:23:28 <mitr> I'm not sure that this is a CWG material
17:23:28 <mmaslano> well, if no cwg is active, then board might help
17:24:17 <nirik> notting: are the two issues tied?
17:24:35 * nirik is missing where that is.
17:24:50 <notting> no, just saying if deciding whether ecj version updates are OK is our business, dealing with cobbler updates being OK/not OK would seem to be too
17:24:55 <mitr> nirik: both are about update/regression acceptability
17:25:10 <nirik> ah. so some history...
17:25:25 <nirik> epel was (but unclear if it still is) a project... like docs or ambassadors...
17:25:36 <nirik> which wouldn't put it under fesco, but rather the board.
17:25:46 <mitr> notting: One difference is that per http://fedoraproject.org/wiki/EPEL/GuidelinesAndPolicies EPEL is governed by its SIG.
17:25:52 <nirik> personally, I don't care, we could say it's a SIG under fesco...
17:26:05 <nirik> but thats probibly something to discuss rather than just decide.
17:26:41 <nirik> in any case, I would say the first stop would be the epel-devel list. I've not seen this issue mentioned there at all...
17:27:25 <limburgher> That would give the wider community the best chance to weigh in if interested.
17:27:30 * nirik notes abadger1999 has also commented in on the bug and offered to help.
17:27:35 <notting> yeah, sounds good
17:27:39 <mitr> Right
17:27:54 * abadger1999 looks in, reads up
17:28:09 <pjones> nirik: I think you're probably right on that.
17:28:17 <nirik> I'm also happy to help mediate, but not sure I can help fix the underlying selinux/python issue.
17:30:10 <abadger1999> yeah, historically, epel was under the board... so it would be dcided under the epel equivalent of fesco (historically).  I haven't gotten any response from the spacewalk people or a message to epel-devel yet.
17:30:34 <abadger1999> Would prefer to see that tried before something else goes forward.
17:30:44 <t8m> abadger1999, +1
17:31:00 <abadger1999> If fesco wanted to re-evaluate whther epel should be a separate project from epel I suppose that could be done separately.
17:31:12 <abadger1999> Err..
17:31:15 <limburgher> :)
17:31:29 <mitr> So, proposal: ask them to use epel-devel, and reopen if that fails.
17:31:31 <abadger1999> By that I mean -- fesco, epel, and the board could evaluate that separately.
17:31:36 <t8m> mitr, +1
17:31:36 * nirik should try and get epel more active again, but it's hard to do when things are mostly setup and the work to be done/decided is small and/or very hard.
17:31:41 <limburgher> mitr +1
17:31:52 <limburgher> nirik: Nods
17:32:11 <notting> mitr: +1
17:32:22 <nirik> sure.
17:33:02 <mitr> #agreed: Please ask epel-devel for a decision, and reopen a ticket if that doesn't lead to a resolution (+5)
17:33:09 <mitr> #topic Next week's chair
17:33:37 <mitr> Anyone?
17:33:52 <notting> i might be late to next week's meeting, so not i
17:34:24 <limburgher> Been a while, I can.
17:34:38 <mitr> Thanks.
17:34:47 <mitr> #info limburgher will chair the Oct 24 meeting
17:34:52 <mitr> #topic Open Floor
17:34:56 <mitr> Anything for open floor?
17:35:10 * nirik has nothing.
17:36:26 * mitr will close the meeting in 19:38 if nothing comes up
17:38:21 <mitr> #endmeeting