18:01:05 <mmaslano> #startmeeting FESCO (2012-11-14)
18:01:05 <zodbot> Meeting started Wed Nov 14 18:01:05 2012 UTC.  The chair is mmaslano. Information about MeetBot at http://wiki.debian.org/MeetBot.
18:01:05 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
18:01:10 <mjg59> Hi
18:01:10 <mmaslano> #meetingname fesco
18:01:10 <zodbot> The meeting name has been set to 'fesco'
18:01:16 <jwb> hello
18:01:19 <nirik> morning
18:01:19 <mmaslano> #chair notting nirik mjg59 mmaslano t8m pjones mitr limburgher jwb
18:01:20 <zodbot> Current chairs: jwb limburgher mitr mjg59 mmaslano nirik notting pjones t8m
18:01:23 <mmaslano> #topic init process
18:01:33 <pjones> morning.
18:01:51 * limburgher here
18:02:02 <mitr> Hello
18:02:28 * notting is here
18:02:37 * jreznik is lurking
18:02:47 <mmaslano> let' start
18:03:10 <mmaslano> .fesco #963
18:03:10 <zodbot> mmaslano: Error: '#963' is not a valid integer.
18:03:20 <mmaslano> #topic #963 change of names of configuration files
18:03:30 <pjones> .fesco 963
18:03:30 <mmaslano> .fesco 963
18:03:31 <zodbot> pjones: #963 (change of names of configuration files) – FESCo - https://fedorahosted.org/fesco/ticket/963
18:03:34 <zodbot> mmaslano: #963 (change of names of configuration files) – FESCo - https://fedorahosted.org/fesco/ticket/963
18:03:42 <mmaslano> mjg59: could you help michal or Kay?
18:03:45 <mjg59> Yeah
18:03:52 <mjg59> Sorry, hadn't really been online much for the past week
18:03:58 <mjg59> I'll follow up on that
18:03:58 <mmaslano> sure, thanks
18:04:21 <mitr> They could just unpack/analyze rawhide themselves I'd expect..
18:05:50 <mmaslano> any proposal? I would be fine with mjg's help
18:06:07 <mitr> if mjg59 wants to help, I'm completely fine
18:06:11 <nirik> proposal: defer for now and see if mjg59 can get them access to the info they seek
18:06:13 <mmaslano> but it should be done before freeze if there are broken packages
18:06:43 <mitr> mmaslano: We already froze for Beta
18:06:50 <mmaslano> yes
18:07:05 <notting> well, packages have been 'broken' inasmuch as there were two configuration files for two releases already. what is the plan if the work mjg59 is helping kay with does not happen?
18:07:20 <nirik> if there are pending fixes we could pass them thru the freeze as a NTH... or wait until after.
18:07:41 <t8m> As the breakage is not critical I think that the fixes can be done in updates
18:08:03 <mmaslano> so for now I agree with nirik's proposal
18:08:22 <mitr> notting: We are not currently equipped to handle that question AFAICT.  (We do need to be, but that's for another time.)
18:08:57 * nirik shrugs. I don't think I would block on it.
18:08:58 <t8m> nirik, +1
18:09:09 <nirik> it would be very nice ot fix before release tho...
18:10:20 <mjg59> Sure, where possible that clearly ought to happen
18:10:39 <mmaslano> more votes on nirik's proposal?
18:10:41 <limburgher> +1 nirik
18:10:56 <mitr> +1 I think
18:11:40 * nirik is for his own proposal too oddly enough.
18:11:46 * mmaslano too
18:11:56 <notting> +1 for lack of an alternative
18:12:01 <pjones> +1 I guess.
18:12:09 <jwb> sure
18:12:34 <mmaslano> #agreed defer for now and see if mjg59 can get them access to the info they seek (+8,-0)
18:12:34 <pjones> I mean, that's the process anyway if we /don't/ vote on it....
18:12:55 <mmaslano> #topic #971         Freezing for Fedora 18 Beta
18:13:00 <mmaslano> .fesco 971
18:13:02 <zodbot> mmaslano: #971 (Freezing for Fedora 18 Beta) – FESCo - https://fedorahosted.org/fesco/ticket/971
18:13:13 <nirik> I took that to be 'no great objection to freeze'
18:13:19 <jwb> we're already frozen
18:13:25 <nirik> so, close this, freeze happened. ;)
18:13:31 <mmaslano> great
18:13:40 <jwb> jreznik, who is "RH's SB manager"
18:13:52 <mmaslano> #info Fedora 18 was already frozen
18:14:18 <notting> jwb: in as much as 'guy running the meetings', jack
18:14:18 <jreznik> jwb: the person responsible for SB as far as I know
18:14:33 <jwb> jreznik, i'm looking for a name, not a role definition
18:14:58 * nirik wonders what SB expands to.... oh, secure boot?
18:15:06 <jreznik> nirik: yep
18:15:07 <pjones> jreznik: he wants to know who you were referring to
18:15:21 <jreznik> pjones: notting answered
18:15:39 <pjones> okay
18:15:46 <jwb> that is the most obtuse way of answering my question, ever.
18:15:53 <jwb> whatever.  move on
18:16:16 <mmaslano> #topic #969         libexecdir guideline conflicts with extant packages
18:16:24 <mmaslano> .fesco 969
18:16:25 <nirik> so, I have some info here.
18:16:26 <zodbot> mmaslano: #969 (libexecdir guideline conflicts with extant packages) – FESCo - https://fedorahosted.org/fesco/ticket/969
18:16:37 <nirik> FPC is currently discussing a very similar case of this related to java.
18:16:55 <nirik> it's not been decided either way, but it's very similar to this issue.
18:17:15 <mitr> nirik: Something different than the multilib exception for java that we voted on recently?
18:17:19 <nirik> so, I propose we defer this, ask FPC to consider it with java and wait for them to rule on that before we do anything.
18:17:59 <nirik> mitr: it's related. The question then becomes can non multilib things just use lib (like java and systemd do)
18:18:24 <nirik> (at least my quick understanding of it. Didn't read the full FPC meeting)
18:18:59 <notting> if they want to tackle it first, i'm ok with it. w.r.t. the ticket, i'd be proposing 1) and 2) listed there anyway
18:19:42 <nirik> see also: http://lists.fedoraproject.org/pipermail/packaging/2012-November/008757.html
18:20:53 <mjg59> I wasn't quite clear from the ticket
18:20:58 <mitr> So at this point I would suggest
18:21:00 <mitr> proposal: formally vote to confirm that As a general matter, Fedora policies trump upstream intentions and preferences (although they can be considered).  Rationale: the only way to make Fedora a consistent distribution.
18:21:02 <mitr> And I'd support a deferral of the ticket for a specific resolution re:systemd (unfortunately I haven't had enough time to form an opinion)
18:21:03 <mjg59> Is it /usr/lib, or is it /usr/%(libdir)?
18:21:26 <t8m> mjg59, /usr/lib
18:21:32 <nirik> it's %{prefix}/lib/ on all arches.
18:21:35 <notting> mjg59: the complaint is about x86_64 packages using /usr/lib instead of /usr/%(libdir) or /usr/libexec
18:21:50 <mjg59> notting: Ok from the ticket it sounded like it was primarily about libexec
18:22:15 * gholms is here
18:22:28 <mitr> s/can be considered/can and should be considered/ above
18:22:39 <t8m> gholms, why FPC rejected to allow /usr/lib for non-multilib packages in the systemd case?
18:22:43 <mjg59> mitr: I'm -1 to that as written
18:23:06 <mjg59> mitr: Or, rather, not as written. I agree with the statement, but I don't know that it's the appropriate statement to make in this case
18:23:30 <mjg59> mitr: Where our policies are incompatible with the behaviour of many upstreams, we should reconsider whether our policies are actually helping or harming
18:23:37 <nirik> well, I agree with it, but it's kinda a given isn't it?
18:23:38 <gholms> t8m: I wasn't involved in that discussion, but I can try to find out if necessary.
18:23:58 <nirik> we shouldn't recklessly trump upstream. Only in cases we really must for good reasons.
18:24:04 <mitr> mjg59: I don't know how that applies to systemd in this case.  But we have systemd maintainers thinking otherwise, and I don't want the opposite to become a widely accepted oinion.
18:24:05 <gholms> t8m: The decision itself is here, along with some justifiction in the comentary:  https://fedorahosted.org/fpc/ticket/158
18:25:40 <mitr> mjg59: https://fedorahosted.org/fpc/ticket/158#comment:6 sums the situation up.
18:25:41 * nirik nods. based on the info at the time...
18:25:50 <nirik> anyhow, any votes on my proposal? ;)
18:26:17 <mjg59> Ok. What's the benefit of requiring libdir rather than /usr/lib for this case?
18:26:26 <mitr> nirik: +1 to deferral.
18:26:58 <gholms> nirik: That's for deferring until fpc decides upon the java stuff, right?
18:27:03 <nirik> mjg59: consistency I guess?
18:27:12 <mitr> mjg59: e.g. ability to run an automated test for misplaced 64-bit binaries
18:27:19 <pjones> yeah, I'm +1 to deferral until the java ruling comes down.
18:27:19 <nirik> gholms: yes, and ask them to think about this too at the same time.
18:27:25 <t8m> +1 to deferral
18:27:27 * notting is +1 for deferral
18:27:39 <mmaslano> +1
18:27:49 <limburgher> +1
18:27:49 <mjg59> I'm +1 to deferral, but the rationale presented for the policy so far seems weak
18:28:13 <jwb> DEFER
18:29:11 <mmaslano> #agreed defer the decision (until Java rulling comes down) (+9,-0)
18:29:13 <mjg59> Are there any cases where you could simultaneously have a 32-bit version of an executable binary in /lib and a 64-bit version in /lib64
18:29:16 <mjg59> ?
18:29:37 <mitr> mjg59: yes
18:29:43 <notting> mjg59: helpers executed by a library, yes
18:29:46 <nirik> sure
18:30:01 * nirik looks. systemd is multiarch?
18:30:14 <nirik> ah, but uses -libs. ok.
18:30:24 <notting> nirik: not the things in /lib/systemd, no
18:30:36 <mjg59> So the objection to using /usr/lib is just that a package might accidentally drop a 64-bit binary there despite supporting simultaneous 32 and 64-bit installation?
18:30:59 <mjg59> And forcing the use of libdir means that we can automatically check for that?
18:32:38 <notting> kind of, yes. if you're putting 64-bit binaries in /usr/lib, you need to 'know your package is never intended to be installed as multilib and will not accidentally be installed that way'
18:32:42 <mjg59> Ok
18:32:46 <notting> which is hard to clearly check against the guideline
18:33:04 <nirik> also lsb says: http://www.linuxbase.org/betaspecs/fhs/fhs.html#usrlibexec
18:33:18 <jwb> you just killed a cat.
18:33:21 <mjg59> nirik: Yeah but the LSB is failing to describe reality in this case
18:33:24 <nirik> yeah, true.
18:33:35 <nirik> anyhow, I'll stop now.
18:33:48 <nirik> we have an agreed and are wasting time. ;)
18:33:50 <mmaslano> next topic?
18:33:53 <mjg59> notting: It seems like we could solve that easily enough by just permitting packages to ship a list of "I really meant to do this"
18:34:06 <nirik> (or just drop 32bit. ;)
18:34:09 <t8m> mmaslano, please
18:34:14 <mmaslano> #topic #970 F19 Feature: RPM 4.11 http://fedoraproject.org/wiki/Features/RPM4.11
18:34:17 <jwb> nirik, or multilib
18:34:17 <mjg59> It's unclear to me that this policy buys us anything other than divergence from upstreams
18:34:23 <mmaslano> .fesco 970
18:34:23 <mjg59> Anyway
18:34:25 <zodbot> mmaslano: #970 (F19 Feature: RPM 4.11 - http://fedoraproject.org/wiki/Features/RPM4.11) – FESCo - https://fedorahosted.org/fesco/ticket/970
18:34:26 <mjg59> +1 to rpm
18:34:30 <limburgher> +1!
18:34:35 <nirik> +1 make it so.
18:34:36 <mmaslano> +1
18:34:36 <jwb> +1
18:34:37 <mitr> +1
18:34:40 <pjones> big +1
18:34:41 <nirik> I'd love more f19 features now. ;)
18:34:45 <limburgher> We'll have the 411!
18:34:52 <notting> sure
18:34:53 <notting> +1
18:34:55 <t8m> +1 sure
18:35:15 <mmaslano> #agreed rpm was accepted as f19 feature (+9,-0)
18:35:26 <mmaslano> that's it
18:35:29 <mmaslano> #topic Next week's chair
18:35:52 <jwb> i will be out next week
18:36:01 <nirik> I can do it I suppose...
18:36:19 <mmaslano> #info nirik will be the chairman next week
18:36:30 <mmaslano> #topic Open Floor
18:36:44 <mjg59> It's the day before thanksgiving next week?
18:36:48 <limburgher> Yup.
18:36:52 <nirik> yep
18:36:56 <mjg59> Not that it matters in my case
18:37:08 <nirik> I expect many folks will be gone thursday/friday.
18:37:14 <limburgher> I will.
18:37:16 <pjones> yeah
18:37:17 <notting> yeah, I may or may not be here. will comment in tickets in any case
18:37:18 <nirik> I hope we can get to a beta before next wed.
18:37:33 <limburgher> From your IRC client to $_DEITY's ears.
18:38:13 <mmaslano> I'll close meeting in 5 minutes!
18:39:07 <notting> just want to thank those who threw their name in the hat for the FESCo elections
18:39:54 <limburgher> And Ankur for wrangling.
18:40:06 * gholms concurs
18:40:23 * nirik nods.
18:44:15 <mmaslano> #endmeeting