18:02:11 <sgallagh> #startmeeting FESCO (2013-04-24)
18:02:11 <zodbot> Meeting started Wed Apr 24 18:02:11 2013 UTC.  The chair is sgallagh. Information about MeetBot at http://wiki.debian.org/MeetBot.
18:02:11 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
18:02:11 <sgallagh> #meetingname fesco #chair abadger1999 jwb mitr mmaslano notting nirik pjones t8m sgallagh #topic init process
18:02:11 <zodbot> The meeting name has been set to 'fesco_#chair_abadger1999_jwb_mitr_mmaslano_notting_nirik_pjones_t8m_sgallagh_#topic_init_process'
18:02:27 <pjones> hello.
18:02:31 <nirik> thats a long name. ;)
18:02:34 * abadger1999 present
18:02:34 <sgallagh> #meetingname fesco
18:02:34 <zodbot> The meeting name has been set to 'fesco'
18:02:34 <sgallagh> #chair abadger1999 jwb mitr mmaslano notting nirik pjones t8m sgallagh #topic init process
18:02:34 <zodbot> Current chairs: #topic abadger1999 init jwb mitr mmaslano nirik notting pjones process sgallagh t8m
18:02:41 * nirik is here tho
18:02:59 <mitr> Hello
18:03:12 * notting is here
18:05:05 <sgallagh> Well, we have quorum. Shall we wait a few more minutes or begin?
18:05:17 <pjones> we can wait a few, the schedule is, uh, light.
18:05:24 <pjones> I mean, if we're actually expecting others.
18:06:41 <sgallagh> #topic init process
18:06:59 <sgallagh> (sorry, I mass-pasted a bunch of commands and my client oddly dropped the newlines)
18:08:50 <sgallagh> Ok, I don't think anyone else is coming.
18:09:06 <pjones> okay.
18:09:10 <sgallagh> #topic #1108 Provenpackager request - jplesnik
18:09:10 <sgallagh> .fesco 1108
18:09:13 <zodbot> sgallagh: #1108 (Provenpackager request - jplesnik) – FESCo - https://fedorahosted.org/fesco/ticket/1108
18:09:56 <sgallagh> So jplesnik is working on PERL mass rebuilds and wants to be granted provenpackager access to facilitate this, if I understand the request correctly.
18:10:05 <notting> 2 +1, one -1 in the ticket.
18:11:03 <pjones> I'm not seeing a good reason we should treat this differently than we did e.g. boost rebuilds.
18:11:23 <sgallagh> pjones: Refresh my memory: we gave pp to the boost rebuilder, correct?
18:11:36 <mitr> I'm +1 as well
18:11:55 <pjones> sgallagh: right
18:11:56 * nirik is +1
18:11:59 * pjones is +1
18:12:01 * sgallagh notes that he himself is a provenpackager primarily because he was managing SSSD/FreeIPA/Samba/Bind updates constantly.
18:12:02 <mitr> sgallagh: yes, https://fedorahosted.org/fesco/ticket/989
18:12:04 <sgallagh> So I'm +1
18:12:09 <notting> i'm +1 as well
18:12:51 <abadger1999> yeah, for a case of "person needs to do rebuilds" i think it's just a question of whether we think the person will limit themselves to the scope they've mentioned (rebuilds for new perl).
18:12:59 <mitr> (to be preciese - the ticket has a +1 from Tomas and +1 from Stano, who is not a FESCo member)
18:13:08 <abadger1999> i do note that the person applying didn't say that the scope they were seeking...
18:13:15 <sgallagh> Yes, so I count +6 (from FESCo members)
18:13:38 <abadger1999> but it sounds like mmaslano is talking with the maintainer in person and that's her expectation.
18:13:52 <abadger1999> +1
18:14:24 <sgallagh> That's unanimous from present members, so I think we're done here.
18:14:33 <pjones> abadger1999: if they limit themselves to that *and* reasonable fixes in other things, I'm still happy with it ;)
18:14:39 <sgallagh> #agreed grant provenpackager status to jplesnik
18:14:57 <abadger1999> pjones: <nod>  Wouldn't that be the case for anyone though? ;-)
18:15:02 <sgallagh> Who wants to set the ACL?
18:15:25 <notting> i
18:15:27 <notting> i'll do it
18:15:47 <sgallagh> #action notting to grant provenpackager to jplesnik
18:15:58 <abadger1999> I'm meaning... if there's concerns that they don't have enough of a proven track record to be doing reasonable fixes, they should still be able to do mass rebuilds if they are willing to limit themselves to that.
18:16:20 <sgallagh> #topic Next week's chair
18:16:32 * sgallagh tosses the hot potato
18:17:20 * abadger1999 can do it.  I'll make sure after the meeting I know all the things that entails.
18:17:50 <mitr> May 1 and May 8 are public holidays in Czech Republic, so a few of us might be absent
18:18:01 <mitr> (I don't have definite plans yet)
18:18:02 <sgallagh> #info  mitr: May 1 and May 8 are public holidays in Czech Republic, so a few of us might be absent
18:18:10 <pjones> mitr: I'm kind of amazed you guys still have May Day as a holiday.
18:18:19 <sgallagh> #action abadger1999 to chair May 1 meeting
18:18:31 <sgallagh> #topic Open Floor
18:19:03 <pjones> (or Labor Day, depending on where you are and whatnot...)
18:19:09 * nirik would like to congratulate all the folks who worked on Alpha. ;)
18:20:27 <sgallagh> Yes, masterful work everyone.
18:22:41 <nirik> did we want to do anything with the relro/etc ticket?
18:23:06 <nirik> https://fedorahosted.org/fesco/ticket/1104
18:23:14 * nirik suspects we could just close it now?
18:23:38 <sgallagh> mitr: Is there anything more to be discussed there?
18:24:16 <mitr> We can either close it as halfie's happy with the current progress (and has been filing bugs AFAICS), or try to deal with https://fedorahosted.org/fesco/ticket/1104#comment:17 .
18:25:04 <nirik> oh, FWIW, I mentioned we should have a mass bugs SOP, and its such a good idea that I actually made one a while back and forgot about it: http://fedoraproject.org/wiki/Mass_bug_filing
18:25:25 <halfie> mitr, I could use some help from FESCo. Lot of packagers haven't responded so far.
18:25:29 <mitr> Let's get into the minutes
18:25:36 <mitr> #info http://fedoraproject.org/wiki/Mass_bug_filing
18:26:44 <mitr> I think I'd prefer everything PIE + using prelink for non-_hardened_build , but it's a tough call and it requires someone to do the implementation work...
18:27:21 <mitr> halfie: My opinion on that is in https://fedorahosted.org/fesco/ticket/1104#comment:19 , FESCo might not share it
18:27:25 <abadger1999> iirc, jakub was against hardening everything with all the proposed flags but I'm pretty sure _hardened_build doesn't use all the flags he talked about.  So I'm not sure what his position would be on applying that across the board.
18:27:47 <nirik> he is against dropping prelink I am pretty sure. ;)
18:29:06 <nirik> if we are going to change the policy, I'd prefer a more detailed write up of the possible polices and upsides/downsides for each.
18:31:39 <mitr> nirik: Right.  So, close the ticket and hope for someone to pick up the topic?
18:32:24 <nirik> we could yeah. close and ask anyone if they would like to submit a more detailed proposal on changing the policy?
18:33:16 <notting> sounds good to me
18:33:28 <abadger1999> wfm
18:33:47 * nirik may actually try and propose dropping prelink. will see if I have the time.
18:34:03 <sgallagh> mitr: +1
18:34:37 <sgallagh> #action mitr to close  https://fedorahosted.org/fesco/ticket/1104 as respondents in the ticket seem content at the current time
18:34:48 <sgallagh> Any other topics for Open Floor?
18:36:33 <sgallagh> If there are no other topics, I'll close the meeting in two minutes
18:38:42 <sgallagh> #endmeeting