18:00:06 <abadger1999> #startmeeting FESCO (2013-05-01)
18:00:06 <zodbot> Meeting started Wed May  1 18:00:06 2013 UTC.  The chair is abadger1999. Information about MeetBot at http://wiki.debian.org/MeetBot.
18:00:06 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
18:00:08 <abadger1999> #meetingname fesco
18:00:08 <zodbot> The meeting name has been set to 'fesco'
18:00:09 <abadger1999> #chair abadger1999 jwb mitr mmaslano notting nirik pjones t8m sgallagh
18:00:09 <zodbot> Current chairs: abadger1999 jwb mitr mmaslano nirik notting pjones sgallagh t8m
18:00:11 <abadger1999> #topic init process
18:00:16 <pjones> morning, party people.
18:00:25 * notting is here
18:00:26 <jwb> hello
18:00:52 <mitr> Hello
18:00:56 <abadger1999> Good morning everyone, time for another fun and exciting fesco meeting :-)
18:01:08 <nirik> hello
18:01:13 <sgallagh> Ciao
18:01:55 <abadger1999> Well, that's seven, enough for quorum
18:02:26 <abadger1999> Pretty light schedule today:
18:02:28 <abadger1999> #topic #1110 systemd preset for ipmi
18:02:30 <abadger1999> .fesco 1110
18:02:31 <zodbot> abadger1999: #1110 (systemd preset for ipmi) – FESCo - https://fedorahosted.org/fesco/ticket/1110
18:04:31 * notting attempts to parse this. he wants to install his own preset file based on the presence of hardware?
18:04:38 <sgallagh> So I'm not sure why this is coming to FESCo
18:05:13 <sgallagh> I don't see any indication that he's approached the maintainers of OpenIPMI or systemd about this.
18:05:41 <nirik> .bug 728436
18:05:42 <zodbot> nirik: Access Denied - https://bugzilla.redhat.com/show_bug.cgi?id=728436
18:05:45 <nirik> nice
18:05:53 <mitr> sgallagh: He is a maintainer of OpenIPMI
18:06:18 <mitr> the maintainer, even
18:06:26 <sgallagh> ok
18:06:56 <abadger1999> https://admin.fedoraproject.org/pkgdb/users/packages/aledvink?acls=owner
18:07:00 <sgallagh> I still don't quite understand what he's asking for, or what exception he's seeking.
18:07:11 <abadger1999> OpenIPMI, freeipmi, and ipmitool
18:07:33 <sgallagh> Is he basically just asking for permission to autostart a daemon?
18:08:51 <mitr> to load modules, or whatever http://pkgs.fedoraproject.org/cgit/OpenIPMI.git/tree/openipmi-helper does
18:09:17 <mitr> Isn't this covered by the first sentence in https://fedoraproject.org/wiki/Starting_services_by_default as "up to individual maintainer" already?
18:10:13 <mitr> "Except this proposal violates ​https://fedoraproject.org/wiki/Features/PackagePresets by taking back it's preset management" ... I have no idea what that means I'm afraid (and I didn't ask, my bad)
18:10:30 * nirik is also somewhat confused as to exactly what they want to do here.
18:11:38 <nirik> so, perhaps we should ask them more specifically what they wish?
18:11:53 <nirik> or, are they on irc anywhere?
18:12:47 <mitr> Today is a holiday in Czech republic, AFAICS he isn't online
18:12:53 <nirik> ok
18:13:05 <pjones> yeah, I think we just have to get him to explain further
18:13:23 <abadger1999> k.  i'll ask him to clarify what he wants
18:13:25 <pjones> Possibly with a note that if none of us can figure out what he's asking, we're going to lean towards denying the request ;)
18:13:40 <abadger1999> #action abadger1999 to ask for clarification in the ticket
18:14:00 <nirik> perhaps ask for a diff of specific changes they want?
18:14:06 <abadger1999> <nod>
18:14:11 <abadger1999> #topic #1111 systemd preset for ipmievd
18:14:13 <abadger1999> .fesco 1111
18:14:14 <zodbot> abadger1999: #1111 (systemd preset for ipmievd) – FESCo - https://fedorahosted.org/fesco/ticket/1111
18:14:22 <abadger1999> Another request from the same maintainer.
18:15:07 <nirik> depends on the last ticket too
18:15:30 <abadger1999> Overall question -- are systemd presets supposed to be managed by packages?
18:15:46 <mitr> Per https://fedoraproject.org/wiki/Features/PackagePresets it is centralized
18:15:48 <nirik> we never got too clear an answer.
18:15:53 <nirik> or at least I don't recall one
18:16:05 <abadger1999> I thought default enable/disable was managed a different way in packages and presets were for distro/spin level
18:16:17 <nirik> see https://fedorahosted.org/fesco/ticket/945
18:16:26 <mitr> (we didn't get any _useful_ results out of presets because the spin policy hasn't been written)
18:16:39 * nirik nods.
18:17:17 <mitr> abadger1999: The https://fedoraproject.org/wiki/Packaging:ScriptletSnippets?rd=Packaging/ScriptletSnippets#New_Packages macros don't let packages specify enabled/disabled
18:18:16 <abadger1999> mitr: " Services can either be enabled or disabled by default. To determine which case your specific service falls into, please refer to FESCo's policy here: Starting_services_by_default." ?
18:18:25 <nirik> well, I thought the idea was central default then things like spins could ship their own
18:18:58 <gholms> nirik: Right, but we don't have a policy for spins that want to ship their own yet.
18:19:05 <mitr> Perhaps that both of the tickets should actualy be filed against systemd in bugzilla, but at least the #1110 is unclear enough that I'd rather wait for clarification
18:19:17 <mitr> abadger1999: See the paragraph starting "If your package includes one or more systemd units that need to be enabled by default on package installation, they need to be covered by the default Fedora preset policy."
18:19:17 <pjones> perhaps we should at least wait for the other thing to be clarified since this is clearly related
18:19:23 <pjones> mitr: exactly
18:19:34 <nirik> gholms: yep.
18:21:07 <abadger1999> mitr: ah I think I see what you're saying.
18:21:36 <abadger1999> so one thing I should say in the tickets is that packages do not add their own presets.
18:21:49 <abadger1999> they get placed into one ofthe existing presets
18:22:37 <abadger1999> and the maintainer might need to re-architect the way his autodetection works to make that possible.
18:23:26 <abadger1999> anyhow... sounds like this one can't be approved without further info either.
18:23:56 <abadger1999> #action abadger1999 will ask for clarification on this ticket similar to 1110
18:24:00 <abadger1999> #topic Clarify release name guidelines - Explicitly list blacklisted characters
18:24:07 <pjones> We meant: | & ; ( ) < > { } ' " #
18:24:15 <pjones> And we are deeply remorseful that the manual for the shell treats tokenization points and operators as the same thing.
18:24:40 <abadger1999> <nod>
18:24:42 * nirik nods. fine with me. typing this line is already more than I care about this topic. ;)
18:25:30 <abadger1999> Proposal: Update guideline to explicitly list out the bad characters:    | & ; ( ) < > { } ' " #
18:25:32 <abadger1999> +1
18:25:35 <pjones> +1
18:25:36 <sgallagh> +1
18:25:42 <jwb> +1
18:25:59 <notting> +1
18:25:59 <nirik> +1
18:26:18 <abadger1999> That's 6, proposal passes.  I'll update the page
18:26:59 <abadger1999> #info Update release name guidelines to explicitly blacklist  | & ; ( ) < > { } ' " #  passes (+1:6, 0:0, -1:0)
18:27:07 <abadger1999> #topic Next week's chair
18:27:13 <abadger1999> Who wants the potato?
18:27:34 <jwb> i'll bite
18:29:01 <nirik> make sure you cook the potato... raw ones are not that tasty. ;)
18:29:19 <abadger1999> #action jwb will chair nextweek's meeting
18:29:27 <abadger1999> #topic Open Floor
18:29:27 <jwb> i am secretly hoping a meeting won't be needed, but hey
18:29:31 <jwb> i have something
18:29:57 <abadger1999> You have the floor :-)
18:30:19 <jwb> so spot sent out a proposal for how the flock conference schedule is going to work.  if that stands, they want a member FESCo to help review proposals and set the schedule
18:30:36 <jwb> review talk/hackfest/etc proposals that is
18:30:49 <jwb> if nobody else is interested in doing that, i'll volunteer
18:30:55 <jwb> thoughts?
18:31:07 * nirik is happy to have jwb do it. Hope there's lots of good proposals
18:31:40 <abadger1999> I could volunteer too but if we only need one I'm happy for jwb to do it :-)
18:31:59 <sgallagh> Ditto with abadger1999
18:32:12 <sgallagh> Has flock nailed down a date yet?
18:32:34 <jwb> afaik, not specifically.  "around the 9th of august" is the best we have
18:32:43 <sgallagh> Also, where did he send out that proposal?
18:32:53 <jwb> flock-planning@lists
18:32:57 * sgallagh suspects it was on one or both of the remaining mailing lists he hasn't subscribed to
18:33:26 <jwb> basically, spot, rbergeron, suehle, and one member from the Board, FESCo, and FAMSCo
18:33:35 <jwb> to create the conference committee
18:34:05 <jwb> his post has not gathered a ton of feedback yet.  the feedback it has gathered has been positive
18:34:25 <nirik> I think it's a reasonable idea...
18:34:26 <sgallagh> jwb: It might be worth expanding it to a more heavily-subscribed list
18:34:58 * jwb wonders if spot is listening
18:35:04 <nirik> I suspect he was looking for feedback on the plan before spreading it out to more lists, etc.
18:36:40 <jwb> anyway, that's all i had.  if someone REALLY wants to be the FESCo rep, let me know.  otherwise i'll plan on it
18:38:18 <nirik> just as a reminder: there's a lists.fedoraproject.org outage starting at 21:00UTC today...
18:38:42 <jwb> REPRIEVE
18:38:48 <jwb> uh.. i mean...
18:38:49 * suehle chimes in with a lack of information about dates... The College of Charleston is pushing back on the room reservations, so we're trying to satisfy their needs. It's between orientation and school starting, so it's a challenge.
18:39:09 <jwb> thanks suehle
18:40:11 <suehle> the intended time frame is around August 9-13
18:41:08 <pjones> August in Charleston.
18:41:10 <pjones> Wonderful.
18:41:36 <suehle> Better than January in Blacksburg IMO
18:42:22 <mitr> (Is Flock timing a FESCo topic?)
18:42:32 <abadger1999> mitr: it could sorta kinda be...
18:43:09 <jwb> not really.  i think we can close the meeting.
18:43:21 <abadger1999> but I think it would have to be something like: no one on fesco/few of our packagers can attend at that time -- ask flock-planning committee to reconsiderthe schedule.
18:43:36 <abadger1999> and I'd think the planning committee would already have heard if that were the case.
18:44:34 * abadger1999 will close in 2 minutes if there's nothing further.
18:46:25 <abadger1999> #endmeeting