18:01:28 <sgallagh> #startmeeting FESCO (2013-07-03)
18:01:28 <zodbot> Meeting started Wed Jul  3 18:01:28 2013 UTC.  The chair is sgallagh. Information about MeetBot at http://wiki.debian.org/MeetBot.
18:01:28 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
18:01:31 <sgallagh> #meetingname fesco
18:01:31 <zodbot> The meeting name has been set to 'fesco'
18:01:35 <sgallagh> #chair abadger1999 mattdm mitr mmaslano notting nirik pjones t8m sgallagh
18:01:35 <zodbot> Current chairs: abadger1999 mattdm mitr mmaslano nirik notting pjones sgallagh t8m
18:01:39 <sgallagh> #topic init process
18:01:42 <nirik> morning everyone.
18:01:49 <mattdm> or afternoon :)
18:01:50 <sgallagh> pjones told me he will not be making it today.
18:01:53 <mitr> Evening everyone
18:02:37 * abadger1999 here
18:03:35 <mmaslano> hi
18:04:13 <sgallagh> Anyone know if notting and t8m are planning to attend today?
18:04:22 <sgallagh> (We have quorum in any case)
18:05:00 <mmaslano> I didn't see him online few days, probably vacation
18:05:13 <mitr> t8m had a PTO planned until today
18:05:16 <sgallagh> OK, let's proceed then.
18:05:34 <sgallagh> So, today marks the first day of the new FESCo
18:05:48 <mattdm> hi!
18:05:56 <sgallagh> I'd like to thank jwb for his service and welcome mattdm to his new office.
18:06:18 <abadger1999> hurrah!
18:06:22 <nirik> welcome and thanks!
18:06:33 <mattdm> thanks for the welcome and thanks to jwb!
18:07:02 <sgallagh> Ok, on to business. First, a follow-up from last week:
18:07:05 <sgallagh> #topic #1128 switching from "-fstack-protector" to "-fstack-protector-strong" in Fedora 20
18:07:08 <sgallagh> .fesco 1128
18:07:10 <zodbot> sgallagh: #1128 (switching from "-fstack-protector" to "-fstack-protector-strong" in Fedora 20) – FESCo - https://fedorahosted.org/fesco/ticket/1128
18:08:03 <sgallagh> I'm not certain why this is still open, actually.
18:08:15 <sgallagh> I think we gave it the go-ahead last week
18:08:16 <nirik> the bug hasn't been acted on by the maintainer...
18:08:19 <nirik> yet anyhow.
18:08:40 <sgallagh> Which maintainer, redhat-rpm-config?
18:08:50 <abadger1999> yeah, panu.
18:09:12 <sgallagh> Ok, I'll ping him again about including it
18:09:24 <mitr> Do we want to track this as a F20 blocker?  If not, let's just close the ticket I think.
18:09:32 <sgallagh> #action sgallagh to ping panu about including -fstack-protector-strong patch
18:09:51 <nirik> yeah, close is fine, as long as we make sure it's actually done. ;)
18:09:57 <sgallagh> mitr: I suggest we track the redhat-rpm-config bug as an F20Alpha blocker
18:10:01 <abadger1999> Do we need a mass rebuild with this?
18:10:19 * abadger1999 wonders if we should have a mass rebuild tracker of some sort too.
18:10:24 <nirik> abadger1999: we may yeah, if nothing else to make sure nothing breaks.
18:10:25 <sgallagh> abadger1999: We should include it in the inevitable gcc mass-rebuild
18:10:26 <mitr> abadger1999: good point, a mass rebuild should happen after this lands
18:10:42 <nirik> how about a new ticket for mass rebuild and note the things that might need it?
18:10:56 <nirik> so we can coordinate schedules, etc.
18:11:03 <sgallagh> nirik: Mind taking that?
18:11:07 <abadger1999> nirik: SOunds good.  I'll file and add this and the python-setuptools thing.
18:11:24 <sgallagh> #action abadger1999 to file mass-rebuild tracker ticket for F20
18:11:27 <nirik> sure, I can file one. Should it be in fesco or releng trac?
18:11:39 <nirik> or abadger1999 can. thats just dandy with me. ;)
18:11:40 <sgallagh> #undo
18:11:40 <zodbot> Removing item from minutes: <MeetBot.items.Action object at 0x14b09ad0>
18:11:48 <sgallagh> Decide amongst yourselves :)
18:12:11 <abadger1999> I'll talk to dgilmore/the other #fedora-releng folks and decide.
18:12:17 <nirik> sounds good.
18:12:25 <sgallagh> #action abadger1999 to file mass-rebuild tracker ticket for F20. He will discuss with dgilmore where to file it.
18:12:31 <nirik> we might ping gcc / rpm maintainers too to see if they need one.
18:12:47 <sgallagh> Ok, so we'll close FESCo ticket 1128?
18:12:59 <nirik> +1
18:13:01 <abadger1999> +1
18:13:15 <mitr> Sure
18:13:19 <mattdm> +1
18:13:36 <sgallagh> +1
18:13:51 <mmaslano> +1
18:14:08 <sgallagh> #agreed Close ticket 1128 and address remaining issues with a mass-rebuild
18:14:18 <sgallagh> On to new business...
18:14:23 <sgallagh> #topic #1132 libtool + %global _hardened_build 1 = no full hardening
18:14:27 <sgallagh> .fesco 1132
18:14:28 <zodbot> sgallagh: #1132 (libtool + %global _hardened_build 1 = no full hardening) – FESCo - https://fedorahosted.org/fesco/ticket/1132
18:15:05 <sgallagh> So... has proper analysis of this been performed yet?
18:15:14 <sgallagh> I may have missed it on the list
18:16:07 <mitr> Note that, AFAICS from the ticket and bug, this only applies to shared libraries
18:16:07 <abadger1999> I didn't see anything on the list either.
18:16:09 * nirik didn't see any.
18:16:21 <nirik> this is another redhat-rpm-config change?
18:16:32 <sgallagh> nirik: Probably?
18:17:06 <nirik> I'd say another bug should be filed and we should see if there's any issues with the proposed fix. (possibly a devel list post noting it and pointing to the bug?)
18:17:10 <mitr> Discussion in the bug (https://bugzilla.redhat.com/show_bug.cgi?id=978949) suggests that the patch is not ideal
18:17:34 * nirik missed the bug. looking
18:17:50 <mattdm> looks like we need comment from ajax?
18:18:08 <sgallagh> Who is on vacation at the moment.
18:18:09 * nirik nods
18:18:25 <mattdm> (aka Adam Jackson for the record)
18:18:36 <sgallagh> I think he'll be back next week, so shall we defer for a week pending his input?
18:19:52 <nirik> fine with me
18:19:53 <mitr> Given that this only applies to shared libraries, I don't think we really need to track it
18:20:18 <sgallagh> mitr: Why do you say that?
18:21:13 <mitr> sgallagh: 1) It's the daemons/executables that really need LD_BIND_NOW (but I haven't actually verified that not having it on libraries doesn't hurt) 2) Why is this different from any other bug?
18:21:42 <sgallagh> mitr: Well, it's failing to comply with our security guidelines.
18:22:06 <sgallagh> Also, executable plugins are still shared libraries, so there's exposure there.
18:22:29 <sgallagh> I'll grant you that it was a bit heavy-handed to bring it to FESCo so quickly, but I don't know that it's sensible to ignore it.
18:23:40 <mitr> I'm not going to be difficult about this :)  Keep the ticket open if it saves us time in the meeting.
18:24:20 <sgallagh> Proposal: shelve for a week, pending ajax input
18:24:25 * mattdm wonders if there's a way to fix the issue in libtool rather than hacking around it?
18:24:53 <sgallagh> mattdm: My understanding is that this is another incarnation of a classic libtool issue that upstream doesn't consider to be a bug.
18:25:11 <sgallagh> Though I'll admit that my understanding comes thirdhana
18:25:15 <sgallagh> *thirdhand
18:25:20 <nirik> +1 proposal
18:25:45 <mattdm> anyway yeah +1 to the "pending input" proposal
18:26:14 <mitr> +1
18:26:18 <mmaslano> +1
18:26:20 <sgallagh> mattdm: Basically it's a side-effect of libtool reorganizing the order of certain flags before executing. This is done to be compatible with certain platforms, but breaks Linux sometimes in hard-to-understand ways.
18:27:06 <mattdm> sgallagh I wonder if it could be taught to deal with _these specific flags_ in the right way, rather than the big hammer approach suggested?
18:27:30 <sgallagh> mattdm: All things are possible, but I'm the wrong person to ask if it's feasible :)
18:27:42 <mattdm> right. let's move on. :)
18:27:53 <sgallagh> #agreed shelve for a week, pending ajax input
18:28:03 <sgallagh> #topic 1131 Organize FESCo attendance at Flock
18:28:07 <sgallagh> .fesco 1131
18:28:08 <zodbot> sgallagh: #1131 (Organize FESCo attendance at Flock) – FESCo - https://fedorahosted.org/fesco/ticket/1131
18:28:48 <nirik> how do we want to go about this?
18:28:49 <sgallagh> There are an awful lot of sessions occurring at Flock this summer that might benefit from FESCo attendance.
18:29:01 * mattdm will be there
18:29:31 <sgallagh> First: who will be there? Second: Which are the important sessions for FESCo/those specific people?
18:29:39 * nirik will be there.
18:29:50 * mitr will be there
18:30:00 <sgallagh> I will be there unless my daughter arrives a few weeks early.
18:30:27 <sgallagh> I believe notting will also be there
18:30:39 <sgallagh> Not sure about pjones or t8m
18:30:43 * abadger1999 will be there
18:31:31 <mmaslano> I and t8m won't
18:31:38 <nirik> :(
18:31:59 <abadger1999> pjones is listed on the flock registration page
18:32:09 <sgallagh> ok
18:32:20 * nirik isn't sure how to note things that could use fesco input... it could really be any of them depending on where they go. ;)
18:32:52 <sgallagh> Well, some are obvious (to me, at least)
18:32:54 <mitr> With 10 parallel sessions there's too few of us anyway :)
18:33:11 <mattdm> I think we should probably aim to be at "Meet Your FESCo".
18:33:11 <sgallagh> The "Fedora Crystal Ball" and "Revamp" sessions for starters
18:33:45 * nirik was planning on making revamp
18:34:05 <abadger1999> I won't make either of those.
18:34:15 <sgallagh> I'm moderating the Crystal Ball and will be at revamp as well
18:34:21 <nirik> I'm running a db thing at the same time as crystal ball
18:34:28 <mmaslano> I hope someone will make meeting minutes, please
18:34:42 * nirik really hopes we can rope in some db savvy people for that.
18:34:56 <sgallagh> mmaslano: We'll be trying. Also, the sessions will be streamed by video as well, if you wish to attend remotely (or watch later)
18:35:00 <abadger1999> Did anyone see anything in the morning (talk) sessions?  I've only been looking at conflicts in the workshop/hackfest/discussion sessions (afternoon)
18:35:38 <sgallagh> ARM vs. Cloud in the very first session might be worth splitting our attention
18:35:45 <sgallagh> I was planning to attend the Cloud one
18:35:47 <mitr> "Evolution of ... ecosystem" vs. "Fedora ARM state of the union" might both be relevant
18:36:09 <sgallagh> Ok, so a three-way tie in the first hour :)
18:36:10 <mattdm> on saturady, "Using Fedora for developing things other than Fedora" is at the same time as Meet Yor FESCo
18:36:19 <abadger1999> ugh.
18:36:20 <sgallagh> Yeah, that's unfortunate :(
18:36:26 <mattdm> sgallagh The cloud one is boring :)
18:36:36 * abadger1999 just refreshed his schedule page... the sched.org schedule is so much less usable :-(
18:37:24 <sgallagh> Should we perhaps consider canceling or requesting a reschedule of "Meet Your FESCo"?
18:37:36 <sgallagh> Maybe we could incorporate that into one of the night's social events instead of a talk?
18:37:51 <mattdm> sgallagh That is definitely my idea of a party
18:37:58 <sgallagh> -_-
18:38:00 * mattdm is sadly half-serious
18:38:06 <mmaslano> mattdm: lol
18:38:14 <nirik> another idea: make it somehow easy for people to find a fesco member if they need to rope one into a talk? (not sure how... publish our schedules, setup a ping thing)
18:38:40 <mattdm> +1 nirk
18:38:42 <mattdm> +1 nirik
18:38:46 <abadger1999> mattdm: meet your fesco *could* be structured as a more social event.
18:38:49 <sgallagh> nirik: Not a bad idea. I'm sure we could rig something up.
18:39:12 <mattdm> I do think it would be better that way.
18:39:14 <sgallagh> Proposal: Change "Meet your FESCo" to "Buy your FESCo a beer"
18:39:19 <nirik> :)
18:40:08 <abadger1999> sgallagh: or the opposite if spot/suehle have funds: sodas, ice, pizza, and the audience throws questions at us.
18:40:29 <spot> please don't assume we have funds.
18:40:32 * abadger1999 thinks if we have pizza, we'd probably have the whole conference, though... maybe that's too much :-)
18:40:34 <mattdm> oh hi spot
18:40:35 <sgallagh> abadger1999: I think they'd tend more towards throwing sodas, ice pizza (and the audience) at us
18:40:56 <abadger1999> sgallagh: depends on how tasty the pizza is :-)
18:41:32 <nirik> can we have food/drinks in the room?
18:41:41 <mattdm> maybe pencil it in as a bring-your-own-pizza event?
18:41:54 <sgallagh> Serious proposal now, though: Cancel the "Meet Your FESCo" session and incorporate it into one of the evening events? Possibly as a game?
18:42:13 <nirik> if so, we should just have fesco pitch in and offer punch and pie to anyone who shows up. ;)
18:42:32 <sgallagh> I've seen that movie. The punch and pie is a lie!
18:42:34 <mattdm> strike "possibly as a game" and i'm +1
18:42:44 <abadger1999> mattdm: Agreed.
18:42:54 <sgallagh> Ok, consider that portion dropped.
18:43:02 * nirik is fine with just leaving it, moving it to evening or whatever.
18:43:10 <nirik> do we know if anyone has 'starred' it as something they want to attend?
18:43:26 <sgallagh> Well, if we have some members with conflicts at that time, it's not really serving its purpose
18:43:34 <nirik> '4 attending'
18:44:11 <sgallagh> There are three non-FESCo members starred there.
18:44:13 <abadger1999> I don't think we have any fesco-member conflicts?
18:44:24 <abadger1999> Just other things people would want to go to.
18:44:31 <abadger1999> Which would be the same in the evening too...
18:45:02 <sgallagh> Didn't someone claim a conflict with "Using Fedora for other things"?
18:45:07 <abadger1999> "Oh hey, so-and-so that I haven't seen since last year is going out to dinner... too bad I have Meet your FESCo now", etc.
18:45:44 <mattdm> sgallagh I am interested in that, because I would like Fedora to be useful.
18:46:05 <sgallagh> Let me ask a different question, then. What do we want to have this session be about? Just a general AMA?
18:46:34 <abadger1999> sgallagh: hmm...
18:46:35 <sgallagh> mattdm: Yeah, I'd attend that one as well if this session was moved/canceled, probably
18:46:37 <abadger1999> Here's a thought --
18:46:59 <abadger1999> What about moving to the 4PM slot on Sunday?  So it can be a wrap up for fesco of the conference too?
18:47:01 <abadger1999> ah
18:47:02 <abadger1999> except
18:47:05 <abadger1999> openlmi conflicts
18:47:09 <abadger1999> which is your talk
18:47:18 <sgallagh> Conference runs on Monday too...
18:47:29 <abadger1999> sgallagh: Monday is a bad idea imho
18:47:50 <abadger1999> Monday is going to be jam packaed with people desperately trying to do fifty things at once before flying home.
18:47:56 <sgallagh> I'll move my OpenLMI back to 2:00, then. I moved it so I could go to Bodhi, but that was a "want", not a "need"
18:49:32 <sgallagh> abadger1999: Your idea makes sense to me, enough that I'm willing to adjust the OpenLMI session back where it started. Assuming that the rest of us agree?
18:49:56 <abadger1999> That works for me if it's not too inconvenient for you :-)
18:50:09 <mitr> sgallagh: Sunday 4pm works for me
18:50:18 * nirik is fine with that... or could we somehow stick it inbetween... it shouldn't need 2 hours?
18:50:24 <nirik> but openlmi might well.
18:50:27 <mattdm> I'm okay with that too.
18:50:48 <sgallagh> nirik: I'm frankly not expecting anyone to actually show up for that hackfest. I'm *hopeful*, but not expectant.
18:52:38 <nirik> whatever works.
18:53:01 <sgallagh> Proposal: Move "Meet Your FESCo" to Sunday 4pm to act as a capstone discussion for the conference.
18:53:13 <abadger1999> +1
18:53:25 <mitr> +1
18:53:30 <mattdm> +1
18:53:42 <nirik> sure, +1
18:54:05 <nirik> perhaps we could add "Conference recap" or something to it also?
18:54:08 * mmaslano abstains
18:54:14 <sgallagh> nirik: Sure
18:54:32 <sgallagh> #agreed Move "Meet Your FESCo" to Sunday 4pm to act as a capstone discussion for the conference.
18:54:43 <sgallagh> "Conference Recap with FESCo"?\
18:54:49 <mattdm> yep
18:54:55 * nirik nods.
18:55:04 <sgallagh> Ok, I'll talk to the organizers and sort that out.
18:55:23 <sgallagh> #action sgallagh to speak with Flock conference organizers to shuffle the schedule
18:56:04 <sgallagh> With this planned as a capstone, I think we can probably trust that our individual interests will spread us around the other talks, yes?
18:56:13 <nirik> yeah, hopefully so.
18:56:21 <sgallagh> (i.e. we probably don't need to go into much detail about the other sessions)
18:56:39 <mattdm> yeah sounds good.
18:57:11 <sgallagh> Does anyone have any other conflicts they'd like us to discuss before we move to next week's chair?
18:57:42 * nirik has lots of them, but thats just because there's so much I want to go to going on. ;) nothing fesco can do...
18:57:53 <sgallagh> I know the feeling
18:58:12 <sgallagh> Ok, moving on then
18:58:17 <sgallagh> #topic Next week's chair
18:58:35 * sgallagh shoots the arrow in the air. Who's going to catch it?
18:58:41 <abadger1999> I can volunteer.
18:58:58 <sgallagh> #info abadger1999 to chair next week's meeting
18:59:04 <sgallagh> #topic Open Floor
18:59:18 <sgallagh> Anything for open floor?
19:00:13 <nirik> Thanks to everyone for a nice fedora 19 release. ;) Went smoothly and so far people seem to like it overall. :)
19:00:26 <sgallagh> Yeah, smoothest release in a long time.
19:00:44 <mattdm> yes :)
19:01:18 <sgallagh> Let's keep this up with F20, okay?
19:01:55 <mattdm> yessir
19:02:15 <sgallagh> abadger1999: Do you want to discuss the setuptools change at all?
19:03:49 <abadger1999> sgallagh: I've built the setuptools-0.7 package for rawhide today.
19:04:08 <abadger1999> My limited rebuilds have only shown one problem pakage and there's an upstream beta that should fix that.
19:04:14 <sgallagh> I saw that, but you are planning on building 0.8 soon as well?
19:04:26 <abadger1999> There is a setuptools-0.8 which is scheduled for a few weks -- reading hte changelog I think we want to use that.
19:04:41 <abadger1999> I'm going to talk to ncoghlan asap about whether he agrees.
19:04:50 <abadger1999> yeah -- it's currently 0.8b2
19:05:03 * sgallagh notes that "first" is a Fedora tenet
19:05:16 <sgallagh> A few weeks is still well before beta
19:05:23 <sgallagh> err, alpha
19:05:31 <abadger1999> <nod>
19:06:39 <sgallagh> In a non-FESCo-capacity, I'm in favor of landing 0.8 for F20.
19:07:28 <abadger1999> Cool.
19:08:47 <mattdm> In an a non-FESCo-capacity, it is time for me to take my kids to piano lessons.
19:09:47 <sgallagh> Oh, one important question
19:10:03 <sgallagh> Does this timeslot continue to work for everyone (particularly mattdm, our new member)?
19:10:10 <sgallagh> Or should we run through a whenisgood?
19:10:31 <mattdm> yes, it's good for me.
19:11:02 <sgallagh> Ok, if no one has anything else, I'll close out the meeting
19:11:18 <mattdm> I'm good. thanks for running the meeting.
19:11:44 * nirik is fine with this timeslot.
19:12:03 * mmaslano has to go now
19:12:24 <mmaslano> I'm also fine with this time, it may change in September
19:12:34 <sgallagh> thanks all
19:12:37 <sgallagh> #endmeeting