#fedora-meeting: FESCO (2013-11-20)

Meeting started by sgallagh at 17:59:37 UTC (full logs).

Meeting summary

  1. init process (sgallagh, 17:59:47)
  2. #1193 reboots for all updates -- are we ready for this? (sgallagh, 18:02:13)
    1. ACTION: mattdm to contact the Change owner to update the wiki page and release notes (sgallagh, 18:04:29)

  3. #1185 Enable "-Werror=format-security" by default (sgallagh, 18:04:43)
    1. 400 packages fail rebuild (mattdm, 18:06:56)
    2. AGREED: 1) wait a week for devel feedback (from people already interested); 2) if there are no show-stoppers identified, mass file bugs; 3) 3 weeks later, enable in rawhide configuration by default (+8, 0, -0) (sgallagh, 18:14:50)
    3. AGREED: Please file a Change page for this. (+7, 0, 0) (sgallagh, 18:17:44)

  4. #1198 Possible changes to Fedora EOL bug procedure (sgallagh, 18:18:08)
    1. AGREED: Ask the Bugzilla administrators to implement the reopen-and-re-version request (+8, 0, -0) (sgallagh, 18:20:21)

  5. #1140 F20 Self Contained Changes - week 2013-07-10 - 2013-07-17 (sgallagh, 18:20:52)
    1. http://fedoraproject.org/wiki/Features/Java8TechPreview and "ibus-gnome3 is provided in a ibus subpackage as a technology preview for Fedora 16." are some older examples. (nirik, 18:26:07)
    2. https://bugzilla.redhat.com/show_bug.cgi?id=1024144 (adamw, 18:33:16)
    3. https://bugzilla.redhat.com/buglist.cgi?bug_status=NEW&bug_status=ASSIGNED&bug_status=POST&bug_status=MODIFIED&bug_status=ON_DEV&bug_status=ON_QA&bug_status=VERIFIED&bug_status=RELEASE_PENDING&component=anaconda&component=lvm&component=lvm2&component=python-blivet&list_id=1922711&query_format=advanced&short_desc=thin&short_desc_type=allwordssubstr is a quick sesarch i just came up with for anaconda, blivet and lvm bugs with 'thin' in the summary (adamw, 18:46:38)
    4. http://fedoraproject.org/wiki/Features/Java8TechPreview (mattdm, 18:46:45)
    5. AGREED: leave the decision of whether to hide or fix thinp to anaconda. We're also okay with QA's interpretation of the criteria which may lead to release slippage if some thinp bugs are considered blockers (+7, 0 -0) (sgallagh, 18:52:07)

  6. #1205 Workstation WG governance charter (sgallagh, 18:52:28)
    1. AGREED: Workstation Governance Document is approved (+9, 0, -0) (sgallagh, 18:54:51)

  7. #1203 Soft dependencies (sgallagh, 18:57:27)
    1. AGREED: FESCo would be OK with some implementations of soft dependencies. To get a more clear ACK or NAK, come up with an implementation design (+7, 0, -1) (sgallagh, 19:08:57)

  8. #1202 Release and Support lifecycle questions (sgallagh, 19:09:04)
    1. AGREED: If working groups want to use different cycles, they should provide us with what they want to do with rationale along with the PRD. They should be aware that even if we can okay the plan, it is unlikely to be implementable for one or more releases. Please do not make your PRD depend on an alternate release lifecycle. (+7, 0, -1) (sgallagh, 19:38:14)

  9. #1206 Allowed licenses in Copr (sgallagh, 19:39:07)
    1. AGREED: COPR projects must use approved Fedora licenses for now (+6, 0, -1) (sgallagh, 19:46:38)

  10. #1204 F21 System Wide Change: Python 3.4 -https://fedoraproject.org/wiki/Changes/Python_3.4 (sgallagh, 19:46:59)
    1. AGREED: Python 3.4 Change is approved (+8, 0, -0) (sgallagh, 19:49:34)

  11. #1201 Enabling third party repositories (sgallagh, 19:50:20)
    1. AGREED: Defer to the next FESCo meeting and ask further questions in the ticket for clarification. (sgallagh, 19:58:43)

  12. Next week's chair (sgallagh, 19:58:49)
    1. mmaslano to chair the next meeting (sgallagh, 19:59:28)

  13. Open Floor (sgallagh, 20:00:51)


Meeting ended at 20:03:21 UTC (full logs).

Action items

  1. mattdm to contact the Change owner to update the wiki page and release notes


Action items, by person

  1. mattdm
    1. mattdm to contact the Change owner to update the wiki page and release notes


People present (lines said)

  1. sgallagh (187)
  2. nirik (87)
  3. abadger1999 (82)
  4. mitr (71)
  5. mattdm (70)
  6. pjones (63)
  7. notting (50)
  8. t8m (41)
  9. adamw (32)
  10. mmaslano (26)
  11. jreznik (22)
  12. jwb (19)
  13. zodbot (17)
  14. Viking-Ice (12)
  15. dlehman (8)
  16. kparal (5)
  17. drago01 (3)
  18. iThinkDev (3)


Generated by MeetBot 0.1.4.