16:58:45 <sgallagh> #startmeeting FESCO (2014-05-14)
16:58:45 <zodbot> Meeting started Wed May 14 16:58:45 2014 UTC.  The chair is sgallagh. Information about MeetBot at http://wiki.debian.org/MeetBot.
16:58:45 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
16:58:47 <sgallagh> #meetingname fesco
16:58:47 <zodbot> The meeting name has been set to 'fesco'
16:58:50 <sgallagh> #chair abadger1999 dgilmore mattdm mitr notting nirik pjones t8m sgallagh mmaslano jwb
16:58:50 <zodbot> Current chairs: abadger1999 dgilmore jwb mattdm mitr mmaslano nirik notting pjones sgallagh t8m
16:58:53 <sgallagh> #topic init process
16:58:55 <t8m> hi
16:58:58 <sgallagh> .hellomynameis sgallagh
16:58:59 <zodbot> sgallagh: sgallagh 'Stephen Gallagher' <sgallagh@redhat.com>
16:59:10 <sgallagh> #info pjones will be unable to attend while at UEFI hackfest
16:59:12 <mitr> Hello all
16:59:21 <nirik> morning. I'm here, but also poking at the pkgdb upgrade thats still ongoing, so might be slow.
16:59:27 * notting is here, although very behind on e-mail/trac/etc
16:59:52 <sgallagh> Looks to be a non-controversial agenda today.
16:59:53 <abadger1999> I'm not really here -- dealing with pkgdb upgrade in infra.
17:00:13 <abadger1999> If there's something that needs my vote to pass I can try to look back in
17:03:16 <mattdm> hi!
17:03:26 <sgallagh> Anyone seen dgilmore today?
17:04:11 <sgallagh> Ok, let's proceed
17:04:18 <sgallagh> #topic #1178 Fedora 21 scheduling strategy
17:04:19 <sgallagh> .fesco 1178
17:04:21 <zodbot> sgallagh: #1178 (Fedora 21 scheduling strategy) – FESCo - https://fedorahosted.org/fesco/ticket/1178
17:04:56 <sgallagh> jreznik_ would like us to schedule the mass-rebuild
17:05:18 <sgallagh> I'd prefer to have dgilmore's and nirk's attention for this, so maybe defer a week?
17:05:32 * nirik looks to see if we have all the info.
17:05:39 <t8m> sgallagh, definitely +1
17:05:39 <nirik> might be good to defer yeah...
17:05:54 <t8m> sgallagh, +1 to defer that is
17:05:56 <mattdm> +1 wait for dgilmore
17:05:58 <nirik> and propose a date and get the affected changes to weigh in
17:05:59 <mitr> +1
17:06:12 <notting> fine with deferring, or doing in ticket
17:06:46 <sgallagh> nirik: Yeah, contacting the Change owners would be a good idea.
17:06:50 <sgallagh> Volunteers?
17:07:08 <nirik> 2014-06-09 (as proposed in the releng ticket) might be ok.
17:07:23 <nirik> I can talk with dgilmore and we can update the ticket(s) with proposals.
17:07:50 <sgallagh> nirik: That sounds like the best move
17:08:05 <sgallagh> #action nirik and dgilmore to coordinate and make a recommendation in the ticket
17:08:26 <sgallagh> Good enough for now?
17:08:53 <nirik> sure
17:08:55 <jreznik_> sgallagh: sorry, I was out
17:08:59 <sgallagh> #topic #1250 F21 Self Contained Changes
17:09:00 <sgallagh> .fesco 1250
17:09:01 <zodbot> sgallagh: #1250 (F21 Self Contained Changes) – FESCo - https://fedorahosted.org/fesco/ticket/1250
17:09:25 <sgallagh> jreznik_: Were there any self-contained changes for this week?
17:09:34 <jreznik_> nirik: I'll watch the ticket
17:09:47 <jreznik_> sgallagh: no
17:09:54 <sgallagh> ok, that was easy :)
17:10:01 * dgilmore is here
17:10:06 <jreznik_> a few leftovers were announced today
17:10:10 <sgallagh> #topic #1291 F21 System Wide Change: BerkeleyDB 6 - https://fedoraproject.org/wiki/Changes/BerkeleyDB_6
17:10:10 <sgallagh> .fesco 1291
17:10:11 <zodbot> sgallagh: #1291 (F21 System Wide Change: BerkeleyDB 6 - https://fedoraproject.org/wiki/Changes/BerkeleyDB_6) – FESCo - https://fedorahosted.org/fesco/ticket/1291
17:11:06 <sgallagh> Has upstream weighed in on the symbol problem?
17:11:17 <jreznik_> sgallagh: btw. for contacting change owners for mass rebuild, already started pinging a few but any help welcomed :)
17:12:02 <nirik> jreznik_: they should all be cc'ed on the releng ticket no?
17:12:11 <dgilmore> jreznik_: we need all the side tags merged back into f21 first
17:12:12 <sgallagh> Also, I heard something this past week about the AGPL change possibly resulting in issues for users too
17:12:41 <dgilmore> sgallagh: well AGPL will require users to make thier source available
17:13:21 <dgilmore> so if you have a webapp thats inhouse using bdb you will need to make your webapps sources available
17:13:23 <jreznik_> nirik: should be but as QA guys says - it's s* word
17:13:28 <t8m> huh, that's pretty bad
17:13:36 <nirik> well, or switch to compat-db
17:13:42 <dgilmore> right
17:13:43 <sgallagh> Yeah, that's bordering on unacceptable
17:14:08 <nirik> or switch to a upstream that doesn't relicense in crazy ways. ;)
17:14:15 <mattdm> also, it's not just *web* apps. it's anything network.
17:14:24 <sgallagh> There's going to be a lot of fallout from that.
17:14:24 <mattdm> which could hit a lot of db-using things
17:14:25 <dgilmore> I honestly think we should stay at db5
17:14:30 <mitr> That's why the proposal is to have both, that’s not the issue under discussion AFAIK
17:14:42 <sgallagh> Proposal: reject BDB 6 for Fedora 21 while the maintainers and upstream sort out the issues.
17:14:51 <mitr> It’s just that we haven't heard from upstream
17:15:21 <sgallagh> mitr: Having both doesn't necessarily solve the problem if we default to upgrading to 6
17:15:40 <mitr> sgallagh: That has already been resolved by the owner promising to audit every package
17:16:02 <sgallagh> mitr: That doesn't help anyone building on top of Fedora
17:16:22 <t8m> mitr, if the agpl seriously changes things even for users it is bad to switch the default for any dependent app
17:16:26 <mitr> sgallagh: -1 I can’t see that anything has changed regarding licensing, and I haven’t seen that the delay in getting the versioning plan implemented is problematic enough to warrant such a drastic action
17:16:28 <sgallagh> Using packages from CPAN/PyPI/NPM/etc
17:16:48 <mitr> (alternatively, "reject and allow them to sort out and reaply" and "defer" are the same thing except one is more emotionally charged)
17:16:53 <dgilmore> users can very easily get to a point where they unkowingly violate the license
17:17:22 <mitr> That can happen with all the upstream tarballs either way; we can wash our hands of it or actually help solve that problem for upstreams
17:17:38 <t8m> sgallagh, I'd still prefer deferring the rejection at this time and give maintainers chance to sort it out
17:17:46 <sgallagh> Carrying both is only acceptable in my opinion if the upgrade path does not force anyone onto 6
17:17:58 <t8m> sgallagh, +1
17:18:23 <mattdm> sgallagh so that argues for new name for the 6 package
17:18:33 <sgallagh> mitr: In general, I agree with you. However BDB is somewhat exceptional in that it's used everywhere (often inside a dependency that you don't know about)
17:18:56 <sgallagh> mattdm: I was trying to avoid mandating an implementation, but yes that's the most likely approach
17:19:47 <notting> mattdm: db6/db6-devel isn't without precedent
17:20:00 <dgilmore> indeed
17:20:06 <mitr> I’m not really happy with the implication that the longer a FESCo ticket stays open, the more likely it is for FESCo to reverse its position without new facts... OTOH if it compelled maintainers to respond<evil/>
17:20:31 <sgallagh> Well, the longer it stays open, the less comfortable we are with landing the change in a particular cycle
17:20:52 <sgallagh> *stays open with unanswered questions and known issues
17:20:53 <nirik> we can't always avoid upstream license changes for users...
17:21:19 <sgallagh> nirik: No, but when we have advance knowledge we can try to mitigate it
17:21:27 <dgilmore> nirik: we can't, but this particular change has very wide ranging implications
17:22:24 <nirik> I suppose. It kinda sets a nasty precident if we try and always protect users from changes tho... but I agree this is a widespread package.
17:22:49 <nirik> anyhow, last time I asked the change owner questions they were quick to answer... we were waiting for upstream this time tho right?
17:23:03 <dgilmore> nirik: yeah, seems upstream is quiet
17:23:17 <notting> proposal: wait another week for upstream response
17:23:22 <nirik> notting: +1
17:23:22 <mattdm> +1 notting
17:23:26 <t8m> notting, +1
17:23:47 <sgallagh> +1
17:24:21 <sgallagh> #info Waiting one more week for upstream response
17:24:52 <sgallagh> #info FESCo is concerned about the wide-ranging impact that the license change to AGPL may cause and is considering how to proceed.
17:24:52 <dgilmore> notting: +1
17:25:18 <sgallagh> #topic #1307 F22 System Wide Change: Default Local DNS Resolver - https://fedoraproject.org/wiki/Changes/Default_Local_DNS_Resolver
17:25:19 <sgallagh> .fesco 1307
17:25:20 <zodbot> sgallagh: #1307 (F22 System Wide Change: Default Local DNS Resolver - https://fedoraproject.org/wiki/Changes/Default_Local_DNS_Resolver) – FESCo - https://fedorahosted.org/fesco/ticket/1307
17:25:33 <nirik> so, was this for f21?
17:25:50 <dgilmore> no its F22
17:25:56 <t8m> this is for F22 AFAIK
17:26:06 <mattdm> plus we already asked for some stuff.
17:26:07 <nirik> right. ok.
17:26:28 <mattdm> i think this should be taken off the agenda for 6 months or so
17:26:38 <t8m> yep
17:26:40 <sgallagh> ok
17:26:52 <mitr> There will be a meeting discussing this on Thursday next week, so 2 weeks at least seems necessary
17:26:59 <notting> didn't see any answers to the docker question. so maybe remove meeting keyword until we have those?
17:27:08 <sgallagh> I dropped the 'meeting' keyword for now
17:28:10 <sgallagh> #topic Next week's chair
17:28:19 <t8m> sgallagh, I can do it
17:28:28 <sgallagh> #undo
17:28:28 <zodbot> Removing item from minutes: <MeetBot.items.Topic object at 0x160806d0>
17:28:51 <sgallagh> #info Taking off the meeting agenda until we receive feedback on the container issues
17:28:54 <sgallagh> #topic Next week's chair
17:29:03 <sgallagh> #info t8m to chair next week's meeting
17:29:06 <sgallagh> #topic Open Floor
17:29:34 <dgilmore> sgallagh: id like to go back to mass rebuild, i was finishing up lunch at the start of the meeting
17:29:51 <sgallagh> #topic #1178 Fedora 21 scheduling strategy
17:30:03 <dgilmore> for mass rebuild we need all the things with side tags to be done and merged back in
17:30:04 <sgallagh> dgilmore: You have the podium :)
17:30:19 <dgilmore> some of them seem to be taking overly long
17:30:28 <dgilmore> and not really doing any work
17:30:40 * nirik nods sadly.
17:30:51 <nirik> we could give them a deadline if we schedule the mass rebuild?
17:31:03 <dgilmore> the python 3.4 guys did ask me to rebuild everything for them
17:31:27 <dgilmore> i had to fix some issues for them last week
17:31:38 <dgilmore> there was some packaging bugs in some python packages
17:32:12 <nirik> how many side tags do we have? /me looks
17:32:18 <dgilmore> too many
17:32:19 <sgallagh> dgilmore: Say it ain't so! ;-)
17:32:23 <dgilmore> ruby tcl and puthon
17:32:25 <dgilmore> python
17:32:40 <nirik> f21-llvm f21-python f21-ruby f21-tcl
17:32:41 <dgilmore> tcl has been there for 6 months
17:32:48 <nirik> f21-xorg
17:32:53 <dgilmore> xorg is done
17:32:55 <nirik> (but I thought that one was done)
17:33:00 <nirik> ok
17:33:06 <nirik> llvm is done too right?
17:33:16 <dgilmore> yes
17:33:24 <dgilmore> active is python and tcl
17:33:29 <dgilmore> http://koji.fedoraproject.org/koji/buildtargets
17:33:49 <jreznik_> deadline would be nice to set -> miss deadline, you're not going into f21...
17:34:22 <jreznik_> there's also boost, pmachata put it into the ticket
17:34:23 <dgilmore> jreznik_: well we merge the tag in, remove the target and they deal with breakages in rawhide
17:34:40 <dgilmore> jreznik_: boost cant be handled in mass rebuild
17:34:47 <dgilmore> it will need a side tag
17:34:54 <kalev> boost and python have quite a bit of overlap, would be nice to finish one before the other one starts
17:34:56 <jreznik_> dgilmore: he told me it's done this way
17:35:02 <dgilmore> it can be done before or after the mass rebuild
17:35:08 <dgilmore> jreznik_: what way?
17:35:25 <nirik> how about we give them until the 26th, and do the mass rebuidl on jun 9th
17:35:35 <jreznik_> dgilmore: part of mass rebuild, if not, better... petr told me it was done as part of mass rebuild all the time
17:35:50 <jreznik_> but seems he has short memory :)
17:35:55 <dgilmore> jreznik_: its not possible
17:36:18 <dgilmore> jreznik_: and its never been done as part of the massrebuild
17:36:35 <jreznik_> dgilmore: ok, for some reason he was confused, doesn't matter now
17:36:44 <dgilmore> jreznik_: it involves soname bumps and build ordering
17:36:52 <jreznik_> dgilmore: I get it
17:36:54 <dgilmore> the mass rebuild goes from a-Z
17:37:10 <dgilmore> and the builds of the mass rebuidl do not land in the buildroot
17:37:18 <dgilmore> we put them in a side tag
17:37:26 <dgilmore> and then merge them in when done
17:37:58 <dgilmore> I wouldnt be oppsosed to writing tooling to do mass rebuilds for soname bumps
17:38:07 <dgilmore> but we do not have that today
17:38:14 <jreznik_> sure
17:38:58 <jreznik_> nirik: 26th seems ok, if communicated now and I've been asked by a few people to include it in the schedule so they know
17:39:20 <dgilmore> id rather start the mass rebuild on a monday or a friday
17:39:36 <dgilmore> last time i started friday night and it was done monday morning
17:39:47 <kalev> I'd like to suggest that boost rebuild is better to land _before_ the mass rebuild
17:39:50 <kalev> the reason is that boost ships a lot of it's libraries in header only form
17:39:54 <kalev> and without a mass rebuild, it can be hard to be sure all consumers have been rebuilt
17:40:06 * nirik thinks mass rebuild will be faster yet this time. we have more builders.
17:40:20 <jreznik_> dgilmore: Jun 9 is Monday
17:40:41 * dgilmore looked at the wrong month
17:40:48 <dgilmore> I looked at July
17:41:06 <dgilmore> so i think id rathe do it June 6th
17:41:24 <dgilmore> then we should be able to merge it back in Monday the 9th
17:43:00 <nirik> fine with me
17:43:07 <nirik> is the 26th ok for a side tag deadline?
17:43:18 <dgilmore> lets aim to have all the side tags merged back by MAy 26th
17:43:31 <dgilmore> its fine by me
17:43:41 <dgilmore> we can have a weeks leeway
17:43:46 <nirik> hopefully boost can get done by then too
17:44:34 <dgilmore> kalev: can you get onto the boost guys to get the side tag in?
17:44:46 <jreznik_> dgilmore: I'll talk to Petr
17:45:22 <kalev> yeah, that would be better, I haven't had any contact with the boost people
17:45:45 <dgilmore> jreznik_: cheers
17:48:20 <nirik> any objections to that plan?
17:48:32 <sgallagh> I'm good with it
17:48:35 <dgilmore> proposal side tags done May 26th Mass rebuild June 6th
17:48:52 <t8m> +1
17:49:32 <nirik> +1
17:49:35 <dgilmore> im +1 obviously
17:49:40 <sgallagh> +1
17:49:42 <mitr> +1
17:49:54 <dgilmore> mattdm: notting: pjones:
17:50:03 * mattdm wakes up
17:50:07 <mattdm> sorry +1
17:50:09 <notting> sure, +1
17:50:23 <pjones> Still not present.
17:50:39 <sgallagh> #agreed Side tags must complete their builds by May 26th. The mass rebuild will take place on June 6th. (+7, 0, -0)
17:50:45 <sgallagh> #topic Open Floor
17:50:51 <sgallagh> Anything for open floor this week?
17:50:52 <jreznik_> could you please announce it? better to have it written by you guys
17:51:01 <jreznik_> and I'll update schedule with dates
17:51:24 <jreznik_> dgilmore, nirik: ^^^
17:51:29 <dgilmore> jreznik_: sure
17:51:40 <jreznik_> dgilmore: thanks!
17:53:29 <sgallagh> I'll close out the meeting in one minute if there is nothing else
17:54:40 <sgallagh> Hey look, we kept a FESCo meeting under an hour!
17:54:42 <sgallagh> #endmeeting