17:02:00 <t8m> #startmeeting FESCO (2014-07-16)
17:02:00 <zodbot> Meeting started Wed Jul 16 17:02:00 2014 UTC.  The chair is t8m. Information about MeetBot at http://wiki.debian.org/MeetBot.
17:02:00 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
17:02:03 <t8m> #meetingname fesco
17:02:03 <zodbot> The meeting name has been set to 'fesco'
17:02:03 <t8m> #chair abadger1999 dgilmore jwb kylem mattdm mitr mmaslano nirik pjones  sgallagh t8m
17:02:03 <zodbot> Current chairs: abadger1999 dgilmore jwb kylem mattdm mitr mmaslano nirik pjones sgallagh t8m
17:02:15 <t8m> #topic init process
17:02:16 <nirik> morning.
17:02:20 <mitr> Hello
17:02:25 <abadger1999> Good morning.
17:02:33 <pjones> hello.
17:02:35 <mattdm> Good $TIMEOFDAY!
17:02:39 <t8m> good afternoon, morning, night, everyone :)
17:02:55 <dgilmore> hole
17:03:00 <dgilmore> hola
17:03:35 <t8m> sgallagh_afk, ping?
17:03:40 * jreznik is around...
17:04:32 <t8m> I do not see kylem
17:04:44 <nirik> t8m: sgallagh_afk is on vacation...
17:04:48 <t8m> We have a quorum so let's start
17:04:59 <jwb> i think kylem is on vacation as well
17:05:14 <pjones> --- [kyle] is away (pto.)
17:05:16 <pjones> yep
17:05:26 <t8m> #topic #1322  F21 Changes - Progress on Changes Freeze
17:05:31 <t8m> .fesco 1322
17:05:32 <zodbot> t8m: #1322 (F21 Changes - Progress on Changes Freeze) – FESCo - https://fedorahosted.org/fesco/ticket/1322
17:05:54 <t8m> Is anyone concerned about any particular change?
17:06:37 <mattdm> I have a change that slipped through the process cracks....
17:06:39 <jreznik> this is what I was able to collect so far...
17:06:46 <jreznik> mattdm: which one?
17:06:59 <mitr> The uboot/syslinux one seems like it can use a lot of testing, and has an Alpha deadline - but can we do anything to help besides getting out of the way?
17:07:05 <mattdm> jreznik: docker container image
17:07:20 <mattdm> It's a self-contained change that I asked to skip one week and we never got back to it
17:07:32 <jreznik> aha
17:07:36 <mattdm> https://fedoraproject.org/wiki/Changes/Docker_Container_Image
17:07:50 <mattdm> looks like there's actually a tracker bug...
17:07:54 <mattdm> hmmm, maybe I'm crazy :)
17:08:13 <mattdm> oh yes, i see from the wiki history that i am
17:08:14 <jreznik> and it's accepted f21
17:08:18 <jreznik> :)
17:08:25 <mattdm> hmmm. no idea what I was smoking there. carry on :)
17:08:40 <jreznik> maybe you meant Atomic_Cloud_Image?
17:08:46 <jreznik> I see it stuck in the process
17:08:58 <abadger1999> For SCL, the Ruby SCL was pulled by mmaslano.  So there won't be scls in fedora main repo for f21.  But that doesn't stop them from appearing in the playground repo.
17:08:59 <jreznik> https://fedoraproject.org/wiki/Changes/Atomic_Cloud_Image
17:09:07 <mattdm> jreznik: ah yes! That's totally it!
17:09:29 <jreznik> so acks!
17:09:47 <mattdm> I'm +1 to this change. It is furiously in progress. :)
17:10:02 <t8m> if it is in progress +1
17:10:31 <drago01> (+ others do not have something like this so good selling point)
17:11:08 <nirik> I'm +1 to the change, but when do we decide it is going to make it? if there's an image by alpha?
17:11:30 <dgilmore> im +1 to this and working to make it happen
17:11:45 <dgilmore> I think we nearly have the bits lined up to make it
17:11:52 <pjones> +1
17:12:01 <nirik> cool
17:12:02 <dgilmore> but there is still issues to be resolved on how to get updates out
17:12:03 <mattdm> nirik: yeah, if we miss alpha we will need to take stock
17:12:30 <mitr> +1
17:12:35 <dgilmore> im +1
17:13:04 <abadger1999> +1
17:13:12 <t8m> #approved Atomic_Cloud_Image Self contained change is accepted for Fedora 21 (+7, -0, 0:0)
17:13:14 <mitr> mattdm: The "new Fedora product" wording might be worth looking at, so that it is not confused with the 3 major products.  (Not sure whether just a s/product/image/ or something more complex)
17:13:26 <mitr> ... wording in relnotes on the change page, that is.
17:13:41 <t8m> mitr, +1
17:14:14 * jreznik is going to process it
17:14:40 <t8m> Anything else to discuss for Changes?
17:14:49 <mattdm> mitr yep good call
17:16:17 <t8m> It doesn't seem so, so let's go on with a new tickets
17:16:31 <jreznik> thanks guys!
17:16:44 <t8m> #topic #1323 Deliberate packaging guidelines / compiler flags violation in dpdk
17:16:49 <t8m> .fesco 1323
17:16:50 <zodbot> t8m: #1323 (Deliberate packaging guidelines / compiler flags violation in dpdk) – FESCo - https://fedorahosted.org/fesco/ticket/1323
17:17:36 <t8m> So what can we do with this problem?
17:17:40 <nirik> I think the problem here is that the breakage isn't actually clear... but then if it's going to be fixed in a few weeks I am ok with waiting.
17:18:29 <t8m> Not that I like ignoring the RPM_OPT_FLAGS, I think that we can wait a few weeks for fix
17:19:06 <mitr> So... revisit in 4 weeks?  (And then what’s our plan?)
17:19:29 <t8m> Block the package?
17:20:47 <nirik> pretty sad that they pushed a f20 update.
17:21:09 <mitr> I'd rather have a provenpackager override the spec if there is one interested (to wade through the non-autotools buildsystem)
17:21:44 <mattdm> I'm sad about the name calling
17:22:14 <nirik> well, it's unclear to me at least what the breakage is.
17:22:23 <nirik> I asked in ticket, but didn't see a response.
17:22:25 <t8m> mitr, I have no problem with that, however if there are build failures it might be nontrivial task
17:22:40 <t8m> mattdm, +1
17:23:06 <mitr> t8m: There is some amount of inline asm
17:23:32 <nirik> anyhow, I am +1 to revisit in 3-4weeks.
17:23:38 <mitr> Not an obviously prohibitive amount, but enough to make it plausible that the code is a bit iffy and changing compiler settings could break it
17:24:04 <pjones> eh, worth finding out though.
17:24:57 <mattdm> given "no one will build a product out of the package without a complete rebuild of the libraries anyway.
17:25:05 <mattdm> " it really seems like this is better as a Copr
17:25:11 <abadger1999> yeah, probably need to block the package and reprimand the packager if it isn't fixed in 4 weeks.
17:25:12 <t8m> mattdm, yep
17:25:34 <abadger1999> but willing to defer to see what progress is made then.
17:25:34 <mattdm> so.... block the package and suggest that we have a better place for it?
17:25:39 <mitr> Proposal: Revisit on Aug 13, then default to letting any interested provenpackager to change the flags as they see fit
17:26:08 <t8m> mitr, I think we can let any interested provenpackager to fix it even before Aug13
17:26:17 <nirik> mattdm: problem with blocking is that it's out in f20 now... so if people installed it...
17:26:42 <jwb> i think you guys are over thinking this
17:26:45 <nirik> proposal: revisit on aug 13th. :)
17:26:53 <dgilmore> +!
17:26:55 <dgilmore> +1
17:26:59 <mattdm> okay +1
17:27:05 <abadger1999> +1
17:27:09 <mitr> +1
17:27:36 <pjones> +1
17:27:57 <t8m> +1
17:29:02 <t8m> nirik, I suppose you're +1?
17:29:21 <nirik> yeah
17:29:31 <t8m> #agreed We will revisit on Aug 13th (+7, -0, 0:0)
17:29:58 <t8m> #topic #1324 Feature page "outcome"
17:30:02 <t8m> .fesco 1324
17:30:04 <zodbot> t8m: #1324 (Feature page "outcome") – FESCo - https://fedorahosted.org/fesco/ticket/1324
17:30:13 <mattdm> ping  langdon
17:30:37 <mattdm> although there's not much extra to say :)
17:30:44 <mattdm> jreznik what do you think?
17:30:54 <nirik> I like the idea, but it's mostly on the feature wrangler. ;)
17:30:55 <mitr> We actually have most of the informaiton in there already, but somewhat invisible as category:xx
17:31:30 <mitr> So we might only need someone skilled with wiki macros and interested in this to expose it better
17:32:16 <mattdm> mitr: that's a good suggestion. although links to outcome/results/currentstate probably need to be done by hand (should be by the feature owner)
17:32:41 * jreznik is looking
17:32:58 <mitr> Yeah, ideally we could just link to the relnote snippet (within the Change page or actual relnotes), but those are the parts that tend most to be left stale
17:33:53 <jreznik> and the status and if it was implemented/killed is visible in bugzilla
17:34:22 <jreznik> and in the end it's collected in changeset, what was done
17:34:32 <jreznik> so I really think we already do what's in the ticket
17:34:56 <t8m> We do, but maybe the visibility of it is not good
17:34:57 <jreznik> maybe we should be more strict on having up to date relnotes part
17:35:13 <abadger1999> So maybe making the bugzilla link more prominent?
17:35:24 <jreznik> t8m: well, on the other hand - change/feature pages are internal planning thing, it should not be visible at all
17:35:37 <jreznik> for visibility, we have release announcement etc.
17:35:51 <jreznik> as it always needs some love to be presentable for end users
17:36:15 <jreznik> that's why I put "internal planning tool" to the changeset page
17:36:26 <jreznik> btw. I hope for F22 it will move from wiki completely :)
17:36:38 <mitr> jreznik: The Change pages do (at least in my bubble) get a fairly good google-fu (due to being linked from the mailing list, and fairly detailed), compared to the final relnotes
17:36:47 <jreznik> with websites guys we plan change tracking application
17:36:55 <t8m> for end users maybe, but developers might want to look at them
17:37:05 <jreznik> mitr: for F21, from F22+ it's going to be in app (I hope)
17:37:28 <mitr> jreznik: I don’t think (or at least hope) that won't make a difference
17:37:34 <jreznik> as it's hardly manageable in the wiki...
17:37:35 * randomuser notes that the final relnotes can be updated and other documentation can be linked from Change pages for posterity
17:37:45 <mitr> Is my impression correct that we would all like easier to use pages, but it needs an interested volunteer?
17:37:52 <jreznik> mitr: then we can do several views on features, generate content etc.
17:38:00 <t8m> mitr, the double negative in your sentence above is confusing me :)
17:38:37 <jreznik> mitr: I have two volunteers for that app but then they saw how much work it is :)
17:38:53 <jreznik> but I'll add this question to requirements
17:39:00 <jreznik> we're now collecting
17:39:56 <jreznik> as it's my ultimate goal actually to make sure all proposed in the ticket will happen
17:40:47 <t8m> #proposal Wait for the development of Changes application
17:40:54 <mattdm> meanwhile, we can make some pretty macros to go at the top of the completed pages. or langdon can :)
17:41:20 <t8m> mattdm, +1 to that as well
17:41:32 <t8m> if there are volunteers :)
17:41:45 <jreznik> well, it should not be that difficult
17:42:14 <mattdm> jreznik the template/macros should not be?
17:42:28 <jreznik> what's more difficult is to really know change was implemented and it was implemented as described in change
17:42:41 <t8m> jreznik, yeah :)
17:42:58 <jreznik> qa guys are looking at some, top changes affecting release but we would need twice more qa :(
17:43:16 <jreznik> for many changes, there are test days...
17:43:21 <jreznik> so it's actually becoming better
17:43:25 <t8m> or we need honest change owners to properly update the changes
17:44:02 <mattdm> t8m: I don't think it's honesty... it's just easy-to-forget-metawork
17:44:29 <jreznik> or the reason why we have qa - you may honestly think it's ok but ...
17:44:53 <pjones> that's a new word for it.
17:44:55 <t8m> jreznik, sure
17:45:18 <mattdm> pjones which is a new word?
17:45:23 <pjones> "metawork"
17:45:24 <mitr> mattdm: Yeah; I wouldn’t want this ticket end up with adding yet another part to the process (“now that real relnotes are great, make sure to copy them to the wiki”)
17:45:44 <t8m> so anything to vote about for this ticket?
17:45:47 <mitr> Automation and links, yes
17:46:06 * mattdm uses that word all the time. perhaps has been in academic environments too long
17:47:03 <jreznik> meta-mphetamine-work
17:47:35 <pjones> huh.
17:47:47 <mattdm> eh, I think we don't need to spend more time on it. just wanted to get the idea discussed. and now I know about the Changes App plan
17:47:56 <jreznik> by using bugzilla for tracking stuff, we have quite a lot of data available, so it's now about how to present it
17:48:32 <jreznik> I can't promise anything but I can try to do it for F21 even without Change app in place
17:48:50 <jreznik> with that app it's going to be definitely much, much more easier
17:49:06 <t8m> Ok, that was the last topic on agenda.
17:49:24 <mattdm> jreznik: sounds good.
17:49:52 <t8m> #info FESCo and Change wrangler will look how to improve the visibility of Change outcome data
17:50:23 <t8m> #topic Next week's chair
17:50:27 <t8m> Anyone?
17:50:59 * nirik will likely not be here next week
17:51:44 <mitr> I can do it
17:52:02 <t8m> #action mitr to chair then next week's FESCo meeting
17:52:17 <t8m> #topic Open Floor
17:53:32 <mitr> Kevin brought up the FESCo blocker bug on the list; should we start using it regularly?
17:53:47 <mitr> (Or shall I make a ticket so that we can think it over and discuss for next week?)
17:53:50 <nirik> mitr: if we have things we think are blockers that don't block based on any qa issues.
17:54:02 <nirik> IMHO thats happened very rarely.
17:54:54 <mitr> Yeah; it seems to me have many decisions we would rather not see just ignored (which unfortunately does happen), but wouldn’t be willing to block the release over them
17:55:48 <nirik> yeah.
17:56:38 <t8m> I am not sure what we should do in such cases.
17:56:43 <mattdm> nirik: that's because adamw is very very clever about making any real problem fit _some_ criteria
17:56:55 <nirik> :)
17:57:02 <mitr> So, I suppose, no action and no policy change for now?
17:57:11 <nirik> I think we should just be aware that we can mark things blocker if we want...
17:57:21 <mattdm> +1 aware :)
17:57:49 <adamw> fwiw, my take on the 'fesco criterion' is it's mainly intended for use in relation to the change process
17:58:10 <adamw> if fesco wants to get serious about requiring changes to hit certain states of readiness at certain milestones, that would be a good use for it
17:58:29 <mattdm> adamw makes sense.
17:58:48 <mitr> Oooh! Have every Change bug block that tracker until the Change owner explicitly updates bug state and drops it from the tracker!  NOT
17:59:14 <mitr> adamw: Having that tool to track Changes that need extra attention is a great idea, though.
18:00:35 <jreznik> yep
18:02:07 <t8m> Anything else to discuss for Open Floor?
18:03:29 <t8m> I will close the meeting in a minute then.
18:05:05 <t8m> #endmeeting