17:00:46 <jwb> #startmeeting FESCO (2014-09-10)
17:00:46 <zodbot> Meeting started Wed Sep 10 17:00:46 2014 UTC.  The chair is jwb. Information about MeetBot at http://wiki.debian.org/MeetBot.
17:00:46 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
17:00:46 <jwb> #meetingname fesco
17:00:46 <jwb> #chair dgilmore jwb kalev mattdm mitr mmaslano nirik sgallagh t8m thozza
17:00:46 <jwb> #topic init process
17:00:46 <zodbot> The meeting name has been set to 'fesco'
17:00:46 <zodbot> Current chairs: dgilmore jwb kalev mattdm mitr mmaslano nirik sgallagh t8m thozza
17:00:53 <jwb> ok, let's get rolling
17:00:53 <nirik> morning everyone.
17:00:56 <jwb> who's around
17:01:02 <dgilmore> hola
17:01:04 <mitr> Hello
17:01:10 <mattdm> hello!
17:01:11 <kalev> hello
17:01:11 <sgallagh> Here we go again :)
17:01:19 <jwb> apologies for the typo in the date yesterday
17:01:37 <dgilmore> jwb: bahh, it happens
17:01:48 <nirik> no biggie
17:02:05 <jwb> sadly, i did it for 2 meetings
17:02:15 <jwb> that's what i get for waiting until the last minute and rushing
17:02:43 * sgallagh notes that he sent out last week's agenda a few short hours before the meeting
17:03:06 <jwb> is thozza on PTO?
17:03:33 <jwb> hi t8m
17:03:42 <t8m> hello all
17:03:56 <jwb> ok, let's move on to the first topic
17:04:04 <jwb> #topic #1178 Fedora 21 scheduling strategy
17:04:04 <jwb> .fesco 1178
17:04:05 <jwb> https://fedorahosted.org/fesco/ticket/1178
17:04:06 <zodbot> jwb: #1178 (Fedora 21 scheduling strategy) – FESCo - https://fedorahosted.org/fesco/ticket/1178
17:04:19 <jwb> tbh, i forget why this is still in the meeting category
17:04:22 <jwb> someone enlighten me?
17:05:15 <jwb> i mean, afaik we only have tc6, it's broken, and we're still waiting for another TC to be spun
17:05:45 <nirik> yeah, not much point in the ticket anymore I think.
17:05:52 <sgallagh> Well, one thing
17:06:02 <nirik> proposal: close unless there's some exceptional situation that comes up?
17:06:24 <sgallagh> I've been saying this unofficially for a while, but maybe we should REALLY come out and say that Fedora isn't allowed to slip out of 2014?
17:06:43 <jwb> sgallagh, and how would we realistically enforce that?
17:06:45 <nirik> well, how do we do that?
17:06:47 <sgallagh> As in, we'll start cutting out problematic pieces rather than slip again?
17:07:02 <jwb> i'm not about to agree to that today
17:07:14 <jwb> because we have no idea what "problematic pieces" actually means
17:07:28 <kalev> I too would rather cut features than slip forever
17:07:38 <jwb> guys... we aren't stalled on features
17:07:53 <jwb> we're stalled on bugs
17:08:00 <sgallagh> Not right now, but I trust that once the rel-eng stuff is resolved, it will stay that way.
17:08:06 <kalev> like, arm netinstall doesn't work by the time of the release -- leave it out and do Alpha without this particular image
17:08:08 <jwb> and you can't say "i'm going to cut out anaconda because it doesn't work on the workstation netinstall iso"
17:08:38 <kalev> or workstation netinstall doesn't work -- ship alpha without it, just to be on time.
17:09:01 <jwb> i don't disagree with the sentiment, but i don't think that's something we can actually say today with any kind of certainty.  i'd rather address it as it comes up
17:09:14 <jwb> "oh, we're blocked on arm netinstall?  ok, vote on not blocking."
17:09:15 * nirik agrees with jwb.
17:09:19 <mattdm> I agree with Josh
17:09:25 <nirik> we aren't down to just 1 thing either.
17:09:30 <sgallagh> Sure, that's fine.
17:09:31 <jwb> right
17:09:43 <sgallagh> I was more just trying to set the stage for dealing with that if we get to it.
17:09:47 <mattdm> What is the summary of the current state of "rel-eng stuff"?
17:09:50 <jwb> which, at the root of it, is really just nirik's proposal above
17:09:55 <sgallagh> (Making sure we're willing to make those decisions)
17:10:09 <mitr> jwb: Just slipping one more week is the very default path, though; the process more or less says "we slip" not "we ask FESCo whether to drop the feature"
17:10:21 <nirik> https://qa.fedoraproject.org/blockerbugs/milestone/21/alpha/buglist
17:10:24 <sgallagh> mattdm: I don't think Dennis has slept more than three consecutive hours since the original Alpha date :-/
17:10:26 <t8m> jwb, +1
17:10:43 <jwb> mitr, well, FESCo can look at why we're suggesting to slip.  so we can actually do what is proposed.  we just have to do it.
17:11:21 <nirik> we could also play with the time between milestones (which we did before) to shorten things... but I think that would need to be after alpha.
17:11:30 <jwb> nirik, yes
17:11:52 * sgallagh nods
17:12:22 <jwb> so for this specific ticket:
17:12:22 <jwb> < nirik> proposal: close unless there's some exceptional situation that  comes up?
17:12:37 <mattdm> +1
17:12:47 <nirik> so, looking again over things... there is one thing that seems kinda large we could ask to just not do for alpha...
17:13:09 <nirik> the per product netinstalls + mirrormanager changes for that.
17:13:16 <t8m> +1
17:13:16 <mitr> jwb/nirik: +1
17:13:34 <nirik> aside from that I don't see anything we could really point to.
17:13:48 <jwb> nirik, let's vote, then get back to that
17:13:56 <jwb> +1 to the proposal
17:13:57 <nirik> jwb: sure. Sorry to derail.
17:14:07 * nirik is +1 to his proposal for the record.
17:14:23 <sgallagh> nirik: Umm, what's the alternative?
17:14:32 <sgallagh> Just ship the ISOs and no net install trees?
17:14:48 <nirik> sgallagh: right. say 'sorry, no netinstalls, we will have them for beta, thanks'
17:14:50 * sgallagh holds his question until after the vote
17:15:04 <jwb> dgilmore, sgallagh ?
17:15:14 <jwb> kalev, ?
17:15:38 <sgallagh> +1
17:15:39 <kalev> +1
17:16:10 * jwb waits 30 more secs
17:17:07 <jwb> #agreed close unless there's some exceptional situation that comes up (+1:7, -1: 0, 0: 0)
17:17:16 <jwb> #topic F21 Alpha status
17:17:33 <jwb> ok, now you guys can talk about what we could possibly drop
17:17:34 <jwb> :)
17:17:59 <jwb> nirik, on your suggestion... it's somethign we could do but i fear that if we drop it for Alpha we'll not actually get it working for beta
17:18:14 <nirik> well, I would only actually want to do that if it's the only blocker.
17:18:14 <sgallagh> jwb: Why not?
17:18:27 <nirik> if there's other things it seems not worth it.
17:19:11 <jwb> sgallagh, because it seems like something that needs time to figure out, and it's important.  if we decide it's not important for alpha, i'm concerned we'll worry about other more important things and it will eventually get pushed to the back burner
17:19:45 <sgallagh> I suspect that this *specific* case won't have that problem
17:19:57 <sgallagh> Since so many people rely on netinstalls
17:20:00 <jwb> sgallagh, it also seems disjoint with the screams that workstation has to have a netinstaller because IMPORTANT, and then we drop it for alpha
17:20:02 <sgallagh> We wouldn't let that slide
17:20:21 <t8m> Yep, If something is not so important for alpha it does not mean it is not seriously important for beta and final
17:20:30 <jwb> sgallagh, if it's a majorly important install method, then i think it needs to land in alpha so we have time to fix the bugs found in it before beta
17:20:54 <kalev> my rather strong view is that _if_ we ship something, we need to make sure it actually works and not blame users for our bugs
17:21:23 <kalev> so if we drop an image from being a Alpha release blcoker, then we have to also make sure to not ship that image to not give a bad public perception
17:21:37 <dgilmore> i am working on the netinstall issues
17:21:48 <dgilmore> we should be good by the end of teh week
17:21:59 <jwb> dgilmore, to be clear, i don't think anyone is saying you aren't :)  we're just discussing it's importance
17:22:06 <jwb> its even
17:22:34 <jwb> so since it's being worked on, and dgilmore says we should be ok, move on?
17:22:36 <nirik> yeah, so, lets wait and see... if that ends up being the last/only blocker?
17:22:39 <dgilmore> jwb: sure. it is important, I think we do want it for alpha
17:22:39 <nirik> yeah.
17:22:42 <mattdm> +1 that.
17:22:44 <jwb> cool
17:22:51 <mattdm> dgilmore: is there stuff we can get you help with?
17:23:13 <mattdm> (either directly related or to move other things that need to get done off your plate this week?)
17:23:22 <dgilmore> mattdm: having people step up and help manage mirrormanager would be lovely
17:23:37 <sgallagh> dgilmore: What does that entail?
17:23:56 <nirik> dgilmore: I was wondering if I could ask puiterwijk about that... he dug into mm in the past, so he might be able to take a look. (I've not asked him tho)
17:24:10 <dgilmore> nirik: can't hurt to ask
17:24:23 * nirik can do so
17:24:37 <mattdm> awesome
17:24:52 <dgilmore> sgallagh: understanding how the code works to help do the tweaking to move links around
17:25:16 <sgallagh> OK, then yes. Let's politely ask puiterwijk to bail us out :)
17:25:27 <jwb> #action nirik to talk to puiterwijk about mirrormanager
17:25:57 <jwb> ok, move on?
17:26:10 * nirik nods
17:26:12 <jwb> #topic #1338 Non-responsive maintainer: masahase
17:26:12 <jwb> .fesco 1338
17:26:12 <jwb> https://fedorahosted.org/fesco/ticket/1338
17:26:13 <zodbot> jwb: #1338 (Non-responsive maintainer: masahase) – FESCo - https://fedorahosted.org/fesco/ticket/1338
17:26:59 <jwb> ok, this seems fairly straighforward to me
17:27:01 <nirik> +1 to orphaning packages so active folks can become point of contact.
17:27:10 <jwb> +1
17:27:19 <kalev> +1
17:27:26 <t8m> OK, +1
17:27:49 <mattdm> +1 rubber stamp. looks like clear-cut example of process... proceeding.
17:27:54 <kalev> just to be clear: is this orphaning both of his packages, or just the one that mooninite asks?
17:28:00 <jwb> i would say both
17:28:16 <kalev> me too, otherways the other one will just linger and not get any fixes
17:28:21 <nirik> both
17:28:24 <nirik> right
17:28:51 * nirik can do the orphaning and update the ticket...
17:29:02 <daumas> thanks guys, thanks kevin :)
17:29:04 <mitr> +1
17:29:59 <jwb> sgallagh, dgilmore ?
17:30:16 <mitr> I have another proposal after one is voted on.
17:30:27 <sgallagh> Both. +1
17:30:40 <jwb> mitr, ok.  hold one sec
17:31:14 <jwb> #agreed orphan masahase's packages so active people can become points of contact (+1: 7, -1: 0, 0: 0)
17:31:18 <jwb> mitr, ok, go ahead
17:31:25 <mitr> Proposal: In step 5 of http://fedoraproject.org/wiki/Policy_for_nonresponsive_package_maintainers , replace "to the Fedora devel list" with "to the FESCo trac".
17:31:38 <jwb> #action nirik to orphan packages and update ticket
17:31:56 <mitr> Rationale: it seems to happen from time to time that nobody from FESCo acts on that mailing list mail.  (An alternative is that we just each individually promise to pay more attention to such mails.)
17:32:12 <jwb> mitr, i'd suggest both actually
17:32:14 <nirik> yeah, +1... I try and catch them, but sometimes I miss. ;(
17:32:19 <mattdm> mitr: +1
17:32:30 <t8m> +1 this is just codifying the current practice
17:32:31 <jwb> because the devel list mailing is for other packagers to get a heads up.  the fesco ticket would be for us to pay attention
17:32:50 <mitr> jwb: The public heads-up is step 4.
17:32:56 <jwb> oh, hehe
17:32:58 <jwb> yes, sorry
17:33:01 <mattdm> the procedure does already include a mail to devel in #4 --- this is a _second_ mail
17:33:06 <jwb> ok, i'm good with your proposal then.  +1
17:33:23 <sgallagh> +1
17:33:28 <mitr> (Current practice does tend to deviate from the formal policy, we tend to cut corners… but codifying that is for someone else to propose.)
17:33:55 <dgilmore> +1
17:34:23 <kalev> +1
17:34:43 <jwb> #agreed In step 5 of http://fedoraproject.org/wiki/Policy_for_nonresponsive_package_maintainers replace "to the Fedora devel list" with "to the FESCo trac" (+1: 8, -1: 0, 0: 0)
17:34:53 <jwb> mitr, care to update the wiki with that?
17:35:08 <mitr> jwb: will do
17:35:16 <jwb> #action mitr to update wiki
17:35:24 <jwb> thanks.  good proposal.
17:35:26 <jwb> moving on
17:35:35 <jwb> #topic #1339 missing acl's for some packages for epel7
17:35:35 <jwb> .fesco 1339
17:35:36 <jwb> https://fedorahosted.org/fesco/ticket/13389
17:35:36 <zodbot> jwb: #1339 (missing acl's for some packages for epel7) – FESCo - https://fedorahosted.org/fesco/ticket/1339
17:35:45 <jwb> i'm fine with granting the ACLs for now
17:35:48 * nirik as noted in ticket was +1
17:35:51 <dgilmore> im +1 to granting him access
17:35:52 <mitr> +1
17:35:53 <t8m> +1
17:36:20 <kalev> +1
17:36:45 * nirik can do so if we approve
17:36:47 <sgallagh> +1
17:37:12 <mattdm> +1
17:37:22 <jwb> #agreed grant raveit65 epel7 ACLs for the relevant packages (+1: 8, -1: 0, 0: 0)
17:37:29 <jwb> #action nirik to grant ACLs
17:37:48 <jwb> ok, that's the end of the agenda
17:37:54 <jwb> #topic Next week's chair
17:38:25 <jwb> come on...
17:38:27 <jwb> not everyone at once
17:38:42 * dgilmore should be able to
17:39:15 <mattdm> Nope. I'll do it so dennis doesn't have another thing. :)
17:39:18 <jwb> dgilmore, you sure?  your plate seems extra full lately
17:39:33 <jwb> i'm using my chair privs to go with mattdm ;)
17:39:40 <jwb> #info mattdm to chair next week
17:39:47 <dgilmore> jwb: okay
17:39:49 <jwb> thanks for offering though dgilmore
17:39:54 <jwb> #topic Open Floor
17:40:03 <jwb> who's got something else to chat about?
17:40:41 <mattdm> dgilmore: yes thanks. it's awesome that you are always willing to pick things up.
17:41:17 * jwb waits 2 min
17:42:55 <jwb> ok, i guess we all have better things to work on :)
17:43:01 <jwb> ending in 3
17:43:01 <mattdm> thanks jwb!
17:43:03 <jwb> 2
17:43:05 <jwb> 1
17:43:08 <jwb> #endmeeting