#fedora-meeting: FESCO (2015-02-11)

Meeting started by mitr at 18:00:17 UTC (full logs).

Meeting summary

  1. init process (mitr, 18:00:23)
  2. Welcoming new FESCo members (mitr, 18:04:47)
    1. ACTION: mitr to send a whenisgood form, results to be discussed on the next meeting (mitr, 18:07:17)

  3. #1384 F23 System Wide Change: Harden all packages with position-independent code - https://fedoraproject.org/wiki/Changes/Harden_all_packages_with_position-independent_code (mitr, 18:08:44)
    1. https://fedorahosted.org/fesco/ticket/1384 (mitr, 18:08:48)
    2. AGREED: F23 System Wide Change: Harden all packages with position-independent code approved (+5) (mitr, 18:11:39)

  4. #1390 F22 System Wide Change: RpmOstree - Server side composes and atomic upgrades - https://fedoraproject.org/wiki/Changes/RpmOstree (mitr, 18:13:25)
    1. https://fedorahosted.org/fesco/ticket/1390 (mitr, 18:13:29)

  5. #1396 F22 System Wide Change: Atomic Host - https://fedoraproject.org/wiki/Changes/AtomicHost (mitr, 18:13:31)
    1. https://fedorahosted.org/fesco/ticket/1396 (mitr, 18:13:35)

  6. #1397 F22 System Wide Change: Bare Metal Installer for Fedora Atomic Host - https://fedoraproject.org/wiki/Changes/Bare_Metal_Atomic (mitr, 18:13:40)
    1. https://fedorahosted.org/fesco/ticket/1397 (mitr, 18:13:44)
    2. AGREED: Defer tickets 1390, 1396, 1397 until we get more specifics, remove meeting keyword until then (+6) (mitr, 18:15:17)

  7. #1392 Review scope of "Python 3 as default" Change for F22 (mitr, 18:15:31)
    1. https://fedorahosted.org/fesco/ticket/1392 (mitr, 18:15:35)
    2. AGREED: Close this ticket, discuss the specifics in #1413 instead. (+5) (mitr, 18:18:27)

  8. #1413 F22 System Wide Change: Python 3 Migration Improvements - https://fedoraproject.org/wiki/Changes/Python_3_Migration_Improvements (mitr, 18:18:44)
    1. https://fedorahosted.org/fesco/ticket/1413 (mitr, 18:18:48)
    2. AGREED: F22 System Wide Change: Python 3 Migration Improvements has been accepted (+6) (mitr, 18:21:11)

  9. #1406 F22 System Wide Change: Systemd Package Split - https://fedoraproject.org/wiki/Changes/SystemdPackageSplit (mitr, 18:21:20)
    1. https://fedorahosted.org/fesco/ticket/1406 (mitr, 18:21:24)
    2. No conclusion reached (+3 -1 1×0), will discuss next week (mitr, 18:40:02)

  10. #1377 enable kdump addon by default (mitr, 18:40:11)
    1. https://fedorahosted.org/fesco/ticket/1377 (mitr, 18:40:15)
    2. AGREED: Enabling the kdump addon by default was rejected (-5) (mitr, 18:49:52)

  11. #1408 New package/branch request processes (off bugzilla to pkgdb) (mitr, 18:50:04)
    1. https://fedorahosted.org/fesco/ticket/1408 (mitr, 18:50:08)
    2. AGREED: Implement a similar waiting period for Fedora branch as we do for EPEL branch (+5) (mitr, 18:55:13)

  12. #1409 provenpackager request: mstuchli (mitr, 18:55:28)
    1. https://fedorahosted.org/fesco/ticket/1409 (mitr, 18:55:32)
    2. AGREED: Change http://fedoraproject.org/wiki/Provenpackager_policy step 4, s/In case of negative votes/If you haven’t been automatically approved/ (+5) (mitr, 19:02:48)

  13. #1410 Updates Policy should try harder to prevent updates that break future updates (mitr, 19:03:02)
    1. https://fedorahosted.org/fesco/ticket/1410 (mitr, 19:03:06)
    2. AGREED: Increasing the time spent in testing was rejected (-5) (mitr, 19:06:37)
    3. AGREED: Replacing gnome-packagekit by gnome-software in critical path definition has been approved (+5) (mitr, 19:09:17)
    4. AGREED: 1) Ask librepo maintainer to test off-line updates before pushing any updates. 2) Recommend gnome-software maintainers to write automated tests for their update mechanism (+6) (mitr, 19:18:13)

  14. #1411 F21 privacy issue, Geolocation done for every install (mitr, 19:18:15)
    1. https://fedorahosted.org/fesco/ticket/1411 (mitr, 19:18:19)
    2. AGREED: Cc: spot for fedora-legal to see whether there is any issue or whether we need to update privacy policy (+5) (mitr, 19:34:37)

  15. #1269 Closing all 'Merge Review' bugs (mitr, 19:34:47)
    1. https://fedorahosted.org/fesco/ticket/1269 (mitr, 19:34:51)
    2. AGREED: Reassign all merge reviews to their component, version=rawhide, with the comment in https://fedorahosted.org/fesco/ticket/1269#comment:16 (+5-1) (mitr, 19:40:38)
    3. ACTION: crobinso to mass-edit and reassign the bugs (mitr, 19:41:19)

  16. #1326 change to fesco replacement process? (mitr, 19:41:28)
    1. https://fedorahosted.org/fesco/ticket/1326 (mitr, 19:41:32)
    2. deferred (mitr, 19:44:53)

  17. Next week's chair (mitr, 19:45:57)
    1. jwb will chair next week’s meeting (mitr, 19:46:41)

  18. Open Floor (mitr, 19:46:46)


Meeting ended at 19:49:24 UTC (full logs).

Action items

  1. mitr to send a whenisgood form, results to be discussed on the next meeting
  2. crobinso to mass-edit and reassign the bugs


Action items, by person

  1. crobinso
    1. crobinso to mass-edit and reassign the bugs
  2. mitr
    1. mitr to send a whenisgood form, results to be discussed on the next meeting


People present (lines said)

  1. mitr (174)
  2. ajax (73)
  3. rishi (55)
  4. jwb (48)
  5. thozza (25)
  6. paragan (22)
  7. zodbot (20)
  8. mcatanzaro (15)
  9. zbyszek (8)
  10. tibbs|w (7)
  11. jreznik (6)
  12. crobinso (6)
  13. adamw (5)
  14. moezroy (5)
  15. rdieter (1)
  16. mattdm (1)
  17. sgallagh (0)
  18. nirik (0)
  19. dgilmore (0)


Generated by MeetBot 0.1.4.