18:00:00 <nirik> #startmeeting FESCO (2015-04-08)
18:00:00 <zodbot> Meeting started Wed Apr  8 18:00:00 2015 UTC.  The chair is nirik. Information about MeetBot at http://wiki.debian.org/MeetBot.
18:00:00 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
18:00:00 <nirik> #meetingname fesco
18:00:01 <nirik> #chair ajax dgilmore jwb mitr nirik paragan rishi thozza sgallagh
18:00:01 <nirik> #topic init process
18:00:01 <zodbot> The meeting name has been set to 'fesco'
18:00:01 <zodbot> Current chairs: ajax dgilmore jwb mitr nirik paragan rishi sgallagh thozza
18:00:19 <sgallagh> .hello sgallagh
18:00:20 <zodbot> sgallagh: sgallagh 'Stephen Gallagher' <sgallagh@redhat.com>
18:00:20 <ajax> hi
18:00:22 <nirik> who all is around for a hopefully short fesco meeting? ;)
18:00:25 <paragan> hi
18:00:27 <ajax> hi
18:00:29 <thozza> hi all
18:01:12 <nirik> jwb is out today...
18:01:18 <nirik> dgilmore was around eariler.
18:03:33 <nirik> ok, I guess we can go ahead and get started.
18:03:43 <nirik> #topic #1416 F22 Changes - Progress at Change Checkpoint: Change Checkpoint: 100% Code Complete Deadline
18:03:43 <nirik> .fesco 1416
18:03:43 <nirik> https://fedorahosted.org/fesco/1416
18:03:45 <zodbot> nirik: #1416 (F22 Changes - Progress at Change Checkpoint: Change Checkpoint: 100% Code Complete Deadline) – FESCo - https://fedorahosted.org/fesco/ticket/1416
18:03:57 <nirik> so mostly here we were going to revisit the new atomic images...
18:04:07 <nirik> which we probibly need dgilmore to give us status on.
18:05:05 <nirik> there was breakage in the rc1 compose around the dnf replaces yum change.
18:05:45 <sgallagh> nirik: BZ?
18:05:48 <paragan> https://bugzilla.redhat.com/show_bug.cgi?id=1209695
18:06:01 <sgallagh> Thanks
18:06:14 <nirik> yeah, that. There's already a fix commited by walters it looks like.
18:07:22 <dgilmore> so I think we are really close to something
18:07:42 <dgilmore> but dnf taking over /usr/bin/yum broke rpm-ostree
18:08:10 <sgallagh> OK, so it looks like atomic is going to just use yum-deprecated for now?
18:08:16 <nirik> sgallagh: yes
18:08:19 <dgilmore> sgallagh: yes
18:08:49 <nirik> their master branch/next release apparently already doesn't use yum or dnf... it uses hawkey/whatever directly.
18:09:06 <sgallagh> BTW, adamw raised a good point in the BZ: did we ever formally declare Atomic to be release-blocking?
18:09:14 <sgallagh> I thought we decided exactly the opposite of that last week...
18:09:52 <nirik> well, "atomic" isn't very descriptive
18:10:06 <nirik> I think the atomic cloud image is... because it's part of the cloud product?
18:10:56 <sgallagh> jzb, kushal: Could one of you clarify which media the Cloud WG considers blocking?
18:11:51 <roshi> the only release blocking media is the Cloud base image, afaik
18:12:14 <roshi> there were some people under the impression that Atomic would be one, but not for F22
18:12:54 <jzb> sgallagh: Docker image and Cloud base image
18:12:56 <roshi> unless it was decided somewhere else - because I never thought it did and no one on the QA team does either, it's always been optional for testing
18:13:11 <jzb> sgallagh: do you want all formats as well? (e.g., AMI, qcow2, etc.)
18:13:27 <roshi> I didn't know docker was - probably need some testcases and release criteria for it
18:13:29 <sgallagh> jzb: No, we just needed to have Atomic clarified.
18:13:35 <dgilmore> sgallagh: the atomic cloud image and tree is
18:13:46 <dgilmore> but the new deliverables are not
18:14:02 <nirik> dgilmore: thats what I thought too... but sounds like thats not the case?
18:14:04 <sgallagh> dgilmore: The Cloud WG just told us it isn't...
18:14:23 <dgilmore> sgallagh: ive been told by management it has to happen
18:14:49 <jzb> dgilmore: where is that coming from?
18:15:04 <dgilmore> sgallagh: well let me rephrase I am getting a lot of preasure to make it work
18:15:16 <sgallagh> dgilmore: I can believe that. I'm not saying it shouldn't work.
18:15:22 <dgilmore> jzb: mattdm and stickster
18:15:30 <sgallagh> I'm saying that if it comes down to slipping the release for it, it doesn't sound like that's where we are.
18:15:31 <jzb> dgilmore: gotcha
18:16:08 <nirik> well, if thats our only issue with rc1, I think it would be sane to make a rc2 with it fixed... then we can decide at go/no-go which to take.
18:16:33 <jzb> sgallagh: we're currently having issues with dnf and rpm-ostree tools, is that right?
18:16:35 <sgallagh> nirik: Fine with me, as long as QA is good with accepting RC1 test results as valid for RC2
18:16:42 <nirik> but in general it sounds like we are close on this change, and I'm fine leaving it in unless we end up shipping beta without it, in which case we drop it
18:17:01 <nirik> jzb: yes, there's a patch and a hopefully fixed build already. ;)
18:17:19 <nirik> sgallagh: well, if rpm-ostree is the only thing that changes I would think that would be fair... but I am not qa. :)
18:17:30 <nirik> adamw: ^ roshi ^
18:17:50 <roshi> I would think it would be fine to reuse stuff
18:17:55 <dgilmore> I do think that we will only deliver part of the change though
18:18:00 <roshi> but I'd still want to get a couple spot checks in just in case
18:18:12 <nirik> dgilmore: just the install, not the pxe-live thing?
18:18:19 <dgilmore> https://fedorahosted.org/rel-eng/ticket/6119?replyto=12#comment:14
18:18:36 <stickster> Being more exact about the exact images... I was under the impression that Vagrant images were an important item for mattdm.
18:18:45 <dgilmore> nirik: yes, the pxe to live thing requires that we spin up new installer every update push
18:18:45 <stickster> oops, sorry for overusing word "exact" there.
18:19:16 <dgilmore> sgallagh: wrong topic
18:19:23 <dgilmore> stickster: wrong topic
18:19:27 <dgilmore> sorry sgallagh
18:19:31 <sgallagh> np
18:19:47 <nirik> this is where adamw's proposed "deliverables" faq/checklist would sure be nice. ;)
18:20:06 <nirik> walters: you have a fix in hand for rpm-ostree? (I saw built packages with the fix?)
18:20:17 <dgilmore> the pxe to live thing needs a massive investment from QA to do daily testing, since we have to respin the installer every time we push updates
18:20:37 <walters> Creating a new update for  rpm-ostree-2015.3-7.fc22
18:20:42 <dgilmore> along with a massive rework of many updates work flows
18:21:05 <stickster> OIC, sorry -- this is regarding fixes needed for PXE-to-Live?
18:21:30 <dgilmore> stickster: no, its regarding pxe-to-live and teh atomic install media
18:21:41 <nirik> stickster: well, this is about the f22 change
18:22:06 <dgilmore> I think we will only be able to deliver the atomic install media for f22
18:22:09 <nirik> https://fedoraproject.org/wiki/Changes/AtomicHost
18:22:14 <nirik> and the vagrant things right?
18:22:16 <dgilmore> and we will have to work on the rest for f23
18:22:19 <nirik> they are already made?
18:22:31 <dgilmore> nirik: we make teh atomic vagrant image
18:22:46 <walters> i'm not totally sure about the expectations around how often pxe-to-live is respun...If someone only changes e.g. a package description, i doubt anyone's going to care, but it's an important discussion
18:22:57 <dgilmore> but mattdm did want the extention of the files changed. it will require someoen to write a patch for koji
18:23:01 <walters> we obviously also only need to respin if one of the input packages actually changed
18:23:08 <nirik> so, sounds like we want to just adjust the change for f22 to drop the pxe-to-live for now and continue working on it for f23 then, right?
18:23:08 <walters> which is something that rpm-ostree in git master does inherently
18:23:35 <nirik> dgilmore: that could be post beta tho right? not a beta blocker?
18:23:48 <dgilmore> walters: right, but QA needs to sign on for that, and we have to figure out how to make it all and setup a gating so that QA signs off on it before it is released. which will hold up all updates
18:23:50 * nirik always finds it odd to read... 'beta blocker'
18:23:58 <dgilmore> nirik: not a beta blocker no
18:25:05 <nirik> right, so is anyone opposed to: adjust the change for f22 to drop the pxe-to-live for now and continue working on it for next release
18:25:19 <nirik> walters: is that ok? or you want to push for it in f22?
18:25:41 <walters> it's fairly beta so I'm OK with it
18:26:01 <walters> obviously we'll need a place to iterate on it and release it for people to try and incrementall fix it, but alt.fp.org works for that
18:26:09 <nirik> yeah.
18:26:15 <nirik> fesco votes?
18:26:31 <rishi> I am +1 in favour of your proposal, if we are voting.
18:26:44 <ajax> +1
18:26:45 * nirik is +1 to his own proposal
18:26:50 <paragan> +1
18:26:52 <dgilmore> walters: well, as part of what we are doing for changing how we compose, we plan to get to doing full composes nightly
18:26:52 <sgallagh> nirik: +1
18:27:09 <dgilmore> walters: so when we do it will be made nightly as part of rawhide
18:27:20 <dgilmore> +1 for nirik
18:27:36 <nirik> #agreed adjust the change for f22 to drop the pxe-to-live for now and continue working on it for next release (+6,0,0)
18:27:43 <nirik> Anything else on this?
18:27:52 <nirik> I guess the decision for a rc2 will be from qa?
18:28:40 <dgilmore> nirik: yes
18:28:43 <nirik> I had one other topic I forgot to add to the emailed agenda...
18:28:46 <nirik> #topic fesco list
18:29:13 <nirik> Right now our policy is that the fesco private list has fesco members, the fpl, and the working group liasons on it.
18:29:38 <walters> i updated https://fedoraproject.org/wiki/Changes/AtomicHost to note the deferral
18:29:51 <sgallagh> walters: Thanks
18:30:18 <nirik> Do we want to extend that to add the outreach and diversity council folks?
18:30:28 <dgilmore> nirik: I think that is fine
18:30:38 <nirik> (and engineering but they would most likely already be a fesco person)
18:30:56 <ajax> sure
18:30:57 <rishi> nirik: I am fine with that.
18:30:59 <paragan> I am okay to extend it
18:31:07 <sgallagh> Does the fesco list really need to be a superset of the council list?
18:31:07 <nirik> IMHO it's fine, and we should continue to not use the list as much as possible. ;)
18:31:10 <thozza> I'm ok with it
18:31:23 <sgallagh> But yeah, given that we rarely use the list, I'm not sure I care
18:31:37 <nirik> sgallagh: well, it could help I suppose if there was some private matter the council wanted to discuss with fesco...
18:31:59 <nirik> ok, sounds like we are fine doing that for now at least.
18:32:06 <sgallagh> I'm just going to vote 0 on the grounds that it likely makes no difference
18:33:19 <nirik> #agreed council enginnering, outreach and diversity members can also be on the fesco list if they like
18:33:24 <nirik> #topic next weeks chair
18:33:27 <nirik> who wants the fun next week?
18:33:38 <rishi> I could give it a shot.
18:34:05 <nirik> thanks rishi!
18:34:12 <nirik> #action rishi to chair next week
18:34:16 <nirik> #topic Open Floor
18:34:21 <rishi> Need to brush up my bot handling skills.
18:34:21 <nirik> anyone have anything for open floor?
18:34:32 <nirik> rishi: there's a wiki page that has all the process. :) it's not hard.
18:34:43 <rishi> nirik: Ah, ok. Good to know. :)
18:35:08 <sgallagh> So, I just heard in #fedora-qa that the blocker list may be out of date.
18:35:13 <nirik> https://fedoraproject.org/wiki/FESCo_meeting_process
18:35:21 <sgallagh> Apparently RHBZ changed something last night and it broke syncing
18:35:46 <nirik> yeah, hopefully it's moot. ;)
18:36:07 <sgallagh> Anyway, we need to check up on that.
18:36:26 <sgallagh> I'm going to dive into it after the meeting and if there's a delta, I'll post it to the devel@ and test@ lists
18:36:38 <nirik> yep.
18:37:32 <nirik> ok, will close out the meeting in a min if nothing else.
18:37:53 <dgilmore> sgallagh: I just filed a blocker
18:38:04 <dgilmore> though it may not be acceted
18:38:18 <sgallagh> dgilmore: Mind linking it?
18:38:27 * rishi prepares to go AFK
18:38:50 <nirik> do we need to discuss it here?
18:39:45 <dgilmore> https://bugzilla.redhat.com/show_bug.cgi?id=1210042
18:39:50 <dgilmore> nirik: no we do not
18:40:07 <nirik> cool. lets continue in devel/releng/qa/etc. ;)
18:40:12 <nirik> Thanks for coming everyone!
18:40:16 <nirik> #endmeeting