18:01:35 <thozza> #startmeeting FESCO (2015-07-01)
18:01:35 <zodbot> Meeting started Wed Jul  1 18:01:35 2015 UTC.  The chair is thozza. Information about MeetBot at http://wiki.debian.org/MeetBot.
18:01:35 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
18:01:36 <thozza> #meetingname fesco
18:01:36 <thozza> #chair ajax dgilmore hguemar jwb nirik paragan rishi thozza sgallagh
18:01:36 <thozza> #topic init process
18:01:36 <zodbot> The meeting name has been set to 'fesco'
18:01:36 <zodbot> Current chairs: ajax dgilmore hguemar jwb nirik paragan rishi sgallagh thozza
18:01:40 <thozza> \o/
18:01:42 <sgallagh> .hello sgallagh
18:01:45 <thozza> hi all
18:01:51 <paragan> Hi
18:01:58 <number80> .hello hguemar
18:02:00 <rkuska> hello everyone
18:02:15 <mstuchli> Hi!
18:02:38 <jkurik_mtg> .hello jkurik
18:02:47 <thozza> I count 4
18:03:09 <thozza> dgilmore wrote he won't be around
18:03:14 <zodbot> sgallagh: sgallagh 'Stephen Gallagher' <sgallagh@redhat.com>
18:03:17 <zodbot> sgallagh: sgallagh 'Stephen Gallagher' <sgallagh@redhat.com>
18:03:20 <zodbot> number80: hguemar 'Haïkel Guémar' <karlthered@gmail.com>
18:03:23 <zodbot> jkurik_mtg: jkurik 'Jan Kurik' <jkurik@redhat.com>
18:03:41 <number80> zodbot: naughty you
18:03:47 <paragan> I think nirik also on vacation
18:04:01 <jwb> he is
18:04:17 <thozza> jwb: with you we are 5
18:04:30 <mhroncok> hi
18:04:34 * rishi` is here
18:04:40 <number80> quorum reached :)
18:04:50 <thozza> ok, so let's start, we have a lot of work to do
18:05:02 <thozza> #topic #1450 F23 System Wide Change: Python 3 as the Default Implementation
18:05:02 <thozza> .fesco 1450
18:05:03 <zodbot> thozza: #1450 (F23 System Wide Change: Python 3 as the Default Implementation) – FESCo - https://fedorahosted.org/fesco/ticket/1450
18:05:20 <thozza> So I asked change owners to participate, they are here
18:05:26 <thozza> I had a discussion with them
18:05:27 <rkuska> <- here
18:05:33 <mhroncok> <- here
18:05:57 <thozza> the bottom line is that the change was technically around for 2 releases, but the first one was aiming for rawhide
18:06:04 <thozza> so this is second and last time
18:06:09 <jwb> er
18:06:12 <jwb> no
18:06:16 <mstuchli> Here as well
18:06:28 <rkuska> jwb:  no what?
18:06:46 <jwb> the main argument against this was what "default" means, and several people on FESCo expressed that default should include the tools actually used to build Fedora
18:07:10 <number80> agreed
18:07:35 <rkuska> We have defined in scope what does default means.
18:07:46 <jwb> and FESCo members disagreed with that definition
18:07:59 <thozza> jwb: not all of them
18:08:13 <jwb> correct.  so call for a vote and see if you have enough that do
18:08:17 <thozza> jwb: so you would like to have also the fedora infra tool in the scope?
18:08:18 <sgallagh> So yet again, we argue over the name of the Change instead of its contents?
18:08:18 * rishi` raises his hand
18:08:22 <rkuska> Lets first discuss this please.
18:08:38 <rishi`> Regarding the issue of Koji using python3 ...
18:08:38 <mhroncok> so it's about the name?
18:08:41 <thozza> jwb: I think we should sort out the issues rather than vote and let it fail
18:09:01 <rishi`> ajax raised it with Adam Miller during a presentation that he did 2 weeks ago.
18:09:04 <pravins> thozza: +1
18:09:08 <rkuska> Stating that Python3 is default for Fedora as a distribution is important in eyes of community and projects which yet do not fully support Python3.
18:09:13 <jwb> the issues have been pointed out.  they were hand waved away with "not in the defined scope"
18:09:29 <ajax> all i really have to say here is, if 'python3 is self-hosting' isn't an eventual goal, i think 'python3 is default' isn't an especially meaningful set of goals
18:09:35 <mitr> rkuska: Lying to get better marketing is not generally valued, OTOH
18:09:39 <ajax> if those goals are all that's being attempted, fine
18:09:41 <thozza> jwb: I don't think that fedora infra is a show stopper
18:09:42 <rkuska> This is not lying.
18:09:43 <ajax> but i'd want better
18:09:46 <thozza> is more a nice to have thing
18:09:57 <jwb> thozza, yes.  we had this discussion 2 weeks ago.  you and i disagree
18:10:03 <rkuska> We will have only python3 shipped by default on live distribution.
18:10:10 <thozza> it requires time and I'm sure it will be in TODO, but it is impossible to make it for F23
18:10:19 <jwb> then the change should be deferred
18:10:26 <thozza> jwb: I think making the Python3 as default is beneficial for making others to actually change their packages and do some work. Also Py2 will go EOL in 2020
18:10:32 <rishi`> thozza: I am saying that we did raise it with Fedora infra' (Adam Miller) 2 weeks ago.
18:10:47 <thozza> rishi`: what was the outcome?
18:10:51 <jwb> thozza, we disagree on that too.  it isn't "default" today and anaconda was ported just fine
18:10:59 <rishi`> He didn't blow the idea way completely, in my understanding.
18:11:12 <rkuska> jwb there are many other projects which wait for python3 becomes more mainstream
18:11:12 <jwb> i'm not interested in completely rehashing the conversation we had 2 weeks ago and on the list in the interim
18:11:14 <thozza> jwb: because it was advertised last release as default
18:11:19 <rishi`> thozza: He said something on the lines of "I'll see what I can do and revert back".
18:11:25 <thozza> it helps to make other to prioritize the work
18:11:44 <rishi`> thozza: It was ajax who did the actual talking. :)
18:11:48 <rkuska> jwb: and this counts towards python3 becoming more mainstream, for example ansible
18:12:06 <jwb> yes, i've heard all this.  i disagree.
18:12:28 <sgallagh> Proposal: rename the Change Proposal to: Python 3 is the only guaranteed python interpreter on default installs
18:12:39 <mstuchli> sgallagh: +1
18:12:58 * ajax tempted to move the goalposts by adding fedora-packager to the workstation dvd kickstart...
18:13:02 <ajax> (no not really)
18:13:30 <jwb> ajax, it's certainly a possibility though
18:13:51 <rkuska> just for a sake of your argument? or whats the point of adding fedora-packager?
18:14:07 <jwb> it negates sgallagh's proposal
18:14:11 <jwb> because it requires python2
18:14:24 <ajax> rkuska: the workstation is the developer experience.  i would want that to include the ability to develop _fedora_.  which means i need to be able to invoke koji(1).
18:14:28 <rkuska> we work on this change for a long time, and there was not a fedora-packager in the kickstarter
18:14:36 <ajax> i'm aware
18:14:45 <thozza> Python3 is already preffered by the packaging guideliness\
18:14:58 <jwb> which is excellent
18:15:01 <thozza> so this is more of a technical and marketing change as I see it
18:15:01 <ajax> i am, how you say, trolling.
18:15:11 <rkuska> yes, but we need it to be default also for older packages, the guideliness refers only to new packages
18:15:18 <mstuchli> ajax: But you'd still have that ability, albeit not on the default install, but is that really that important?
18:15:46 <sgallagh> This conversation is troublesome enough without trolling...
18:15:53 <mhroncok> by the same logic, I could say, we can add python2 to the kickstart just to kill the goals, right?
18:15:55 <ajax> mstuchli: define "that important".  if we can't build python3 from a fedora toolchain that relies on no other python, then i think we haven't actually finished bootstrapping.
18:16:04 <rishi`> mstuchli: I think it is more important that you can't build Fedora without python2, if we are still talking about "default".
18:16:11 <sgallagh> jwb: What change would you like to see to this proposal to allow this work to land in F23?
18:16:12 <ajax> and i would expect "bootstraps" to be implied by "default"
18:16:20 <ajax> but, not my feature
18:16:32 <mstuchli> Well in that case, just theoretically, would you agree with renaming the change?
18:16:44 <sgallagh> Because there is *real value* in making this effort "blessed" and *supported* by FESCo
18:17:03 <thozza> sgallagh: exactly my point
18:17:09 <rkuska> sgallagh: +1
18:17:09 <number80> I agree, but this is not "default"
18:17:12 <ajax> mstuchli: i wouldn't object to renaming it.  for that matter i wouldn't object to _not_ renaming it.  i'm primarily concerned with the work being done, and it does look like good work.
18:17:16 <jwb> sgallagh, i'd prefer the scope included the tools required to build Fedora.  if that isn't possible for F23, i'd suggest deferring it until it is possible.
18:17:30 <mstuchli> ajax: I see :)
18:17:34 <jwb> sgallagh, barring any of that, the bare minimum change sould be s/default/perferred
18:17:38 <ajax> if y'all want to call it default and define default to mean something less rigorous than my personal sense of taste, well, okay
18:17:43 <ajax> i'm disappointed if so, but
18:17:55 <jwb> er, preferred
18:17:58 <sgallagh> jwb: That's a self-sustaining problem though. If we (FESCo) aren't pushing for it to happen, then it won't happen
18:17:59 <thozza> jwb: why not to have change of its own for the infra tools?
18:18:05 <sgallagh> Something needs to upset the status quo
18:18:11 <mstuchli> thozza: +1
18:18:13 <jwb> sgallagh, anaconda didn't happen because of something fesco did
18:18:14 <mhroncok> thozza: +1
18:18:22 <thozza> jwb: I think it did
18:18:24 <rkuska> thozza: +1
18:18:29 <jwb> sgallagh, the REST OF THE PYTHON WORLD that needs work isn't going to magically fucking happen because we bless a wiki page
18:18:33 <thozza> at least it helped to prioritize the effort there
18:18:46 <rkuska> we plan to do this, we are not stopping with this change, we plan to port also fedora-packager tools, but this is for now too much work
18:19:04 <sgallagh> jwb: I think you might be surprised at how much of the Python world follows the examples of Fedora/RH and Ubuntu
18:19:14 <jwb> sigh
18:19:34 <thozza> jwb: I don't think it is fair to ask them to do it in the change a make it a hard requirement while fedora RCM does not seem to be interested
18:19:42 <thozza> because Py3 is not default
18:19:45 <thozza> ;)
18:19:52 <thozza> or I don't know why
18:20:00 <ajax> more because they're busy with other work
18:20:05 <thozza> right
18:20:06 <ajax> which is legitimate
18:20:08 <thozza> like everyone
18:20:10 <rishi`> I get the feeling that nobody is really interested in pursuing this with the Fedora infra' people.
18:20:12 <rishi`> :/
18:20:15 <jwb> i don't think it's fair to portray a reality that doesn't exist
18:20:37 <mstuchli> rishi`: We most certainly are, it's just that we've focust on other things so far
18:20:37 <sgallagh> And none of that other work will ever get prioritized without someone (i.e. us) pushing for it
18:20:55 <rkuska> jwb: we are not stopping with only with having pytohn3 by default on live cd
18:21:06 <jwb> rkuska, i'm aware and i think that is absolutely excellent
18:21:22 <rishi`> mstuchli: I already said (twice), that this was brought up with them, and it was not totally blown away. I am interested in knowing what they have to say.
18:21:23 <mhroncok> jwb: so the only problem is calling it "default"?
18:21:33 <jwb> YES
18:21:35 <thozza> jwb: do you really think that someone will care to spend time porting to python3 if there is no real need?
18:21:47 <jwb> thozza, YES
18:21:52 <thozza> jwb: dream on
18:22:01 <number80> before continuing a neverending discussion, do we agree that it's ok to ship python3 as the only python interpreter on default install?
18:22:09 <maxamillion> I'm not sure I'm really supposed to (or allowed to?) talk in these meetings but it was just brought up that something was raised with Fedora Infra via me two weeks ago and I'm not sure that's entirely accurate or that I'm the best person to even be dicsussing that with since I'm not on the Fedora Infra team
18:22:09 <rkuska> jwb: there are many upstream who dont, take samba for example
18:22:19 <sgallagh> number80: s/it's ok/it's mandatory/ ?
18:22:35 <jwb> guess what.  you're repeating yourselves.
18:22:38 <number80> sgallagh: if we agree, it'll be mandatory :)
18:22:59 <sgallagh> number80: By which I mean: make a proposal, let's vote
18:23:04 <thozza> ok, 20 minutes passed
18:23:11 <ajax> i'm honestly fine with the feature as worded, and calling any future instances of requiring python2 to do distro work as a bug
18:23:18 <sgallagh> Somebody make a proposal we can vote on.
18:23:37 <number80> proposal: let's make python3 the only python interpreter on default installs
18:23:41 <sgallagh> ajax: I like that interpretation
18:23:52 <sgallagh> number80: +1
18:23:57 <number80> +1
18:24:12 <thozza> number80: what does this mean?
18:24:21 <ajax> it means the feature as written, i sincerely hope
18:24:23 <thozza> does it approve the change as is?
18:24:47 <number80> ajax: yes, but I understand jwb opinion (which is valid) as the proposal is not about making python3 default
18:25:05 <number80> I don't want to waste time on wording issue, we can rename the proposal to fit reality
18:25:06 <ajax> +1 then
18:25:13 <thozza> it is, but I think it is silly to expect it will happen over one release
18:25:19 <thozza> number80: +1 then
18:25:30 <thozza> +4
18:25:35 <paragan> number80, +1
18:25:35 <thozza> anyone
18:25:37 <number80> thozza: sadly, yes and we need incentive
18:25:49 <jkurik> +1
18:25:51 <number80> (to push people porting apps to python3)
18:26:14 <thozza> #agreed let's make python3 the only python interpreter on default installs (+5, 0, -0)
18:26:23 <mstuchli> \o/
18:26:34 <number80> dear feature owners, please rename accordingly your proposal
18:26:34 <jwb> -1
18:26:34 <sgallagh> Supplementary proposal: As ajax suggested: keep the "default" terminology and treat python2-only work as a bug in the implementation
18:26:43 <jwb> please amend the vote record
18:26:44 * thozza hopes he got the keyword correctly
18:26:50 <mstuchli> sgallagh: +!
18:26:51 <thozza> #undo
18:26:51 <zodbot> Removing item from minutes: AGREED by thozza at 18:26:14 : let's make python3 the only python interpreter on default installs (+5, 0, -0)
18:27:02 <thozza> #agreed let's make python3 the only python interpreter on default installs (+5, 0, -1)
18:27:04 <jwb> sgallagh, -1
18:27:12 <number80> -1
18:27:26 <thozza> sgallagh: +1
18:27:46 <sgallagh> +1 to my supplementary proposal for the record.
18:27:46 <rishi`> sgallagh: -1, that sounds too much like a marketing gimmick
18:28:10 <thozza> there is already not enough of us to reject nor approve the additional proposal
18:28:18 <thozza> with given votes
18:28:31 <jwb> if you don't have enough votes for approval, it is rejected
18:28:45 <jwb> it doesn't stay in some weird limbo state
18:28:52 <thozza> jwb: but is there some keyword for it?
18:29:25 <mhroncok> proposal: Python 3 as the only Python interpreter on default installs as a step towards Python 3 as default
18:29:35 <sgallagh> #info Supplementary proposal to treat python2-only work as a bug in the implementation had insufficient votes (+2, 0, -3)
18:29:46 <sgallagh> #undo
18:29:46 <zodbot> Removing item from minutes: INFO by sgallagh at 18:29:35 : Supplementary proposal to treat python2-only work as a bug in the implementation had insufficient votes (+2, 0, -3)
18:29:51 <sgallagh> #info Supplementary proposal to treat python2-only work as a bug in the implementation had insufficient votes (+3, 0, -3)
18:29:54 <sgallagh> (miscounted)
18:29:56 <thozza> sgallagh: thanks I was about to submit it
18:30:04 <jwb> yeah, that works
18:30:17 <thozza> sgallagh: the previous count was right
18:30:23 <thozza> no?
18:30:33 <sgallagh> oh right, mstuchli doesn't have a vote. Mea culpa
18:30:37 <sgallagh> #undo
18:30:37 <zodbot> Removing item from minutes: INFO by sgallagh at 18:29:51 : Supplementary proposal to treat python2-only work as a bug in the implementation had insufficient votes (+3, 0, -3)
18:30:40 <sgallagh> #info Supplementary proposal to treat python2-only work as a bug in the implementation had insufficient votes (+2, 0, -3)
18:30:44 * mstuchli is sorry!
18:30:57 <thozza> let's move on
18:31:00 <thozza> #topic #1445 F23 Self Contained Changes
18:31:01 <thozza> .fesco 1445
18:31:02 <zodbot> thozza: #1445 (F23 Self Contained Changes) – FESCo - https://fedorahosted.org/fesco/ticket/1445
18:31:08 <thozza> do you want to go 1 by 1?
18:31:17 <thozza> I think it makes sense with the ammount
18:31:19 <paragan> yes
18:31:19 <sgallagh> thozza: Policy is to approve in bulk
18:31:36 <sgallagh> Unless there are reservations, then address only those separately
18:31:46 <number80> *nods*
18:31:56 * ajax scans the change pages...
18:31:57 <thozza> I think the netizen spin is the hard one ;)
18:31:58 <number80> the io.js thing for instance
18:32:11 <sgallagh> netizen and io.js are the big ones.
18:32:20 <paragan> right
18:32:31 <cleong> i'm here for the netizen spin
18:32:31 <number80> (the node/io.js merge makes it less interesting)
18:32:35 <thozza> sgallagh: io.js is not there AFAIK
18:32:43 <jwb> thozza, yes it is
18:32:50 <jwb> "io.js Technology Preview"
18:32:53 <thozza> jwb: was not
18:32:58 <thozza> edited 30 hours ago
18:33:02 * number80 has the trac opened
18:33:08 <jwb> i'm staring at it right now
18:33:09 <jwb> it's there
18:33:15 <thozza> yes
18:33:48 <thozza> do you want to discuss some particular change more?
18:34:18 <sgallagh> thozza: So quick vote to approve the rest?
18:34:29 <paragan> I think except netizen and io.js changes all others looks good to be approved
18:34:30 <sgallagh> Anyone else have any problems with any others?
18:34:37 <number80> the same
18:35:02 <thozza> Proposal: All self-contained changes are approved (except netizen spin and io.js which are discussed separately)
18:35:02 <jkurik> sgallagh: even from mailing list the "others" looks "non-conflict"
18:35:02 <ajax> those two are my only concern, yeah
18:35:12 <ajax> thozza: +1
18:35:15 <sgallagh> jkurik: ack
18:35:20 <number80> +1
18:35:21 <paragan> thozza, +1
18:35:21 <sgallagh> thozza: +1
18:35:28 <thozza> I'm +1
18:35:36 <rishi`> thozza: I hope the ibus change doesn't break GNOME's input sources stuff.
18:35:57 <number80> rishi`: it's a different proposal
18:35:58 <ajax> rishi`: link? i don't know what "input sources" means here
18:35:59 <paragan> rishi`, it will not, its just default input method change
18:36:12 <rishi`> ajax: keyboard layouts and input methods
18:36:39 <thozza> rishi`: can you elaborate on some example scenario?
18:36:42 <thozza> how it can break?
18:36:48 <number80> ibus is ticket #1458, we're discussing #1445
18:36:51 <rishi`> paragan: Well, that is what was said when the local resolver change was passed. Then we saw that networking broke.
18:36:57 <thozza> we can add a note to cooperate with GNOME folks ;)
18:37:21 <thozza> rishi`: nothing broke
18:37:28 <thozza> only my hope
18:37:32 <paragan> rishi`, I don't think it will break
18:37:38 <thozza> for some particular desktop
18:37:40 <ajax> rishi`: it seems like it'd be a functional change if you're used to ibus-chewing, but otherwise...
18:37:42 <rishi`> number80: I thought we were passing everything except io.js and netizen.
18:37:55 <thozza> rishi`: it is already approved
18:37:56 <thozza> ;)
18:37:57 <number80> rishi`: nope, #1445 is a bundle of proposal
18:38:07 <rishi`> thozza: I really don't want to start arguing over the definition of "broke".
18:38:12 <sgallagh> OK, so... Netizen?
18:38:20 <thozza> rishi`: we did for default ;)
18:38:38 <thozza> #agreed All self-contained changes are approved (except netizen spin and io.js which are discussed separately) (+5, 0, -1)
18:38:59 <thozza> so the netizen
18:39:04 <rishi`> number80: Eh?
18:39:12 <sgallagh> cleong: I'm not sure I'm in favor of creating a Netizen spin that is only a set of packages. That would be better solved by tools like Software and the KDE equivalent (whose name escapes me)
18:39:27 <number80> rishi`: https://fedorahosted.org/fesco/ticket/1445#comment:8
18:39:32 <thozza> I think what was the issue before didn't change.... like that it is bunch of preinstalled packages, but no additional integration
18:39:40 <thozza> at least from what I read
18:39:42 <sgallagh> It would be more interesting as a complete, configured live system
18:39:43 <rishi`> sgallagh: Apper
18:40:12 <cleong> didn't see comment:8, addressed the detailed description
18:40:13 <rishi`> number80: The first item there is ibus-libzhuyin
18:40:22 <sgallagh> Or better still, as a set of tools to convert a Workstation or KDE system into a Netizen system
18:40:33 <rishi`> number80: ok
18:40:34 <number80> rishi`: oups, we have another ibus tickt
18:40:40 <number80> (sorry)
18:40:49 <thozza> sgallagh: maybe an additional option in the installation menu
18:40:50 <cleong> the packages are the first arrangement or organization
18:41:22 <sgallagh> thozza: That's a big effort and one better suited to something like the Workstation WG to push for
18:41:41 <sgallagh> cleong: To me, that's not justification for a spin (with all the effort that entails)
18:41:52 <thozza> cleong: are you in workstation WG?
18:42:08 <cleong> no i am not in workstation wg
18:42:18 <thozza> sgallagh: then nobody will push for it in Workstation WG
18:42:26 <cleong> the benefits and description sets the justification imo
18:42:38 <number80> cleong: you don't need to be formally part of a WG to participate in their sessions
18:42:57 <cleong> ok thanks for that
18:42:58 <sgallagh> thozza: As number80 says; cleong can bring it up with them
18:43:22 <thozza> cleong: are you ok with such outcome?
18:43:25 <sgallagh> cleong: I'm not denying that a Netizen configuration has merit. I'd like to see it.
18:43:26 <cleong> the target market are specific to public charities, gov, and other ngo's
18:43:41 <sgallagh> I don't think a Spin is the correct solution without configuration
18:44:27 <sgallagh> And I'd *much* rather see it as part of the Workstation or KDE SIG efforts, because they have the knowledge and resources to do it right
18:44:31 <thozza> cleong: my last question... ?
18:44:36 <cleong> i plan is to present the spin at conferences and demoing how to configure from the defaults
18:44:49 <cleong> what type of outcome?
18:45:22 <thozza> I mean that we don't agree on the spin, but rather on option to install the whole suite as part of installation
18:45:38 <thozza> having own option in anaconda
18:45:52 <thozza> for Workstation product e.g.
18:46:02 <cleong> ahh ok i would be fine with that
18:46:15 <number80> great
18:46:17 <sgallagh> Note: we're not asserting that they will do this.
18:46:27 <sgallagh> You would still have to pitch it to those groups
18:46:35 <cleong> as long as i can resubmit for a spin in the future
18:46:47 <cleong> ok
18:46:55 <thozza> Proposal: Netizen is not approved as spin. We approve the option to have netizen as optional suite in anaconda. Please work with Workstation WG.
18:47:05 <number80> thozza: +1
18:47:12 <sgallagh> cleong: You can always resubmit it, but I think a better solution would be for this to become an official piece of the Workstation offering
18:47:13 <thozza> I'm +1
18:47:31 <paragan> thozza, +1
18:47:34 <number80> cleong: this is encouragement to keep refining that effort withing the Workstation WG
18:47:34 <sgallagh> thozza: +1
18:47:37 <cleong> ok i'll join and research the workstation wg
18:47:59 <cleong> thank you for the advisement and time
18:48:03 <thozza> jwb: are you voting?
18:48:06 <ajax> +1
18:48:15 <jwb> +1
18:48:37 <rishi`> +1
18:48:50 <thozza> #agreed Netizen is not approved as spin. We approve the option to have netizen as optional suite in anaconda. Please work with Workstation WG. (+7, 0, -0)
18:48:58 <thozza> so the io.js now
18:49:06 <cleong> will do
18:49:13 <thozza> cleong: thanks
18:49:23 <number80> the io.js thing will be at best a short-lived effort
18:49:28 <thozza> cleong: we really appreciate your effort
18:50:01 <thozza> number80: right, if someone wants to do it, let them do it
18:50:09 <thozza> as long as it does not break things for others
18:50:40 <number80> I'm not sure if it needs a feature, but of course, anyone is free to submit it
18:50:56 <rishi`> I wonder what other distributions are doing about this.
18:51:13 <thozza> Proposal: io.js is approved.
18:51:51 <sgallagh> Counter-proposal: If it's merging back anyway, maybe just build the nodejs package from the io.js sources?
18:51:53 <rishi`> It sounds like LO vs Apache OO from the outside.
18:52:02 <jwb> seems somewhat superfluous
18:52:05 <number80> sgallagh: that's what will happen upstream
18:52:39 <rishi`> sgallagh: Yes, that sounds like a more sane idea to me. Although, I have very little clue about the node.js world.
18:53:03 <sgallagh> /me wishes he had thought of this more than 30s ago and had mentioned it on the list...
18:53:08 <thozza> Could they build it in COPR?
18:53:23 <ajax> the more i look at this the more this looks like a simple alternatives setup
18:53:28 <sgallagh> thozza: The main advantage is that it runs on more architectures than current node
18:53:38 <sgallagh> So there's value to the secondary arches in having it in Fedora proper
18:53:40 <thozza> sgallagh: right, that is good
18:53:49 <ajax> if there's someone driving the io.js part then great, they get the bugs when it breaks, and if it's too broken we stop trusting their acumen in the future
18:54:00 <ajax> thozza: +1 approve
18:54:10 <paragan> I am not sure if it requires packaging guidelines update
18:54:11 <sgallagh> ajax: The io.js submitter is the node.js primary maintainer
18:54:19 <ajax> even better
18:54:25 <ajax> the domain expert is on it
18:54:37 <sgallagh> /me nods
18:54:46 <paragan> module package names start with iojs-*
18:55:13 <sgallagh> I'm wary of the iojs-* solution
18:55:22 <thozza> so any more votes/proposals?
18:55:25 <sgallagh> Because (as noted above) this is merging back into the next version of node.js
18:55:40 <sgallagh> It seems foolish to bring in a whole bunch of parallel packages that are going to merge back
18:55:54 <paragan> I think its better to have it as a copr repo only
18:56:13 <sgallagh> I'd rather it just replace node.js entirely, if it's the 100% replacement claimed
18:56:14 <thozza> paragan: secondary arches again
18:56:29 <rishi`> How about we vote for sgallagh 's idea?
18:56:34 <sgallagh> Or at least alternatives and it can host the existing nodejs-* packages
18:56:55 <sgallagh> rishi`: I'd rather not vote on that without the maintainer involved, honestly.
18:56:59 <number80> sgallagh: the same owner made the node.js 0.12 proposal, so I think he pretty much has a gist of the path to move toward the merged back io.js
18:57:02 <sgallagh> Can we defer a week and I'll raise it on th elist?
18:57:05 <thozza> Proposal: Let the owner consider replacing node.js completely and revisit next week.
18:57:15 <number80> thozza: +1
18:57:17 <rishi`> sgallagh: That is true.
18:57:31 <sgallagh> thozza: +1
18:57:36 <paragan> thozza, +1
18:57:41 <rishi`> thozza: +1
18:57:55 <thozza> I'm +1 ;)
18:58:07 <thozza> jwb: ajax?
18:58:08 <number80> (note this delay also the node.js 0.12 proposal vote)
18:58:33 <thozza> number80: it is not in the agenda
18:59:18 <ajax> sure, defer, why not
18:59:19 <ajax> +1
18:59:28 <thozza> #agreed io.js change: Let the owner consider replacing node.js completely and revisit next week. (+6, 0, -0)
18:59:43 <jwb> yeah, +1
18:59:50 <thozza> #undo
18:59:50 <zodbot> Removing item from minutes: AGREED by thozza at 18:59:28 : io.js change: Let the owner consider replacing node.js completely and revisit next week. (+6, 0, -0)
19:00:01 <thozza> #agreed io.js change: Let the owner consider replacing node.js completely and revisit next week. (+7, 0, -0)
19:00:05 <number80> thozza: it was marked as a meeting item this afternoon (if it isn't anymore, my apologies)
19:00:19 <thozza> number80: too late ;)
19:00:21 <thozza> #topic #1451 F23 System Wide Change: SELinux policy store migration
19:00:21 <thozza> .fesco 1451
19:00:22 <zodbot> thozza: #1451 (F23 System Wide Change: SELinux policy store migration) – FESCo - https://fedorahosted.org/fesco/ticket/1451
19:01:13 <thozza> mgrepl: is around to answer questions
19:01:22 <mgrepl> sure, together with plautrba
19:01:41 <plautrba> generally, we need to stay in touch with the upstream, the change also incorporates some performance enhancements
19:01:58 <ajax> any chance this speeds up upgrades of selinux-policy-foo ?
19:02:08 <mgrepl> definitelly
19:02:09 <sgallagh> Frankly, I trust the proposers to make decisions on the implementation of SELinux more than any of the FESCo members, so I'm just going to hand over a +1 :)
19:02:26 <jwb> there were some questions from the systemd people.  did those get sorted out?
19:02:30 <mgrepl> all policy operation going to be faster
19:02:31 <thozza> I know there were some ideas from Dan Walsh, didn't see any outcomes?
19:02:34 <jwb> (apologies, i can't find them in my inbox)
19:02:44 <mgrepl> yes, we discussed it on fedora-devel
19:02:44 <thozza> jwb: I think it was in the same conversation
19:03:58 <thozza> mgrepl: did you adjusted the change anyhow after the discussion?
19:04:01 <plautrba> i think we cleared out all the questions with some future improvements for next release
19:04:27 <ajax> that's my reading of the thread
19:04:31 <jwb> ok
19:04:42 <jwb> then yeah i'm with sgallagh on this one
19:04:43 <jwb> +1
19:04:51 <plautrba> thozza: actually no, its no really needed, but for future thre's space for more changes
19:04:52 <thozza> Proposal: F23 System Wide Change: SELinux policy store migration is approved
19:05:00 <sgallagh> thozza: +1
19:05:01 <ajax> +1 and please do measure some speedups
19:05:01 <jwb> +1
19:05:04 <thozza> plautrba: ok, thanks
19:05:06 <number80> thozza: +1
19:05:09 <thozza> +1
19:05:09 <ajax> marketing loves numbers
19:05:27 <mgrepl> ajax:sure, we have some numbers on fedora change page
19:05:28 <ajax> and i love faster dnf transactions
19:05:29 <number80> (and we know how much selinux needs good marketing)
19:05:49 <plautrba> ajax: there are some numbers in Benefit to Fedora section but we'll provide more
19:05:55 <thozza> #agreed F23 System Wide Change: SELinux policy store migration is approved (+5, 0, -0)
19:06:10 <thozza> moving on
19:06:12 <thozza> #topic #1452 F23 System Wide Change: Two Week Atomic
19:06:13 <thozza> .fesco 1452
19:06:14 <zodbot> thozza: #1452 (F23 System Wide Change: Two Week Atomic) – FESCo - https://fedorahosted.org/fesco/ticket/1452
19:07:41 <thozza> I think Atomic guys know what they need and it may not be the same as for the rest of Fedora
19:07:42 <number80> well, I won't hide that this is something that the Cloud WG is enthusiastic about
19:08:03 <thozza> any questions?
19:08:06 <number80> yes, Atomic is quite a different beast, and it moves at a faster pace
19:08:48 <thozza> I hope they coordinated with RCM since they expect some changes to koji
19:08:59 <sgallagh> rel-eng is aware and preparing for this, according to the Change page
19:09:06 <thozza> sgallagh: good
19:09:08 <ajax> yeah, looks like the right people are aware
19:09:27 <thozza> Proposal: F23 System Wide Change: Two Week Atomic is approved
19:09:30 <ajax> and i'm always a fan of rapid updates
19:09:33 <number80> thozza: that's why maxamillion is among owners :)
19:09:34 <ajax> thozza: +1
19:09:36 <paragan> thozza +1
19:09:39 <thozza> +1
19:09:41 <number80> thozza: +1 (no reserve=
19:09:50 <maxamillion> number80: and dgilmore :)
19:10:08 <jwb> +1
19:10:10 <sgallagh> +1
19:10:30 <thozza> #agreed F23 System Wide Change: Two Week Atomic is approved (+6, 0, -0)
19:10:43 <thozza> #topic #1453 F23 System Wide Change: Glibc locale subpackaging
19:10:43 <thozza> .fesco 1453
19:10:44 <zodbot> thozza: #1453 (F23 System Wide Change: Glibc locale subpackaging) – FESCo - https://fedorahosted.org/fesco/ticket/1453
19:11:40 <thozza> I think I'm OK with this one
19:11:49 <ajax> i like this idea, seems a little sparse on realization
19:11:50 <thozza> anyone any concerns?
19:12:07 <thozza> ajax: what do you mean exactly?
19:12:07 <rishi`> +1
19:12:08 <number80> looks like an improvement, but I wonder about the upgrade path
19:12:43 <thozza> Proposal: F23 System Wide Change: Glibc locale subpackaging is approved. Please be careful with upgrade path.
19:12:50 <rishi`> (I am packing before leaving on vacation, which is why my responses are a bit brief.)
19:13:03 <number80> np
19:13:05 <paragan> thozza, +1
19:13:29 <thozza> +1
19:13:29 <number80> thozza: +1 (still has doubts but this is something that could be rollbacked in time)
19:13:43 <ajax> thozza: just a little concerned about things like "either en-locales is a metapackage or"
19:14:00 <ajax> thozza: seems like the sort of thing you'd know ahead of time
19:14:25 <ajax> that said, the revert path is straightforward, you just install a new glibc that obso's all the old subpackage names
19:14:28 <ajax> so, +1
19:14:39 <sgallagh> +1
19:15:23 <thozza> ajax: I understand it as there will be packages for languages and metapackage installing the most common ones
19:15:43 <jwb> +1
19:16:17 <thozza> #agreed F23 System Wide Change: Glibc locale subpackaging is approved. Please be careful with upgrade path. (+6, 0, -0)
19:16:35 <thozza> 2 to go :)
19:16:36 <thozza> #topic #1454 F23 System Wide Change: Unicode 8.0 support
19:16:36 <thozza> .fesco 1454
19:16:37 <zodbot> thozza: #1454 (F23 System Wide Change: Unicode 8.0 support) – FESCo - https://fedorahosted.org/fesco/ticket/1454
19:17:06 <mfabian> Work for this is already finished: https://sourceware.org/ml/libc-alpha/2015-06/msg00934.html
19:17:30 <thozza> mfabian: great
19:17:33 <mfabian> We did the same for Unicode 7.0.0 already for Fedora 22, so this should be without problems.
19:17:36 <sgallagh> +1, this seems straightforward and an obvious improvement
19:17:38 <ajax> woo yeah emoji
19:17:38 <ajax> +1
19:17:39 <number80> +1
19:17:41 <paragan> +1
19:17:47 <sgallagh> []
19:17:49 <thozza> Proposal: F23 System Wide Change: Unicode 8.0 support is approved
19:17:58 <pravins> mfabian: nice !!
19:18:07 <thozza> so +4 already
19:18:11 <thozza> I'm +1
19:18:36 <jwb> +1
19:18:43 <thozza> #agreed F23 System Wide Change: Unicode 8.0 support is approved (+6, 0, -0)
19:18:58 <thozza> #topic #1455 F23 System Wide Change: Standardized Passphrase Policy
19:18:58 <thozza> .fesco 1455
19:18:59 <zodbot> thozza: #1455 (F23 System Wide Change: Standardized Passphrase Policy) – FESCo - https://fedorahosted.org/fesco/ticket/1455
19:19:17 <thozza> #info postponed until there is some concrete proposal
19:19:24 <thozza> #topic Next week's chair
19:19:39 <thozza> so any volunteers? it is a lot of fun :D
19:19:57 * number80 still has to catch up
19:21:02 <sgallagh> I'm on vacation next week
19:21:03 <thozza> rest?
19:21:24 <ajax> i have a soft conflict with another meeting
19:21:33 <ajax> which is a phone call, but it's hard to do both
19:21:42 <paragan> I can chair next week
19:21:53 <number80> thanks
19:21:59 <number80> paragan++
19:21:59 <zodbot> number80: Karma for pnemade changed to 4:  https://badges.fedoraproject.org/tags/cookie/any
19:22:13 <thozza> #info paragan to chair next week
19:22:18 <thozza> paragan: thanks
19:22:26 <thozza> #topic Open Floor
19:22:45 <thozza> rishi`: you wanted to discuss the DNS resolver 2 weeks ago IIRC
19:22:56 <ajax> just a quick note: now that we're past the mass rebuild i'm collecting some stats about the impact of the "harden everything" change
19:23:14 <jwb> ooh, nice
19:23:20 <ajax> i don't have data yet, will post to devel@ when i do
19:23:26 <thozza> ajax: feel free to update the ticket with some info, it is still opened
19:23:39 <thozza> ajax: thanks
19:23:52 <ajax> thozza: will do
19:24:23 <jkurik> can we do one more Change ? https://fedorahosted.org/fesco/ticket/1458
19:24:54 <thozza> I would need to go through it
19:25:26 <ajax> as long as "xkb prefix icon" doesn't mean "flag" that sounds fine at first glance
19:26:05 <thozza> I also think it looks sane at the first glance
19:26:10 <ajax> if we're not under deadline pressure for beta or something then i'd prefer to do it next week
19:26:24 <thozza> jkurik: are we?
19:26:37 * thozza checks
19:26:38 <jkurik> I do not think so
19:27:00 <sgallagh> I can't even make sense of this proposal. Can someone translate it before next week?
19:27:35 <sgallagh> This reads like http://git-man-page-generator.lokaltog.net/ to me
19:27:40 <thozza> I think it is good to ask the owner to participate
19:27:59 <paragan> I will ask owner to add more information there
19:28:28 <thozza> so if this is all I'm going to end the meeting in couple of minutes
19:30:08 <thozza> I'll update the tickets and send summary tomorrow. It's too late for me and I'm exhausted...
19:30:09 <thozza> #endmeeting