18:00:24 <sgallagh> #startmeeting FESCO (2015-08-19)
18:00:24 <zodbot> Meeting started Wed Aug 19 18:00:24 2015 UTC.  The chair is sgallagh. Information about MeetBot at http://wiki.debian.org/MeetBot.
18:00:24 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
18:00:24 <sgallagh> #meetingname fesco
18:00:24 <sgallagh> #chair ajax dgilmore hguemar jwb nirik paragan rishi thozza sgallagh
18:00:25 <sgallagh> #topic init process
18:00:25 <zodbot> The meeting name has been set to 'fesco'
18:00:25 <zodbot> Current chairs: ajax dgilmore hguemar jwb nirik paragan rishi sgallagh thozza
18:00:34 <thozza> hi all
18:00:35 <nirik> morning
18:00:53 <sgallagh> Greetings
18:01:52 * rishi waves
18:02:32 <sgallagh> /me waits for quorum
18:03:33 <thozza> sgallagh: we have some votes in tickets, so maybe we can decide something also without the quorum... I mean if it is OK to do it that way
18:03:42 <ajax> hey
18:04:22 <sgallagh> And we have quorum :)
18:04:33 <sgallagh> #topic #1466 non-responsive maintainer exception process for skottler
18:04:33 <sgallagh> .fesco 1466
18:04:34 <zodbot> sgallagh: #1466 (non-responsive maintainer exception process for skottler) – FESCo - https://fedorahosted.org/fesco/ticket/1466
18:04:48 <sgallagh> Josh isn't here this week, so I assume we'll just punt
18:05:04 <sgallagh> Proposal: Revisit this next week
18:05:09 <ajax> ack
18:05:09 <nirik> sure. +1
18:05:27 <rishi> +1
18:05:39 <sgallagh> +1
18:05:53 <sgallagh> thozza: ?
18:05:54 <thozza> +1
18:06:06 <sgallagh> #agreed Revisit this next week (+5, 0, -0)
18:06:12 <sgallagh> #topic #1471 F24 System Wide Change: TeXLive 2015
18:06:12 <sgallagh> .fesco 1471
18:06:13 <zodbot> sgallagh: #1471 (F24 System Wide Change: TeXLive 2015) – FESCo - https://fedorahosted.org/fesco/ticket/1471
18:06:19 <thozza> +1 for the change
18:06:27 <sgallagh> +1, seems perfectly sensible
18:06:36 <rishi> +1
18:06:36 <sgallagh> Also +10,000 for early proposal
18:07:16 <ajax> +1, though i'd like to see this accompanied with the actual generated doc differences
18:07:17 <rishi> The new TexLive is already in rawhide.
18:07:36 <nirik> +1
18:07:54 * nirik would be happy if we could split it, but that would require some work.
18:08:17 <rishi> ajax: In "how to test" it says "should be identical" or "actually better".
18:08:28 <dgilmore> hi
18:08:49 <ajax> rishi: yes i saw that.  i'm saying i'd like to see it measured not just just asserted.
18:09:17 <ajax> the "omg harden everything" change didn't actually take as much effect as was promised
18:09:19 <dgilmore> not critical, but I would like to see a plan to make texlive sane packaging wise
18:09:43 <dgilmore> but +1
18:09:49 <ajax> so i think it's reasonable to start asking for proof that the change worked
18:10:35 <sgallagh> #agreed F24 System Wide Change: TeXLive 2015 is accepted (+6, 0, -0)
18:10:53 <sgallagh> #topic #1469 i686 as a non-blocking architecture
18:10:53 <sgallagh> .fesco 1469
18:10:54 <zodbot> sgallagh: #1469 (i686 as a non-blocking architecture) – FESCo - https://fedorahosted.org/fesco/ticket/1469
18:11:12 * nirik notes jwb asked this be discussed next week when he was around
18:11:50 <sgallagh> Yes, though he also offered a vote, so...
18:12:10 <sgallagh> Oh, actually. He and paragan voted on Texlive as well
18:12:12 <sgallagh> #undo
18:12:12 <zodbot> Removing item from minutes: <MeetBot.items.Topic object at 0x7f54e9cfbe10>
18:12:13 <sgallagh> #undo
18:12:13 <zodbot> Removing item from minutes: AGREED by sgallagh at 18:10:35 : F24 System Wide Change: TeXLive 2015 is accepted (+6, 0, -0)
18:12:20 <sgallagh> #agreed F24 System Wide Change: TeXLive 2015 is accepted (+8, 0, -0)
18:12:33 <sgallagh> #topic #1469 i686 as a non-blocking architecture
18:12:54 <sgallagh> So do we want to discuss this today at all?
18:12:54 * thozza said that we have some votes in tickets :)
18:13:07 <sgallagh> thozza: I know, I just forgot when counting them up
18:13:09 <dgilmore> sgallagh: no
18:13:12 <thozza> np ;)
18:13:23 * rishi comments on the ticket
18:13:28 <nirik> I'd say lets wait until next week. should have a lot more feedback by then too.
18:13:29 <thozza> I'm also OK with postponing the discussion
18:13:38 <sgallagh> OK, then.
18:13:58 <sgallagh> #info Discussion postponed until next week to wait for more feedback.
18:14:08 <sgallagh> #topic Next week's chair
18:14:31 <rishi> sgallagh: I can do it next week.
18:14:57 <sgallagh> #info rishi to chair next week's meeting
18:14:58 <sgallagh> Thanks!
18:15:03 <sgallagh> #topic Open Floor
18:15:25 <sgallagh> woo, fifteen minutes to Open Floor.
18:15:26 <ajax> i'll be on pto the next three weeks, and then likely at xdc the week after
18:15:41 <ajax> i'll try to comment on tickets ahead of time, but i probably won't be able to make meetings
18:15:41 <sgallagh> #info ajax will be unable to attend for the next 3-4 meetings
18:16:38 <thozza> I'll create the issue for the Changes approval process we discussed on Flock... I mean the explicit approval from WGs for system-wide changes
18:17:13 <thozza> I didn't have time to do it yet, still catching up with pending tasks
18:17:27 <thozza> Just a note that I didn't forget ;)
18:17:27 <sgallagh> thozza: Thanks
18:17:52 <sgallagh> #action thozza to create a ticket around Change approval process as discussed at Flock
18:20:14 <sgallagh> OK, anything else?
18:20:16 * nirik sent some rawhide plans to list(s)... feedback welcome
18:20:32 <sgallagh> Yeah, I haven't got any feedback on that. I pretty much agree with every word.
18:20:49 <sgallagh> /me plans to have fun painting the shed of the rebranding
18:21:25 <rishi> Here is a crazy thought: now that we have products and WGs, have we ever thought about the role of FESCo?
18:22:04 <ajax> as long as they're all committing to the same package git and use the same compose tools...
18:22:39 <ajax> granted the scope of that common ground might get smaller, but there's still overlap, so there's still some need for fescish oversight
18:22:51 <rishi> Maybe it should have atleast one representative from each WG?
18:23:09 <nirik> well, we have liasions to each group, no?
18:23:38 <ajax> there might be some room for "this change/feature is product-specific and doesn't necessarily need fesco approval" i guess
18:23:55 <sgallagh> rishi: We have liaisons and the Council has representative seats for the whole project
18:23:58 <thozza> rishi: the Changes approval process is one of the things we should update because we now have WGs... I think we could think about specific things or processes, but I think there is still room for FESCo to decide some technical questions, that are not really WGs specific
18:24:51 <rishi> We do, but I am wondering about giving the liasions / representatives a more central role and (slowly?) deprecating FESCo as we know it.
18:25:07 <rishi> Obviously, I have not completely thought this through.
18:25:25 <rishi> It just a thought that has been lingering in the back of mind for a while.
18:26:21 <rishi> At the end of the day, the WGs ship products, so if the WGs can come to some consensus among themselves, why should anybody else come and intervene on techincal grounds.
18:26:34 <thozza> rishi: there are still processes like unresponsive maintainers, proven packagers and for sure more that I can not imagine being decided by WGs
18:26:57 <thozza> personally I think it may be even good that some FESCo members are not really members of any WGs
18:27:05 <ajax> also i like the notion that we'd have wg's that are generally cooperative amongst each other; that'd be a nice future to live in ;)
18:27:31 <rishi> ajax: :)
18:28:34 <sgallagh> ajax: If you don't feel that's the case today, I'd love to hear about it.
18:28:44 <thozza> sgallagh: I almost forgot... At Flock we discussed tasking the Base WG to come up with something specific, right?
18:28:45 <sgallagh> /me has been actively trying to build that future
18:28:50 <rishi> thozza: I can imagine a committee comprising of WG representatives being able to do that. We could have a few non-WG people on the committee too, for the sake of stuff like spins.
18:28:51 <thozza> I'm not sure what it was
18:28:53 <nirik> well, I think if we find someday fesco having no meeting topics or things to do, then perhaps we should look at this? :) or a bit before thta
18:29:07 <langdon> rishi, isn't that the fedora council?
18:29:17 <thozza> rishi: I think this is basically FESCo even now
18:29:20 <thozza> ;)
18:29:42 <sgallagh> thozza: I think that was the Council, actually
18:29:42 <rishi> langdon: In my understanding, the Council doesn't deal with techinical issues.
18:30:14 <thozza> sgallagh: ooh, ok... I thought it was FESCo, since it was something technical
18:30:31 <langdon> rishi, sorry.. was reading your stmt more broadly than it may have been intended.. so maybe a combo of fesco and council depending on subject matter..
18:30:48 <rishi> I don't see the need for this bunch of people trying to approve stuff, when it is really the WGs, release team, and a few others doing the real work.
18:31:23 <rishi> I can say/vote whatever I want in FESCo, but it doesn't matter because I won't be actually doing anything in most cases.
18:31:25 <thozza> rishi: I think also people outside of WGs are doing real work ;)
18:31:48 <rishi> thozza: Yes, like the release team, for example.
18:32:24 <thozza> rishi: like contributors that are trying to make changes that didn't come out of WGs
18:32:43 <thozza> rishi: I explicitly mean others than what you mentioned
18:32:57 <sgallagh> /me notes that FESCo's composition is technically up to the Council to decide upon
18:33:49 <sgallagh> So let me ask this question: "What is FESCo doing poorly that changing its composition will fix (and how)?"
18:33:54 <rishi> thozza: Sure, but in the end we ship 3 products. So the WGs should be able to decide if a change is acceptable for their products.
18:34:08 <rishi> Even if the change was proposed by some random contributor.
18:34:29 <langdon> I guess I also have been trying to encourage some of the WG's work, where it overlaps with other WGs to work in a more central space.. like "container all the things" and moving some or all of those discussions to e&s .. i would think fesco would want similar..
18:34:34 <thozza> rishi: right, but WGs should be also open to other ideas than theirs
18:35:06 <rishi> sgallagh: I won't use the word "poorly". It is a bit too negative.
18:35:50 <sgallagh> rishi: s/poorly/insufficiently well/ if you want to be picky ;-)
18:36:03 * nirik hasnt had time to think about this off hand, so probibly won't contribute much today.
18:36:16 <rishi> From my point of view, when a change comes in I look at it from the Workstation point of view. If it is relevant, I try to form an opinion or ask others in WG for an opinion.
18:36:48 <rishi> If it is something else, then I either go and ask people who work on it, or try to do some background study to form an opinion.
18:36:59 <rishi> All this seems a bit inefficient to me.
18:37:12 <rishi> Say this i686 change.
18:37:35 <rishi> It is mostly an issue between the kernel team and the various WGs.
18:37:56 <rishi> If they can sort it out between themselves, why do we need a bunch of people to approve or disapprove it.
18:37:58 <rishi> ?
18:39:01 <sgallagh> Well, FESCo isn't solely about approval
18:39:13 <sgallagh> It's our job to make sure that the right people are involved in those conversatonis
18:39:19 <nirik> rishi: how about proposing something on list/in a ticket and we can discuss next week? this seems like a particularly poor thing to just land in open floor...
18:39:22 <sgallagh> So that no one gets surprised when stuff lands
18:39:57 <thozza> rishi: I think I'm not enthusiastic about what you are proposing, since I saw a lot of misunderstanding with the Default DNS resolver change from workstation WG and people commenting and making opinions without understanding the change from technical point of view
18:40:35 <langdon> nirik, rishi i would also argue that this is a conversation with fesco and the council.. if you are considering fesco's role..
18:40:37 <thozza> rishi: as for the changes process, I think you want something we discussed at Flock and what I wanted to propose
18:40:53 <thozza> that changes should be approved by WGs before going to FESCo
18:41:16 <rishi> nirik: Yeah, we don't need to decide anything right now. :)
18:41:17 <sgallagh> Right, please propose a change to the process and we'll discuss it next week
18:41:37 <sgallagh> /me explicitly doesn't specify if that was directed at rishi or thozze ;-)
18:42:08 <rishi> :)
18:42:34 <thozza> rishi: I'll try to put together the proposal we discussed at FLock ASAP so you can review if you would like some additional changes
18:42:40 <sgallagh> Anything else for Open Floor?
18:42:49 <rishi> thozza: Ok.
18:43:20 <ajax> nothing more from me
18:43:24 <sgallagh> /me sets the fuse for 120s
18:45:29 <sgallagh> #endmeeting