17:22:37 <dgilmore> #startmeeting FESCO (2016-01-08)
17:22:37 <zodbot> Meeting started Fri Jan  8 17:22:37 2016 UTC.  The chair is dgilmore. Information about MeetBot at http://wiki.debian.org/MeetBot.
17:22:37 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
17:22:37 <zodbot> The meeting name has been set to 'fesco_(2016-01-08)'
17:22:37 <dgilmore> #meetingname fesco
17:22:37 <zodbot> The meeting name has been set to 'fesco'
17:22:37 <dgilmore> #chair maxamillion dgilmore number80 jwb nirik paragan jsmith kalev sgallagh
17:22:37 <zodbot> Current chairs: dgilmore jsmith jwb kalev maxamillion nirik number80 paragan sgallagh
17:22:40 <dgilmore> #topic init process
17:22:43 <sgallagh> .hello sgallagh
17:22:44 <zodbot> sgallagh: sgallagh 'Stephen Gallagher' <sgallagh@redhat.com>
17:22:46 <dgilmore> who all is here
17:22:57 <paragan> .hello pnemade
17:22:58 <dgilmore> Sorry I had teh wrong time
17:22:59 <zodbot> paragan: pnemade 'Parag Nemade' <pnemade@redhat.com>
17:23:10 <nirik> morning
17:23:14 <nirik> .hello kevin
17:23:14 <kalev> morning
17:23:15 <zodbot> nirik: kevin 'Kevin Fenzi' <kevin@scrye.com>
17:23:23 <kalev> .hello kalev
17:23:24 <zodbot> kalev: kalev 'Kalev Lember' <klember@redhat.com>
17:23:40 <dgilmore> .hello ausil
17:23:41 <zodbot> dgilmore: ausil 'Dennis Gilmore' <dennis@ausil.us>
17:23:54 <dgilmore> we have 5
17:24:10 <dgilmore> so that is quorum
17:24:19 <number80> .hello hguemar
17:24:20 <zodbot> number80: hguemar 'Haïkel Guémar' <karlthered@gmail.com>
17:24:41 <dgilmore> jsmith: jwb: you guys still around
17:24:43 <jwb> yes
17:25:58 <sgallagh> jsmith has been voting in tickets
17:26:30 <dgilmore> #topic #1351 Consider renaming "Change(s) freeze" and "Beta deadline/accepted  changes 100% complete" points
17:26:37 <dgilmore> .fesco 1351
17:26:38 <dgilmore> https://fedorahosted.org/fesco/ticket/1351
17:26:38 <zodbot> dgilmore: #1351 (Consider renaming "Change(s) freeze" and "Beta deadline/accepted changes 100% complete" points) – FESCo - https://fedorahosted.org/fesco/ticket/1351
17:26:54 <maxamillion> .hello maxamillion
17:26:56 <zodbot> maxamillion: maxamillion 'Adam Miller' <maxamillion@gmail.com>
17:27:08 <dgilmore> I thought this was all long resolved
17:27:12 <maxamillion> apologies, I missed my calendar reminder
17:27:53 <dgilmore> we can not complete a mass rebuild in two weeks
17:27:53 <nirik> I'm ok with most of it, but don't like 2 weeks for mass rebuild. In the past thats not been enough to really clean things up.
17:27:57 <dgilmore> we need at least 3
17:28:01 <jwb> maxamillion: we just started
17:28:09 <dgilmore> 1 to do the rebuild and 2 for clean up
17:28:18 <maxamillion> jwb: oh, I thought it started at the hour
17:28:23 <number80> sounds good
17:28:26 <dgilmore> nirik: indeed
17:28:29 <jwb> maxamillion: there was a mixup on the time.
17:28:32 <paragan> I agree we need 3 weeks for mass rebuild
17:28:35 <maxamillion> jwb: rgr
17:28:37 <nirik> the rebuild is the easy part... ;) it's the fixing things that needs human interaction thats pesky and longer.
17:28:49 <dgilmore> not sure why he is pushing for that, we used to allow 4 we do the builds faster now. but there is still cleanup
17:29:11 <dgilmore> maxamillion: I brainfarted the time
17:29:13 <sgallagh> I agree we need 3 weeks for a mass rebuild. I'm also not thrilled about finding out so late that we will need one for F24 -_-
17:29:38 <kalev> I think it would make sense to stick a mass rebuild in schedules in advance
17:29:46 <dgilmore> so I am okay with jkurik's proposal, o ther than the mass rebuild window
17:29:49 <kalev> like, always have one in the schedule and take it out if it turns out we won't be needing one
17:29:56 <jwb> kalev: yes
17:30:01 <dgilmore> kalev: we should and we used to. not sure why they got dropped
17:31:00 <maxamillion> what would need to be done to add that back?
17:31:01 <nirik> so, +1 to this aside the mass rebuild (which we have another ticket to discuss about too later anyhow)
17:31:02 <dgilmore> #proposed jkuriks proposal with a change from 2 weeks to 3 weeks for mass rebuild is accepted
17:31:09 <maxamillion> it appears to be favorable to have
17:31:11 <dgilmore> gahh
17:31:31 <dgilmore> nirik: this is just about future schedules
17:31:40 <sgallagh> dgilmore: +1
17:31:44 <nirik> ok. So, +1 to your proposal
17:31:44 <jwb> maxamillion: ask jkurik to add it back in
17:31:58 <jwb> +1
17:32:23 <maxamillion> +1
17:32:32 <paragan> +1
17:32:45 <dgilmore> #accepted jkurik's proposal with a change from 2 weeks to 3 weeks for mass rebuild is accepted (6,0,0)
17:32:57 <dgilmore> #topic #1453 F24 System Wide Change: Glibc locale subpackaging
17:32:57 <dgilmore> .fesco 1453
17:32:57 <dgilmore> https://fedorahosted.org/fesco/ticket/1453
17:32:58 <zodbot> dgilmore: #1453 (F24 System Wide Change: Glibc locale subpackaging) – FESCo - https://fedorahosted.org/fesco/ticket/1453
17:33:29 <jwb> +1
17:33:51 <number80> +1 again
17:33:58 <dgilmore> I am +1 to the idea
17:34:06 <paragan> yes +1 again
17:34:37 <sgallagh> +1 to doing this, though I'm not certain the current plan is clearly thought-out.
17:34:45 <maxamillion> +1
17:34:52 <nirik> yeah, +1
17:34:59 <kalev> I'm a bit unsure about this one, because our packaging tools don't support locale subpackages particularly well right now
17:35:16 <kalev> PackageKit doesn't have any support for locale subpackages, for example
17:35:36 <nirik> this may end up being just laying the groundwork this cycle... and letting the tools catch up.
17:35:42 <dgilmore> #agreed Glibc locale subpackaging accepted (7,0,1)
17:35:45 <nirik> but I like the idea of smaller installs.
17:36:02 <dgilmore> kalev: that seems like a shortcoming in PackageKit
17:36:30 <nirik> well, AFAIK, anaconda doesn't yet support them either right? ie, nothing really does yet?
17:36:35 <number80> well, if we don't start the groundwork, it'll never happen
17:36:40 <dgilmore> kalev: if you use system-config-language doesnt it use PackageKit to install the language packs?
17:36:51 <dgilmore> anyway it is accepted
17:36:59 <kalev> sure, but that's an add-on tool, not something that's in the default install
17:37:16 <kalev> anyway, looks like the plan is erring on the side of caution :)
17:37:22 <dgilmore> kalev: just pointing out that there is some support
17:37:23 <kalev> I think it should be fine as it is
17:37:25 <dgilmore> #topic #1478 F24 Self Contained Changes
17:37:25 <dgilmore> .fesco 1478
17:37:26 <dgilmore> https://fedorahosted.org/fesco/ticket/1478
17:37:26 <zodbot> dgilmore: #1478 (F24 Self Contained Changes) – FESCo - https://fedorahosted.org/fesco/ticket/1478
17:37:52 <kalev> +1
17:37:55 <dgilmore> +1 to all 3
17:38:00 <paragan> +1 to all 3
17:38:04 <nirik> +1 to all
17:38:05 <dgilmore> jsmith was +1 in trac
17:38:06 <sgallagh> +1/+1/+1
17:38:10 <kalev> +3!
17:38:20 <maxamillion> +1
17:38:22 <jwb> +1
17:38:41 <dgilmore> #agreed all of todays proposed changes accepted (8,0,0)
17:38:53 <dgilmore> #topic #1508 redeclipse package maintainer not responding
17:38:53 <dgilmore> .fesco 1508
17:38:54 <dgilmore> https://fedorahosted.org/fesco/ticket/1508
17:38:54 <zodbot> dgilmore: #1508 (redeclipse package maintainer not responding) – FESCo - https://fedorahosted.org/fesco/ticket/1508
17:39:29 <dgilmore> paragan: you added it to the meeting
17:39:38 <sgallagh> What exactly do we want to do here? It didn't sound like mastaiza plans to maintain it himself.
17:39:57 <sgallagh> He (or she?) seems to keep just pestering FESCo to update packages.
17:40:22 <kalev> Not sure. I feel like there's a bit of a language barrier as well.
17:40:25 <paragan> should we orphan this package?
17:40:44 <maxamillion> I think they are requesting the package be orphaned so they can take ownership?
17:40:45 <number80> nope, unless someone wants to maintains it
17:41:02 <sgallagh> maxamillion: mastaiza is not a packager
17:41:09 <paragan> yes he is not packager
17:41:17 <maxamillion> ohhhh
17:41:29 <paragan> so orphan this package, announce on devel for new maintainer needed
17:41:34 <nirik> I'd be fine orphaning it... the maintainer seems missing.
17:41:36 <number80> proposal: just allow admins to change PoC if there are candidates and maintainer doesn't answer fast enough
17:41:42 <maxamillion> nirik: +1
17:41:42 <sgallagh> This is also the third or fourth FESCo ticket that mastaiza has opened, basically demanding that FESCo update a package
17:41:53 <dgilmore> I would be okay orphaning the package
17:42:00 <sgallagh> But yeah, orphaning it and announcing that on devel@ is fine with me
17:42:04 <kalev> does the maintainer have any other packages?
17:42:08 <nirik> nope, just the one
17:42:17 <paragan> just one
17:42:18 <sgallagh> Proposal: Orphan redeclipse and announce it on devel@lists.fp.o
17:42:24 <sgallagh> (for formal vote)
17:42:28 <nirik> sure, +1
17:42:28 <number80> +0 (to sgallagh proposal)
17:42:36 <jwb> +0
17:42:42 <paragan> +1 to sgallagh proposal
17:42:50 <dgilmore> sgallagh: would be good to try get someone to communicate with mastaiza about doing things in a more productive way
17:42:54 <dgilmore> +1
17:43:00 <number80> I'm unsure about force orphaning a package when maintainer is willing to have comaintainers
17:43:05 <nirik> There is a pretty high language barrier
17:43:16 <kalev> I'd be +1 if someone had started the orphaning procedure. Right now it feels a bit like just taking the package from the maintainer without any warning.
17:43:17 <paragan> dgilmore, I have sent him personal email already but still language seems a barrier
17:43:21 <nirik> number80: oh? I missed that, where did they say that?
17:43:26 <kalev> +0 as it is
17:43:39 <number80> https://bugzilla.redhat.com/show_bug.cgi?id=1204600#c8
17:43:42 <nirik> ah, I see. in the bug...
17:43:46 <number80> nirik: ^
17:44:16 <kalev> ahh, he did say he's looking for a new maintainer, I totally missed that
17:44:18 <kalev> +1 then :)
17:44:24 <dgilmore> the we should send an email to devel list asking for co-maintainers
17:44:32 <paragan> current maintainer said, he is okay for anyone else to take over maintainership
17:44:51 <sgallagh> Yeah, but I'm going to change to -1 for orphaning, based on that.
17:45:02 <sgallagh> But I'm fine with proxying his request for comaintainers to devel@
17:45:11 <dgilmore> proposal send email to devel@ asking for someone to help maintaing redeclipse
17:45:17 <number80> +1
17:45:17 <sgallagh> dgilmore: +1
17:45:24 <kalev> dgilmore: +1
17:45:28 <nirik> There was also a post on games list with not much response...
17:45:30 <nirik> sure, +1
17:45:33 <paragan> okay fine the new proposal by dgilmore also okay +1
17:45:46 <dgilmore> I am +1
17:45:47 <maxamillion> +1
17:45:49 <kalev> I didn't even know there's a games list ... doubt it's something that a lot of people read
17:46:04 <jwb> +0
17:46:06 <sgallagh> kalev: It's basically the Games Spin list
17:46:13 <dgilmore> #accepted send email to devel@ asking for someone to help maintaing redeclipse (6,0,1)
17:46:21 <nirik> who is doing the sending?
17:46:35 <paragan> I can
17:46:37 <dgilmore> #action dgilmore to send email
17:46:52 <paragan> cool np
17:46:55 <dgilmore> paragan: if you want I will let you
17:46:59 <dgilmore> but happy to do it
17:47:09 <paragan> Let me send
17:47:14 <dgilmore> #undo
17:47:15 <zodbot> Removing item from minutes: ACTION by dgilmore at 17:46:37 : dgilmore to send email
17:47:21 <dgilmore> #action paragan to send email
17:47:28 <dgilmore> #topic #1522 F24 System Wide Change: GCC6
17:47:28 <dgilmore> .fesco 1522
17:47:28 <dgilmore> https://fedorahosted.org/fesco/ticket/1522
17:47:29 <zodbot> dgilmore: #1522 (F24 System Wide Change: GCC6) – FESCo - https://fedorahosted.org/fesco/ticket/1522
17:47:34 <dgilmore> so gcc6
17:47:35 <sgallagh> Perhaps it wouldn't hurt to also have someone who speaks Russian talk with mastaiza?
17:47:46 <dgilmore> sgallagh: that would be useful
17:48:01 <sgallagh> dgilmore: I'll check if dpal would be willing to lend us a hand
17:48:02 <kalev> would be good to get GCC 6 in as soon as possible
17:48:47 <number80> *nods*
17:49:02 <sgallagh> I have mixed feelings about this.
17:49:04 * dgilmore is +1 to gcc6
17:49:17 <sgallagh> I feel like GCC causes schedule confusion rather often.
17:49:23 <dgilmore> I do wish it had landed and came up sooner
17:49:28 <nirik> I'm +1, but we will need to shoehorn in a mass rebuild.
17:49:36 <number80> my question is, what's the deadline to get in GCC6 for the mass rebuild?
17:49:55 <jwb> sgallagh: denying gcc6 won't fix that.  it's an orthogonal issue to approving the package bump itself
17:50:00 <kalev> I don't think GCC 6 neccesarily requires a mass rebuild, but having a mass rebuild probably makes GCC more stable as it helps the maintainers catch bugs
17:50:05 <sgallagh> The thing that bothers me is doing a mass rebuild of an unreleased compiler.
17:50:20 <sgallagh> I know it's beneficial *to gcc* to have us do that, but it puts us in an awkward position
17:50:35 <nirik> we have done it many times before I think. ;)
17:50:46 <nirik> they often have a stage3/4 one for the mass rebuild.
17:50:50 <kalev> yeah, if there's a compiler bug that requires another mass rebuild, we might be in trouble
17:50:58 <maxamillion> kalev: +1
17:51:09 <sgallagh> nirik: People do lots of things many times that are bad ideas. I eat at McDonald's sometimes.
17:51:13 <sgallagh> Doesn't make it wise :)
17:51:14 <kalev> but we did arrange 3 weeks after the mass rebuild, so we might be able to pull off a second mass rebuild in that time if it is really needed
17:51:15 <nirik> ha. ;)
17:51:29 <maxamillion> the possibility of compiler bugs are concerning ... and given that it's still software, bugs aren't outside of the realm of normal possibilities
17:51:46 <nirik> there is always the possiblity of bugs.
17:52:05 <sgallagh> Yeah, we can't live in fear of that.
17:52:06 <dgilmore> maxamillion: there is always the possibility
17:52:06 <nirik> we should know more after their test mass rebuild
17:52:19 <maxamillion> nirik: +1
17:52:20 <sgallagh> And frankly, without a mass rebuild, we'd be more likely to discover them *after* the "stable" release
17:52:29 <kalev> in general, the GCC team is totally awesome and fixes compiler issues really quickly
17:52:40 <kalev> I think we'll know quite soon after the mass rebuild where we are exactly standing
17:52:45 * nirik nods. Completely agreed.
17:53:00 <maxamillion> agreed
17:53:06 <dgilmore> know jakub will be doing a internal mass rebuild before it lands
17:53:14 <dgilmore> and will be reporting on failures
17:53:18 <nirik> yep
17:53:28 <maxamillion> yeah, that's also a good point
17:53:32 <maxamillion> I'm +1 to gcc6
17:53:49 <nirik> anyhow, I am +1 to the change, but how do we want to insert the mass rebuild? or is that for another ticket?
17:53:49 <dgilmore> if there is too many issues I trust that Jakub will hold off landing it
17:53:53 <sgallagh> nirik: Another ticket
17:53:56 <dgilmore> nirik: that is the next ticket
17:54:02 <nirik> ok. +1 then
17:54:04 <sgallagh> mass-rebuild also impacts glibc
17:54:10 <kalev> I'm +1 as well. we still have time to back out if something goes horribly wrong, the 3 weeks after the mass rebuild give us that.
17:54:15 <nirik> sgallagh: oh?
17:54:24 <sgallagh> rather, is impacted by
17:54:42 <sgallagh> nirik: I'll discuss it when we get there :)
17:55:02 <nirik> sure
17:55:15 <sgallagh> I'm +1 on GCC 6
17:55:29 <jwb> +1
17:55:38 <paragan> +1
17:55:47 <number80> +1
17:56:32 <dgilmore> #agreed, GCC6 change is accepted (8,0,0)
17:56:43 <dgilmore> #topic #1519 reevaluate Fedora 24 schedule
17:56:43 <dgilmore> .fesco 1519
17:56:44 <dgilmore> https://fedorahosted.org/fesco/ticket/1519
17:56:45 <zodbot> dgilmore: #1519 (reevaluate Fedora 24 schedule) – FESCo - https://fedorahosted.org/fesco/ticket/1519
17:57:24 <sgallagh> nirik: What I was referring to before was comment #1 here.
17:57:41 <nirik> ok. wish there was a better idea of when that might land.
17:57:48 * mattdm has Opinions here.
17:57:57 <sgallagh> nirik: Within the next week
17:58:09 <nirik> ok
17:58:17 <sgallagh> nirik: Those particular patches are going into Fedora before upstream (along with a couple others)
17:58:20 <dgilmore> so we have gcc and glibc changes needed mass rebuild, and due to rpm changes are expecting a higer than normal failure rate
17:58:42 <sgallagh> The build for that was expected yesterday, but then a Fire-Drill happened
17:58:42 <kalev> failures are fine. we don't need to fix up everything before branching
17:59:08 <nirik> but it's nice if we can fix as much as we can
17:59:10 <kalev> sure :)
17:59:18 <nirik> so we don't need to fix it in two places all the time.
17:59:36 <dgilmore> kalev: we have two weeks post branching to get fixes in also. just means double builds
17:59:37 <kalev> I mean, we don't neccessarily have to push out the schedule to fix up FTBFS failures. The binary packages are still going to continue working.
18:00:10 <dgilmore> kalev: as long as there is no ABI changes, which I do not think there is any
18:00:16 * kalev nods.
18:00:28 <sgallagh> Yeah, given the lateness of this change, I'm more inclined to say that the convenience isn't worth delaying the schedule
18:00:46 <sgallagh> I'd rather branch sooner after the mass rebuild if possible.
18:00:50 * nirik notes phoronix already had a "fedora f24 slips two weeks" article. ;)
18:00:55 <dgilmore> I would prefer 4 weeks but think we need at least 3
18:01:27 <nirik> mattdm: your Opinions? :)
18:02:13 <mattdm> nirik: I don't think a delay is problematic, but if we do that, I want to keep F25 on the standard October target, which would make it a _very_ short cycle.
18:02:33 <dgilmore> mattdm: I am okay with that
18:02:45 <maxamillion> is there any inclination that we'd have this level of churn for the f25 dev cycle?
18:02:46 <mattdm> This is what FESCo basically decided last time this came up in _theory_, but now it's actually looking like reality :)
18:02:55 <sgallagh> If we do that, we really need that schedule ahead of time.
18:03:05 <nirik> yeah, if we do that we should schedule f25 nowish
18:03:08 <sgallagh> And it needs to clearly state that no Change requiring a mass rebuild will be permitted for F25
18:03:14 <mattdm> sgallagh, nirik ++
18:03:21 * nirik nods. no mass rebuild
18:03:32 <kalev> I'd rather plan for not pushing out F24 that much, to leave more time for F25
18:03:33 <dgilmore> sgallagh-- nirik++
18:03:56 <sgallagh> dgilmore: Care to elaborate?
18:04:02 <dgilmore> sgallagh: it really depends on what the change is and if the mass rebuild is all or partial
18:04:02 <jwb> kalev, why?
18:05:05 <jwb> we aren't going to do the f25 schedule today because jkurik isn't present
18:05:10 <jwb> so we have a week to work it over
18:05:11 <kalev> jwb: our release process is pretty heavy, it feels like having just a few months is a bit too little
18:05:20 <dgilmore> sgallagh: "no Change requiring a mass rebuild will be permitted for F25" could be taken to mean boost can not be reved, or any language, or gnomem or kde
18:05:34 <nirik> possible other option: take the 2 week change option for f24, but start mass rebuild at the change deadline (jan 26th) that gets us another week. However, I have no idea if gcc would be ready by then.
18:05:42 <sgallagh> dgilmore: Yeah, that's pretty much exactly what I was saying.
18:05:44 <number80> dgilmore: we can allow partial mass rebuild?
18:05:53 <kalev> nirik: I would like that option.
18:05:54 <dgilmore> number80: sure
18:05:59 <jwb> uh
18:06:13 <jwb> boost, new gnome stack, etc are not what i consider to be a mass rebuild as is commonly used
18:06:27 <kalev> yeah, those have their own small mass rebuilds
18:06:35 <dgilmore> sgallagh: thats not going to happen, you would piss everyone off saying that no stack can be bumped for 12 months
18:06:39 <sgallagh> Ah, I misread the end of that line.
18:06:52 <number80> jwb: well, it doesn't hurt to clarify that point
18:06:55 <sgallagh> But language stacks? I'm pretty okay with that.
18:07:29 <sgallagh> The alternative (to me) would be to plan to skip the fall release entirely.
18:07:36 <dgilmore> number80: we could just rebuild thinsg written in c++ for instance, or that link to glibc
18:07:41 <maxamillion> sgallagh: can we do that?
18:07:44 <jwb> if you're going to do that, then just get rid of releases entirely
18:07:50 <mattdm> maxamillion: we can do anything :)
18:07:52 <jwb> because this is way more hassle than it's worth
18:07:59 <sgallagh> jwb: I don't follow your logic
18:07:59 <maxamillion> mattdm: magic
18:08:15 <sgallagh> maxamillion: We skipped a release for F21, as I recall.
18:08:18 <number80> ack
18:08:27 <mattdm> Other options: A) long F24 _and_ F25, with short F26
18:08:30 <jwb> sgallagh: if you skip an entire release, you extend the prior release's lifetime by another 6 months
18:08:45 <mattdm> B) 8 months for F24, F25, F26, bringing us back around to the schedule
18:08:52 <jwb> and if you're skipping releases arbitrarily (from an outside view), then there's no point in actually doing planned releases
18:09:03 <number80> mattdm: I like B
18:09:07 <dgilmore> sgallagh: we slip f25 6 months f23 gets 6 months extra life
18:09:14 <dgilmore> and f24 does also
18:09:18 <maxamillion> I like B as well actually
18:09:20 <kalev> downstreams such as GNOME are counting on Fedora releasing twice a year. not doing it might be screwing them over.
18:09:36 <nirik> so, no one likes my idea? (except kalev)?
18:09:37 <jwb> kalev: that is a very strange phrasing of downstream
18:09:43 <sgallagh> nirik: Which was that?
18:09:45 <dgilmore> mattdm: where would B put F25?
18:09:51 <nirik> take the 2 week change option for f24, but start mass rebuild at the change deadline (jan 26th) that gets us another week. However, I have no idea if gcc would be ready by then.
18:09:57 <maxamillion> kalev: yeah, that's something that needs to be taken into consideration ... I'd say upstream, but the point still remains
18:10:01 <jwb> kalev: in that you are essentially saying fedora is the only viable delivery vehicle for UPSTREAM gnome
18:10:07 <mattdm> dgilmore: releasing january/february 2017
18:10:12 <nirik> that would have f25 not too much off what it could be now... possibly shorter with no mass rebuild
18:10:17 <sgallagh> nirik: let me see if I can get an answer from the GCC folks.
18:10:17 <kalev> jwb: yes. upstream gnome is writing a user interface for fedora, essentially.
18:10:18 <sgallagh> Please hold.
18:10:22 <number80> kalev: would the workstation WG against having an upgrade of GNOME within a single release?
18:10:28 <dgilmore> nirik: I put the mass rebuild date in my ticket based on when Jakub said that gcc6 would be ready
18:10:29 <kalev> not sure.
18:10:34 <mattdm> number80: scary.
18:10:48 <jwb> mattdm: they did it in rhel7.  not that scary
18:10:48 <sgallagh> number80: Happened once before, wasn't a great experience.
18:10:56 <dgilmore> mattdm: january/february would mean at least some people have to skip shutdown
18:11:04 <number80> mattdm, sgallagh:  not that scary, GNOME 3 is pretty much stable now
18:11:12 <nirik> dgilmore: I don't see a specific date from you there...
18:11:33 <mattdm> dgilmore: well, the idea would be to factor that in to the schedule so they wouldn't have to.
18:11:45 <dgilmore> nirik: oh I meant to but it would have to be the first week in Feb
18:12:08 <nirik> bummer
18:12:26 <dgilmore> mattdm: early january release the release has to be done before Christmas, then just has to ship
18:12:26 <kalev> why does it have to be first week of February?
18:12:47 <dgilmore> mattdm: late jan we would be doing composes during shutdown
18:12:56 <mattdm> dgilmore: so, february :)
18:13:01 <dgilmore> Feb we are doing beta during shutdown
18:13:13 <sgallagh> dgilmore: Shutdown in January?
18:13:17 <sgallagh> Isn't that... December?
18:13:23 <dgilmore> unless we say 6 or 7 weeks from Beta to GA
18:13:24 <mattdm> dgilmore: so we build in a week for that.
18:13:31 <sgallagh> Oh, never mind. I follow now.
18:13:42 <jwb> mattdm: you're looking at more like 2 weeks
18:13:59 <jwb> mattdm: shutdown is required.  most take either the week before or after as well
18:14:02 <dgilmore> what jwb said
18:14:08 <mattdm> jwb fair. In any case, with two months added total, we should be able to find two weeks
18:14:26 <dgilmore> mattdm: it just gets very messy
18:14:46 <mattdm> Well, my first choice is still the short F24.
18:14:49 <mattdm> uh, 25
18:14:57 <jwb> dgilmore: the release schedule is always messy.  every release.  without fail.
18:15:00 <dgilmore> mattdm: I think that is my first choice also
18:15:02 <nirik> of the current options then if gcc isn't ready until feb, I'd take the 3 week change for mass rebuild in f24, then say no mass rebuild in f25 and schedule it out asap.
18:15:05 <kalev> mattdm: mine too.
18:15:22 <kalev> I wonder if we can ask the gcc people to make it ready a week earlier?
18:15:27 <kalev> sgallagh: are you talking to them?
18:15:29 <sgallagh> I'm fine with the short F25, as long as we are very up-front about not taking risky stuff like a new GCC
18:15:39 <sgallagh> kalev: Yes, trying to get an answer as we speak.
18:15:41 <jwb> nirik: i'm fine with that but i want to be clear on what "no mass rebuild" means
18:15:50 <kalev> yeah, gcc is on a yearly schedule afaik, don't think we'd have an update in F25 timeframe
18:15:51 <jwb> nirik: because sidetag builds of e.g. boost seem fine to me
18:15:57 <dgilmore> sgallagh: given a shorter cycle we will have to manage the changes appropriately, but bigger changes are likely not going to happen anyway
18:15:59 <nirik> yes, those are fine to me too.
18:16:11 <nirik> no releng run bumping each spec and rebuilding every package.
18:16:16 <sgallagh> dgilmore: They're likely to happen if we don't tell people not to :)
18:16:27 <number80> amen to that
18:16:27 <jwb> nirik: matches my expectation
18:16:40 <jwb> nirik: doesn't seem to match sgallagh's with his "no language stack rebuilds"
18:16:56 <sgallagh> jwb, nirik: I can be okay with that
18:17:08 <dgilmore> I am okay with saying no universe rebuild for F25
18:17:15 <sgallagh> Hopefully if we are clear about our intent to shorten the cycle, people will refrain from costly stack rebuilds.
18:17:20 <nirik> I'm fine with those personally as long as they are done early in the cycle, once we branch, etc... they should just do that in rawhide only.
18:17:40 <dgilmore> but allowing for any subsets to be rebuilt so long as its all done by change freeze
18:17:45 <nirik> right
18:17:48 <sgallagh> Works for me
18:17:49 * kalev agrees.
18:18:14 <kalev> we can also nack anything that sounds too scary through the Change process, there's still that too
18:18:39 <jwb> kalev: wait... use process to our advantage?  BRILLIANT ;)
18:18:39 <mattdm> nack or ask for it to be targetted at the next release, yeah.
18:18:57 <sgallagh> mattdm: Well, in reality that's usually what a nack means
18:19:00 * kalev nods.
18:19:32 <dgilmore> proposed #agreed push out teh f24 schedule 3 weeks, request the f25 schedule be set now with a late october ship date.  in F25 there will be no universe mass rebuild. any changes requiring it will have to be postponed to F26
18:19:47 <number80> +1
18:19:56 <jwb> +1
18:19:57 <kalev> I'd be more inclined to go with nirik's alternative proposal
18:20:13 <nirik> kalev: well, we don't know if gcc will be ready then... sounds like not.
18:20:13 <kalev> where we push out 2 weeks and start the mass rebuild early, to give more time after mass rebuild.
18:20:21 <kalev> nirik: sgallagh is talking to gcc people right now
18:20:58 <sgallagh> Can I amend that policy to include "2 weeks if GCC people say it's feasible?"
18:21:05 <sgallagh> s/policy/proposal/
18:21:22 <kalev> let's go with nirik's proposal for now and amend it next week to go with 3 weeks if it turns out gcc is not ready?
18:21:36 <sgallagh> kalev: Phrase it formally?
18:21:40 <dgilmore> 03:23 <jakub> but I think we can have only preliminary packages ready by the end of first week of January, then a week for test mass rebuild and analysis, so only 3rd or 4th week of January realistically the real mass rebuild
18:22:05 <sgallagh> dgilmore: That sounds like Jan 26th is workable...
18:22:05 <dgilmore> so maybe we could follow nirik's proposal
18:22:15 <kalev> excellent :)
18:22:32 <nirik> cool, so we can try that, and if it's not punt to the 3 week one.
18:22:44 <sgallagh> Yeah, we can always slip later if we have to.
18:23:30 <nirik> proposal: push schedule out 2 weeks with mass rebuild starting on jan 26th. If gcc not ready push out 3 weeks and rebuild starts feb 2nd. Request f25 schedule for late october release. No mass rebuild in f25.
18:23:39 <maxamillion> nirik: +1
18:23:41 * nirik tried to get it all in there.
18:23:48 <dgilmore> nirik: +1
18:23:49 <paragan> +1 to nirik's proposal
18:23:50 <kalev> nirik: +1
18:23:53 <sgallagh> nirik: +1
18:23:59 <sgallagh> nirik++
18:23:59 <zodbot> sgallagh: Karma for kevin changed to 24 (for the f23 release cycle):  https://badges.fedoraproject.org/tags/cookie/any
18:24:02 <maxamillion> words are hard yo
18:24:04 <sgallagh> (For making that clear)
18:24:04 <maxamillion> nirik++
18:24:04 <zodbot> maxamillion: Karma for kevin changed to 25 (for the f23 release cycle):  https://badges.fedoraproject.org/tags/cookie/any
18:24:12 <jwb> +1
18:24:49 * nirik is +1 to his own proposal too
18:24:58 <dgilmore> #agreed push schedule out 2 weeks with mass rebuild starting on jan 26th. If gcc not ready push out 3 weeks and rebuild starts feb 2nd. Request f25 schedule for late october release. No mass rebuild in f25. (7,0,0)
18:25:24 <dgilmore> #topic Next week's chair
18:25:31 <dgilmore> who wants to go next
18:25:58 * nirik will not be here next week. off at the lovely datacenter all week.
18:26:35 <kalev> I'm not sure I have time to do it next week, but I could take the one after
18:26:55 <sgallagh> /me is updating his RHCE next week and will miss the meeting
18:26:56 <dgilmore> maxamillion: want to take a stab at it?
18:27:57 * number80 starting another month of travel next week
18:28:02 <maxamillion> dgilmore: I'll actually be traveling to a wedding next Friday :(
18:28:14 <maxamillion> dgilmore: I can try my hand the week after that
18:28:28 <jwb> are we even going to have quorum?
18:28:30 <paragan> hmm will we have quorum next week?
18:28:35 <maxamillion> it doesn't sound like it
18:28:47 <jwb> nirik, maxamillion, sgallagh, number80, and possibly myself will be absent
18:28:47 <number80> well, I should be there but not necessarily from home
18:28:59 <maxamillion> by show of +/-1 (+ being you will be here, - not) ... who all will be here next week?
18:29:02 <maxamillion> -1
18:29:08 <dgilmore> sounds like we may not have quarom next week
18:29:08 <number80> +0.5
18:29:09 <jwb> +0
18:29:10 <sgallagh> -1
18:29:15 <dgilmore> +1
18:29:18 <nirik> -1
18:29:19 <paragan> better postpone meeting 2 weeks later
18:29:24 <kalev> +1
18:29:50 <dgilmore> lets skip next weeks meeting
18:29:55 <number80> ok
18:30:00 <dgilmore> who wants to run the meeting in 2 weeks time
18:30:26 <kalev> I can do it
18:30:43 <dgilmore> #info kalev to run the meeting on Jan 22
18:30:59 * dgilmore will not be able to make meetings on Jan 29 and Feb 5
18:31:17 <number80> the same, going to Beerdem and devconf
18:31:22 <maxamillion> I think many of us will be at DevConf Feb 5, yes?
18:31:27 <dgilmore> #topic Open Floor
18:31:31 <dgilmore> maxamillion: yep
18:31:34 <maxamillion> +1
18:31:42 <sgallagh> Who will be at DevConf?
18:31:46 <number80> o/
18:31:50 <sgallagh> We may actually have an in-person quorum :)
18:31:51 <dgilmore> o/
18:31:59 <sgallagh> o/
18:31:59 <jwb> should be
18:32:01 <number80> people going to FOSDEM too?
18:32:11 <jwb> no
18:32:13 <maxamillion> o/
18:32:14 * kalev isn't going to either one
18:32:22 <dgilmore> number80: I am
18:32:27 * maxamillion won't be at FOSDEM
18:32:41 <sgallagh> Just DevConf for me
18:33:26 <number80> maxamillion: you're missing the best part of the travel ;)
18:34:07 <sgallagh> /me prefers the beer in Brno
18:34:10 <maxamillion> number80: :(
18:34:39 <number80> maxamillion: remember that for your next year ;)
18:34:44 <number80> -your
18:34:56 <dgilmore> so we have maxamillion sgallagh number80 dgilmore jwb? at DevConf
18:34:58 <dgilmore> ?
18:35:03 <number80> yup
18:35:30 <dgilmore> so not quite enough for a in person meeting
18:36:17 <dgilmore> anyone got anything for open floor?
18:36:24 <dgilmore> or should I wrap up?
18:37:16 <sgallagh> I count five
18:37:19 <sgallagh> That's quorum :)
18:38:32 <dgilmore> okay going to wrap up
18:38:36 <dgilmore> #endmeeting