16:00:40 <jsmith> #startmeeting FESCO (2016-06-10)
16:00:40 <zodbot> Meeting started Fri Jun 10 16:00:40 2016 UTC.  The chair is jsmith. Information about MeetBot at http://wiki.debian.org/MeetBot.
16:00:40 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
16:00:40 <zodbot> The meeting name has been set to 'fesco_(2016-06-10)'
16:00:40 <jsmith> #meetingname fesco
16:00:40 <zodbot> The meeting name has been set to 'fesco'
16:00:40 <jsmith> #chair maxamillion dgilmore number80 jwb nirik paragan jsmith kalev sgallagh
16:00:40 <jsmith> #topic init process
16:00:40 <zodbot> Current chairs: dgilmore jsmith jwb kalev maxamillion nirik number80 paragan sgallagh
16:00:47 <jsmith> .hellomynameis jsmith
16:00:48 <zodbot> jsmith: jsmith 'Jared Smith' <jsmith.fedora@gmail.com>
16:00:55 <paragan> .hello pnemade
16:00:56 <zodbot> paragan: pnemade 'Parag Nemade' <pnemade@redhat.com>
16:00:58 <number80> .hello hguemar
16:01:02 <zodbot> number80: hguemar 'Haïkel Guémar' <karlthered@gmail.com>
16:01:07 <nirik> .hello kevin
16:01:08 <zodbot> nirik: kevin 'Kevin Fenzi' <kevin@scrye.com>
16:01:10 <kalev-afk> .hello kalev
16:01:11 <zodbot> kalev-afk: kalev 'Kalev Lember' <klember@redhat.com>
16:01:59 <jsmith> We have a quorum :-)
16:02:22 <jsmith> jwb said he wouldn't be able to make it
16:02:26 <handsome_pirate> Ahoy
16:02:32 <jsmith> sgallagh said he'd likely be absent
16:02:41 <jsmith> and I think dgilmore is in Brno, if I understand correctly
16:02:53 * kalev-afk is on a bus with bad wifi
16:03:11 <maxamillion> .hello maxamillion
16:03:12 <zodbot> maxamillion: maxamillion 'Adam Miller' <maxamillion@gmail.com>
16:03:15 <jsmith> So let's go ahead and get started, and hopefully we'll have at least five members able to vote :-)
16:03:32 <jsmith> #topic Follow-ups
16:03:43 <jsmith> #topic #1576 Evaluate Workstation graphical upgrade Change status
16:03:43 <jsmith> .fesco 1576
16:03:43 <jsmith> https://fedorahosted.org/fesco/ticket/1576
16:03:44 <zodbot> jsmith: #1576 (Evaluate Workstation graphical upgrade Change status) – FESCo - https://fedorahosted.org/fesco/ticket/1576
16:04:10 <jsmith> Anybody want to give us a status update?
16:04:51 <number80> kalev-afk?
16:05:15 <kalev-afk> I think we should have things lined up by next week, https://fedorahosted.org/fesco/ticket/1576#comment:21 summarizes how things currently are
16:05:15 <jsmith> There is an update from a couple of days ago in the ticket, fwiw.
16:05:44 <jsmith> kalev-afk: Besides that -- does it look to you like good progress is being made, or are there still significant bugs to be worked out?
16:06:02 <kalev-afk> we have two bugs that QA identified as blockers for shipping this. we're working on addressing them
16:06:17 <kalev-afk> I am optimistic :)
16:06:34 <jsmith> OK, sounds good.  I guess we'll all keep a close eye on it, and check back in next week :-)
16:06:37 <dgilmore> jsmith: I am on a train to PRague :)
16:06:37 <number80> wfm
16:06:46 <maxamillion> +1
16:06:53 <jsmith> Moving on...
16:07:05 <paragan> sure check on next week
16:07:05 <jsmith> #topic #1573 Docker Layered Image maintainer guildelines, naming guidelines and review
16:07:05 <jsmith> .fesco 1573
16:07:05 <jsmith> https://fedorahosted.org/fesco/ticket/1573
16:07:06 <zodbot> jsmith: #1573 (Docker Layered Image maintainer guildelines, naming guidelines and review) – FESCo - https://fedorahosted.org/fesco/ticket/1573
16:07:28 <jsmith> I've re-read the guidelines again, and don't find anything that concerns me
16:08:07 <jsmith> And since this been postponed for several weeks, I think it's time we take a vote.
16:08:28 <maxamillion> I was secretly hopng people would re-read and go "oh man, we need to fix/change/add all this stuff" ;)
16:08:40 <jsmith> (The guidelines aren't carved in stone, but they need to be approved before maxamillion can continue his work)
16:08:47 <maxamillion> I suspect the guidelines will evolve as time goes on, but I mostly wanted to make sure and get approval on the first run at things
16:08:58 <paragan> yes enough next week on this ticket
16:09:04 <jsmith> maxamillion: I have some minor nit-pick stuff, but mostly just from a docs standpoint :-p
16:09:06 * nirik meant to re-read, but got swamped.
16:09:09 <number80> Yeah but most of it makes sense
16:09:11 <maxamillion> jsmith: eh, I haven't really blocked on them ... I just wanted them in place before we start accepting docker-ized software into the build system
16:09:23 <jsmith> maxamillion: That's what I meant, of course :-p
16:10:19 <jsmith> Any other comments/concerns before we vote?
16:10:35 <nirik> I am 100% sure we will need to adjust them as we go, but thats fine.
16:10:44 <maxamillion> nirik: +1
16:10:53 <jsmith> Proposal: Accept the container layered image guidelines as in the ticket
16:10:57 <maxamillion> +1
16:10:58 <jsmith> +1 from me
16:10:58 <paragan> +1
16:11:03 <number80> +1
16:11:18 <nirik> +1
16:11:21 <kalev-afk> +1
16:11:36 <dgilmore> +1
16:12:31 <jsmith> #agreed #1573 Docker Layered Image maintainer guidelines, naming guidelines and review are approved (+1: 7, +0:0, -1:0)
16:12:53 <jsmith> #topic New Business
16:13:05 <jsmith> #topic #1584 Please process systemd presets request, bz :1340061
16:13:05 <jsmith> .fesco 1584
16:13:05 <jsmith> https://fedorahosted.org/fesco/ticket/1584
16:13:07 <zodbot> jsmith: #1584 (Please process systemd presets request, bz :1340061) – FESCo - https://fedorahosted.org/fesco/ticket/1584
16:13:40 <nirik> I think we should just close this one
16:13:52 <number80> *nods*
16:14:01 <jsmith> I do too -- I don't see anything for us to do on it, other than acknowledge that it's being worked on
16:14:09 <maxamillion> +1
16:14:10 <paragan> yes we can close this
16:14:49 <jsmith> I wasn't sure if there was actually a preset request that we were being asked to decide upon
16:14:56 <jsmith> If there is, I'm not finding it
16:15:47 <jsmith> #agreed Closing #1584, as there's nothing for FESCo to do about it at this time
16:16:06 <jsmith> #topic #1568 F25 Self Contained Changes
16:16:07 <jsmith> .fesco 1568
16:16:07 <jsmith> https://fedorahosted.org/fesco/ticket/1568
16:16:08 <zodbot> jsmith: #1568 (F25 Self Contained Changes) – FESCo - https://fedorahosted.org/fesco/ticket/1568
16:16:18 <jsmith> There are three new self-contained changes this week
16:16:47 <jsmith> New version of glibc
16:16:59 <jsmith> A scale-out docker registry
16:17:09 <jsmith> And a rel-eng automation workflow engine
16:17:49 <maxamillion> as a side note on both scale-out docker registry and releng automation, I won't be running those solo ... I just haven't hammered down who specifically will be suckered into helping each :)
16:17:49 <paragan> +1 to all three changes
16:18:09 <maxamillion> (I noticed that was a concern on my two changes from jwb)
16:18:16 <maxamillion> +1 to all three changes
16:18:19 <number80> +1 for all changes
16:18:20 <nirik> +1
16:18:27 <dgilmore> +1
16:18:36 <jsmith> maxamillion: Minor point about the docker registry -- have you updated your proposal based on our conversations at the Cloud FAD earlier this week?
16:18:40 <kalev-afk> +1
16:18:50 <dgilmore> MOOOR work for maxamillion
16:18:56 <jsmith> maxamillion: (in particular, with regards to Pulp/Crane and the redirects?)
16:19:07 <maxamillion> jsmith: it's included in the design, yes
16:19:43 <jsmith> maxamillion: Yes, but I thought that bowlofeggs said that it wouldn't quite work the way you designed it -- maybe I misunderstood
16:20:19 <maxamillion> jsmith: well, there's some concern about docker 1.10/1.11 and the crane api so we might have to add functionality upstream to crane and/or work with the pulp team around that topic
16:20:33 <jsmith> OK, was just curious
16:20:39 <maxamillion> jsmith: +1
16:21:12 <jsmith> I'm also +1 to all three changes
16:22:06 <jsmith> #agreed #1568 Self Contained Changes: All three new requested changes are approved
16:22:21 <jsmith> #topic Next Week's Chair
16:22:32 <jsmith> sgallagh had volunteered for next week, as I recall
16:22:53 <jsmith> #topic Open Floor
16:23:04 <jsmith> Anybody have any items for the open floor?
16:23:33 * maxamillion does not
16:23:35 <dgilmore> nada
16:23:46 <number80> void
16:24:10 <jsmith> (If nothing else, I'll complain that upgrading F24-latest to Rawhide leaves a completely broken X, at least on a Lenovo X1 Carbon 2nd generation)
16:24:21 <jsmith> (I tried it three times, and it broke all three times)
16:24:42 <maxamillion> jsmith: wayland?
16:24:55 <jsmith> maxamillion: Xorg
16:24:58 <maxamillion> huh
16:25:01 <maxamillion> ¯\_(ツ)_/¯
16:25:18 <maxamillion> alright, if nothing else I'm going to crawl back into bed with my tissues :)
16:25:28 <nirik> jsmith: strange.
16:25:48 <jsmith> nirik: Very much so -- X doesn't find any displays attached
16:25:51 <nirik> X is working fine for me in rawhide. (but I didn't upgrade)
16:26:07 <kalev-afk> I'm still on F24 for what it's worth
16:26:19 <jsmith> nirik: And about 50% of the time boot hangs soon after switching root
16:26:32 <jsmith> nirik: It was working fine for me until Monday night when I upgraded again :-/
16:26:41 <maxamillion> before we go further down this path, anything else for FESCo? because I was serious about crawling back into bed ... I'm sick as hell :/
16:26:43 * nirik is happy to help try and debug in devel
16:26:57 <gholms> maxamillion: :(
16:27:02 <jsmith> Anyhoo -- I'll light the proverbial fuse.... if there's nothing else for the open floor, I'll end in one minute.
16:27:19 <jsmith> maxamillion: You got sick from the FAD too?  I think I'm about the only one who didn't get sick
16:27:47 <maxamillion> jsmith: yes :(
16:29:30 <jsmith> Ending in three...
16:29:35 <jsmith> Two...
16:29:39 <jsmith> One...
16:29:41 <jsmith> Thanks everyone!
16:29:44 <jsmith> #endmeeting