16:00:06 <jwb> #startmeeting FESCO (2016-07-15)
16:00:06 <zodbot> Meeting started Fri Jul 15 16:00:06 2016 UTC.  The chair is jwb. Information about MeetBot at http://wiki.debian.org/MeetBot.
16:00:06 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
16:00:06 <zodbot> The meeting name has been set to 'fesco_(2016-07-15)'
16:00:06 <jwb> #meetingname fesco
16:00:06 <jwb> #chair maxamillion dgilmore number80 jwb nirik paragan jsmith kalev sgallagh
16:00:06 <jwb> #topic init process
16:00:06 <zodbot> The meeting name has been set to 'fesco'
16:00:06 <zodbot> Current chairs: dgilmore jsmith jwb kalev maxamillion nirik number80 paragan sgallagh
16:00:13 <kalev> .hello kalev
16:00:14 <zodbot> kalev: kalev 'Kalev Lember' <klember@redhat.com>
16:00:15 <sgallagh> .hello sgallagh
16:00:16 <zodbot> sgallagh: sgallagh 'Stephen Gallagher' <sgallagh@redhat.com>
16:00:25 <maxamillion> .hello maxamillion
16:00:25 <zodbot> maxamillion: maxamillion 'Adam Miller' <maxamillion@gmail.com>
16:00:28 <paragan> .hello pnemade
16:00:30 <zodbot> paragan: pnemade 'Parag Nemade' <pnemade@redhat.com>
16:00:36 <jsmith> .hello jsmith
16:00:37 <zodbot> jsmith: jsmith 'Jared Smith' <jsmith.fedora@gmail.com>
16:00:39 <nirik> .hello kevin
16:00:40 <zodbot> nirik: kevin 'Kevin Fenzi' <kevin@scrye.com>
16:00:41 <jsmith> (For what it's worth, I'm at a conference with terrible wifi)
16:01:21 <jwb> so missing number80 and dgilmore
16:01:49 <jwb> i think we'll press on and hopefully they show up
16:02:15 <jwb> #topic #1593 cryptkeeper package is unmaintained / as well as upstream
16:02:15 <jwb> maintainer
16:02:15 <jwb> .fesco 1593
16:02:15 <jwb> https://fedorahosted.org/fesco/ticket/1593
16:02:17 <zodbot> jwb: #1593 (cryptkeeper package is unmaintained / as well as upstream) – FESCo - https://fedorahosted.org/fesco/ticket/1593
16:02:54 <sgallagh> I wish this had just gone through the normal non-responsive maintainer process, but I agree it's time to retire cryptkeeper.
16:03:01 <jwb> yeah.  looks like the current best solution is to retire
16:03:02 <maxamillion> sgallagh: +1
16:03:21 <number80> o/
16:03:30 <number80> +1
16:03:52 <paragan> +1 to retire this package
16:03:53 <kalev> could also orphan as per the usual process and then it gets auto retired if nobody picks it up
16:04:16 <sgallagh> True, but given that upstream is dead (not even on life-support, just dead) I think it's an empty gesture.
16:04:27 <number80> kalev: it's unmaintained upstream for years, it'll be a completely new project if someone picks it up
16:04:33 <sgallagh> It's sufficiently dead that if someone wants to pick it up, I think I'd rather see a re-review
16:04:36 <kalev> fair enough
16:04:39 <nirik> sure, +1 retire
16:04:41 <maxamillion> oooo, the XPS 13 Developer Edition can do hardware updates with fwupd <3 <3 <3
16:04:47 <maxamillion> oooops, wrong channel
16:04:54 <kalev> +1 retire
16:05:02 <maxamillion> +1 retire
16:05:09 <jwb> i'll retire it after the meeting
16:05:20 <sgallagh> Thanks, jwb
16:05:41 <jwb> #agreed Retire cryptkeeper (+8, 0, 0)
16:05:45 <jwb> #info jwb to retire
16:05:48 <jwb> #undo
16:05:48 <zodbot> Removing item from minutes: INFO by jwb at 16:05:45 : jwb to retire
16:05:49 <pjones> maxamillion: yes :)
16:05:54 <jwb> #info jwb to retire cryptkeeper
16:06:02 <jwb> ok, moving on
16:06:14 <jwb> #topic #1568 F25 Self Contained Changes
16:06:14 <jwb> .fesco 1568
16:06:14 <jwb> https://fedorahosted.org/fesco/ticket/1568
16:06:15 <zodbot> jwb: #1568 (F25 Self Contained Changes) – FESCo - https://fedorahosted.org/fesco/ticket/1568
16:06:54 <paragan> +1 to all
16:07:32 <nirik> +1 to all
16:07:33 <sgallagh> I'm not sure the Golang one qualifies as self-contained. Do we treat Perl and Boost upgrades as self-contained?
16:07:41 <sgallagh> But I'm +1 to all of them, regardless
16:07:56 <number80> +1 to all Bodhi non-RPM artefacts (I'd like to get status about it first)
16:08:04 <jwb> sgallagh: i don't think we do, but golang's prevalence isn't as wide-spread in the distro either
16:08:11 <number80> sgallagh: Boost is treated as self-contained
16:08:23 <jwb> number80: specific questions on it?
16:08:27 <maxamillion> +1 to all
16:08:28 <kalev> +1 to all
16:08:43 <sgallagh> jwb: I'm slightly concerned with the proposal to have Cloud become OpenShift-based (which is golang)
16:08:45 <jwb> +1 to all
16:08:51 <number80> jwb: just status, it was not clear for everyone last time we speak about it
16:09:00 <sgallagh> (As it happens, OpenShift does build on 1.7, but it's still a major component that's dependent)
16:09:39 <jwb> number80: isn't that something we normally continue to follow up on during the lifecycle of development?
16:09:41 <number80> my apologies, boost is treated as system-wide for a while now
16:09:54 <number80> well, if maxamillion is confident about it, I'm +1
16:11:10 <jwb> jsmith: ?
16:11:13 <maxamillion> number80: sgallagh: I'm confused ... is there an OpenShift component in the change list I'm not seeign?
16:11:16 <maxamillion> seeing*
16:11:45 <sgallagh> maxamillion: I'm referring to https://lists.fedoraproject.org/archives/list/cloud@lists.fedoraproject.org/thread/7MZJQ3SL6ATVXV3FEPGCMPWYPU4MBT4F/
16:12:01 <jsmith> +1 to all
16:12:15 <jwb> #agreed All Self-Contained Changes approved (+8, 0, 0)
16:12:27 <jwb> maxamillion: i think that was more in reference to golang
16:12:44 <number80> openshift core components are written in go
16:12:46 <maxamillion> sgallagh: that URL didn't go anywhere for me --> The requested URL /archives/list/cloud@lists.fedoraproject.org/thread/7mzjq3sl6atvxv3fepgcmpwypu4mbt4f/ was not found on this server.
16:12:52 <maxamillion> jwb: ah ok
16:12:56 <sgallagh> Right, I was arguing that golang is becoming fundamental, so calling it Self-Contained is wrong
16:13:03 <maxamillion> sgallagh: ahhhh, fair
16:13:40 <jwb> sgallagh: we can bring that up separately going forward i think.  it's a good point
16:13:47 <maxamillion> +1
16:14:02 <jwb> #info golang may need to be a system-wide change in the future
16:14:11 <sgallagh> Thanks
16:14:19 <jwb> #topic #1594 F25 System Wide Change: IBus Emoji Typing
16:14:19 <jwb> .fesco 1594
16:14:20 <jwb> https://fedorahosted.org/fesco/ticket/1594
16:14:21 <zodbot> jwb: #1594 (F25 System Wide Change: IBus Emoji Typing) – FESCo - https://fedorahosted.org/fesco/ticket/1594
16:14:52 <jwb> seems there was a bit of discussion on-list.  i haven not had time to follow that thread myself yet
16:15:24 <paragan> Yes, Fujiwara is looking into that discussion
16:15:59 <number80> Yeah, a GNOME developer has been working on that topic too, so he wanted to collaborate w/ Fujiwara on that feature
16:16:47 <paragan> I don't think there is anything currently blocking, let the implementation happen and we will see it at next stage
16:16:47 <sgallagh> From what I can tell, there's argument about specific implementation, but nothing that would seem to impact anyone except the people working on it.
16:16:50 <sgallagh> So I'm +1
16:16:55 <number80> Yup, +1
16:16:58 <maxamillion> this is adding nodejs as a dep to ibus?
16:17:18 <paragan> +1 from side as well
16:17:26 <sgallagh> maxamillion: Wait, I missed that. Where is that happening?
16:17:38 <maxamillion> sgallagh: https://fedoraproject.org/wiki/Changes/IBus_Emoji_Typing <--- Dependencies
16:17:47 <sgallagh> Ah, hmm.
16:17:48 <jwb> it depends on nodejs-emojione
16:17:54 <sgallagh> I'm not sure I'm comfortable with that.
16:18:19 <jwb> perhaps we should defer until next week to allow people more time to discuss implemenation and dependencies
16:18:23 <maxamillion> I'm not for or against it inherently, but thought I'd point it out for further discussion ... it's a whole new toolchain into the mix
16:18:25 <sgallagh> Yeah
16:18:29 <maxamillion> +1 to defer
16:18:30 <sgallagh> I'm switching to 0
16:18:37 <jwb> +1 to defer
16:18:40 <paragan> I am okay to defer
16:18:54 <kalev> Bastien's comments on the mailing list make sense to me as well, probably a good idea to follow his advice there I think
16:18:55 <sgallagh> Not just a toolchain, but a significant addition to the base package set
16:18:59 <kalev> +1 to defer
16:19:01 <maxamillion> nodejs has proven itself mature, they're even using it to code HUDs in space suits at NASA now, but it's still a whole new pile of things tac'd onto ibus
16:19:03 <number80> +1 ok to defer
16:19:13 <paragan> kalev, but he is also pointing to some nodejs module
16:19:18 <jsmith> +1 to defer
16:19:32 <maxamillion> sgallagh: also that
16:19:52 * nirik nods. +1 defer
16:19:53 <sgallagh> Yeah, I'm not overly worried about Node.js's maturity. Particularly since we decided to only ship versions of Node.js that will become LTS releases.
16:19:55 <maxamillion> sgallagh: I'm curious how that would affect modularization also
16:20:04 <maxamillion> sgallagh: +1
16:20:22 <maxamillion> annnyhoo, it looks like we're deferring so I'll move my comments to the mailing list
16:20:25 <jwb> #agreed Defer approval to allow more discussion on implementation and dependencies (+8, 0, 0)
16:20:33 <sgallagh> maxamillion: Thanks
16:20:53 <jwb> ok, moving on
16:21:01 <jwb> #topic #1595 F25 System Wide Change: Automatic Provides for Python RPM Packages
16:21:01 <jwb> .fesco 1595
16:21:01 <jwb> https://fedorahosted.org/fesco/ticket/1595
16:21:03 <zodbot> jwb: #1595 (F25 System Wide Change: Automatic Provides for Python RPM Packages) – FESCo - https://fedorahosted.org/fesco/ticket/1595
16:21:51 <nirik> +1 here
16:22:29 <jwb> seems like a good change to me, though i'm not a python developer.  +1
16:23:05 <kalev> +1
16:23:07 <paragan> +1
16:23:08 <sgallagh> The folks developing this know what they're doing, so I'm +1
16:23:22 <tibbs> Still not even a hint of draft packaging guidelines.
16:23:23 <jsmith> No concerns here... +1 from me
16:23:41 <number80> mmm, I'm not found of it
16:23:41 <maxamillion> +1
16:23:52 <number80> +1 nonetheless
16:24:08 <number80> it's an important step for fixing python packaging long-term
16:24:15 <jwb> #agreed Approved Automatic Provides for Python RPM Packages (+8, 0, 0)
16:24:20 <tibbs> I don't think that's a particularly big deal in this case, though I do wish at least a draft was a requirement.
16:24:27 <jwb> tibbs: we can ask them again
16:24:45 <jwb> #info follow up on packaging guidelines draft is needed
16:25:28 <jwb> #topic #1597 F25 System Wide Change: Ruby on Rails 5.0
16:25:28 <jwb> .fesco 1597
16:25:28 <jwb> https://fedorahosted.org/fesco/ticket/1597
16:25:30 <zodbot> jwb: #1597 (F25 System Wide Change: Ruby on Rails 5.0) – FESCo - https://fedorahosted.org/fesco/ticket/1597
16:25:37 <number80> +1
16:25:46 <kalev> +1
16:25:47 <maxamillion> +1
16:25:56 <paragan> +1
16:25:59 <nirik> +1
16:26:03 <jwb> +1
16:26:26 <sgallagh> +1
16:26:53 <jwb> jsmith: ?
16:27:12 <jsmith> Sorry, my connection keeps dropping
16:27:15 <jsmith> +1 from me
16:27:22 <jwb> #agreed Approved Ruby on Rails 5.0 (+8, 0 ,0)
16:27:33 <jwb> #topic #1598 F25 System Wide Change: SSSD fast cache for local users
16:27:33 <jwb> .fesco 1598
16:27:34 <jwb> https://fedorahosted.org/fesco/ticket/1598
16:27:36 <zodbot> jwb: #1598 (F25 System Wide Change: SSSD fast cache for local users) – FESCo - https://fedorahosted.org/fesco/ticket/1598
16:27:50 <sgallagh> I can talk about this if there are questions
16:27:59 <jwb> no commentary on the list
16:28:10 <nirik> +1 here.
16:28:13 <jwb> +1
16:28:36 <maxamillion> yeah, the proposal looks sane, it was discussed upstream with glibc maintiners
16:28:39 <maxamillion> +1 here
16:29:01 <paragan> +1
16:29:12 <sgallagh> /me abstains from voting since I am one of the owners
16:29:14 <kalev> +1, looks like a nice change that should be transparent for most people and just work
16:30:04 <number80> +1 well, no blocker
16:30:08 <jsmith> +1 from me
16:30:21 <jwb> #agreed Approved SSSD fast cache for local users (+7, 0, 0)
16:30:36 <jwb> #topic #1599 F25 System Wide Change: Unicode 9.0 support
16:30:36 <jwb> .fesco 1599
16:30:36 <jwb> https://fedorahosted.org/fesco/ticket/1599
16:30:38 <zodbot> jwb: #1599 (F25 System Wide Change: Unicode 9.0 support) – FESCo - https://fedorahosted.org/fesco/ticket/1599
16:31:14 <jwb> +1
16:31:16 <jwb> yay unicode
16:31:16 <paragan> +1
16:31:25 <nirik> +1
16:31:27 <kalev> +1
16:31:34 <maxamillion> +1
16:31:44 <sgallagh> +1
16:31:59 <jsmith> +1 from me -- no concerns here
16:32:26 <paragan> unicode-ucd is already updated to 9.0.0 release in F25+
16:32:33 <jwb> number80: ?
16:34:04 * jwb waits another minute or two...
16:35:15 <jwb> perhaps he stepped afk for a bit.  we have quorum so moving on
16:35:22 <jwb> #agreed Approved Unicode 9.0 support (+7, 0, 0)
16:35:44 <jwb> i'm going to go out of order in the agenda briefly
16:35:53 <jwb> #topic #1590 F25 System Wide Change: GHC 7.10
16:35:53 <jwb> .fesco 1590
16:35:54 <jwb> https://fedorahosted.org/fesco/ticket/1590
16:35:56 <zodbot> jwb: #1590 (F25 System Wide Change: GHC 7.10) – FESCo - https://fedorahosted.org/fesco/ticket/1590
16:36:14 <jwb> +1
16:36:16 <paragan> +1
16:36:33 <kalev> +1
16:36:54 <nirik> +1
16:36:57 <sgallagh> +1
16:37:25 <jwb> jsmith: and number80 were both +1 in the ticket
16:37:31 <jwb> maxamillion: ?
16:37:56 <maxamillion> +1
16:37:57 <maxamillion> sorry
16:38:02 <jwb> #agreed Approved GHC 7.10 (+8, 0, 0)
16:38:18 <jwb> #topic #1601 F25 System Wide Change: Fedora Media Writer as Primary Downloadable
16:38:18 <jwb> .fesco 1601
16:38:18 <jwb> https://fedorahosted.org/fesco/ticket/1601
16:38:20 <zodbot> jwb: #1601 (F25 System Wide Change: Fedora Media Writer as Primary Downloadable) – FESCo - https://fedorahosted.org/fesco/ticket/1601
16:38:57 <nirik> this makes me somewhat sad, but +1
16:39:03 <sgallagh> +1 I really hope we hit this this time.
16:39:08 <sgallagh> nirik: Why sad?
16:39:28 <nirik> because we have to have/run/manage windows and osx in Fedora infrastructure to build this.
16:39:34 <maxamillion> yeah ...
16:39:41 <paragan> yeah
16:39:42 <nirik> but such is life
16:39:58 <maxamillion> I'm +1 ... for grand mustard
16:40:20 <paragan> +1
16:41:03 <jwb> kalev, jsmith, number80?
16:42:13 <kalev> +1
16:42:34 <jwb> +1 myself i guess
16:42:55 * jwb waits another minute
16:43:59 <number80> +1
16:44:50 <jsmith> +1
16:44:54 <jwb> #agreed Approved Fedora Media Writer as Primary Downloadable (+8, 0, 0)
16:44:57 <jwb> thanks guys
16:45:10 <jwb> ok, last agenda item
16:45:20 <jwb> #topic #1600 F25 System Wide Change: KillUserProcesses=yes by default
16:45:20 <jwb> .fesco 1600
16:45:20 <jwb> https://fedorahosted.org/fesco/ticket/1600
16:45:23 <zodbot> jwb: #1600 (F25 System Wide Change: KillUserProcesses=yes by default) – FESCo - https://fedorahosted.org/fesco/ticket/1600
16:45:40 <jwb> so sgallagh put a proposal in the ticket
16:45:45 <jwb> do you want to repeat it here sgallagh ?
16:46:03 <sgallagh> I'd prefer to just link it, since it's multi-step
16:46:26 <sgallagh> https://fedorahosted.org/fesco/ticket/1600#comment:4
16:47:00 <maxamillion> I'm +1 to sgallagh's proposal in the ticket (comment:4) ... or however that should properly be written
16:47:28 <sgallagh> zbyszek: ping
16:47:28 <zodbot> sgallagh: Ping with data, please: https://fedoraproject.org/wiki/No_naked_pings
16:47:36 <sgallagh> ... I deserved that
16:47:40 <nirik> I'm +1 also, but I agree with zbyszek's last comment... we shouldn't put everything that could be in tier1 in tier1
16:47:41 <zbyszek> sgallagh: I responded in the ticket...
16:48:04 <sgallagh> zbyszek: Yeah, but we're discussing things live so I figured you would want to be present
16:48:16 <nirik> and hopefully the logging would land soon so we could enable that and help gather those packages that should exempt themselves
16:48:18 <sgallagh> I don't think I suggested that.
16:48:20 <zbyszek> Yeah, thanks.
16:48:35 <sgallagh> I was saying we should decide which things are important *enough* that they block this rollout
16:49:03 <sgallagh> For example, despite their relative importance, I can't see DNF or fedup being tier1
16:49:27 <zbyszek> sgallagh: But most things should not have any support for turning themselves into a service, even if they are otherwise important.
16:49:40 <sgallagh> zbyszek: I'm not disagreeing with you.
16:49:49 <sgallagh> I just think you drew the wrong conclusion from my proposal
16:49:52 <jwb> nirik: the logging you mention is that which was just discussed on-list, correct?
16:49:53 <nirik> I would think dnf would be important... if its in the middle of a transaction...
16:50:05 <maxamillion> +1
16:50:23 <nirik> jwb: yeah, (and I actually suggested when the thread first came up, we go full circle. :)
16:50:25 <sgallagh> nirik: but it already is broken that way, even without KillUserProcess
16:50:30 <sgallagh> So that's a non-argument, IMHO
16:50:42 <sgallagh> It's the exact reason for ostree, in fact :)
16:50:59 <number80> mmm pondering
16:51:02 <nirik> I'm not sure I am following.
16:51:15 <jwb> i'm not sure it's the exact reason for ostree, but it's certainly something ostree helps with
16:51:36 <sgallagh> jwb: from my conversations with Colin, it was first started to avoid the "plug pulled during upgrade" problem
16:52:05 <nirik> if dnf is running and you logout without killuserprocesses, I am pretty sure it either keeps going (if it was in rpmland) or quits (if it was just downloading), but it isn't killed
16:52:16 <sgallagh> nirik: If the session is exited during a DNF transaction, it's currently going to exit anyway. It's not SIGHUPed to my knowledge.
16:52:29 <number80> +1 to the current plan
16:52:31 <nirik> I don't think thats true, but I would have to test it to be sure.
16:52:40 <number80> but I'm worried about which packages will be in Tier 1
16:52:47 <sgallagh> nirik: Actually, doesn't DNF inhibit shutdown/logout with systemd anyway?
16:52:52 <sgallagh> So it's probably safe *enough*
16:52:57 <number80> (tmux, screen and stuff like that are a must for me)
16:53:09 <nirik> it does for shutdown.. I don't think it does for logout.
16:53:10 <sgallagh> tmux and screen are the two most obvious ones to me
16:53:29 <zbyszek> sgallagh: yeah, there's no way to inhibit logout
16:53:38 <number80> well, I'm not confident since tmux already refused to patch upstream
16:53:40 <sgallagh> nirik: I'd make the argument that if we don't all agree that something is Tier 1, it probably isn't.
16:54:00 <sgallagh> number80: That doesn't mean they wouldn't accept a patch that worked differently
16:54:13 <sgallagh> They don't want to grow a systemd-specific dependency.
16:54:20 <number80> sgallagh: knowing them, i'll be difficult
16:54:23 <nirik> number80: it likely would be worth approaching them again... that ticket/bug became political
16:54:26 <sgallagh> So maybe we find another way, or make it optional
16:54:34 <number80> but that should not prevent us to try again
16:54:50 <sgallagh> Yeah, this seems like a case where someone should approach the project leaders directly, rather than on a public list
16:55:34 <jwb> there's also always the option of carrying a downstream patch
16:55:58 <zbyszek> Yes, I'll try to prepare a patch, which hopefully will not be too ugly or invasive, and that will be a better moment to talk again with tmux upstream.
16:56:00 <sgallagh> OK, so I have three questions: 1) Are we okay with my proposal? 2) Are we agreed that at least screen and tmux are Tier 1 under it? 3) Are there any other concrete proposals for Tier 1?
16:56:31 <jwb> i dislike having Tier 1 and Tier 2 lists tbh
16:56:31 <nirik> would nohup be another possible?
16:56:31 <smooge> is nohup covered under it? [or already supported?]
16:56:40 <nirik> jinx. ;)
16:56:50 <jwb> it's more stuff to police and follow up on over time, which we're notoriously terrible at
16:57:13 <sgallagh> jwb: I do too, but if we say everything is blocking, this will never happen.
16:57:14 <zbyszek> I was thinking that nohup calls should be replaced with systemd-run.
16:57:20 <sgallagh> And there *are* benefits to it.
16:57:56 <nirik> there is also the 'disown' shell builtin... but not sure how that could be handled.
16:58:00 <jwb> sgallagh: at the least, can we just get a single list?  i don't see the point in Tier 2
16:58:27 <sgallagh> jwb: Well, the point of Tier 2 was mostly for us to have something for the Common Bugs page.
16:58:52 <paragan> I am okay with either single or tier 1,2 list
16:59:05 <sgallagh> zbyszek: Would it be possible for the systemd project to take over the nohup command and provide the same arguments?
16:59:18 <sgallagh> I'm okay with dropping the secondary list if it's a distraction
16:59:25 <zbyszek> possible: certainly. welcomed: dunno ;)
16:59:30 <jwb> i have no better alternative, so i'm not going to block on the list(s) issue
16:59:38 <jwb> just note that we suck at maintaining lists of things
16:59:44 <nirik> well, the secondary list common bug would be the same... just the name changes. ;)
16:59:45 * jsmith prefers the tier 1,2 list
16:59:49 <sgallagh> I just wanted it to be clear that we were acknowledging that some things wouldn't be important enough to block on
17:00:10 <maxamillion> sgallagh: +1
17:00:19 <sgallagh> jwb: Right, I'll add "Fix being bad at maintaining lists" to my "todo list"
17:00:42 <jwb> sgallagh: hey, i said "we".  not a slam on anyone in particular
17:00:43 <sgallagh> zbyszek: Welcomed by whom?
17:00:58 <zbyszek> the wider community
17:01:01 <sgallagh> jwb: I got that, I was just making a joke. I didn't take it personally :)
17:01:01 <nirik> coreutils ?
17:01:30 <jwb> ok, so it sounds like we mostly have consensus
17:02:07 <zbyszek> sgallagh: I don't want to commit to nohup at this time, because I don't know enough about how people use it.
17:02:27 <jwb> proposal: FESCo approves KillUserProcess=yes by default with the steps sgallagh has proposed in the ticket
17:02:29 <sgallagh> zbyszek: That's fair. I'm not trying to dump a lot of extra work on you either.
17:02:36 <number80> +1 to jwb proposal
17:02:50 <number80> (let's keep discussion to the list or ticket)
17:02:55 <nirik> +1
17:02:58 <maxamillion> +1
17:02:59 <jwb> +1
17:03:03 <sgallagh> But if FESCo decides 'nohup' is Tier 1, *someone* will have to figure it out, so I was asking if that was an easy way.
17:03:08 <sgallagh> +1
17:03:09 <paragan> +1
17:03:25 <jwb> jsmith: kalev ?
17:03:41 <kalev> I think it's a good way forward, +1 to sgallagh's proposal
17:03:57 <number80> sgallagh: we should ask actual users how this change their workflow, and which components we should pay attention to
17:04:16 <number80> not that we will automatically add all suggestion to Tier1 but we'll consider their arguments
17:04:17 <sgallagh> "I want to see a crowdsourced list of all the packages known to be negatively affected by this change. (This should be possible by investigating the various email threads on the issue)." (from my proposal)
17:04:27 <number80> *nods*
17:04:42 <nirik> and easier when there's logging. ;)
17:04:58 <jwb> #agreed FESCo approves KillUserProcess=yes by default with the steps sgallagh has proposed in the ticket (+7, 0, 0)
17:05:04 <number80> Can this be driven by Fedora Server WG?
17:06:13 <jwb> number80: i think we can follow up with the list and its maintainers on-list
17:06:19 <number80> ack
17:06:29 <zbyszek> I just tested starting dnf upgrade from a ssh session, and disconnecting. With KillUserProcesses=no, dnf (in the download phase) and rpm (in the install phase) are killed immediately. So I don't think dnf belongs in tier1. (Unless I messed up my test, but I don't think so.)
17:06:44 <jwb> #topic Next Week's chair
17:06:57 <maxamillion> I can do it
17:07:02 <jwb> i'll miss next week as i'm on PTO.  then flock is the week after
17:07:04 <nirik> zbyszek: bummer. ok.
17:07:06 <jwb> maxamillion: thanks
17:07:10 <nirik> zbyszek: thanks for testing
17:07:11 <jwb> #info maxamillion to chair next week
17:07:12 <sgallagh> I won't be able to make next week's meeting, but I'll volunteer for the 29th
17:07:19 <jwb> #topic Open Floor
17:07:37 * maxamillion has something for OpenFloor
17:07:43 <number80> go ahead
17:08:02 <kalev> I'll be missing from next two meetings, travelling next week and then the Friday after again
17:08:18 <maxamillion> I wanted to just have people take a look at https://bugzilla.redhat.com/show_bug.cgi?id=1308561 and the resulting ticket https://fedorahosted.org/council/ticket/61 and mailing list thread https://lists.fedoraproject.org/archives/list/packaging@lists.fedoraproject.org/thread/6LLERBZU5JX5DW7XJX7FWXV36K5G7AZR/
17:08:29 <maxamillion> this is about using third party repos in weak deps
17:08:59 <sgallagh> I'm a little disappointed that the conversation stalled.
17:09:17 <maxamillion> sgallagh: +1
17:09:22 <jwb> the Council hasn't met in a bit
17:09:31 <jwb> mostly because mattdm has been on PTO and decause left
17:10:00 <jwb> i suspect this will get picked up again at the next Council meeting.  perhaps along with the other third party software proposal
17:10:06 <number80> maxamillion: this question should be asked on legal-list first
17:10:15 <paragan> I use some packages from rpmfusion but not seen any security updates, Do maintainers push any security updates in rpmfusion?
17:10:42 <number80> paragan: rpmfusion is in shortage of contributors
17:10:59 <maxamillion> number80: probably so
17:11:01 <nirik> FWIW, I think it shouldn't be allowed. Mostly since we can't know what 3rd party repo someone intended and there could be different names
17:11:32 <smooge> or same names but different packages
17:11:56 <jwb> nirik: add that to the ticket please
17:12:01 <nirik> sure.
17:12:22 <number80> well, if legal says no, it would stop the discussion early
17:12:27 <jwb> it's essentially the point of my leading question there, but further follow up is good
17:12:59 <jwb> number80: this is something the Council needs to take into account overall with third party proposals IMO.  consulting legal will be part of that
17:13:11 <number80> ack
17:14:01 <jwb> if other's have comments or opinions, i'd ask you to put them in the ticket
17:15:19 <jwb> maxamillion: anything further you'd like to address here?
17:16:06 <maxamillion> no, just wanted to get it on everyone's radar in hopes that we could help drive the discussion
17:16:09 <maxamillion> thank you
17:16:23 <jwb> thanks
17:16:26 <jwb> anything else for open floor?
17:16:56 * jwb will end meeting in 1min
17:17:48 <jwb> ok, thanks everyone.  lots of stuff to get through today and we did it in a timely manner
17:17:52 <jwb> #endmeeting