#fedora-meeting: FESCO (2016-08-19)

Meeting started by maxamillion at 16:00:29 UTC (full logs).

Meeting summary

  1. init process (maxamillion, 16:00:40)
  2. Follow Ups (maxamillion, 16:03:01)
  3. #1605 finish retirement of sysvinit-only packages (maxamillion, 16:03:14)
    1. https://fedorahosted.org/fesco/ticket/1605 (maxamillion, 16:03:35)

  4. #1606 F25 approved Changes not in MODIFIED status (maxamillion, 16:07:23)
    1. https://fedorahosted.org/fesco/ticket/1606 (maxamillion, 16:07:23)
    2. AGREED: defer KillUserProcess to Fedora 26 (+1: 8, -1: 0, +0: 0) (maxamillion, 16:20:50)
    3. AGREED: maxamillion to take the review of cargo to move the rust change through (+1: 8, -1: 0, +0: 0) (maxamillion, 16:23:51)
    4. AGREED: defer Koji Generates Installation Media change until Fedora 26 (+1: 8, -1: 0, +0: 0) (maxamillion, 16:28:41)
    5. AGREED: Approve Release Engineering Automation Workflow Engine Change (+1: 8, -1: 0, +0: 0) (maxamillion, 16:32:11)

  5. #1609 Fedora 26 schedule proposal (maxamillion, 16:32:22)
    1. https://fedorahosted.org/fesco/ticket/1609 (maxamillion, 16:32:22)
    2. AGREED: more in ticket discussion needed for schedule, will revisit later (maxamillion, 16:45:36)

  6. #1611 Continued lack of support for RPM weak deps in distro tooling (maxamillion, 16:45:44)
    1. https://fedorahosted.org/fesco/ticket/1611 (maxamillion, 16:45:49)
    2. AGREED: releng will try and move all compose tools to support weak deps, but in the mean time issues with composes and weak deps will need to be handled on a case by case basis. (+1: 9, -1: 0, +0: 0) (maxamillion, 16:56:28)

  7. New Business (maxamillion, 16:57:28)
  8. #1613 Deletion of EOL AMIs (maxamillion, 16:57:34)
    1. https://fedorahosted.org/fesco/ticket/1613 (maxamillion, 16:57:34)
    2. AGREED: defer decision on Deletion of EOL AMIs until the AWS billing issue is sorted (+1: 7, -1: 0, +0: 1) (maxamillion, 17:15:17)

  9. #1614 FHS exception for /snap (maxamillion, 17:15:25)
    1. https://fedorahosted.org/fesco/ticket/1614 (maxamillion, 17:15:26)
    2. https://build.opensuse.org/package/show/system:snappy/golang-github-snapcore-snapd (Pharaoh_Atem, 17:23:24)
    3. ACTION: maxamillion to reach out to openSUSE, arch, and debian contacts on /snap topic to aid in cross-distro agreement on approach (maxamillion, 17:31:15)
    4. AGREED: defer FHS exception for /snap until next week's meeting (+1: 8, -1: 0, +0: 0) (maxamillion, 17:36:08)

  10. #1615 Consider Wayland by default for F25 (maxamillion, 17:38:11)
    1. https://fedorahosted.org/fesco/ticket/1615 (maxamillion, 17:38:19)
    2. AGREED: FESCo agrees to go ahead with Wayland by default provided that release notes and common bugs are clear about how to switch back to X11 if needed. (+1: 7, -1: 0, +0: 0) (maxamillion, 17:46:26)

  11. #1612 Provenpackager request jforbes (maxamillion, 17:47:54)
    1. https://fedorahosted.org/fesco/ticket/1612 (maxamillion, 17:48:05)
    2. https://fedoraproject.org/wiki/Provenpackager_policy (nirik, 17:53:19)
    3. AGREED: Approve jforbes Provenpackager request (+1: 7, -1: 1, +0: 0) (maxamillion, 18:00:17)

  12. Next week's chair (maxamillion, 18:01:26)
    1. dgilmore to chair next weeks meeting (maxamillion, 18:02:47)

  13. Open Floor (maxamillion, 18:03:00)


Meeting ended at 18:06:09 UTC (full logs).

Action items

  1. maxamillion to reach out to openSUSE, arch, and debian contacts on /snap topic to aid in cross-distro agreement on approach


Action items, by person

  1. maxamillion
    1. maxamillion to reach out to openSUSE, arch, and debian contacts on /snap topic to aid in cross-distro agreement on approach


People present (lines said)

  1. maxamillion (191)
  2. jwb (66)
  3. dgilmore (65)
  4. Pharaoh_Atem (54)
  5. sgallagh (52)
  6. nirik (51)
  7. Rathann (33)
  8. paragan (30)
  9. jsmith (28)
  10. kalev (26)
  11. zodbot (25)
  12. jforbes (21)
  13. pbrobinson (10)
  14. stickster (10)
  15. pid1 (10)
  16. tibbs (7)
  17. gholms (6)
  18. pjones (3)


Generated by MeetBot 0.1.4.