16:02:56 <maxamillion> #startmeeting FESCO (2017-04-28)
16:02:56 <zodbot> Meeting started Fri Apr 28 16:02:56 2017 UTC.  The chair is maxamillion. Information about MeetBot at http://wiki.debian.org/MeetBot.
16:02:56 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
16:02:56 <zodbot> The meeting name has been set to 'fesco_(2017-04-28)'
16:02:56 <maxamillion> #meetingname fesco
16:02:56 <zodbot> The meeting name has been set to 'fesco'
16:02:56 <maxamillion> #chair maxamillion dgilmore jwb nirik jforbes jsmith kalev sgallagh Rathann
16:02:56 <zodbot> Current chairs: Rathann dgilmore jforbes jsmith jwb kalev maxamillion nirik sgallagh
16:02:59 <maxamillion> #topic init process
16:02:59 <maxamillion> nirik: sorry
16:03:05 <nirik> no worries. :)
16:03:10 <kalev> morning
16:03:17 <sgallagh> .hello sgallagh
16:03:18 <zodbot> sgallagh: sgallagh 'Stephen Gallagher' <sgallagh@redhat.com>
16:03:18 <jforbes> .hello jforbes
16:03:21 <zodbot> jforbes: jforbes 'Justin M. Forbes' <jforbes@redhat.com>
16:03:39 <maxamillion> .hello maxamillion
16:03:40 <zodbot> maxamillion: maxamillion 'Adam Miller' <maxamillion@gmail.com>
16:06:38 <maxamillion> how long to we wait?
16:07:22 <sgallagh> maxamillion: We have quorum, so up to you
16:07:31 <maxamillion> oh wait, we do have quorum
16:07:32 * maxamillion derp
16:07:37 <maxamillion> I counted 4 at first
16:07:41 <maxamillion> #topic #1699 xml-security-c new maintainer
16:07:41 <maxamillion> .fesco 1699
16:07:42 <maxamillion> https://pagure.io/fesco/issue/1699
16:07:42 <zodbot> maxamillion: Issue #1699: meeting: xml-security-c new maintainer request - fesco - Pagure - https://pagure.io/fesco/issue/1699
16:07:58 <maxamillion> this is a follow up from last week that was still on the agenda
16:08:23 <jforbes> Right, we couldn't look at anything because bz/pkgdb/etc were down
16:08:32 <maxamillion> correct
16:09:18 <kalev> I remember a mailing list discussion about this which basically went along the lines that
16:09:50 <kalev> "Hi, I talked to anttix and he is ok with someone working on xml-security-c to bring it up to date, is anyone interested?"
16:10:24 <nirik> and no one was? ;)
16:10:25 <kalev> and then someone showed up and said that the maintainer doesn't respond in bugzilla
16:10:39 <kalev> no, someone was interested, I think that's the person who filed the fesco ticket now
16:10:53 <nirik> https://admin.fedoraproject.org/pkgdb/packager/anttix/ shows they are point of contact for 3 packages
16:11:46 * dgilmore is here
16:12:06 <jforbes> But I do see them listed on the package in question now
16:12:16 <kalev> aha, found the original discussion: https://lists.fedoraproject.org/archives/list/devel@lists.fedoraproject.org/thread/NUGEJ5SYOT2LKURY4P33YHMWNNDVX52L/
16:12:30 <jforbes> https://admin.fedoraproject.org/pkgdb/package/rpms/xml-security-c/ shows kloczek as an administrator
16:12:55 <jforbes> Which tells me there is nothing else to do here.
16:13:12 <kalev> ohh, indeed
16:13:40 <maxamillion> jforbes: +1
16:13:47 <nirik> yeah. nothing to do unless we want to orphand the others... which sounds like we don't
16:14:00 <jforbes> They didn't follow the non-responsive maintainer policy, even after being asked to
16:14:12 <maxamillion> jforbes: correct
16:14:27 <jforbes> So I recommend that we leave as is and close the ticket
16:14:33 <nirik> +1
16:14:34 <maxamillion> jforbes: +1
16:14:50 <kalev> +1
16:15:04 <dgilmore> +1
16:15:24 <sgallagh> +1
16:16:47 <maxamillion> #agreed - xml-security-c new maintainer request - leave as is, administrator already updated (+1:6, -1:0, +0:0)
16:16:55 <maxamillion> #topic #1653 Better communicating roles and responsibilities of FESCo for elections
16:16:58 <maxamillion> .fesco 1653
16:16:59 <zodbot> maxamillion: Issue #1653: [Meta] Better communicating roles and responsibilities of FESCo for elections - fesco - Pagure - https://pagure.io/fesco/issue/1653
16:17:00 <maxamillion> https://pagure.io/fesco/issue/1653
16:18:08 <nirik> oh this just needs adding.
16:18:10 <nirik> I can do that
16:18:15 <maxamillion> nirik: +1 thanks
16:18:20 <jforbes> Oh, that was left open because the wiki was down
16:18:24 <jforbes> thanks nirik
16:18:34 <maxamillion> #info nirik to update the wiki
16:18:42 <maxamillion> #topic #1690 F27 Self Contained Changes - Java 9
16:18:43 <maxamillion> .fesco 1690
16:18:43 <maxamillion> https://pagure.io/fesco/issue/1690#comment-438338
16:18:44 <zodbot> maxamillion: Issue #1690: F27 Self Contained Changes - fesco - Pagure - https://pagure.io/fesco/issue/1690
16:19:14 <dgilmore> ack to java9
16:19:41 <maxamillion> +1 to java9
16:19:42 <jforbes> +1 java9
16:19:45 <kalev> +1 to java9
16:20:35 <maxamillion> nirik: sgallagh: ?
16:20:44 <nirik> +1
16:21:52 <maxamillion> sgallagh: ? :)
16:22:19 <sgallagh> +1
16:22:26 <sgallagh> Sorry, got disconnected.
16:22:40 <dgilmore> -1 internet
16:22:49 <sgallagh> heh
16:23:32 <maxamillion> #agreed - APPROVED: F27 Self Contained Changes - Java 9 (+1:6, -1:0, +0:0)
16:23:40 <maxamillion> #topic #1702 Fedora support_url
16:23:40 <maxamillion> .fesco 1702
16:23:40 <maxamillion> https://pagure.io/fesco/issue/1702
16:23:41 <zodbot> maxamillion: Issue #1702: Fedora support_url - fesco - Pagure - https://pagure.io/fesco/issue/1702
16:24:18 <dgilmore> I do think it is a bug in the desktop that it requires an optional field in /etc/os-release
16:24:43 <dgilmore> and I think we really do not have a support url
16:25:02 <jforbes> I am a big fan of the Getting Help link if we do need something
16:25:09 <dgilmore> but i figured that FESCo should decide if we have one and if we do what it is
16:25:37 <maxamillion> jforbes: +1
16:25:39 <dgilmore> jforbes: I do not think we have to have one
16:25:52 <dgilmore> but I can go with that
16:26:00 <maxamillion> I like the idea of having one, it's difficult for people who are brand new to know where to go without some guideance
16:26:09 <sgallagh> If we have one, I think the wiki I posted is the closest.
16:27:10 <dgilmore> https://fedoraproject.org/wiki/Communicating_and_getting_help
16:27:13 <dgilmore> for the record
16:27:34 <maxamillion> indeed
16:28:04 <dgilmore> so while not really a support url. its a good pointer
16:28:38 <jforbes> Well, I don't actually see any downside of having one, particularly when it is a "help you help yourself" reference such as this.
16:28:51 <dgilmore> jforbes: right
16:29:37 <dgilmore> proposal #agreed FESCo has agreed that https://fedoraproject.org/wiki/Communicating_and_getting_help is the official support url
16:29:45 <maxamillion> dgilmore: +1
16:29:56 <jforbes> +1
16:30:23 <sgallagh> +1
16:30:35 <kalev> +1
16:31:37 <nirik> sure, +1
16:31:42 <maxamillion> #agreed FESCo has agreed that https://fedoraproject.org/wiki/Communicating_and_getting_help is the official support url (+1:6, -1:0, +0:0)
16:31:48 <nirik> we might want to make a pass over it and make sure it's all up to date. ;)
16:32:08 <maxamillion> +1
16:32:10 <dgilmore> probably should yeah
16:32:16 <maxamillion> I'll do that this afternoon
16:32:23 <sgallagh> maxamillion++
16:32:26 <zodbot> sgallagh: Karma for maxamillion changed to 17 (for the f25 release cycle):  https://badges.fedoraproject.org/tags/cookie/any
16:32:46 <maxamillion> #info maxamillion to check https://fedoraproject.org/wiki/Communicating_and_getting_help is up to date
16:32:55 <maxamillion> #topic Next week's chair
16:33:31 <maxamillion> who's up?
16:33:45 <kalev> I haven't done this in a while, happy to be the chair next week
16:33:55 <dgilmore> gracias kalev
16:35:34 <maxamillion> #info kalev to chair next week's meeting
16:35:43 <maxamillion> #topic Open Floor
16:35:50 <maxamillion> I'll be on an airplane during the meeting next week so there's a reasonable chance I won't make it
16:35:54 <maxamillion> I will try though :)
16:36:56 <dgilmore> I have one quick thing
16:37:12 <dgilmore> planning to enable s390x in primary koji this weekend
16:37:18 <maxamillion> rocking
16:37:26 <dgilmore> there has been a few queries if we should do f26 also
16:37:38 * Pharaoh_Atem pops in
16:37:52 * nirik would like that, but I know it's late in the f26 cycle
16:37:53 <Pharaoh_Atem> it'd be cool if s390x was enabled in primary koji for f26, too
16:38:02 <dgilmore> I feel like it is too late in f26 to make the change, but if FESCo felt we should I would support it
16:38:10 <maxamillion> dgilmore: I'd vote yes unless there are any real show stoppers ... I can't think of a reason not to other than it's kind of late in the cycle
16:38:12 <kalev> I think it's a bit too late for f26
16:38:16 <Pharaoh_Atem> why?
16:38:31 <Pharaoh_Atem> other than "lateness", why can't it be moved to primary koji?
16:38:35 <dgilmore> I do think its too late
16:38:52 <dgilmore> because of the possibility of unkown bugs to cause a slip
16:39:06 <nirik> right, if some release blocking thing broke only on s390 it would be a pain to try and scramble to fix it now.
16:39:07 <dgilmore> we are already quite delayefd
16:39:13 <maxamillion> Pharaoh_Atem: being this late in the cycle leaves a shorter runway to fix unforseen/unkonwn issues
16:40:06 <dgilmore> as much as I would love to kill off all the alt arch hubs sooner. I think we should wait
16:40:12 <kalev> but a big +1 to enabling it in rawhide
16:40:20 <nirik> dgilmore: well, we do have a bit until beta tho...
16:40:21 <kalev> nice to get everything together into primary koji
16:40:36 <dgilmore> it will be the last step in the alt arch redefinition change
16:40:56 <nirik> how about this:
16:41:21 <nirik> see how the rawhide merge goes and if it's smooth do f26?
16:41:31 <nirik> but I am not sure we can easily quantify smooth
16:41:48 <Pharaoh_Atem> maxamillion: what could go wrong?
16:41:59 <Pharaoh_Atem> the process has been pretty well-ironed for all the other arches right?
16:42:06 <maxamillion> Pharaoh_Atem: bugs in software
16:42:15 <dgilmore> a lot
16:42:29 <dgilmore> we have not to date built s390x insallers in a long time
16:42:43 <Pharaoh_Atem> :/
16:42:43 <dgilmore> they may be completely broken
16:42:57 <dgilmore> it is very risky
16:43:20 <sgallagh> I'm with nirik here. I would rather defer this decision until we see how badly it goes for Rawhide.
16:43:39 <sharkcz> we still wait for a firewall change to re-enable f26 composes in the s390 koji setup ...
16:43:40 <nirik> but that would also leave us even less time. ;)
16:44:05 <dgilmore> nirik: indeed
16:44:20 <dgilmore> I would say we will know how good s390x is in a week or 2
16:44:31 <dgilmore> at which point we are right on top of beta freeze
16:44:34 <nirik> which takes us to beta freeze. So yeah.
16:44:48 <maxamillion> :/
16:45:42 <sharkcz> dgilmore: would it be possible to merge f26 at GA point? do release in old setup, but build updates in merged koji?
16:45:43 <sgallagh> OK, so formal proposal: Enable s390x support in Rawhide only.
16:45:51 <dgilmore> +1
16:45:55 <sgallagh> +1
16:46:02 <maxamillion> +1
16:46:05 <dgilmore> sharkcz: maybe
16:46:22 <jforbes> +1
16:46:24 <kalev> +1
16:46:30 <nirik> ok I guess. makes me sad to miss f26, but such is life.
16:47:07 <maxamillion> nirik: is that a +1?
16:47:25 <nirik> sure
16:49:52 <maxamillion> #agreed Enable s390x support in Rawhide only - (+1:6, -1:0, +0:0)
16:50:13 <maxamillion> alright, anything else for Open Floor?
16:50:19 <dgilmore> nada
16:50:24 <kalev> nothing from me
16:50:55 <jforbes> nothing here
16:52:33 <maxamillion> alright, thanks all!
16:52:36 <maxamillion> #endmeeting