16:03:22 <bowlofeggs> #startmeeting FESCO (2017-11-17)
16:03:22 <zodbot> Meeting started Fri Nov 17 16:03:22 2017 UTC.  The chair is bowlofeggs. Information about MeetBot at http://wiki.debian.org/MeetBot.
16:03:22 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
16:03:22 <zodbot> The meeting name has been set to 'fesco_(2017-11-17)'
16:03:22 <bowlofeggs> #meetingname fesco
16:03:22 <zodbot> The meeting name has been set to 'fesco'
16:03:22 <bowlofeggs> #chair maxamillion dgilmore nirik jforbes jsmith kalev sgallagh bowlofeggs tyll
16:03:22 <zodbot> Current chairs: bowlofeggs dgilmore jforbes jsmith kalev maxamillion nirik sgallagh tyll
16:03:22 <bowlofeggs> #topic init process
16:03:27 <jforbes> .hello2
16:03:27 <maxamillion> .hello2
16:03:27 <zodbot> jforbes: jforbes 'Justin M. Forbes' <jforbes@redhat.com>
16:03:30 <zodbot> maxamillion: maxamillion 'Adam Miller' <maxamillion@gmail.com>
16:03:30 <jsmith> .hello2
16:03:33 <zodbot> jsmith: jsmith 'Jared Smith' <jsmith.fedora@gmail.com>
16:03:37 <sgallagh> .hello2
16:03:39 <zodbot> sgallagh: sgallagh 'Stephen Gallagher' <sgallagh@redhat.com>
16:03:57 <sgallagh> I'm running another meeting simultaneously, so I'll do my best to be in attendance. Ping me directly if needed.
16:04:06 <nirik> morning
16:04:09 <bowlofeggs> i have corrected my FESCo meeting in my calendar to say 16:00 UTC instead of 12:00 EST :)
16:04:44 <maxamillion> +1
16:05:21 <bowlofeggs> looks like we have quorum
16:05:26 <bowlofeggs> r u ready 4 this
16:05:39 <bowlofeggs> #topic #1767 F28 Self Contained Changes
16:05:39 <bowlofeggs> .fesco 1767
16:05:41 <zodbot> bowlofeggs: Issue #1767: F28 Self Contained Changes - fesco - Pagure - https://pagure.io/fesco/issue/1767
16:06:07 <nirik> +1 for sugar
16:06:15 <bowlofeggs> more specifically, we are looking at https://fedoraproject.org/wiki/Changes/Sugar-112
16:06:23 <jsmith> +1 from me
16:06:42 <jforbes> +1 here
16:07:06 <jsmith> Looks like tyll voted in the ticket, fwiw
16:07:12 <maxamillion> +1
16:07:15 <bowlofeggs> +1
16:07:52 <bowlofeggs> that's 5 so far, sgallagh?
16:08:54 <sgallagh> +1
16:09:13 <bowlofeggs> #agreed Sugar change is approved (+6, 0, -0)
16:09:24 <bowlofeggs> #topic #1784 libsolv and dnf maintainers: failure to respond to critical bug
16:09:24 <bowlofeggs> .fesco #1784
16:09:24 <zodbot> bowlofeggs: Error: '#1784' is not a valid integer.
16:09:31 <bowlofeggs> o rly
16:09:38 <bowlofeggs> https://pagure.io/fesco/issue/1784
16:10:13 <bowlofeggs> i agree with what tyll_ wrote
16:10:33 <nirik> yeah. same here.
16:10:48 <ignatenkobrain> bowlofeggs: I think you need to s/#//
16:10:55 <nirik> it seems like people are trying to fix things, but it's not at all just the dnf maintainers and there are multiple issues people are lumping on to one issue
16:11:03 <bowlofeggs> ignatenkobrain: ah yeah haha
16:11:20 <jsmith> nirik: Couldn't have said it better myself
16:11:47 <bowlofeggs> it sounds like a pretty complex problem
16:11:51 <jsmith> It does look as though the root causes are being worked on, so I'm -1 at this time
16:12:07 <bowlofeggs> because it also only seems to happen in containers, so that's another layer of complication to it
16:12:16 <jsmith> (and hopefully the better communication will continue)
16:13:08 <bowlofeggs> Proposal: -1 to removing dnf maintainers, +1 to moving issues to bugzilla (and separating them into different tickets)
16:13:13 <bowlofeggs> +1
16:13:19 <jsmith> bowlofeggs: +1
16:13:23 <nirik> sure, +1.
16:13:45 <jforbes> +1
16:14:02 <maxamillion> +1
16:14:13 <bowlofeggs> sgallagh: ?
16:14:21 <sgallagh> +1
16:15:03 <bowlofeggs> #agreed dnf maintainers will not be removed. FESCo encourages reporters to file separate tickets for each issue in bugzilla (+7, 0, -0)
16:15:14 <bowlofeggs> #topic #1786 Non-responsive maintainer: jcapik
16:15:14 <bowlofeggs> .fesco 1786
16:15:16 <zodbot> bowlofeggs: Issue #1786: Non-responsive maintainer: jcapik - fesco - Pagure - https://pagure.io/fesco/issue/1786
16:15:27 <bowlofeggs> We've already agreed on this one, but it's time for someone to do it
16:15:31 <bowlofeggs> any volunteers?
16:15:38 <bowlofeggs> i dont' think i have acls to do that
16:15:50 <sgallagh> I don't know if anyone but nirik and dgilmore do
16:15:53 <sgallagh> (on FESCo)
16:15:55 <jsmith> I'm not sure I do either
16:16:02 <nirik> I think tyll_ can as well.
16:16:26 <nirik> but I can do it. I think the best way is a releng ticket... so we have a central place for people to ask for packages.
16:16:46 <bowlofeggs> oh, like just file a releng ticket? i don't mind doing that if that's the way to go
16:16:52 <bowlofeggs> since i have to do post-meeting stuff anyway
16:16:58 <bowlofeggs> i'll take care of filing it
16:17:04 <nirik> ok. yeah
16:17:17 <bowlofeggs> #action bowlofeggs will file a releng ticket to ask for jcapik's packages to be orphaned
16:17:31 <bowlofeggs> #topic 1788 Default path for root is inconsistent between su - and sudo
16:17:32 <bowlofeggs> .fesco 1788
16:17:33 <zodbot> bowlofeggs: Issue #1788: Default path for root is inconsistent between su - and sudo - fesco - Pagure - https://pagure.io/fesco/issue/1788
16:17:46 <bowlofeggs> last time we talked about this, we were not in agreement on the issue
16:17:57 <bowlofeggs> at that time, we had said we would discuss it on the ticket/mailing list
16:18:40 <bowlofeggs> i did try to start a discussion a couple weeks ago in the ticket, but i didn't see further comments from other fesco members
16:19:02 <bowlofeggs> well, 9 days ago i guess isn't a "couple weeks"
16:19:29 <bowlofeggs> i'm still of the opinion that the packagers should have the freedom to decide on this one
16:19:37 <nirik> There was a slight bit of discussuon on list... but not much
16:19:40 <jsmith> I guess at this point, I'm with bowlofeggs
16:19:54 <jsmith> I don't feel strongly enough about the topic to override the packagers
16:20:17 <maxamillion> I'm in agreement with bowlofeggs
16:20:19 <nirik> The setup maintainer said they would do whatever we wanted... they didn't feel strongly about it
16:20:19 <jsmith> (and it's easy enough for me to override on my own should I want something different)
16:21:17 <bowlofeggs> Proposal: The setup and sudo package maintainers are free to make the decision about this issue without FESCo
16:21:34 <sgallagh> Yeah, I really don't see a compelling reason to change it, and it's pretty easy for users to do so if they need to
16:21:40 <nirik> +1
16:21:50 <jsmith> +1
16:22:04 <nirik> anyone using /usr/local/ is easily able to add that...
16:22:09 <maxamillion> bowlofeggs: +1
16:22:56 <bowlofeggs> jforbes: ?
16:23:01 <sgallagh> bowlofeggs: +1
16:23:05 <jforbes> +1 here
16:23:19 <bowlofeggs> tyll_ didn't vote on this one, but that's 6
16:23:35 <bowlofeggs> #agreed The setup and sudo package maintainers are free to make the decision about this issue without FESCo (+6, 0, -0)
16:23:55 <bowlofeggs> on to new business (we are on a roll today!)
16:24:02 <bowlofeggs> #topic #1790 Proposal for 3 week freeze
16:24:02 <bowlofeggs> .fesco 1790
16:24:03 <zodbot> bowlofeggs: Issue #1790: Proposal for 3 week freeze - fesco - Pagure - https://pagure.io/fesco/issue/1790
16:24:31 <bowlofeggs> it's too bad dgilmore isn't here today, i'd like his feedback on this one
16:24:54 <maxamillion> mboddu: ping - you have any thoughts on this? ^^^
16:24:58 <bowlofeggs> he made a comment on the ticket, but it doesn't really state his position on the proposal clearly to me
16:25:26 <jsmith> I guess I'm +1 to the change, given that we're not mandating the infra freeze, and that infra freeze exceptions aren't too difficult to get (in my opinion)
16:25:39 <maxamillion> bowlofeggs: bah, missed it
16:25:41 <bowlofeggs> as an infra member, i actually don't mind the freeze being longer, but i don't deploy bodhi extremely often anyway
16:25:46 <nirik> right, this is about packages going stable freeze.
16:25:51 <dgilmore> bowlofeggs: I am here
16:26:05 <dgilmore> sorry I had the meeting starting in 35 minutes
16:26:06 <bowlofeggs> dgilmore: awesome :) what are your thoughts on thsi one?
16:26:11 <bowlofeggs> dgilmore: yeah i made the same mistake
16:26:12 <dgilmore> bowlofeggs: on what
16:26:19 <bowlofeggs> dgilmore: https://pagure.io/fesco/issue/1790
16:26:23 <nirik> I'm afraid it will annoy maintainers... perhaps we should try and get some list feedback?
16:26:43 <dgilmore> bowlofeggs: it will annoy people
16:26:53 <jforbes> Yes, it will
16:26:57 <jsmith> nirik: No more annoying that the texlive breakage in rawhide :-)
16:26:59 <dgilmore> I think for Beta it is probably wise
16:27:07 <nirik> jsmith: different. ;)
16:27:07 <ignatenkobrain> personally I don't care much since I use rawhide, but it will annoy other people definitely because upgradepath will be "broken" for longer time
16:27:12 <jsmith> nils: But that's a fair point -- let's reach out on the mailing list
16:27:13 <dgilmore> we almost always slip a week at the first milestone
16:27:20 <dgilmore> just getting changes lined up
16:27:21 <ignatenkobrain> jsmith: true!
16:27:27 <nils> jsmith, ITYM nirik
16:27:46 <jsmith> Yeah, tab completion fail :-(
16:27:51 * jsmith hates this keyboard
16:28:21 <bowlofeggs> dgilmore: interesting, so you might suggest a longer freeze on beta, but the same freeze we have now on final?
16:28:31 <bowlofeggs> i'd be +1 to devel list feedback
16:28:37 <dgilmore> bowlofeggs: I think that would be a decent comprimise
16:29:11 <bowlofeggs> Proposal: Document dgilmore's compromise proposal on the ticket, and write the devel list for feedback. defer decision until next week
16:29:37 <dgilmore> I also think if we had CI in place and kept breakages on the side that we would not need to extend teh freeze
16:29:53 <dgilmore> bowlofeggs: I can get behind that
16:29:54 <bowlofeggs> yeah CI would help a lot
16:30:16 <nirik> +1 for both proposal and CI. ;)
16:30:19 <jforbes> ci is in progress, so it should help out
16:30:22 <jforbes> +1 proposal
16:30:36 <dgilmore> reminds me I need to file an issue witha  change to the schedule that was done in f27 and makes no sense
16:30:46 <dgilmore> +!
16:30:47 <dgilmore> +1
16:31:15 <bowlofeggs> maxamillion, sgallagh, jsmith: ?
16:31:21 <maxamillion> +=
16:31:23 <maxamillion> ugh
16:31:24 <maxamillion> +1
16:31:27 <maxamillion> that's my day in a nutshell
16:31:30 <jsmith> +1
16:31:30 <bowlofeggs> haha
16:31:41 * sgallagh reads the proposal. one moment
16:32:36 <sgallagh> OK, so longer beta freeze, same Final?
16:32:37 <sgallagh> +1
16:32:55 <bowlofeggs> #agreed Document dgilmore's compromise proposal on the ticket, and write the devel list for feedback. defer decision until next week (+7, 0, -0)
16:33:12 <bowlofeggs> #action bowlofeggs will document the compromise proposal and write devel
16:33:28 <bowlofeggs> only one left
16:33:34 <bowlofeggs> #topic #1791 F28 System Wide Change: Ruby 2.5
16:33:34 <bowlofeggs> .fesco 1791
16:33:35 <zodbot> bowlofeggs: Issue #1791: F28 System Wide Change: Ruby 2.5 - fesco - Pagure - https://pagure.io/fesco/issue/1791
16:33:46 <sgallagh> +1
16:33:49 <nirik> +1
16:34:15 <jforbes> +1
16:34:53 <bowlofeggs> +1
16:34:57 <maxamillion> it doesn't meantion backwards compat, but I'm pretty sure since 1.9.3 they've not done crazy breakage in minor version bumps
16:35:00 <bowlofeggs> tyll_ was +1 in the ticket
16:35:02 <maxamillion> +1
16:35:13 <bowlofeggs> maxamillion: there is a note in there that things should keep working
16:35:22 <dgilmore> +1
16:35:24 <jsmith> +1
16:35:30 <bowlofeggs> "The Ruby programs/scripts should behave as they were used to. "
16:35:57 <bowlofeggs> #agreed Ruby 2.5 approved (+7, 0, -0)
16:36:05 <bowlofeggs> #topic Next week's chair
16:36:11 <bowlofeggs> oh, will we have a meeting next week?
16:36:17 <bowlofeggs> it's a holiday in the US
16:36:21 <bowlofeggs> and a lot of us are in the US
16:36:24 <nirik> we should skip.
16:36:33 * dgilmore is on PTO all of next week
16:36:37 <bowlofeggs> #topic Chair in two weeks
16:37:08 <bowlofeggs> oh, i just realized i forgot a topic
16:37:09 <maxamillion> bowlofeggs: yeah, but I was looking for some kind of statement of compat from upstream or something
16:37:16 <bowlofeggs> we have one more to talk about after this, sorry
16:37:19 <nirik> I can do it, I haven't in a while... this is 2017-12-01?
16:37:35 <bowlofeggs> nirik: yeah
16:37:44 <bowlofeggs> #action nirik will chair on 2017-12-01
16:37:45 <dgilmore> when is the election?
16:37:57 * dgilmore thinks he missed nominating
16:38:42 <maxamillion> wait, what?
16:38:53 <maxamillion> I need to be better at keeping an eye on that :/
16:39:06 <jforbes> Nominations start next week I thought
16:39:15 <bowlofeggs> let's do my last topic, adn talk about election in open floor, if that's cool
16:39:24 <maxamillion> nirik: thanks for hosting next time!
16:39:27 <bowlofeggs> #topic #1793 Provenpackager creating branches and pushing there
16:39:27 <bowlofeggs> .fesco 1793
16:39:28 <zodbot> bowlofeggs: Issue #1793: Provenpackager creating branches and pushing there - fesco - Pagure - https://pagure.io/fesco/issue/1793
16:39:37 <ignatenkobrain> not very friendly, but it made me very upset yesterday
16:39:56 <dgilmore> bowlofeggs: yep
16:40:32 <bowlofeggs> i would like to hear from ppisar on this too, as tyll_ suggested
16:40:35 <nirik> I'm still hoping this was miscommunication.
16:40:37 <nirik> yeah
16:40:38 <sgallagh> So, our policy is generally that we expect provenpackagers to operate in the best interests of the Project.
16:41:01 <sgallagh> I think in this particular case, ppisar made a mistake.
16:41:16 <sgallagh> I wish ignatenkobrain had just brought this to me rather than all of FESCo; I think we can handle this within Modularity.
16:41:17 <dgilmore> I think that if it needs to diverge then it needs a f27 branch
16:41:29 <dgilmore> updating master to say its f27 is not okay
16:41:32 <maxamillion> it does appear that way but I'd like to hear from ppisar before forming an opinion about the situation
16:41:37 <sgallagh> Proposal: I'll play moderator here
16:41:47 * jsmith is +1 for gathering more information (or having sgallagh do that)
16:41:54 <dgilmore> I also think that particular module should not exist
16:41:58 <sgallagh> dgilmore: It's a little more subtle than that, because these are module branches, not traditional ones
16:42:09 <sgallagh> "master" in this case means that this module is always tracking upstream master.
16:42:11 <dgilmore> there is a lot of known security issues with that particular stack of software
16:42:19 <dgilmore> sgallagh: right
16:42:39 <sgallagh> But at the moment, the "master" branch of platform (aka Rawhide) is broken and unmaintained.
16:42:54 <sgallagh> So we wanted this to be switched to be depending on the known-working platform
16:43:00 <dgilmore> sgallagh: that is a different issue in and of itself
16:43:04 <sgallagh> It shouldn't have caused another branch to be split off
16:43:06 <bowlofeggs> +1 to sgallagh's proposal. if that doesn't work, it can come back to FESCo
16:43:27 <sgallagh> That was a misunderstanding on ppisar's side, and we can resolve that with a conversation I expect
16:43:40 <dgilmore> sgallagh: a different branch, whatever makes sense for a module should be created if we are to follow it
16:44:21 <sgallagh> dgilmore: The *intent* is that the libtom module should be able to specify a range of platform modules that it can use.
16:44:27 <ignatenkobrain_> my IRC client doesn't work....
16:44:30 <sgallagh> That feature isn't ready yet, so we're in an odd shape
16:44:31 <ignatenkobrain_> dgilmore: it doesn't need actually. but that's details. this issue was more about that pp created branch of some project he doesn't maintain and pushed something there... like if he would request some branch for rpm without being maintainer of it -- which means original maintainer of RPM would have to support it
16:45:05 <sgallagh> Anyway, I know the situation, the participants and the technology involved, so I'll handle this.
16:45:06 <ignatenkobrain_> but I agree with sgallagh, this could have been handled within modularity wg.. was too upset that went directly to FESCo
16:45:09 <dgilmore> ignatenkobrain_: that happens sometimes, and I am sure as we embrace arbitory branching will happen more and more
16:45:22 <nirik> proposal: let involved parties + sgallagh work it out, come back to fesco with more info if there is still a dispute.
16:45:29 <ignatenkobrain_> dgilmore: should we make sure that person who creates branch **is** maintaining that repo?
16:45:30 <sgallagh> nirik: +1
16:45:44 <dgilmore> ignatenkobrain_: no one "owns" any of it, they are the maintainer and caretaker, but there is no ownership as such
16:45:54 <dgilmore> ignatenkobrain_: I do not think so
16:46:01 <bowlofeggs> nirik: +1
16:46:13 <sgallagh> Yes, that's another point we should hammer home: the Fedora Project "owns" all of the branches. Individuals help cultivate them :)
16:46:20 <dgilmore> ignatenkobrain_: we should make sure that people who make a branch understand that they are signing up to be the caretaker of that branch
16:46:27 <dgilmore> nirik: +1
16:46:38 <jsmith> nirik: +1
16:46:42 <ignatenkobrain> but agree with sgallagh , we could have handled that within modularity wg
16:46:43 <ignatenkobrain_> dgilmore: you probably didn't got me. I was basically saying that if I'm the only one maintainer of $x and someone wants to have branch, should he being assigned for that particular branch as @owner@?
16:46:44 <ignatenkobrain> dgilmore: it doesn't need actually. but that's details. this issue was more about that pp created branch of some project he doesn't maintain and pushed something there... like if he would request some branch for rpm without being maintainer of it -- which means original maintainer of RPM would have to support it
16:46:45 <maxamillion> nirik: +1
16:46:55 <jforbes> nirik: +1
16:46:55 <dgilmore> ignatenkobrain: I get you
16:47:01 <ignatenkobrain_> oh, my main IRC client went live again
16:47:06 <ignatenkobrain_> and sending old messages
16:47:26 <bowlofeggs> that's 7
16:47:30 <bowlofeggs> including nirik
16:47:35 <dgilmore> ignatenkobrain: I just do not agree with you, by creating taht branch he was signing up to be the caretaker of it
16:47:50 <bowlofeggs> #agreed let involved parties + sgallagh work it out, come back to fesco with more info if there is still a dispute (+7, 0, -0)
16:48:13 <dgilmore> ignatenkobrain: I actaully am planning to get aproposal together to remove all of that stack
16:48:18 <bowlofeggs> more to say on this, or open floor?
16:48:28 <bowlofeggs> (since we have an agreement :))
16:48:49 <sgallagh> dgilmore: I think you and ignatenkobrain are in agreement, just not speaking the same language.
16:49:07 <sgallagh> ignatenkobrain was upset because ppisar created a branch that he expected ignatenkobrain to maintain.
16:49:14 <sgallagh> *That* was incorrect behavior
16:49:46 <bowlofeggs> note: it's been 15 minutes on this topic, do we want to keep talking about it (we have an agreement), or open floor?
16:49:50 <sgallagh> I think we're done here
16:49:52 <dgilmore> sgallagh: perhaps, ppisar even if not intentionally took maintainership of that by his actions
16:49:58 <dgilmore> anyway lets move on
16:50:00 <bowlofeggs> oh sorry, only 10 min actually
16:50:15 <bowlofeggs> #topic open floor
16:50:23 <nirik> https://fedoraproject.org/wiki/Elections has the dates. Nominations start next week.
16:50:49 * jsmith has nothing for the open floor
16:50:54 <dgilmore> after raising elections I realise I am not up this time
16:51:16 <dgilmore> As per the FESCo election policy, the following FESCo members finish their terms, and the seats are up for re-election:
16:51:19 <dgilmore> Kevin Fenzi (nirik) - elected for F26/F27 period Adam Miller (maxamillion) - elected for F26/F27 period Jared Smith (jsmith) - elected for F26/F27 period Justin Forbes (jforbes) - elected for F26/F27 period Kalev Lember (kalev) - elected for F26/F27 period
16:51:27 <dgilmore> those are the seats up for election
16:51:34 <maxamillion> +1
16:51:56 <dgilmore> maxamillion: so for reals its you this time
16:52:00 <bowlofeggs> haha
16:52:01 <maxamillion> :)
16:52:02 <sgallagh> dgilmore: Hah, beat me to it :)
16:52:07 <maxamillion> like, for *real*
16:52:17 <dgilmore> like for real for real
16:52:24 <nirik> really?
16:52:27 <bowlofeggs> maxamillion was running to have two seats last time, with two votes!
16:52:28 <sgallagh> orly?
16:53:09 <sgallagh> I'm a strong supporter of the one man, one vote policy: I'm The Man, I have the vote. (Apologies to Terry Pratchett)
16:53:12 * dgilmore gets ready to play with new network toys
16:53:15 <maxamillion> yeah, someone put in a meeting that my seat was up so I entered the nominations when I shouldn't have :X
16:53:26 <sgallagh> <.<
16:53:27 <sgallagh> ?
16:53:29 <maxamillion> :)
16:53:29 <bowlofeggs> haha
16:53:30 <sgallagh> >.>
16:53:46 <bowlofeggs> cool, ending in 60s if no further topics
16:54:13 * sgallagh has nothing
16:54:26 * dgilmore just filed https://pagure.io/fesco/issue/1794
16:54:31 <dgilmore> but that should wait
16:54:47 <bowlofeggs> #endmeeting