15:00:24 <bowlofeggs> #startmeeting FESCO (2018-05-04)
15:00:24 <zodbot> Meeting started Fri May  4 15:00:24 2018 UTC.
15:00:24 <zodbot> This meeting is logged and archived in a public location.
15:00:24 <zodbot> The chair is bowlofeggs. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:00:24 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
15:00:24 <zodbot> The meeting name has been set to 'fesco_(2018-05-04)'
15:00:25 <bowlofeggs> #meetingname fesco
15:00:25 <bowlofeggs> #chair maxamillion dgilmore nirik jsmith sgallagh bowlofeggs tyll jwb zbyszek
15:00:25 <bowlofeggs> #topic init process
15:00:25 <zodbot> The meeting name has been set to 'fesco'
15:00:25 <zodbot> Current chairs: bowlofeggs dgilmore jsmith jwb maxamillion nirik sgallagh tyll zbyszek
15:00:30 <dgilmore> hola
15:00:31 <maxamillion> .hello2
15:00:31 <zodbot> maxamillion: maxamillion 'Adam Miller' <maxamillion@gmail.com>
15:00:33 <sgallagh> .hello2
15:00:34 <zodbot> sgallagh: sgallagh 'Stephen Gallagher' <sgallagh@redhat.com>
15:00:54 <nirik> morning
15:01:00 <bowlofeggs> cool, that's quorum
15:01:04 <bowlofeggs> let's get this moving
15:01:15 <bowlofeggs> #topic #1877 large number of packages FTBFS in F28
15:01:15 <bowlofeggs> .fesco 1877
15:01:15 <bowlofeggs> https://pagure.io/fesco/issue/1877
15:01:19 <zodbot> bowlofeggs: Issue #1877: large number of packages FTBFS in F28 - fesco - Pagure - https://pagure.io/fesco/issue/1877
15:01:44 <bowlofeggs> i'm not entirely sure why this is a fesco ticket
15:01:55 <bowlofeggs> or what action is expected of fesco - seems like a releng issue?
15:02:49 <maxamillion> In a lot of ways it is, I'm also not really clear as to what we're supposed to advise on or make a decision about
15:03:07 <dgilmore> there was some major process breakdowns on the releng side during the mass rebuild
15:03:07 <nirik> well, I think the orig comment had some info there...
15:03:19 <nirik> suggesting we call out the issue or try and help it.
15:03:46 <bowlofeggs> yeah that's a good point
15:04:04 <nirik> I'm also not sure the status currently, I think tyll_ and  zbyszek were rebuilding everything that was on the failed list again to get a better list
15:04:08 * mboddu is here
15:04:18 <dgilmore> between communications not being sent, and a outage in the middle of it
15:05:09 <bowlofeggs> mboddu: what is the status on the f28 ftbfs's, from your perspective?
15:05:25 <zbyszek> sorry for being late
15:05:32 * nirik notes there is a f29 one on the horizon.
15:06:06 <mboddu> bowlofeggs: I agree with dgilmore, there were some snags in implementing it, but atm tyll_ is rebuilding them
15:06:24 <dgilmore> I think at this point all that can be done is work to make sure the f29 rebuild goes smoothly
15:06:33 <tyll> .hello till
15:06:34 <zodbot> tyll: till 'Till Maas' <opensource@till.name>
15:06:56 <zbyszek> yep, it's too late to do anything meaningful for F28
15:07:23 <bowlofeggs> are there f28 packages that are broken and/or can't install due to this?
15:07:49 * zbyszek is not aware of any
15:07:51 <dgilmore> not that I know of
15:07:53 <bowlofeggs> should fesco just acknowledge the problem and trust releng to sort it out?
15:08:05 <dgilmore> bowlofeggs: +1
15:08:14 <nirik> it might be nice to do some test runs in the weeks leading up to f29 mass rebuild and make sure it all actually works.
15:08:17 <tyll> my next steps are to make sure that there are proper bugs for all FTBFS bugs and then start a cleanup process of FTBFS packages, i.e. announcements to devel list and retirement after 6 weeks or so
15:08:37 <zbyszek> well, I think we should discuss the retirment process
15:09:00 <dgilmore> that the ftbfs bugs were not filed until way after the mass rebuild was a big issue
15:09:01 <bowlofeggs> zbyszek: i'm not sure, but i *think* there might be a policy about retiring FTBFS packages already?
15:09:20 <zbyszek> bowlofeggs: I don't think there is
15:09:25 <bowlofeggs> if there isn't, there probably should be
15:09:27 <tyll> there is a process to do this before branching but we did not follow it
15:09:29 <dgilmore> part of that is on me because I did not follow up strongly enough to make sure it was done
15:09:32 <sgallagh> Well, there must have been, since we had a script that did it
15:09:36 <sgallagh> Didn't we?
15:09:56 <bowlofeggs> https://fedoraproject.org/wiki/Fails_to_build_from_source
15:10:02 <tyll> sgallagh: I re-used the script that I used to report long-time orphaned pkgs for this
15:10:14 <tyll> sgallagh: to create a report
15:10:15 <dgilmore> we have scripts, some of which could use work to make them better, butthe processes are all manual
15:10:20 <dgilmore> there is multiple steps
15:10:26 <bowlofeggs> that page does say that FTBFS packages get autoremoved
15:10:30 * sgallagh nods
15:10:31 <nirik> https://docs.pagure.org/releng/sop_deprecate_ftbfs_packages.html
15:10:41 <maxamillion> dgilmore: steps that have to happen in-order?
15:10:47 <dgilmore> maxamillion: yes
15:10:51 <bowlofeggs> zbyszek: does that page satisfy you that we have a documented policy about FTBFS?
15:11:15 <zbyszek> bowlofeggs: yes, but that policy is significantly different from "retire after 6 weeks".
15:11:19 <dgilmore> maxamillion: the triggers for many of the steps are the person running them remebering to do so
15:11:30 <bowlofeggs> yeah the policy says N+2, which seems way too long to me
15:11:30 <maxamillion> I wonder what we could use to automate in-order tasks across different systems....
15:11:38 <maxamillion> :)
15:11:47 <tyll> zbyszek: 6 weeks was the timeout for orphaned pkgs
15:11:51 <nirik> maxamillion: func!
15:11:53 <zbyszek> We (including me) voted to retire packages after 6 weeks, but I now think that was a mistake.
15:12:03 <bowlofeggs> maxamillion: puppet?
15:12:06 * bowlofeggs runs
15:12:39 <zbyszek> I fear that there are *many* ftbfs packages with significant deps.
15:12:52 <bowlofeggs> yeah i'm sure there are
15:13:05 <bowlofeggs> should we defer this ticket for a few weeks to see what releng can accomplish?
15:13:07 <tyll> zbyszek: usually the warnings about retirement get people to actually do something about them :-)
15:13:20 <nirik> we should also definitely stop retiring before beta.
15:13:37 <sgallagh> Often a rash of non-responsive maintainer bugs ensues
15:13:41 <bowlofeggs> it sounds like we don't really know how many FTBFSs there are or how many deps they have
15:13:43 <mboddu> nirik: Or at least before final freeze
15:14:12 <bowlofeggs> we could make a new ticket to re-think the FTBFS policy
15:14:30 <bowlofeggs> i personally think N+2 is too long, but 6 weeks is too short :)
15:14:41 <maxamillion> bowlofeggs: they do have that new ansible knock-off called bolt
15:14:48 <dgilmore> 6 weeks is only in rawhide
15:14:53 <bowlofeggs> maxamillion: ah interesting
15:15:18 <tyll> bowlofeggs: it is 6 weeks reminders for packages that failed for at the N-2 rebuild, so these are two timeframes
15:15:21 <zbyszek> I think the timeout should be lower if the package is uninstallable
15:15:32 <bowlofeggs> tyll: oh i see. yeah that is reasonable then
15:16:11 <bowlofeggs> proposal: let's defer this ticket to give releng some time to sort it out and revisit in 2 weeks
15:16:23 <maxamillion> bowlofeggs: +1
15:16:29 <nirik> and hope for some more data in the ticket... like numbers from the f28 one
15:16:51 <zbyszek> bowlofeggs: +1
15:16:59 <mboddu> bowlofeggs: +1
15:17:03 <tyll> bowlofeggs: actually, https://docs.pagure.org/releng/sop_deprecate_ftbfs_packages.html said there would be one week notification for pkgs that failed for N-2 rebuilds
15:17:05 <sgallagh> That's fine with me as long as we have a plan made public on devel-announce at least a week before the mass rebuild
15:17:52 <bowlofeggs> haha ok so nirik and sgallagh both wanted adjustments to the proposal
15:17:58 <bowlofeggs> lemme rephrase
15:18:05 <tyll> bowlofeggs: +1 (also I can continue to work on getting the bugs, packages and deps ready)
15:18:05 <zbyszek> FWIW, I think the timeout should be just 6 weeks when a package fails to rebuild in a mass rebuild, *and* becomes uninstallable because of missing deps.
15:18:51 <bowlofeggs> proposal: we defer this issue for 2 weeks. we want data on the ticket (numbers from f28 rebuild), and we want a public plan in devel-announce at least a week before the mass rebuild
15:18:55 <dgilmore> sgallagh: public in what way? one of the steps is to announce the mass rebuild ahead of starting, that was one step that was not done in f28
15:19:01 <tyll> zbyszek: there used to be a seperate cleanup for pkgs with broken deps
15:19:05 <dgilmore> bowlofeggs: -1
15:19:32 <bowlofeggs> dgilmore: you don't like the public plan part?
15:19:35 <dgilmore> I think the ask for numbers and a public plan are not useful without sufficient direction
15:19:45 <dgilmore> bowlofeggs: no I think the ask is poorly formed
15:19:53 <zbyszek> dgilmore: I think tyll is working on this
15:19:55 <sgallagh> dgilmore: I just want there to be a clear understanding with our packagers what will happen if their packages don't rebuild successfully,
15:20:09 <sgallagh> They should know this before the mass rebuild occurs
15:20:14 <dgilmore> bowlofeggs: I also want to know what the public plan means outside of what is supposed to happen already
15:20:42 <dgilmore> sgallagh: that is part of the communication that is supposed to happen already
15:20:44 <sgallagh> I'd also like to propose that we consider successful build from source of any package included on a blocking install media to be a blocker to the release.
15:20:52 <sgallagh> So we don't end up with abandoned critical software
15:20:53 <bowlofeggs> we've been on this for about 20 minutes now - do we want to continue - or do we want to just got with the prior deferal proposal that had enough votes to pass?
15:21:08 <dgilmore> sgallagh: the person who ran the mass rebuild had never done it befer, did not follow the SOP and missed pieces
15:21:09 <sgallagh> err s/blocking install media/default install from blocking media/
15:21:17 <dgilmore> I should have provided better supervision
15:21:33 <zbyszek> What about we go with the proposal, but open a ticket to discuss the policy in parallel?
15:21:34 <sgallagh> dgilmore: You can't be everywhere. I'm not pointing fingers
15:21:38 <dgilmore> sgallagh: the mass rebuild honestly does not protect us for that
15:21:41 <bowlofeggs> zbyszek: yes i think that is a good idea
15:21:51 <tyll> also the cleanup of long-time FTBFS pkgs is not really part of the mass rebuild process (or was not in the past)
15:21:54 <sgallagh> dgilmore: It provides us an opportunity to identify some cases though
15:21:55 <bowlofeggs> i'd like this ticket to stay focused ont eh f28 FTBFS not the policy
15:22:06 <dgilmore> sgallagh: it really does not do a reasonable job of making sure software is not abandoned
15:22:09 <bowlofeggs> let's do policy in its own ticket if we want to reassess it
15:22:10 <sgallagh> If we get to Freeze and a critical FTBFS hasn't been fixed, we can find a new owner
15:22:37 <dgilmore> sgallagh: that is very heavy, but sure
15:23:03 <nirik> well, the owner could also just be trying to fix it and not have a fix yet... like the ppp thing...
15:23:04 <bowlofeggs> proposal: let's defer this ticket for 2 weeks to give releng/tyll/zbyszek time to sort things out some more. let's also file a new ticket to revisit FTBFS policy
15:23:15 <zbyszek> bowlofeggs: +1
15:23:17 <dgilmore> nirik: indeed
15:23:24 <nirik> how about whoever wants to change the policy files the ticket with their proposal?
15:23:24 <sgallagh> nirik: Amended: if it hasn't been fixed or efforts to do so communicated in the BZ
15:23:25 <dgilmore> +1
15:23:32 <tyll> bowlofeggs: +1
15:23:42 <sgallagh> bowlofeggs: +1
15:23:58 <tyll> nirik: afaiu the policy is not the problem but the lack of time to actually follow it ;-)
15:24:18 <zbyszek> tyll: the lack of well-known policy is also a problem, imo
15:24:23 <nirik> +1 to defer. I prefer if we want to change the policy we have a proposal... a 'lets discuss the policy' ticket will be not helpfull IMHO
15:24:36 <zbyszek> nirik: I'll draft a proposal
15:24:40 <nirik> but if everyone wants to do that, great.
15:24:50 <bowlofeggs> zbyszek: +1
15:25:01 <sgallagh> zbyszek++
15:25:02 <zodbot> sgallagh: Karma for zbyszek changed to 2 (for the f28 release cycle):  https://badges.fedoraproject.org/tags/cookie/any
15:25:17 <bowlofeggs> counting, i have +6
15:25:22 <bowlofeggs> maxamillion: ?
15:25:27 <tyll> zbyszek: the current policy is at https://docs.pagure.org/releng/sop_deprecate_ftbfs_packages.html
15:25:34 <maxamillion> bowlofeggs: +1
15:25:54 <bowlofeggs> cool
15:25:54 <maxamillion> sorry, completely blanked ... thought I'd voted
15:26:05 <mboddu> zbyszek++
15:26:05 <zodbot> mboddu: Karma for zbyszek changed to 3 (for the f28 release cycle):  https://badges.fedoraproject.org/tags/cookie/any
15:26:16 <bowlofeggs> #agreed let's defer this ticket for 2 weeks to give releng/tyll/zbyszek time to sort things out some more. let's also file a new ticket to revisit FTBFS policy
15:26:25 <bowlofeggs> #action zbyszek will proposal a new policy in a new ticket
15:26:39 <zbyszek> s/proposal/propose/
15:26:51 <bowlofeggs> haha
15:26:52 <bowlofeggs> #undo
15:26:52 <zodbot> Removing item from minutes: ACTION by bowlofeggs at 15:26:25 : zbyszek will proposal a new policy in a new ticket
15:27:02 <bowlofeggs> #action zbyszek will propose a new policy in a new ticket
15:27:11 <bowlofeggs> mboddu: this next ticket is relevant for you too
15:27:14 <tyll> there are currently 539 pkgs that did not rebuild since the F27 rebuild AFAICS
15:27:19 <bowlofeggs> #topic #1878 Please change "Everything" directory to something less
15:27:19 <bowlofeggs> inaccurately comprehensive
15:27:19 <bowlofeggs> .fesco 1878
15:27:19 <bowlofeggs> https://pagure.io/fesco/issue/1878
15:27:22 <mboddu> bowlofeggs: Yup and I am still around :)
15:27:22 <zodbot> bowlofeggs: Issue #1878: Please change "Everything" directory to something less inaccurately comprehensive - fesco - Pagure - https://pagure.io/fesco/issue/1878
15:27:38 <bowlofeggs> mattdm: if you are around, we are discussing the "Everything" ticket
15:28:00 <bowlofeggs> ok so i said a lot on this ticket, but i think there's something i did not make clear about my position
15:28:07 <dgilmore> This is a expensive change, I also think that mattdm's proposed names are not the most ideal either
15:28:24 <bowlofeggs> my position is not that fedora should not rename it, it's that FESCo should not mandate that Fedora rename it
15:28:30 <dgilmore> making the change does make some sense
15:28:41 <bowlofeggs> because i don't see a favorable ratio of benefit to cost
15:28:56 <bowlofeggs> so if releng and infra want to put the effort into doing it, i do not oppose that
15:28:57 <nirik> whats the frontrunner for the renamed thing/
15:28:58 <nirik> ?
15:29:06 <bowlofeggs> but i do oppose FESCo declaring that they must do this
15:29:24 <bowlofeggs> nirik: i don't think there is a favored name yet
15:29:41 <dgilmore> nirik: mattdm is heavily pushing his option and rejecting all others, but I do not see a strong contender from anyone
15:29:50 * tyll is wondering if there are really people irritated by the name or if it is a theoretical problem
15:29:52 <nirik> I was thinking we might have a middle ground...
15:30:10 <dgilmore> mattdm is the person pushing the hardest for his proposal
15:30:26 <nirik> ask everyone affected to move this to be a configurable thing... and as a low pri do that... with a deadline out like f30 or something.
15:30:26 * zbyszek likes his own proposal of adding a README instead
15:30:32 <bowlofeggs> tyll: i work on infra on a project that uses that name and i barely notice it myself - i have a hard time thinking that many non-infra/releng people see the name very often
15:30:48 <dgilmore> https://pagure.io/fesco/issue/1878#comment-508452
15:31:16 <dgilmore> even then I do not see mattdm as overly pushing for it, more than he feels its the best choice
15:31:16 <sgallagh> bowlofeggs: It has been difficult when drafting blogs and other comms around modularity
15:31:22 <mboddu> This is a massive change, I would actually avoid it if its not necessary, but ...
15:31:25 <nirik> ot another possiblity: we have talked about redesigning our mirror content entirely... take this into consideration when doing that. someday.
15:31:30 <sgallagh> The best we have is "the traditional Fedora repos"
15:31:40 <sgallagh> When trying to differentiate
15:31:51 <dgilmore> https://pagure.io/fesco/issue/1878#comment-508287 has all of my proposals
15:31:59 <sgallagh> The natural way would be to use the variant name, but "Everything" would be confusing in that context
15:32:15 <bowlofeggs> sgallagh: well that's just blog writing - that doesn't have to tie in to what every script/application in the release pipeline names things, imo
15:32:15 <nirik> I feel it would be a lot of work, and I am not keen on it, but I would do it if the FPL feels its important for us to do.
15:32:52 <bowlofeggs> sgallagh: i agree it is hard to think of good wording when *talking* about it, and it would be nice to settle on nice branding there, but does that require us to force infra/releng to do a bunch of work for something people rarely see?
15:32:59 <bowlofeggs> s/rarely/rarely, if ever/
15:33:06 <maxamillion> I don't really see much benefit to the change and it's been expressed many times that it's non-trivial work to accomplish
15:33:07 <dgilmore> nirik: maybe we reccomend that it be defered for a mirror redesign?
15:33:12 <mboddu> nirik: +1
15:33:14 <bowlofeggs> i was a fedora user for *years* and never saw the word "Everything"
15:33:17 <sgallagh> Situations where the external and internal branding differ tend to get confusing for the people doing the talking
15:34:01 <dgilmore> bowlofeggs: Everything goes back to F7 from memory
15:34:04 <sgallagh> e.g. FreeIPA is called Red Hat Identity Manager when shipped as RHEL, but all documentation uses the FreeIPA nomenclature because it's too hard to change from upstream
15:34:06 <bowlofeggs> sgallagh: i'm pretty close to the "internal branding" and i barely notice it
15:34:26 <bowlofeggs> i mean, bodhi uses the label "Everything" too, and even i see that word rarely
15:35:17 <bowlofeggs> but as i said, i'm not opposed to others changing it of their own will, but i am opposed to fesco mandating a change because i just don't see enough benefit to justify that demand
15:35:28 * sgallagh nods
15:35:34 <mboddu> bowlofeggs: That is the reason why I am against the change, as it is very intrusive for some simple name change (like we never had bad nomenclature)
15:35:40 <bowlofeggs> i'm not saying there is no benefit, just a disproportionate ratio
15:35:42 <sgallagh> I'm not sure where I fall
15:35:57 <maxamillion> bowlofeggs: +1
15:36:05 <sgallagh> But I wanted to provide the necessary context
15:36:11 <bowlofeggs> there are so many more important things for us (Fedora i mean, not fesco) to do than this
15:36:25 <zbyszek> bowlofeggs: +1
15:36:27 <bowlofeggs> if we make people work on this, they won't be working on things that affect users much more heavily
15:36:39 * nirik nods
15:37:12 <nirik> if we do a mirror redesign it could do more things that are of benifit... make content more syncable/better modules for mirrors, etc
15:37:45 <bowlofeggs> nirik: i don't think it's just the mirror that is hard to change though, right?
15:38:05 <bowlofeggs> like, pungi and bodhi and probably tons of scripts and who knows what else
15:38:21 <dgilmore> pungi does not need changes, the configs for it do
15:38:25 <bowlofeggs> ah
15:38:46 <dgilmore> mirrormanager will need changes
15:39:11 <bowlofeggs> proposal: FESCo is not opposed to the name changing, but also does not choose to enforce it. the decision is left up to the people who would do the work
15:39:45 <mboddu> I dont maintain a mirror, but does mirror maintainers run any special scripts?
15:39:45 <nirik> yes, there's lots of changes. I am just saying if we are making them, we could make them with more changes that get us more advantage
15:39:56 <mboddu> If they do, then they might have to update their scripts as well
15:40:07 <maxamillion> bowlofeggs: +1
15:40:18 <nirik> mboddu: for everything not really
15:40:18 <sgallagh> bowlofeggs: Let's be honest, that proposal is equivalent to FESCo saying "don't do it". Which is a reasonable proposal, but let's be clear about it.
15:40:35 <zbyszek> sgallagh: I'd prefer that too
15:41:01 <mboddu> nirik: Okay, thats good to know, since it might require for them to change their scripts which we cannot control
15:41:26 <bowlofeggs> sgallagh: well i don't think it's quite that - that would be "FESCo opposes this change."
15:41:34 <nirik> perhaps we could defer again and see if we can get mattdm and adamw here (since they were the other two who had strong opinions)
15:41:35 <sgallagh> Counter proposal: FESCo does not feel that the benefits outweigh the implementation cost and recommends that nomenclature be changed in documentation instead.
15:41:36 <dgilmore> mboddu: some mirrors write custome mirroring scripts, some use generic approaches
15:41:51 <zbyszek> sgallagh: +1
15:41:51 <bowlofeggs> sgallagh: i do not oppose the change happening, i just dont' think it's right for us to force it. that's not the same as "dont' do it"
15:42:28 <dgilmore> sgallagh: perhaps of instead at the end you use first
15:42:38 <dgilmore> leave the door open for the change
15:42:42 <dgilmore> but not mandate it
15:42:44 <sgallagh> bowlofeggs: Without us "forcing" it, we all know that the only other way it would happen is by our primary donor forcing it.
15:42:45 <maxamillion> I'm good with either sgallagh or bowlofeggs' proposal
15:42:53 <sgallagh> dgilmore: I'd be fine with that
15:42:53 <zbyszek> bowlofeggs: I think it's our role to decide some things.
15:43:12 <dgilmore> proposal: FESCo does not feel that the benefits outweigh the implementation cost and recommends that nomenclature be changed in documentation first.
15:43:20 <sgallagh> dgilmore: +1
15:43:24 <zbyszek> dgilmore: +1
15:43:28 <dgilmore> +1 obviously
15:43:40 <bowlofeggs> sgallagh: if our primary donor forces it, that's fine - they pay the people who would be doing the changes :)
15:44:05 <nirik> +1
15:44:15 <bowlofeggs> i'm fine wtih sgallagh/dgilmore's proposal too, but i prefer communicating that we also don't oppose it
15:44:16 <nirik> well, the changes can be made in each area by those groups...
15:44:18 <bowlofeggs> so +1
15:44:45 <nirik> yeah, I am +1 to either
15:45:04 <maxamillion> dgilmore: +1
15:45:09 <bowlofeggs> i think that's 6
15:45:14 <tyll> dgilmore: +1
15:45:18 <bowlofeggs> cool, 7
15:45:30 <mboddu> Not sure mine counts, but +1 :)
15:45:32 <zbyszek> bowlofeggs: this is clearly a change with effects in many different components, so it's something that should be decided publicly, not something to be undertaken by a single person. And FESCo is the way to do the public discussion.
15:45:33 <bowlofeggs> #agreed FESCo does not feel that the benefits outweigh the implementation cost and recommends that nomenclature be changed in documentation first. (+7, 0, -0)
15:46:12 <zbyszek> bowlofeggs: that's why prefer sgallagh/dgilmore's stronger version
15:46:28 <bowlofeggs> zbyszek: i can see that point, but i also think it could be reasonable to have the implementors agree together to do it and only have FESCo step in if we think it's important and they can't agree
15:46:36 <bowlofeggs> anyways, we have an agreement anyway
15:46:39 <bowlofeggs> so let's move on
15:46:52 <bowlofeggs> last issue
15:46:54 <bowlofeggs> #topic #1886 Draft Fedora 30 schedule
15:46:54 <bowlofeggs> .fesco 1886
15:46:54 <bowlofeggs> https://pagure.io/fesco/issue/1886
15:46:55 <zodbot> bowlofeggs: Issue #1886: Draft Fedora 30 schedule - fesco - Pagure - https://pagure.io/fesco/issue/1886
15:47:59 <nirik> +1 here... we can always adjust later
15:48:04 <bowlofeggs> whoah crazy - i thoughti was reading the f29 schedule and it starts with "fedora 29 release" and i was like "uh what?"
15:48:06 <bowlofeggs> haha
15:48:19 <sgallagh> bowlofeggs: We're trying everything backwards this release!
15:48:36 <tyll> what nirik wrote
15:48:39 <tyll> +1
15:48:41 <bowlofeggs> +1
15:48:42 <zbyszek> +1
15:48:43 <sgallagh> Yeah, +1
15:49:02 <bowlofeggs> we have an in-ticket +1 from jwb
15:49:15 <dgilmore> +1
15:49:21 <bowlofeggs> maxamillion: ?
15:49:26 <maxamillion> +1
15:49:36 <maxamillion> sorry, multi tasking badly ... I'm also on the phone
15:49:39 <bowlofeggs> cool, 8
15:50:05 <bowlofeggs> #agreed FESCo approves the very futuristic F30 schedule (+8, 0, -0)
15:50:15 <bowlofeggs> #topic Next week's chair
15:50:21 <nirik> it should be Fedora XXX :)
15:50:21 <bowlofeggs> volunteers?
15:50:30 <bowlofeggs> nirik: haha like superbowls
15:50:33 <sgallagh> I should ask: will we have quorum?
15:50:52 <bowlofeggs> i will be here
15:50:53 <sgallagh> I'll be around, but with RH Summit next week, it might not be true for everyone
15:50:54 <dgilmore> I kinda like the idea of delaying f30 for a year
15:51:08 <sgallagh> I'll chair if we have it
15:51:10 <dgilmore> I will be here next week
15:51:13 * nirik will be here.
15:51:17 <zbyszek> I'll be here
15:51:36 <bowlofeggs> cool
15:51:53 <bowlofeggs> #action dgilmore will chair next week, assuming we reach quorum (please e-mail the list if you can't make it ahead of time)
15:52:03 <sgallagh> Uh
15:52:06 <dgilmore> bowlofeggs: sgallagh said he would, but I can also
15:52:09 <bowlofeggs> the ()'s was aimed at all of us, not dgilmore
15:52:13 <bowlofeggs> oh sorry
15:52:15 <bowlofeggs> misread
15:52:17 <bowlofeggs> #undo
15:52:17 <zodbot> Removing item from minutes: ACTION by bowlofeggs at 15:51:53 : dgilmore will chair next week, assuming we reach quorum (please e-mail the list if you can't make it ahead of time)
15:52:20 <sgallagh> s'all good
15:52:25 <dgilmore> bowlofeggs: it is fine
15:52:30 <bowlofeggs> #action sgallagh will chair next week, assuming we reach quorum
15:52:55 <bowlofeggs> #action FESCo members, please e-mail the list if you can't be here next week so we don't hold a meeting just to find out we dont' have quorum
15:52:57 <sgallagh> I have an item for Open Floor, when we get there
15:53:02 <bowlofeggs> #topic Open Floor
15:53:04 <bowlofeggs> sgallagh: go!
15:53:19 <sgallagh> With F28 released, it's probably time to start talking about elections
15:53:27 * dgilmore has a thing to stay also
15:53:34 <dgilmore> sgallagh: that is what I had
15:53:40 <sgallagh> heh
15:53:40 <bowlofeggs> yep
15:53:45 <dgilmore> sgallagh: elections process started Wednesday
15:53:51 <dgilmore> it is underway
15:53:57 <bowlofeggs> i'm sad because i didn't get a full year in my term due to f28 being on time and f26 being really late :)
15:54:26 <Southern_Gentlem> bowlofeggs,  run again
15:54:34 <bowlofeggs> Southern_Gentlem: yeah i plan to :)
15:54:40 <dgilmore> https://pagure.io/Fedora-Council/tickets/issue/201
15:55:01 * dgilmore notes that his seat is up and he will not be running for FESCo again this time around
15:55:38 <bowlofeggs> dgilmore: :( you will be missed
15:55:42 <dgilmore> election results are due June 7th
15:55:44 <nirik> yeah. ;(
15:55:59 <sgallagh> You will be missed, but you also definitely served your time :)
15:56:10 * bowlofeggs proposes that since dgilmore won't be on fesco anymore that fesco mandate that fedora only support x86_64 as retribution
15:56:25 <sgallagh> .fire bowlofeggs
15:56:25 <zodbot> adamw fires bowlofeggs
15:56:25 <dgilmore> bowlofeggs: I will fight you
15:56:28 <bowlofeggs> haha
15:56:38 <dgilmore> figuratively
15:56:52 <sgallagh> bowlofeggs: Maybe not a wise thing to say when you're running for re-election :-D
15:56:58 <bowlofeggs> adamw has fired so many brave fedowarriors
15:57:08 <bowlofeggs> sgallagh:  ahaha true
15:57:37 <bowlofeggs> any other thoughts on this, or other things for open floor?
15:57:54 * sgallagh has nothing
15:58:19 <bowlofeggs> closing in 45 s
15:59:04 <bowlofeggs> #endmeeting