15:03:16 <maxamillion> #startmeeting FESCO (2018-05-25)
15:03:16 <zodbot> Meeting started Fri May 25 15:03:16 2018 UTC.
15:03:16 <zodbot> This meeting is logged and archived in a public location.
15:03:16 <zodbot> The chair is maxamillion. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:03:16 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
15:03:16 <zodbot> The meeting name has been set to 'fesco_(2018-05-25)'
15:03:16 <maxamillion> #meetingname fesco
15:03:16 <maxamillion> #chair maxamillion dgilmore nirik jsmith sgallagh bowlofeggs tyll jwb zbyszek
15:03:16 <zodbot> The meeting name has been set to 'fesco'
15:03:16 <zodbot> Current chairs: bowlofeggs dgilmore jsmith jwb maxamillion nirik sgallagh tyll zbyszek
15:03:16 <maxamillion> #topic init process
15:03:21 <maxamillion> .hello2
15:03:22 <zodbot> maxamillion: maxamillion 'Adam Miller' <maxamillion@gmail.com>
15:03:30 <sgallagh> .hello2
15:03:31 <zodbot> sgallagh: sgallagh 'Stephen Gallagher' <sgallagh@redhat.com>
15:03:32 <zbyszek> .hello2
15:03:34 <zodbot> zbyszek: zbyszek 'Zbigniew Jędrzejewski-Szmek' <zbyszek@in.waw.pl>
15:03:37 <nirik> morning
15:03:47 <nirik> .hello kevin
15:03:48 <zodbot> nirik: kevin 'Kevin Fenzi' <kevin@scrye.com>
15:03:49 <sgallagh> I'm around, but I may switch to mobile in 30 minutes to grab lunch.
15:03:54 <dgilmore> heya
15:04:10 <bowlofeggs> .hello2
15:04:11 <zodbot> bowlofeggs: bowlofeggs 'Randy Barlow' <rbarlow@redhat.com>
15:04:19 <maxamillion> alright, that's quorum
15:04:27 <maxamillion> #topic Follow Ups
15:04:28 <maxamillion> #topic #1890 updating the FTBFS cleanup policy
15:04:29 <maxamillion> .fesco 1890
15:04:29 <maxamillion> https://pagure.io/fesco/issue/1890
15:04:32 <zodbot> maxamillion: Issue #1890: updating the FTBFS cleanup policy - fesco - Pagure - https://pagure.io/fesco/issue/1890
15:04:42 <maxamillion> zbyszek: the floor is yours :)
15:04:56 <zbyszek> So, if nobody objects, I would send out the proposed announcement and be done with this ticket
15:05:02 <zbyszek> https://pagure.io/fesco/issue/1890#comment-513975
15:05:06 * sgallagh was +1 in the ticket
15:05:17 <bowlofeggs> +1
15:05:34 <nirik> +1
15:05:41 <zbyszek> (I wanted to do this earlier this week, but once it got to Thursday, I decided to wait another day...)
15:06:22 <bowlofeggs> thanks for taking the time to write it up zbyszek
15:06:24 <bowlofeggs> nice :)
15:06:25 <maxamillion> +1
15:06:47 <zbyszek> #action zbyszek to send out the announcement
15:07:06 <maxamillion> alright, anything else on this or should we move on?
15:07:08 <nirik> thanks for all the work on this zbyszek. :)
15:07:10 <zbyszek> Move on.
15:07:15 <maxamillion> zbyszek++
15:07:15 <zodbot> maxamillion: Karma for zbyszek changed to 5 (for the f28 release cycle):  https://badges.fedoraproject.org/tags/cookie/any
15:07:17 <maxamillion> #topic #1892 F29 Self Contained Change: MySQL 8
15:07:17 <maxamillion> .fesco 1892
15:07:17 <maxamillion> https://pagure.io/fesco/issue/1892
15:07:19 <zodbot> maxamillion: Issue #1892: F29 Self Contained Change: MySQL 8 - fesco - Pagure - https://pagure.io/fesco/issue/1892
15:07:27 <tyll_> .hello till
15:07:28 <zodbot> tyll_: till 'Till Maas' <opensource@till.name>
15:07:34 <maxamillion> tyll_: welcome :)
15:07:35 <zbyszek> There was no answer from the change owners
15:07:41 <nirik> did anyone reach out to them?
15:07:45 <bowlofeggs> did we actualyl contact the change owner?
15:07:50 <zbyszek> No.
15:07:54 <bowlofeggs> err, what nirik said
15:07:57 <maxamillion> lol, did we really not do that?
15:08:07 <bowlofeggs> proposal: contact change owner, give another week
15:08:15 <nirik> +1
15:08:23 <tyll_> who will contact them?
15:08:25 <bowlofeggs> #action bowlofeggs will contact change owner
15:08:25 <dgilmore> so I just updated f27 to f28 and postgresql server required me to run an upgrade process and reconfigure the server
15:08:38 <dgilmore> I am +1 to approving it
15:08:43 <zbyszek> Well, the decision was noted in the fesco ticket. If change owners don't bother to look at the ticket (to which they are subscribed), it's not a good sign.
15:08:59 <bowlofeggs> yeah postgres does require manual intervention between fedora upgrades
15:09:09 <bowlofeggs> i've also observed this, and don't necessarily think it's a bad thing
15:09:21 <bowlofeggs> but there are compatibility concerns too
15:10:06 <zbyszek> dgilmore: I would very much like to see this kind of information spelled out in the change page.
15:10:15 <sgallagh> I don't really want to stand in the way of progress here, so I'd be okay with voting it through.
15:10:23 <maxamillion> same
15:10:24 <dgilmore> zbyszek: sure, we can make that a condition of approving
15:10:25 <sgallagh> Who uses MySQL anyway? :-P
15:10:28 <sgallagh> (I kid)
15:10:44 <maxamillion> alright, does anyone want to propose approving it or do we want to reach out and wait another week for a response?
15:10:51 <maxamillion> seems like folks are relatively +1 to it
15:10:56 <maxamillion> so I'm not sure there's much use to wait
15:10:56 <sgallagh> Proposal: MySQL 8 is approved
15:10:58 <sgallagh> +1
15:11:18 <dgilmore> +1
15:11:25 <bowlofeggs> +1
15:11:31 <tyll> how about to approve but still reach out for them to update the info?
15:11:38 <bowlofeggs> (i would like good fedora release notes to be written too though)
15:11:42 <maxamillion> +1
15:12:03 <dgilmore> I get the concerns, but it really does not seem that it is different from normal business, other than mysql has needed manual steps less often
15:12:12 * nirik can be +1, but yes, change page and other docs should be more detailed.
15:12:14 <dgilmore> we need to make sure it is documented
15:12:29 <bowlofeggs> #undo
15:12:29 <zodbot> Removing item from minutes: ACTION by bowlofeggs at 15:08:25 : bowlofeggs will contact change owner
15:12:38 <zbyszek> +0, I guess
15:12:43 <maxamillion> tyll: yeah, I think that makes sense ... we can leave the action item for bowlofeggs if we want that
15:12:43 <dgilmore> they have already updated the packages, backing things out will be harder
15:12:55 <zbyszek> The change is not really documented.
15:13:17 <nirik> right now the change page says "Usual testing as when upgrading between major MySQL versions." and "Downgrade from MySQL 8 to MySQL 5.7 is not supported."
15:13:19 <bowlofeggs> changes do get release notes written later in the process
15:13:20 <nirik> but thats about it
15:13:25 <bowlofeggs> i've seen that with my changes
15:13:38 <bowlofeggs> after the change is approved and done, i get contacted for input on end user release note
15:13:39 <bowlofeggs> s
15:13:56 <maxamillion> #agreed MySQL 8 is approved (+1:5, -1:0, +0:1)
15:14:00 <maxamillion> alright, let's move on
15:14:02 <bowlofeggs> maybe it'd be good for the change page to require release notes, or at least a rough draft, but they don't today afaik
15:14:36 <maxamillion> #topic New Business
15:14:38 <maxamillion> #topic #1893 Non-responsive maintainer for libinvm-i18n,libinvm-cli, libinvm-cim
15:14:39 <maxamillion> .fesco 1893
15:14:39 <maxamillion> https://pagure.io/fesco/issue/1893
15:14:40 <zodbot> maxamillion: Issue #1893: Non-responsive maintainer for libinvm-i18n,libinvm-cli, libinvm-cim - fesco - Pagure - https://pagure.io/fesco/issue/1893
15:14:57 <sgallagh> +1 reassign
15:15:18 * zbyszek was +1 in the ticket
15:15:23 <nirik> +1
15:15:34 <tyll> +1
15:15:37 <maxamillion> +1
15:15:58 <bowlofeggs> isn't there supposed to be a post to devel that CC's the maintainer?
15:16:09 * bowlofeggs looks up the docs on this process
15:16:30 <zbyszek> The mail is dead
15:16:44 <zbyszek> The mail address is dead
15:17:03 <bowlofeggs> oh
15:17:04 <bowlofeggs> +1
15:17:19 <nirik> there's a shortcut in the process if the email address is known invalid
15:17:40 <bowlofeggs> ah yeah i see that
15:18:02 <bowlofeggs> wait
15:18:12 <bowlofeggs> it still says step 4 that you have ot ask if anyone knows how to contact
15:18:15 <bowlofeggs> did that happen?
15:18:27 <bowlofeggs> the exception procedure says to skip to step 4
15:18:29 <bowlofeggs> and that's step 4
15:19:16 <bowlofeggs> .fasinfo nkothapa
15:19:17 <zodbot> bowlofeggs: User: nkothapa, Name: Namratha Kothapalli, email: namratha.n.kothapalli@intel.com, Creation: 2016-05-06, IRC Nick: None, Timezone: US/Mountain, Locale: en, GPG key ID: None, Status: active
15:19:19 <zodbot> bowlofeggs: Approved Groups: fedorabugs packager cla_done cla_intel
15:19:30 <bowlofeggs> i see no posts to devel about this
15:19:30 <bowlofeggs> -1
15:19:31 <zbyszek> I don't think we need to split hairs here, the maintainer is completely inactive with multiple need-infos
15:19:42 <bowlofeggs> well it is the documented procedure
15:19:46 <bowlofeggs> even for a dead e-mail
15:19:52 <maxamillion> hrmmm
15:20:13 <nirik> the process was setup more for the redhat.com case, but sure I guess it applies here too.
15:20:14 <tyll> I blieve there is a fasttrack exception
15:20:42 <nirik> tyll: yes, but it still requires you mail devel and ask if anyone knows how to contact them.
15:21:49 <nirik> so, lets ask them to do that and process it next week? or someone here could send the email?
15:21:52 <maxamillion> Proposal: Follow the documented process for unresponsive maintainer and reach out to devel list to see if anyone know how to contact the maintainer
15:21:59 <bowlofeggs> maxamillion: +1
15:22:01 <maxamillion> +1
15:22:07 <zbyszek> maxamillion: +1
15:22:08 <nirik> +1
15:22:09 <sgallagh> Sure, +!
15:22:12 <sgallagh> err, +1
15:22:17 <tyll> +0
15:22:23 <sgallagh> But maybe we could add the newcomer as comaintainer anyway?
15:22:27 <tyll> IMHO we can just approve it now
15:22:34 <sgallagh> I mean, I dislike discouraging someone who wants to fix things
15:22:51 <zbyszek> Well, the new person wants to retire the packages, so comaintainer doesn't really work
15:22:54 <tyll> sgallagh: they just want to retire it, so it is one step
15:22:55 <maxamillion> sgallagh: I'm open to that, we'll do a follow up vote in a minute
15:23:04 <maxamillion> oh
15:23:05 <maxamillion> hrm
15:23:06 <bowlofeggs> i think it's likely we'll not get in touch with this person
15:23:12 <bowlofeggs> but why not just follow the documented process?
15:23:16 <bowlofeggs> and see what it goes?
15:23:18 <sgallagh> Ah, I missed the retirement part
15:23:21 <bowlofeggs> i see no reason to rush
15:23:24 <bowlofeggs> nothing is broken really
15:23:28 <sgallagh> So we may as well wait one more week
15:23:35 <bowlofeggs> exactly
15:23:36 <maxamillion> true
15:23:37 <maxamillion> alright
15:23:43 <bowlofeggs> just let the process do what it was designed to do
15:23:46 <sgallagh> ack
15:23:49 <maxamillion> #agreed Follow the documented process for unresponsive maintainer and reach out to devel list to see if anyone know how to contact the maintainer (+1:5, -1:0, +0:1)
15:23:50 <dgilmore> maxamillion: +1
15:23:50 <zbyszek> bowlofeggs thanks for sticking up for the law, I appreciate that
15:23:55 <maxamillion> #undo
15:23:55 <zodbot> Removing item from minutes: AGREED by maxamillion at 15:23:49 : Follow the documented process for unresponsive maintainer and reach out to devel list to see if anyone know how to contact the maintainer (+1:5, -1:0, +0:1)
15:23:55 <bowlofeggs> hehe ;)
15:23:59 <maxamillion> #agreed Follow the documented process for unresponsive maintainer and reach out to devel list to see if anyone know how to contact the maintainer (+1:6, -1:0, +0:1)
15:24:08 <zbyszek> maxamillion: the count is wrong
15:24:20 <zbyszek> Oh, never mind, I missed tyll
15:24:35 <bowlofeggs> #action bowlofeggs will write devel to ask if they know how to contact nkothapa
15:24:46 <maxamillion> zbyszek: I appreciate the double check though, I have goofed before ... 'tis human to error :)
15:24:53 <maxamillion> #topic #1894 F29 System Wide Change: Let's Label Our Variants!
15:24:53 <maxamillion> .fesco 1894
15:24:53 <maxamillion> https://pagure.io/fesco/issue/1894
15:24:57 <zodbot> maxamillion: Issue #1894: F29 System Wide Change: Let's Label Our Variants! - fesco - Pagure - https://pagure.io/fesco/issue/1894
15:25:02 <maxamillion> bowlofeggs++ for taking the action items
15:25:10 <bowlofeggs> this one is kinda controversial on devel
15:25:43 <zbyszek> I don't think the arguments agains have much merit.
15:25:48 <bowlofeggs> the controversy seems to be more that people dont' think it serves a purpose, than that it actively harms something
15:25:52 <bowlofeggs> at least that's my read on it
15:26:09 <sgallagh> It didn't look controversial, more like confused
15:26:11 <zbyszek> They are mostly along the lines "you can install arbitrary packages, so the label is not significant"
15:26:12 <bowlofeggs> imo, i kinda agree that it doesn't help much, but since i don't see a way in which it hurts, i'm inclined to approve it
15:26:21 <zbyszek> yep, same here
15:26:22 * nirik is +1
15:26:36 <sgallagh> I think it's useful, if only because it gives a window into the mind of the person who originally installed the machine
15:26:37 * tyll too
15:26:39 <tyll> +1
15:26:40 <sgallagh> I'm +1
15:26:46 <nirik> if it turns out the data gathered isn't helpfull, we can drop it again...
15:26:53 <bowlofeggs> yeah i'm +1 too
15:26:54 <zbyszek> +1 if we're voting
15:27:28 <maxamillion> +1
15:28:14 <dgilmore> +1 if people are signed up to do the work
15:28:18 <maxamillion> I don't really know if it adds a whole lot but I don't think it harms anything so if the FPL sees value in it, I see no reason to argue
15:28:52 <sgallagh> dgilmore: I think that's going to fall on me, so yes.
15:28:53 <bowlofeggs> dgilmore: mohan is one of the change owners, so i presume he's signed up to do the work :)
15:29:02 <maxamillion> #agreed APPROVE: F29 System Wide Change: Let's Label Our Variants! (+1:7, -1:0, +0:0)
15:29:18 <maxamillion> #topic #1896 Election policy unclear on self-nomination
15:29:18 <maxamillion> .fesco 1896
15:29:18 <maxamillion> https://pagure.io/fesco/issue/1896
15:29:20 <zodbot> maxamillion: Issue #1896: Election policy unclear on self-nomination - fesco - Pagure - https://pagure.io/fesco/issue/1896
15:29:53 <bowlofeggs> i like zbyszek's proposal
15:30:00 <dgilmore> I propose changing the text to the one I put in the ticket
15:30:00 <sgallagh> The last proposal there from dgilmore looks fine to me.
15:30:08 <bowlofeggs> but i also think the 3 day thing isn't needed?
15:30:19 <bowlofeggs> for dgilmore's, i'd want to remove "self-" from it
15:30:29 * sgallagh switches to mobile while he goes to buy lunch
15:30:31 <bowlofeggs> because that was the source of confusion with the original text
15:30:45 <maxamillion> Proposal: Accept dgilmore's updated policy text from the ticket comment https://pagure.io/fesco/issue/1896#comment-513965
15:30:47 * nirik likes dgilmore's without self.
15:30:49 <maxamillion> +1
15:31:09 <bowlofeggs> maxamillion: can we adjust it to say "without self-"?
15:31:25 <maxamillion> sure?
15:31:34 <bowlofeggs> just removing the "If the candidate did not self-nominate,"
15:31:34 <zbyszek> Wait. The "three days" were added for the Election Wrangler to have time to process the interviews
15:31:34 <maxamillion> I don't care, I'm not going to bike shed over this
15:31:36 <dgilmore> Candidates must be nominated before the announced date and time for the closure of the election nomination period by writing their information onto the wiki. If the candidate wishes to decline or withdraw the nomination they can do so by removing their name from the page.
15:31:47 <dgilmore> bowlofeggs: like that?
15:31:57 <tyll> dgilmore: +1
15:31:57 <bowlofeggs> maxamillion: i don't think it's bike shedding - the self- was the reason this ticket was filed in the first place
15:32:00 <maxamillion> zbyszek: oh? where is that written?
15:32:14 <bowlofeggs> dgilmore: +1
15:32:15 <nirik> yeah. +1
15:32:18 <maxamillion> bowlofeggs: fair
15:32:50 <maxamillion> what about zbyszek's revelation that the 3 day stipulation comes from the Election Wrangler?
15:32:51 <bowlofeggs> i'm also curious about zbyszek's comment
15:33:43 * jsmith is here late (due to a minor emergency at ${DAYJOB})
15:33:50 <bowlofeggs> (also, sometimes it's important to "bike shed" when writing policies: http://loweringthebar.net/2017/03/the-oxford-comma-use-it.html )
15:33:56 <zbyszek> OK, maybe I'm making stuff up here, but the way I remember this is that after one of the previous elections the time was specified so that the people who post the interviews actually have time to prepare and post them.
15:33:57 <tyll> I believe that was before we had a full week for the interviews t obe done
15:34:03 <bowlofeggs> (a hilarious read if you've not seen it before)
15:34:47 <maxamillion> bowlofeggs: oxford comma or gtfo, I will die on this hill
15:34:55 <bowlofeggs> i feel like there isn't a purpose to the 3 days if new candidates can't be added in those three days
15:34:59 <dgilmore> tyll: bowlofeggs: was your +1 to the updated text in here or the text in the ticket?
15:35:11 <dgilmore> I am +1 to either
15:35:12 <bowlofeggs> like, it's the "nomination period" but no candidates can be added? seems weird
15:35:38 <dgilmore> bowlofeggs: the trhee days is a legacy thing, its not been updated as we changed process
15:35:47 <tyll> dgilmore: +1to the text you wrtote here
15:36:00 <zbyszek> dgilmore: that was my question actually
15:36:05 <bowlofeggs> dgilmore: my +1 is to the text you wrote above
15:36:08 <zbyszek> +1 to dgilmore's text then
15:36:11 <bowlofeggs> "Candidates must be nominated before the announced date and time for the closure of the election nomination period by writing their information onto the wiki. If the candidate wishes to decline or withdraw the nomination they can do so by removing their name from the page."
15:36:14 <nirik> dgilmore: +1 to text above yes.
15:36:17 <bowlofeggs> proposal ^
15:36:30 <bowlofeggs> i think we dont' need the 3 days
15:37:17 <nirik> yeah, lets pass this as is and if we need to adjust it FPM can ask us to.
15:37:38 <dgilmore> proposal #accepted we will update the text to that in https://pagure.io/fesco/issue/1896#comment-513999
15:37:47 <dgilmore> I pasted that text in a new comment
15:37:47 <sgallagh> +1
15:37:51 <dgilmore> +1 from me
15:37:57 <maxamillion> +1
15:37:59 <zbyszek> =1
15:38:04 <zbyszek> *+1
15:38:12 <nirik> +1
15:39:04 <dgilmore> maxamillion: that is enough to pass
15:39:04 <maxamillion> bowlofeggs: jsmith: tyll: ?
15:39:12 <jsmith> +1
15:39:18 <maxamillion> dgilmore: I know ... just nagging people :)
15:39:35 <bowlofeggs> +1
15:39:51 <maxamillion> #agreed proposal #accepted we will update the text to that in https://pagure.io/fesco/issue/1896#comment-513999 (+1:7: -1:0, +0:0)
15:39:59 <maxamillion> #topic Next week's chair
15:40:17 <dgilmore> I can od it one last time
15:40:39 <bowlofeggs> awwww, sad
15:40:42 <bowlofeggs> but poetic too :)
15:40:47 * bowlofeggs will miss dgilmore
15:40:56 <maxamillion> lol
15:40:56 <dgilmore> bowlofeggs: no you wont
15:41:17 <maxamillion> bowlofeggs: he's not dying ... I mean we're all dying, but not like in short order
15:41:34 <sgallagh> ... we hope
15:41:39 <maxamillion> #action dgilmore to chair next FESCo meeting
15:41:40 <maxamillion> #topic Open Floor
15:41:46 <maxamillion> sgallagh: true
15:41:54 <maxamillion> alright, anyone have anything for open floor?
15:42:08 <dgilmore> nominate if you want to be in the next FESCo
15:42:17 <dgilmore> nominate nominate nominate
15:42:38 <dgilmore> puiterwijk: ^^^this means you :D
15:42:42 <maxamillion> +1
15:42:46 <bowlofeggs> +1 to puiterwijk
15:43:00 <maxamillion> puiterwijk++
15:43:04 <dgilmore> or maybe bstinson would be good
15:43:26 <dgilmore> halfline: would be good also
15:43:35 <maxamillion> halfline++
15:43:35 <zodbot> maxamillion: Karma for rstrode changed to 1 (for the f28 release cycle):  https://badges.fedoraproject.org/tags/cookie/any
15:43:52 <dgilmore> halfline++
15:43:52 <zodbot> dgilmore: Karma for rstrode changed to 2 (for the f28 release cycle):  https://badges.fedoraproject.org/tags/cookie/any
15:44:29 <sgallagh> I'd like to see all three of those people nominated.
15:44:45 <dgilmore> sgallagh: indeed
15:45:08 <maxamillion> yesssss
15:45:12 * zbyszek has to run. See y'all next week.
15:45:24 <maxamillion> I completely missed the bstinson menton ... bstinson++
15:45:24 <zodbot> maxamillion: Karma for bstinson changed to 1 (for the f28 release cycle):  https://badges.fedoraproject.org/tags/cookie/any
15:45:54 <dgilmore> maybe I will nominate them along with tibbs
15:46:19 <dgilmore> anyway outside of that I have nothing
15:47:32 <maxamillion> alright ... I'll give it like 60 seconds and then pull the plug
15:47:45 <dgilmore> tibbs++
15:47:45 <zodbot> dgilmore: Karma for tibbs changed to 3 (for the f28 release cycle):  https://badges.fedoraproject.org/tags/cookie/any
15:47:49 <dgilmore> bstinson++
15:47:51 <zodbot> dgilmore: Karma for bstinson changed to 2 (for the f28 release cycle):  https://badges.fedoraproject.org/tags/cookie/any
15:47:58 <dgilmore> maxamillion++
15:48:21 <maxamillion> <3
15:48:33 <maxamillion> alright .. have a good weekend all
15:48:35 <maxamillion> #endmeeting