15:00:00 <nirik> #startmeeting FESCO (2018-07-09)
15:00:00 <zodbot> Meeting started Mon Jul  9 15:00:00 2018 UTC.
15:00:00 <zodbot> This meeting is logged and archived in a public location.
15:00:00 <zodbot> The chair is nirik. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:00:00 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
15:00:00 <zodbot> The meeting name has been set to 'fesco_(2018-07-09)'
15:00:01 <nirik> #meetingname fesco
15:00:01 <zodbot> The meeting name has been set to 'fesco'
15:00:01 <nirik> #chair nirik, maxamillion, jsmith, jwb, zbyszek, tyll, sgallagh, contyk, bowlofeggs
15:00:01 <zodbot> Current chairs: bowlofeggs contyk jsmith jwb maxamillion nirik sgallagh tyll zbyszek
15:00:02 <nirik> #topic init process
15:00:18 <nirik> morning everyone. Lets see if we have quorum today. ;)
15:00:29 <contyk> .hello psabata
15:00:30 <zodbot> contyk: psabata 'Petr Šabata' <psabata@redhat.com>
15:00:55 <nirik> .hello kevin
15:00:57 <zodbot> nirik: kevin 'Kevin Fenzi' <kevin@scrye.com>
15:01:08 <zbyszek> .hello2
15:01:09 <zodbot> zbyszek: zbyszek 'Zbigniew Jędrzejewski-Szmek' <zbyszek@in.waw.pl>
15:01:24 <bcotton> .hello2
15:01:25 <zodbot> bcotton: bcotton 'Ben Cotton' <bcotton@redhat.com>
15:03:10 <jwb> hi
15:03:24 <zbyszek> nirik, maxamillion, jsmith, tyll, sgallagh, contyk, bowlofeggs ?
15:03:39 <nirik> well, thats 4... need one more.
15:03:40 <tyll> .hello till
15:03:41 <zodbot> tyll: till 'Till Maas' <opensource@till.name>
15:03:46 <nirik> hurray. :)
15:03:50 <zbyszek> welcome ;)
15:04:07 <tyll> Hi there!
15:04:10 <nirik> lets go ahead and get started...
15:04:13 <nirik> #topic #1917 F29 System Wide Change: Make BootLoaderSpec-style
15:04:14 <nirik> configuration files the default
15:04:14 <nirik> .fesco 1917
15:04:14 <nirik> https://pagure.io/fesco/issue/1917
15:04:16 <zodbot> nirik: Issue #1917: F29 System Wide Change: Make BootLoaderSpec-style configuration files the default - fesco - Pagure - https://pagure.io/fesco/issue/1917
15:04:16 <contyk> o/
15:05:01 <nirik> There was a bit of discussion about this last week when we didn't have quorum...
15:05:11 <zbyszek> The discussion has died down mostly on fedora-devel
15:05:49 <zbyszek> I think there's general consensus that this is the right direction, even if some details might still change
15:05:52 <nirik> I'm +1 to the change now. I think the discussion was mostly about unrelated things.
15:05:59 <zbyszek> Yeah, +1 too
15:06:07 <tyll> +1 here, too
15:06:31 <tyll> the other issues can still be addresses separately afaiu
15:06:39 <zbyszek> I'd like to see as much compatiblity with the systemd interpration of the spec, but the change process is not the venue for that
15:07:03 * nirik nods.
15:07:23 <nirik> getting rid of grubby will be a nice win
15:07:31 <zbyszek> FWIW, systemd now has boot counting (in a PR), so the next version of systemd, the one in F29, should be able to do fallback-to-previous-boot-entry
15:08:14 <tyll> awesome
15:08:36 <maxamillion> .hello2
15:08:36 <zodbot> maxamillion: maxamillion 'Adam Miller' <maxamillion@gmail.com>
15:08:46 <maxamillion> sorry, I was sitting in #fedora-meeting waiting for it to start
15:08:54 <nirik> welcome maxamillion.
15:09:10 <nirik> sorry. ;( anyhow, we are voting on/discussing the /topic item...
15:09:28 <maxamillion> also, sorry for my absence in recent meetings ... my wife has been in and out of the hospital for the last three weeks (she's home and getting better now)
15:09:53 <nirik> the log so far: https://meetbot-raw.fedoraproject.org/fedora-meeting-1/2018-07-09/fesco.2018-07-09-15.00.log.txt
15:09:53 <zbyszek> hope she gets better soon
15:10:17 <nirik> maxamillion: family comes first. :) Hope for a good recovery...
15:10:51 <nirik> so, contyk, jwb, maxamillion: votes? or discussion items?
15:11:02 <contyk> a little distracted +1
15:11:12 <nirik> javier__: are you around to answer questions if anyone has any?
15:11:46 <javier__> nirik: yes, I'm here
15:12:17 <maxamillion> yeah, I'm +1 to the change ... was just reading a little
15:12:20 <nirik> has this already landed in rawhide?
15:12:36 <javier__> nirik: yes
15:12:55 * nirik makes a note to switch his laptop after the meeting.
15:13:18 <zbyszek> nirik: if you're not online tomorrow, we'll know why :)
15:13:20 <tyll> maxamillion: hope she gets well, soon
15:13:27 <maxamillion> thank you
15:14:01 <nirik> #agreed The Change is approved (+5,0,0)
15:14:08 <nirik> #topic Next weeks chair
15:14:13 <nirik> who wants it next week?
15:14:34 * zbyszek can do it, hasn't done it in a while
15:14:58 <nirik> thanks!
15:15:07 <tyll> thank you
15:15:08 <nirik> #action zbyszek to chair next week
15:15:13 <maxamillion> thanks zbyszek!
15:15:14 <nirik> #topic Open Floor
15:15:20 <nirik> Anyone have anything for open floor?
15:15:21 <maxamillion> I'll take it the week after that because I've also not done it in a while
15:15:21 <zbyszek> I have something
15:15:55 <nirik> zbyszek: go ahead
15:16:04 * mhroncok too
15:16:08 <zbyszek> So... as you might have seen, I filed a bunch of needinfos on the FTBFS-F28 tickets
15:16:25 <zbyszek> I screwed up a bit because some of the people got 1, some 2, and some 3 notifications
15:16:32 <zbyszek> But apart from that, I think it's OK
15:16:41 <zbyszek> A bunch of bugs got handled today already
15:16:52 <nirik> awesome.
15:17:02 <zbyszek> Some packages were orphaned, a bunch were rebuilt, some very already building but my koji queries failed to find the builds
15:17:03 <tyll> zbyszek++
15:17:04 <nirik> Thanks very much for doing that
15:17:06 <zodbot> tyll: Karma for zbyszek changed to 7 (for the f28 release cycle):  https://badges.fedoraproject.org/tags/cookie/any
15:17:12 <mhroncok> zbyszek++
15:17:19 <zbyszek> So I think the needinfo process is good enough for this
15:17:32 <zbyszek> We'll need to send a separate mail before doing any orphaning of course
15:17:57 <tyll> zbyszek: is there script for it published somewhere?
15:17:59 <zbyszek> I hope we can get the whole process working smoothly, because right now there's so many rough edges
15:17:59 <nirik> no objection here.
15:18:13 <mhroncok> zbyszek: I've set my blocked bug to assigned to avoid the orphanning, but shoudl the policy cover this? i.e. the bug is blocked by another bug?
15:18:18 <jsmith> Sorry for being late -- jet-lag got the best of me
15:18:40 <zbyszek> tyll: https://pagure.io/ftbfs/blob/master/f/ftbfs.py
15:19:00 <nirik> So I had one issue I wanted to at least note...
15:19:05 <zbyszek> mhroncok: Yeah, I think setting it ASSIGNED is good enough in this case
15:19:10 <mhroncok> ok
15:19:29 <zbyszek> mhroncok: it's just a marker that the issue is being handled in this case
15:19:45 <zbyszek> nirik go ahead, I think that's all from my side
15:19:58 <nirik> The mass rebuild is 2018-07-11 (in two days) and there's some grumbling on the devel list about anonobin. Should we reach out to maintainers and make sure it's ready for mass rebuild?
15:20:16 <zbyszek> Definitely
15:20:27 <mhroncok> nirik: it got fixed today
15:20:27 <zbyszek> It seems that starting the rebuild with annobin broken doesn't make much sense
15:20:32 <zbyszek> Ah, OK.
15:20:48 <mhroncok> let me comment ont he releng issue
15:20:49 <nirik> mhroncok: great!
15:21:55 <nirik> I don't know of anything else off hand thats blocking the mass rebuild...
15:22:47 <nirik> ok, if nothing else will close out in a minute and give people some time back. ;)
15:22:53 <mhroncok> I have something
15:23:00 <mhroncok> 1) python 3.7, just info
15:23:01 <nirik> oh, ok, go ahead
15:23:15 <mhroncok> #info Python 3.7: 106 FTBFS, 63 blocked, 149 broken deps (not all packages that BR python3 require it)
15:23:26 * mhroncok cannot do #infos I guess
15:23:41 <mhroncok> 2) is about comps
15:23:45 <tyll> #info Python 3.7: 106 FTBFS, 63 blocked, 149 broken deps (not all packages that BR python3 require it)
15:24:00 <zbyszek> #info annobin issue that was causing build failures in rawhide koji is resolved, https://bugzilla.redhat.com/show_bug.cgi?id=1598961#c5
15:24:05 <mhroncok> who "maintains" comps, who has teh power to decde?
15:24:13 <nirik> #chair mhroncok
15:24:13 <zodbot> Current chairs: bowlofeggs contyk jsmith jwb maxamillion mhroncok nirik sgallagh tyll zbyszek
15:24:36 <zbyszek> mhroncok: I think any fedora maintainer can change comps
15:24:37 <nirik> mhroncok: it's a collective type package. Usually big changes are discussed on the devel list.
15:24:42 <mhroncok> I'd liek to see https://pagure.io/fedora-comps/issue/291 fixed for F29, but I'm not sure whether it requires change proposal, or not
15:25:00 <mhroncok> I can post an e-mail to devel
15:25:15 <nirik> https://fedoraproject.org/wiki/How_to_use_and_edit_comps.xml_for_package_groups
15:25:36 <jsmith> mhroncok: My best guess is that yes, that should go through the Change proposal process, as it sounds substantial
15:26:11 <zbyszek> jsmith: +1
15:26:15 <mhroncok> will do
15:26:29 <tyll> +1 for change process
15:26:32 <jsmith> mhroncok: Thanks :-)
15:26:40 <mhroncok> I hope it will  classify as self contained
15:26:41 <contyk> changes never hurt :)
15:26:43 <nirik> yeah. Would we allow a late change for f29 for this?
15:26:58 <mhroncok> as it only changes the comps :D
15:27:09 <nirik> oh, self contained deadline is the 24th. ;)
15:27:13 <mhroncok> exactly
15:27:20 <nirik> great
15:27:21 <mhroncok> that's why I hope for that :D
15:27:45 <mhroncok> ok, thank you
15:28:08 <nirik> thanks mhroncok
15:28:18 <nirik> anything else?
15:28:30 <tyll> o/
15:28:48 <tyll> I wonder, do you have a good workflow to find issues you still need to vote on?
15:29:08 <tyll> do you just click through all open issues and check?
15:29:09 <nirik> not really, I was wondering if we should tag them somehow.
15:29:09 <zbyszek> tyll: I gave up and just open all of them in tabs and go on-by-one ;(
15:29:31 <contyk> tags sound like a good idea
15:29:33 <nirik> like 'voting open' and remove that when it's decided
15:30:27 <tyll> iirc sgallagh proposed to use "notification pending" when it is done, however, I was also wondering about finding issues that I did not yet vote on
15:31:24 <tyll> but I guess there is no nice solution, just wanted to make sure that there is not a tampermonkey script or so to help here
15:31:44 <nirik> yeah, will have to ponder on the best workflow here.
15:32:11 <nirik> ok, thanks everyone for coming!
15:32:15 <nirik> #endmeeting