15:04:59 <zbyszek> #startmeeting FESCO (2018-07-16)
15:04:59 <zodbot> Meeting started Mon Jul 16 15:04:59 2018 UTC.
15:04:59 <zodbot> This meeting is logged and archived in a public location.
15:04:59 <zodbot> The chair is zbyszek. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:04:59 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
15:04:59 <zodbot> The meeting name has been set to 'fesco_(2018-07-16)'
15:04:59 <zbyszek> #meetingname fesco
15:04:59 <zodbot> The meeting name has been set to 'fesco'
15:04:59 <zbyszek> #chair nirik, maxamillion, jsmith, jwb, zbyszek, tyll, sgallagh, contyk, bowlofeggs
15:04:59 <zodbot> Current chairs: bowlofeggs contyk jsmith jwb maxamillion nirik sgallagh tyll zbyszek
15:05:02 <zbyszek> #topic init process
15:05:06 <nirik> morning
15:05:07 <contyk> .hello psabata
15:05:07 <bowlofeggs> .hello2
15:05:07 <zodbot> contyk: psabata 'Petr Šabata' <psabata@redhat.com>
15:05:09 <zbyszek> .hello2
15:05:10 <zodbot> bowlofeggs: bowlofeggs 'Randy Barlow' <rbarlow@redhat.com>
15:05:13 <bcotton> .hello2
15:05:13 <zodbot> zbyszek: zbyszek 'Zbigniew Jędrzejewski-Szmek' <zbyszek@in.waw.pl>
15:05:16 <zodbot> bcotton: bcotton 'Ben Cotton' <bcotton@redhat.com>
15:05:28 <maxamillion> .hello2
15:05:30 <zodbot> maxamillion: maxamillion 'Adam Miller' <maxamillion@gmail.com>
15:05:41 <sgallagh> .hello2
15:05:42 <zodbot> sgallagh: sgallagh 'Stephen Gallagher' <sgallagh@redhat.com>
15:05:47 <zbyszek> OK, let's start with the messy one
15:05:47 <zbyszek> #topic #1936 F29 Self Contained Change: Deprecate YUM 3
15:05:47 <zbyszek> .fesco 1936
15:05:47 <zbyszek> https://pagure.io/fesco/issue/1936
15:05:48 <zodbot> zbyszek: Issue #1936: F29 Self Contained Change: Deprecate YUM 3 - fesco - Pagure - https://pagure.io/fesco/issue/1936
15:06:26 <nirik> I found out this weekend that kojid will break... so I'm -1 until more things are in place.
15:06:31 <zbyszek> I think
15:06:49 <zbyszek> -1 still too, until we have a clear plan and a list of things
15:06:53 <contyk> yeah, pretty much that
15:07:08 <maxamillion> -1 here as well, there's unfortunately too many things not ready for this change
15:07:17 <contyk> -1 but I'd like someone to coordinate the infra/releng changes so that we can do this in f30
15:07:59 <bowlofeggs> it sounds way too late for f29
15:08:02 <bowlofeggs> -1
15:08:03 <sgallagh> -1 as well, but I want this on infra/releng's priority list
15:08:18 <zbyszek> jsmith voted -1 in the ticket
15:08:35 <zbyszek> jwboyer voted +1 in the ticket
15:08:49 <nirik> well, we don't handle these projects upstream... or have cycles to work on it I don't think.
15:09:05 <nirik> koji is the big one
15:10:08 <contyk> we could at least file tickets for that
15:10:11 * bcotton can handle the project management aspect
15:10:22 <zbyszek> nirik: There's the question whether it's enough to have some parts of the stack only working on RHEL/CentOS
15:10:41 <zbyszek> I'd like to hear your (and other's) thoughts on this
15:10:47 <nirik> There is a koji ticket, but no one working on that I know of.
15:10:51 * jsmith is finally here
15:11:07 <jsmith> .hello2
15:11:10 <zodbot> jsmith: jsmith 'Jared Smith' <jsmith.fedora@gmail.com>
15:11:13 <nirik> well, that would partly work for us (fedora infra), but there's others like the riscv people who are running on fedora
15:11:43 <nirik> also all our builders are fedora, so kojid needing yum3 would not work here either.
15:11:56 * jsmith is still -1 for F29, but willing to defer to F30 (knowing what I know now)
15:12:14 <zbyszek> .link https://pagure.io/koji/issue/971
15:12:20 <zbyszek> .info https://pagure.io/koji/issue/971
15:12:37 <zbyszek> #link https://pagure.io/koji/issue/971
15:13:58 <zbyszek> OK, so this is clearly not happening now. What about the following: "The change is rejected for F29, but FESCo would like to see this resubmitted for F30, with a list of dependencies (tickets), that need to be solved first."?
15:14:26 <jsmith> zbyszek: I like that proposal :-)
15:14:35 <bowlofeggs> zbyszek: +1
15:14:39 <sgallagh> zbyszek: +1
15:14:53 <maxamillion> +1
15:14:53 <zbyszek> +1 ftr
15:14:55 <contyk> +1
15:15:06 <nirik> sure, althought I think it's just the koji and mock tickets at this point... but there is mm and some otherlyers that could be done later.
15:15:48 <jsmith> nirik: Agreed :-)
15:16:17 <nirik> anyhow +1 to keep us moving
15:16:17 <zbyszek> nirik: yeah, but somebody needs to go through all the discussions, compile a list of things, and either mark them as needed, or explain why they can be delayed
15:16:31 <zbyszek> jsmith, can I count you as +1?
15:17:50 <jsmith> zbyszek: Yes
15:18:01 <zbyszek> #agreed The change is rejected for F29, but FESCo would like to see this resubmitted for F30, with a list of dependencies (tickets), that need to be solved first (+7, 0, 0)
15:18:22 <zbyszek> I'll close the tickets marked "pending ann." later today. Sorry for that.
15:18:30 <zbyszek> = New business =
15:18:30 <zbyszek> #topic #1940 F29 System Wide Change: Zchunk Metadata
15:18:30 <zbyszek> .fesco 1940
15:18:30 <zbyszek> https://pagure.io/fesco/issue/1940
15:18:31 <zodbot> zbyszek: Issue #1940: F29 System Wide Change: Zchunk Metadata - fesco - Pagure - https://pagure.io/fesco/issue/1940
15:19:49 <contyk> so, as long as we produce the old repodata as well, I don't see a problem here
15:19:53 <maxamillion> Is this being deferred or not? I'm confused by the comments
15:20:09 <bowlofeggs> this one sounds cool, but i do want to make sure it's backwards compatible
15:20:14 <bowlofeggs> sounds like it is
15:20:31 <zbyszek> Yes, that's how I undrstand this too
15:20:33 <nirik> yeah, should be fine
15:21:02 <bowlofeggs> so i like the idea of generating the metadata now but waiting for F30 to have client support
15:21:15 <sgallagh> maxamillion: I want to see the metadata creation happen so that they can test the client with real data, but I don't want to force its use until F30
15:21:22 <bowlofeggs> it will require changes in pungi and possibly bodhi
15:21:33 <bowlofeggs> probably any bodhi change would be small
15:21:33 <contyk> +1 bowlofeggs
15:22:20 <nirik> bowlofeggs: no pungi changes needed I don't think
15:22:23 <nirik> it's all in createrepo_c
15:22:26 <zbyszek> The "Scope" section has a long list of PRs to be accepted. I think it's OK to approve this, even though it's unlikely that everything gets implemented and merged
15:22:29 <maxamillion> alright
15:22:37 <maxamillion> +1 defer
15:23:10 <zbyszek> Hmm, let's vote on F29 first
15:23:36 <nirik> well, IMHO do whatever can be done for f29, and finish in f30 if needed.
15:23:42 <jsmith> +1 to F29 (and defer to F30 if it's not done by F29 deadline)
15:24:04 <zbyszek> jsmith: what does "defer" mean?
15:24:20 <nirik> well, thats just the normal contingency plan right?
15:24:30 <nirik> +1 for the change
15:24:37 <zbyszek> I think nirik's wording is better, because it does not suggest that the parts that are already done have to be disabled
15:25:02 <jsmith> Yes, the regular contingency plan
15:25:15 * jsmith could have been much more precise in his language, sorry
15:25:27 <sgallagh> Could we get a clearly-worded proposal to vote on?
15:26:11 <nirik> Vote to approve the change?
15:26:23 <jsmith> Proposal: Approve for F29.  Whatever pieces aren't done by F29 are approved for F30.
15:26:30 <zbyszek> jsmith: +1
15:26:35 <contyk> +1 to that
15:26:55 <maxamillion> Seems oddly open ended for a change that could break so many users, but alright
15:27:04 <bowlofeggs> the change as worded does say "rather than xz or gzip"
15:27:17 <bowlofeggs> that seems non backward compatible
15:27:30 <bowlofeggs> well except that the wiki says "in addition to"
15:27:37 <zbyszek> bowlofeggs: I think it got changed
15:27:41 <bowlofeggs> ah ok
15:27:46 <sgallagh> bowlofeggs: refresh the page
15:27:47 <bowlofeggs> so the wiki is correct
15:27:51 <jsmith> I don't think this is any way non-backward-compatible, or could "break" a lot of users
15:28:07 <jsmith> At least, as I understand it
15:28:23 <sgallagh> I guess I'm a weak +1 here
15:28:30 <nirik> it is backwards compatible. If there's a problem with the new metadata on the client end, we can remove it and dnf will use the old format
15:28:40 <sgallagh> I'd kind of like to have more runway, but I suppose realistically we won't know if it breaks until it does
15:29:28 <bowlofeggs> it does seem like there's not a lot of time to get it done, but i guess i can be +1 since it's backwards compatible
15:29:50 <maxamillion> alright, I misunderstood
15:29:53 <maxamillion> +1
15:30:21 <zbyszek> nirik: +1?
15:30:37 <nirik> +1
15:30:51 <zbyszek> #agreed Change is approved for F29.  Whatever pieces aren't done by F29 are approved for F30 (+7, 0, 0)
15:31:15 <zbyszek> #topic Next weeks chair
15:31:40 <zbyszek> any takers?
15:31:43 * jsmith will likely be on the road again next week :-(
15:31:47 <bowlofeggs> i haven't done it in a long time
15:32:03 <bowlofeggs> can the agenda be posted on thursday instead of friday?
15:32:11 <jsmith> Sure :-)
15:32:12 <zbyszek> #action bowlofeggs to chair next week's meeting
15:32:12 <bowlofeggs> because i can't do that on friday, sat, or sun :)
15:32:15 <bowlofeggs> hahah cool
15:32:31 <puiterwijk> bowlofeggs: you haven't done about anything in a long time... :)
15:32:38 <bowlofeggs> haha it's true
15:32:49 <bowlofeggs> i forgot what all these buttons on my computer are for
15:32:57 <zbyszek> #topic Open floor
15:33:02 <sgallagh> #1nfo bowlofeggs to be useful for a change ;-)
15:33:16 <bowlofeggs> :)
15:33:33 <puiterwijk> So, on the zchunk thing, I was wondering whether we need an explicit buy-in from Infra before we set a date of shipping
15:33:36 <sgallagh> I had one thing
15:33:51 <sgallagh> go ahead, puiterwijk
15:34:00 <puiterwijk> Because it is going to require some infra stuff (specifically, Bodhi checks metadata contents, and this would need to be added)
15:34:18 <nirik> yeah, I forgot about the bodhi part. ;( Not sure how much work that will be...
15:34:37 <nirik> (but note we could enable for rawhide first)
15:34:40 <puiterwijk> (since we've had a number of times where createrepo_c generates invalid/useless metadata, so we have added checks to Bodhi to be very strict in them)
15:35:05 <puiterwijk> In addition, Bodhi boxes are f27. So we'd need to make sure that all of the build tooling is backported to f27, or we can't until we upgrade the bodhi boxes
15:35:40 <bowlofeggs> yeah good points
15:35:44 <bowlofeggs> i didn't think about the f27 bit
15:37:10 <zbyszek> Who are the poeple we should ask about this? Is an infra ticket the right way?
15:37:13 <puiterwijk> The one part I'm concerned about is that fesco says "ack to f29", and then people are going to go after the infra team "You need to do this *now* because fesco said we'd have everything to deliver this in f29".
15:37:44 <bowlofeggs> i wouldn't say that it's an order from fesco to infra (aka me in this case) to do it by f29
15:37:47 <puiterwijk> zbyszek: probably me and bowlofeggs are the people backing this
15:37:59 <bowlofeggs> more that fesco is ok with the change, good luck getting it done in time :)
15:38:05 <puiterwijk> bowlofeggs: right. I'm not saying fesco would order us to. It's more that other people might interpret a fesco ack as that.
15:38:09 <nirik> I would say we try and do it, if we don't we hit the continngency plan
15:38:29 <puiterwijk> As long as that's explicit, that's fine with me.
15:38:49 <bowlofeggs> i personally do feel like it might be too ambitious to do by f29, but i'm not opposed to them trying
15:38:56 <nirik> There's no urgency on this I don't think. It will be very nice to have, but it's not blocking anything...
15:39:08 <bowlofeggs> i also don't know how far along they are in all the other programs
15:39:12 <bowlofeggs> maybe it's further than i think
15:39:20 <bowlofeggs> yeah agree with nirik
15:39:36 <zbyszek> agreed too
15:39:38 <bowlofeggs> i think it's probably pretty ambitious, but worst case it gets punted
15:40:16 <zbyszek> #info It is understood that infra is busy, and any changes might wait before being merged
15:40:21 <puiterwijk> Okay. Then EOM
15:40:37 <zbyszek> sgallagh?
15:41:42 <zbyszek> sgallagh you mentioned you had something…
15:42:23 <sgallagh> Sorry, got distracted
15:42:49 <sgallagh> Just a minor point that came up while I was away: I think I inadvertently made one change to the new ticket policy when I codified it on the wiki
15:43:09 <sgallagh> I'm not sure we ever *officially* agreed that a -1 vote == put it on the meeting agenda.
15:43:19 <zbyszek> I think it's a good idea ;)
15:43:29 <sgallagh> It seems appropriate, but I wanted to clarify that position
15:44:15 <nirik> +1 to -1 means a meeting item
15:44:27 <zbyszek> +1 to the clarification
15:44:34 <sgallagh> Obvious +1
15:45:08 <zbyszek> maxamillion, jsmith, jwb, tyll, contyk, bowlofeggs, vote
15:45:10 <bowlofeggs> +1 to clarification - fwiw i thought that's what we had agreed to before
15:45:27 <contyk> +1 :)
15:45:29 <sgallagh> bowlofeggs: I think it may have been in the discussion, but none of the agreed proposals used that wording
15:45:38 <bowlofeggs> yeah maybe that's why i thought that :)
15:45:42 <sgallagh> So I was just being thorough
15:45:46 <maxamillion> +1
15:46:05 <sgallagh> OK, thanks
15:46:28 <zbyszek> #agreed The ticket policy is clarified to mean that any -1 votes automatically put the ticket on meeting agenda (as the wiki already states) (+6, 0, 0)
15:46:46 <zbyszek> If nobody has anything else, I'll close in one minute
15:46:58 <sgallagh> Nothing else from me
15:47:58 * sgallagh scratches another tally mark on the "Ask forgiveness, not permission" board
15:48:12 <zbyszek> ;)
15:48:23 <zbyszek> python rulez
15:48:37 <zbyszek> #endmeeting