15:00:06 <sgallagh> #startmeeting FESCO (2018-09-17)
15:00:06 <zodbot> Meeting started Mon Sep 17 15:00:06 2018 UTC.
15:00:06 <zodbot> This meeting is logged and archived in a public location.
15:00:06 <zodbot> The chair is sgallagh. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:00:06 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
15:00:06 <zodbot> The meeting name has been set to 'fesco_(2018-09-17)'
15:00:06 <sgallagh> #meetingname fesco
15:00:06 <zodbot> The meeting name has been set to 'fesco'
15:00:06 <sgallagh> #chair nirik, maxamillion, jsmith, jforbes, zbyszek, tyll, sgallagh, contyk, bowlofeggs
15:00:06 <zodbot> Current chairs: bowlofeggs contyk jforbes jsmith maxamillion nirik sgallagh tyll zbyszek
15:00:06 <sgallagh> #topic init process
15:00:12 <zbyszek> .hello2
15:00:14 <zodbot> zbyszek: zbyszek 'Zbigniew Jędrzejewski-Szmek' <zbyszek@in.waw.pl>
15:00:17 <jforbes> .hello2
15:00:18 <zodbot> jforbes: jforbes 'Justin M. Forbes' <jforbes@redhat.com>
15:00:24 <sgallagh> .hello2
15:00:24 <bowlofeggs> .hello2
15:00:24 <zodbot> sgallagh: sgallagh 'Stephen Gallagher' <sgallagh@redhat.com>
15:00:27 <zodbot> bowlofeggs: bowlofeggs 'Randy Barlow' <rbarlow@redhat.com>
15:01:00 <contyk> .hello psabata
15:01:01 <zodbot> contyk: psabata 'Petr Šabata' <psabata@redhat.com>
15:01:19 <jsmith> .hello2
15:01:20 <zodbot> jsmith: jsmith 'Jared Smith' <jsmith.fedora@gmail.com>
15:01:24 <nirik> morning
15:01:27 * jsmith is seriously jet-lagged, but mostly here
15:01:32 <contyk> just one item on the agenda today
15:01:38 <contyk> we should be able to finish under three hours
15:01:44 <jsmith> contyk: :-)
15:02:01 <zbyszek> OK, let me get a coffee
15:02:13 <bowlofeggs> lol
15:02:20 <sgallagh> #topic #1989 Decide status of "Rename Atomic Workstation to Silverblue" change
15:02:20 <sgallagh> .fesco 1989
15:02:22 <zodbot> sgallagh: Issue #1989: Decide status of "Rename Atomic Workstation to Silverblue" change - fesco - Pagure - https://pagure.io/fesco/issue/1989
15:02:33 <bowlofeggs> note that zbyszek posted a proposal in ticket
15:02:37 <maxamillion> .hello2
15:02:38 <zodbot> maxamillion: maxamillion 'Adam Miller' <maxamillion@gmail.com>
15:02:42 <sgallagh> Hopefully this will be a short discussion, as zbyszek updated the ticket after the Silverblue meeting this morning
15:03:00 * nirik reads up since he just got up
15:03:02 <bowlofeggs> i +1'd his in-ticket proposal, in ticket
15:03:14 <sgallagh> From the ticket:
15:03:14 <sgallagh> proposal: We acknowledge that the change is partially implemented and users might see the old name is various places, but what was already done cannot be reverted meaningfully. If the silverblue team proposes any further changes before GA that need exceptions from the general policy, they will be reviewed on a case-by-case basis. Likewise, if there are any problems, they will be reviewed on a case-by-case basis.
15:03:33 <jforbes> I am +1 to the proposal
15:03:39 <bowlofeggs> +1
15:03:46 <nirik> +1. seems quite resonable to me.
15:03:52 <sgallagh> I'm +1 to the proposal, but mostly because I don't think there's any reasonable way we can do better :-/
15:04:08 <jsmith> +1 from me... but I'm with sgallagh, not sure we have much choice
15:04:08 <zbyszek> sgallagh: my feelings exactly
15:04:21 <contyk> +1 too...
15:04:25 <jforbes> Well, the test day was pretty widely advertised as Silverblue
15:04:46 <nirik> there is also the website... but I think there's a PR...
15:05:40 <sgallagh> nirik: What's the impact if that PR isn't merged before Beta release?
15:06:02 <nirik> people might be confused on how to download it I guess.
15:06:23 <sgallagh> Confused about it or have no idea it exists?
15:06:27 <sgallagh> I think the latter is more likely
15:06:51 <nirik> yeah, not sure, but perhaps. Looking quickly now I don't see it at all...
15:07:06 <nirik> oh there it is.
15:07:21 <nirik> "Try Atomic Workstation" in a side bar on the workstation page
15:07:56 <nirik> so, should be easy to update
15:07:58 <maxamillion> +1
15:08:08 * sgallagh nods
15:08:35 <maxamillion> for the record ... I don't like that people are just shoving things that don't have an useful contingency plan
15:08:40 <sgallagh> Does anyone mind if I propose "Update the getfedora page" as a blocker for Beta?
15:08:48 <zbyszek> nope
15:08:55 <maxamillion> sgallagh: go for it
15:09:02 <nirik> https://pagure.io/fedora-websites/pull-request/864
15:09:26 <sgallagh> Proposal: FESCo will treat the update of the getfedora.org website to reference Silverblue as a blocking issue for F29 Beta.
15:09:40 <nirik> hum... but silverblue itself isn't blocking.
15:09:57 <nirik> so we could get something where it fails and..
15:10:04 <jforbes> Right, it is "preview"
15:10:18 <jforbes> Perhaps treat the update as FE?
15:10:23 <nirik> so, lets just leave it at that and websites will merge that I'm sure.
15:10:50 <zbyszek> sorry sgallagh, it seems nirik is righter this time
15:10:54 <contyk> :)
15:10:58 <sgallagh> nirik: At minimum, I want the website to stop mentioning Atomic Workstation then
15:11:05 <bowlofeggs> i also don't like the lack of contingency plan, but we did also approve this change (incl. contingency plan)
15:11:08 <sgallagh> If it's not building, neither version should be there
15:11:11 <bowlofeggs> so it's a bit on us too
15:11:26 <sgallagh> I'll rephrase my proposal.
15:11:30 <bowlofeggs> maybe a lesson is that we should scrutinize contingincy plans a littl emore going forward
15:11:37 <nirik> bowlofeggs: indeed.
15:12:06 <sgallagh> Proposal: FESCo considers the accuracy of the getfedora.org page relating to Silverblue (nee Atomic Workstation) to be a blocking issue for F29 Beta."
15:12:24 <bowlofeggs> sgallagh: haha, +1
15:12:31 <nirik> hum... but what does that mean in this case?
15:12:34 <bowlofeggs> (nee?)
15:12:45 <nirik> we don't update the websites until right before we are releasing.
15:12:49 <sgallagh> bowlofeggs: Archaic term that basically means "also formerly known as"
15:12:54 <bowlofeggs> i take that to mean we don't want getfedora.org to link to things users can't get?
15:13:09 <sgallagh> bowlofeggs: Exactly
15:13:09 <bcotton> TIL French is archaic ;-)
15:13:11 <bowlofeggs> sgallagh: ah, haven't heard that before
15:13:30 <sgallagh> bowlofeggs: Archaic usage in English, sorry.
15:13:30 <nirik> How about we just say that we would like the websites team to make sure the page is accurate before release?
15:13:40 <sgallagh> err, that last was for bcotton
15:13:58 <sgallagh> nirik: I thought that's pretty much what I was saying
15:14:08 <sgallagh> I was just calling out this particular tricky case explicitly
15:14:08 <bowlofeggs> nirik: do you mean final release?
15:14:13 <bowlofeggs> vs. beta?
15:14:22 <nirik> well, I don't understand the blocking part... I mean this is not in the normal flow of blocker bugs.
15:14:36 <nirik> if we are at go/no-go and the websites isn't updated we are no-go?
15:15:01 <sgallagh> nirik: We have a "release-day" category for update bugs, yes?
15:15:05 <nirik> websites can't usually update until after we are go.
15:15:06 <sgallagh> s/update/upgrade/
15:15:37 <nirik> 0-day blockers... sure I guess we could do that.
15:15:42 <sgallagh> The effect of this being that we would prep all the machinery to do the release on Tuesday, but if this isn't fixed we would delay the announcement until it was.
15:15:48 <nirik> just seems a bit micromanaging, but ok.
15:16:12 <sgallagh> Maybe, but I think the Silverblue situation is confusing enough without incorrect messaging too
15:16:46 <zbyszek> sgallagh: I think nirik's less-formal version is good enough.
15:17:16 * nirik sees how we can make a single topic last. ;)
15:17:43 * sgallagh didn't want to get roped into running next week's meeting if this one was too short ;-)
15:17:44 <nirik> anyhow, I guess I am fine with a 0-day (but we would need to file a bug and get it acked) or just asking them
15:17:51 <contyk> making anything about this change "blocking" doesn't feel right to me
15:18:04 <bowlofeggs> hahaha
15:18:35 <bowlofeggs> i agree that the website mentioning nothing about this is better than it linking to the old thing and it 404'ing
15:18:44 <sgallagh> Yeah, I suppose if we screw up the website, it's relatively quick to get it fixed as well.
15:18:50 <nirik> but thats true of all our stuff on the website. ;)
15:19:38 <sgallagh> I withdraw my proposal for blocking on the website updates
15:20:59 <sgallagh> OK, I have +7 for zbyszek 's original proposal
15:21:18 <sgallagh> #agreed We acknowledge that the change is partially implemented and users might see the old name is various places, but what was already done cannot be reverted meaningfully. If the silverblue team proposes any further changes before GA that need exceptions from the general policy, they will be reviewed on a case-by-case basis. Likewise, if there are any problems, they will be reviewed on a case-by-case basis. (+7,
15:21:18 <sgallagh> 0, -0)
15:21:31 <sgallagh> Do we have anything further on this topic?
15:21:50 <zbyszek> #info FESCo would like the websites team to make sure the page is accurate before release.
15:21:56 <sgallagh> ack
15:21:58 <bowlofeggs> ack
15:22:12 <zbyszek> move on?
15:22:30 <sgallagh> #topic Next week's chair
15:22:37 <zbyszek> I can do it.
15:22:40 * sgallagh throws the chair at zbyszek
15:22:46 * zbyszek ducks
15:23:00 <sgallagh> #action zbyszek to chair the next meeting on 2018-09-24
15:23:19 <bowlofeggs> is it a comfy chair?
15:23:26 <sgallagh> I'll be around for that one, but I'll be at AnsibleFest the following week (along with, I suspect) several other FESCo members.
15:23:54 <jsmith> I *should* be here next week, but will likely miss the two meetings after that.
15:23:59 <jsmith> Will do my best to keep up on tickets, etc.
15:25:47 <sgallagh> #topic Open Floor
15:25:55 <sgallagh> Any topics for Open Floor this week?
15:26:01 * bowlofeggs looks around at all the open space on this floor…
15:26:11 <zbyszek> I opened an issue for the docs conversion
15:26:14 <zbyszek> .fesco 1994
15:26:15 <zodbot> zbyszek: Issue #1994: moving FESCo policy docs under docs.fp.o - fesco - Pagure - https://pagure.io/fesco/issue/1994
15:26:20 * sgallagh pulls the lever and opens the floor under bowlofeggs
15:26:39 <bowlofeggs> haha
15:26:45 <bowlofeggs> zbyszek++
15:26:46 <zodbot> bowlofeggs: Karma for zbyszek changed to 14 (for the current release cycle):  https://badges.fedoraproject.org/tags/cookie/any
15:26:49 <zbyszek> If nobody objects I'll file a PR for fedora-docs to include this repo in the website
15:27:08 <sgallagh> zbyszek: I think we effectively all agreed to this last week, so +1
15:27:24 <zbyszek> Right, I'm not asking for a vote, just letting you know that it's happening.
15:27:36 <jsmith> zbyszek: Sounds great!
15:27:51 <nirik> thanks for working on it
15:28:06 <sgallagh> #info zbyszek is moving forward with the docs improvements
15:28:33 <contyk> zbyszek++
15:28:33 <zodbot> contyk: Karma for zbyszek changed to 15 (for the current release cycle):  https://badges.fedoraproject.org/tags/cookie/any
15:28:56 <sgallagh> zbyszek++
15:29:12 <sgallagh> Anything further or can we close this out in only 30 minutes?
15:29:53 <jforbes> Nothing here
15:29:56 <contyk> nope
15:30:01 <zbyszek> nope
15:30:23 <jsmith> nothing further from me
15:30:34 <sgallagh> Thank you all for coming, then!
15:30:38 <contyk> thanks sgallagh
15:30:40 <sgallagh> #endmeeting