15:01:27 <zbyszek> #startmeeting FESCO (2019-05-31)
15:01:27 <zodbot> Meeting started Fri May 31 15:01:27 2019 UTC.
15:01:27 <zodbot> This meeting is logged and archived in a public location.
15:01:27 <zodbot> The chair is zbyszek. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:01:27 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
15:01:27 <zodbot> The meeting name has been set to 'fesco_(2019-05-31)'
15:01:27 <zbyszek> #meetingname fesco
15:01:27 <zbyszek> #chair nirik, bowlofeggs, jforbes, zbyszek, bookwar, sgallagh, contyk, mhroncok, otaylor
15:01:27 <zodbot> The meeting name has been set to 'fesco'
15:01:27 <zodbot> Current chairs: bookwar bowlofeggs contyk jforbes mhroncok nirik otaylor sgallagh zbyszek
15:01:30 <zbyszek> #topic init process
15:01:43 <ignatenkobrain> .hello2
15:01:44 <zodbot> ignatenkobrain: ignatenkobrain 'Igor Gnatenko' <i.gnatenko.brain@gmail.com>
15:01:56 <zbyszek> .hello2
15:01:57 <zodbot> zbyszek: zbyszek 'Zbigniew Jędrzejewski-Szmek' <zbyszek@in.waw.pl>
15:02:01 <bcotton> .hello2
15:02:02 <zodbot> bcotton: bcotton 'Ben Cotton' <bcotton@redhat.com>
15:02:10 <bookwar> .hello2
15:02:11 <zodbot> bookwar: bookwar 'Aleksandra Fedorova' <alpha@bookwar.info>
15:02:21 <nirik> .hello kevin
15:02:22 <zodbot> nirik: kevin 'Kevin Fenzi' <kevin@scrye.com>
15:02:43 <zbyszek> I forgot to out the agenda.
15:02:50 <zbyszek> The only thing we have is
15:02:58 <zbyszek> .fesco 2137
15:03:00 <zodbot> zbyszek: Issue #2137: Bodhi 4 to stable releases? - fesco - Pagure.io - https://pagure.io/fesco/issue/2137
15:03:56 * nirik was +1 to the plan in ticket. Still is.
15:04:00 <sgallagh> .hello2
15:04:01 <zodbot> sgallagh: sgallagh 'Stephen Gallagher' <sgallagh@redhat.com>
15:04:12 <zbyszek> Yeah, everybody who is here voted already, afaict.
15:04:24 <sgallagh> heh
15:04:37 <sgallagh> Do we have +5?
15:04:43 <sgallagh> because +5 in a meeting is a decision made
15:04:53 <zbyszek> We don't have quorum yet.
15:05:06 <sgallagh> zbyszek: I meant in the ticket
15:05:23 * sgallagh counts +6
15:05:49 <zbyszek> We need one more in the ticket or one more in the meeting. We're short in both.
15:06:29 * sgallagh quickly changes nick to vote as someone else
15:06:46 <zbyszek> mhroncok said he'll not make it today
15:07:05 <bowlofeggs> .hello2
15:07:06 <zodbot> bowlofeggs: bowlofeggs 'Randy Barlow' <rbarlow@redhat.com>
15:07:24 <sgallagh> Well, if bowlofeggs doesn't abstain, we have +7
15:07:41 <bowlofeggs> i'll +1 then, haha
15:07:48 <sgallagh> APPROVED
15:07:52 <bowlofeggs> i guess we dont have to abstain, andit's not like it's very controversial
15:07:55 <bowlofeggs> cool
15:08:20 <bowlofeggs> i'll get started on a bodhi3-client package, maybe miro can review it for me
15:08:26 <zbyszek> #topic #2137 Bodhi 4 to stable releases?
15:08:35 <zbyszek> .fesco 2137
15:08:38 <zodbot> zbyszek: Issue #2137: Bodhi 4 to stable releases? - fesco - Pagure.io - https://pagure.io/fesco/issue/2137
15:08:40 <zbyszek> https://pagure.io/fesco/issue/2137
15:08:50 <zbyszek> APPROVED (+5, 0, 0)
15:09:01 <bowlofeggs> i'm going to file a separate issue for the EPEL SC about this too
15:09:05 <bowlofeggs> since that's their domain
15:09:23 <bowlofeggs> but EL 7 is even older and trickier
15:09:47 <zbyszek> I can do next week's chairing too.
15:09:48 <bowlofeggs> i think i'll propose a similar thing there, but additionally will propose dropping the server entirely
15:10:13 * nirik will not be here next week.
15:10:14 <zbyszek> #action zbyszek to chair next week's meeting
15:10:25 <zbyszek> #action zbyszek to remember to send out the agenda
15:10:42 <zbyszek> #topic Open floor
15:10:59 <zbyszek> Anyone?
15:11:03 <ignatenkobrain> I'd like to bring https://fedoraproject.org/wiki/Changes/RPM-4.15... It's been a week, but bcotton did not create a FESCo issue
15:11:03 <sgallagh> Elections?
15:11:33 <ignatenkobrain> RPM folks would like to put alpha 4.15 out into rawhide next week, so I'm seeking for quick approval 🙂
15:13:26 <zbyszek> It was sent out to fedora-devel a week ago, and there were no replies.
15:13:27 <bookwar> is it connected/dependent/blocking to the https://fedoraproject.org/wiki/Changes/Switch_RPMs_to_zstd_compression ?
15:13:35 * nirik is ok with it as long as alpha is stable enough for day to day use/builds.
15:13:37 <zbyszek> bookwar: I don't think so.
15:13:44 <sgallagh> bookwar: No, they should be unrelated.
15:13:51 <zbyszek> I'm +1
15:13:59 <sgallagh> RPM already has that support in 4.14, it's just not in use in Fedora
15:14:15 <sgallagh> I'm +1 if we're voting today, I suppose.
15:14:25 <sgallagh> Nothing in 4.15 strikes me as particularly dangerous
15:14:49 * bcotton will create FESCo ticket now for record purposes. it's been about a week plus 3 hours at this point :p
15:15:09 <zbyszek> bcotton: ignatenkobrain likes to live on the edge ;)
15:15:34 <zbyszek> OK, let's vote then.
15:15:47 <zbyszek> nirik, bookwar, bowlofeggs?
15:15:50 <nirik> +1
15:16:20 <bowlofeggs> yehah +1
15:16:25 <bowlofeggs> (sorry for afkness)
15:16:52 <bookwar> i'd have miro voting too, as he was participating in the referenced bug https://bugzilla.redhat.com/show_bug.cgi?id=1693751#c10 and i haven't yet read it in full
15:17:10 <bcotton> .fesco 2140
15:17:11 <zodbot> bcotton: Issue #2140: F31 System-Wide Change: RPM 4.15 - fesco - Pagure.io - https://pagure.io/fesco/issue/2140
15:17:47 <zbyszek> #topic #2140 F31 System-Wide Change: RPM 4.15
15:17:56 <bookwar> i mean generally it is +1 as it is a regular update, i am just trying to understand if there is immediate impact on rawhide users, and do we have all rawhide packagers informed of it
15:18:45 <ignatenkobrain> Normal update
15:18:49 <ignatenkobrain> With few rebuilds
15:18:57 <ignatenkobrain> I'll take care of all
15:18:58 <ignatenkobrain> And notifications
15:19:16 <bookwar> ignatenkobrain: is fedora-review ready for it?
15:19:33 <bookwar> rpmlint?
15:19:48 <ignatenkobrain> bookwar: how is it related?
15:20:01 <bowlofeggs> i think fedora-review has been broken a long time in general
15:20:08 <bowlofeggs> at least, it doesn't work on my rawhide box
15:20:43 <bookwar> ignatenkobrain: " Support for %elif, %elifos and %elifarch statements in spec" - how rpmlint will work with that?
15:20:57 <zbyszek> There have been some improvovements to f-r recently, but it's not really relevant.
15:21:01 <ignatenkobrain> bookwar: rpmlint does not implement its own parsing of spec files
15:21:13 <ignatenkobrain> that would be terrible idea to do
15:22:05 <bookwar> you are not answering to the question
15:22:13 <bookwar> is it affected?
15:23:00 <ignatenkobrain> as far as I know, no.
15:24:46 <bookwar> fedora-review? fedpkg?
15:25:04 <zbyszek> fedpkg doesn't care
15:25:05 <ignatenkobrain> none of them are affected as far as I know
15:25:11 <zbyszek> fedora-review is not blocking
15:26:24 <bookwar> https://bugzilla.redhat.com/show_bug.cgi?id=1693751#c8 here the issue for fedpkg was reported too. And it was in 4.14 minor update
15:27:16 <ignatenkobrain> bookwar: yes, but it is not making anything worse. Panu backported patch from 4.15 to 4.14 for testing purposes. so whatever is broken now won't be broken more
15:28:17 <zbyszek> OK, since bookwar has doubts, and the ticket was just opened, let's vote in the ticket.
15:29:01 <zbyszek> #topic Open Floor (again)
15:29:12 <zbyszek> Anyone has anything?
15:29:41 <nirik> do we want to say anything on the rpm compression thread on devel?
15:29:48 <nirik> or just let it run and see where we end up?
15:30:02 <bowlofeggs> i'm ok with letting it run
15:30:07 <bowlofeggs> it's certainly a lively discussion!
15:30:14 <bookwar> ignatenkobrain: don't get me wrong, i am for the change, but I don't like "quick votes" without a moment to recognize who is actually affected and how. And for nearest dependencies we really should have a list with marks "not affected", "not critically affected", "affected and will be fixed", etc. Otherwise it is unclear whether those things were forgotten or were considered and figured out
15:31:50 <ignatenkobrain> bowlofeggs: that is exactly what I'm telling. Nothing is supposed to be affected as far as we know. The python bindings change has happened in rawhide some time ago.
15:32:12 * sgallagh has to drop.
15:32:16 <ignatenkobrain> whoops, that was for bookwar
15:32:24 <sgallagh> Which I think kills quorum, sorry.
15:32:48 <zbyszek> sgallagh: np, we don't have anything to vote most likely
15:34:06 <zbyszek> I think the zstd change has high potential (nice improvement for users), but potential drawback from RHEL
15:34:37 <bowlofeggs> ignatenkobrain: haha i was wondering why you mentioned me
15:34:39 <bowlofeggs> haha
15:34:48 <zbyszek> In related news, systemd upstream will be switching to zstd most likely soon too.
15:35:04 <bowlofeggs> i'm surprised that many people would try to install fedora rpms on RHEL
15:35:09 <bowlofeggs> that sounds risky
15:35:12 <bowlofeggs> RHisky?
15:35:28 * nirik isn't sure it's worth all the hassle.
15:35:40 <ignatenkobrain> it is not about installing, it is also about reading
15:35:53 <zbyszek> Exactly.
15:35:55 <bowlofeggs> ignatenkobrain: oh like looking at the metadata and what not?
15:36:19 <zbyszek> nirik: "it" ?
15:36:29 <ignatenkobrain> nirik: we just need to do calculations and see
15:36:30 <nirik> switching rpm compression
15:37:19 <bcotton> fwiw, i'm trying to get a sense from the RHEL product folks if we could get zstd support in RHEL 8.1 or .2 or if it'll be something that has to wait longer. if they're willing to enable the support soon, it may be worth pushing this back to F32. I don't see that it's solving an issue that's so burning that it's worth the headache
15:37:59 <zbyszek> Decompression is *vastly* faster, and there's higher potential for multithread operation...
15:40:11 <zbyszek> Anyway, discussion on fedora-devel is ongoing...
15:40:20 * nirik is not looking forward to the extra work, but I guess it's a chance to move the koji hubs into openshift anyhow.
15:41:53 <zbyszek> Anything else for open floor? If not I'll close in a minute...
15:42:10 <bowlofeggs> making dnf install go faster does seem like a good thing to me in isolation
15:42:19 <bowlofeggs> (i'm sure that statement is true for everyone ☺)
15:43:19 <zbyszek> There's still the issue of filepath metadata (I can't recall the prooper name right now). Somebody should tackle this some day.
15:43:41 <zbyszek> Optimizing this would have a big impact on dnf speed.
15:44:31 <zbyszek> #endmeeting