15:00:20 <zbyszek> #startmeeting FESCO (2019-10-07)
15:00:20 <zodbot> Meeting started Mon Oct  7 15:00:20 2019 UTC.
15:00:20 <zodbot> This meeting is logged and archived in a public location.
15:00:20 <zodbot> The chair is zbyszek. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:00:20 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
15:00:20 <zodbot> The meeting name has been set to 'fesco_(2019-10-07)'
15:00:20 <zbyszek> #meetingname fesco
15:00:20 <zodbot> The meeting name has been set to 'fesco'
15:00:20 <zbyszek> #chair nirik, ignatenkobrain, jforbes, zbyszek, bookwar, sgallagh, contyk, mhroncok, otaylor
15:00:20 <zodbot> Current chairs: bookwar contyk ignatenkobrain jforbes mhroncok nirik otaylor sgallagh zbyszek
15:00:23 <zbyszek> #topic init process
15:00:26 <zbyszek> .hello2
15:00:27 <zodbot> zbyszek: zbyszek 'Zbigniew Jędrzejewski-Szmek' <zbyszek@in.waw.pl>
15:00:30 <jforbes> .hello2
15:00:31 <zodbot> jforbes: jforbes 'Justin M. Forbes' <jforbes@redhat.com>
15:00:32 <bookwar> .hello2
15:00:34 <nirik> .hello kevin
15:00:34 <zodbot> bookwar: bookwar 'Aleksandra Fedorova' <alpha@bookwar.info>
15:00:37 <zodbot> nirik: kevin 'Kevin Fenzi' <kevin@scrye.com>
15:00:41 <sgallagh> .hello2
15:00:42 <zodbot> sgallagh: sgallagh 'Stephen Gallagher' <sgallagh@redhat.com>
15:00:58 <sgallagh> I have a hard stop in 45 minutes to get to an appointment.
15:01:17 <contyk> .hello psabata
15:01:18 <zodbot> contyk: psabata 'Petr Šabata' <psabata@redhat.com>
15:01:20 <zbyszek> We have quorum, let's go then.
15:01:31 <zbyszek> #topic #2236 Default Stream for Eclipse module
15:01:34 <zbyszek> .fesco 2236
15:01:36 <zodbot> zbyszek: Issue #2236: Default Stream for Eclipse module - fesco - Pagure.io - https://pagure.io/fesco/issue/2236
15:01:46 <zbyszek> .bugzilla 1759176
15:02:05 <zbyszek> .bug 1759176
15:02:07 <zodbot> zbyszek: 1759176 – Eclipse fails to install out-of-the-box on F31 - https://bugzilla.redhat.com/1759176
15:02:12 <zbyszek> .bug 1759179
15:02:13 <zodbot> zbyszek: 1759179 – Please do not filter glassfish-el - https://bugzilla.redhat.com/1759179
15:02:23 <zbyszek> .bug 1759187
15:02:25 <zodbot> zbyszek: 1759187 – Drop glassfish-el from module - https://bugzilla.redhat.com/1759187
15:02:44 <zbyszek> Those were just filed, so there hasn't been any time for a reaction from other maitnainers.
15:03:15 <mbooth> This bug covers the bare minimum IMO, fix the conflicts in maven and eclipse modules. This way, installation of ursine Eclipse *should* work, but is suboptimal because this version of Eclipse is EOL and I can't build bug/security fixes for it.
15:03:35 <bookwar> proposal: retire eclipse from F31, do not enable default module, release f31 with eclipse being installed only from module. Let maintainers resolve confilcts between java modules
15:04:13 <nirik> so, no eclipse in f31? thats pretty sad
15:04:21 <contyk> bookwar: I don't understand the second point
15:04:30 <nirik> oh, I see, just explicitly enabling the module...
15:04:34 <bookwar> nirik: i don't see other option at this point
15:04:35 <zbyszek> contyk: see the linked bugs
15:04:49 <otaylor> .hello otaylor
15:04:50 <zodbot> otaylor: otaylor 'Owen Taylor' <otaylor@redhat.com>
15:05:30 <bookwar> contyk: eclipse module will be there, user can explicitly enable it
15:05:40 * contyk looks at the bus
15:05:42 <bookwar> but there won't be any default eclipse
15:05:42 <nirik> if they know to
15:05:57 <contyk> bookwar: yeah, except that requiring people to explicitly enable something just to install a package that was always there sucks
15:06:05 <zbyszek> bookwar: I like this proposal.
15:06:05 <nirik> contyk: +1
15:06:19 <mbooth> Yeah, that's why I wanted default stream, so the upgrade is transparent for users
15:06:22 <nirik> why can't we just make it default also?
15:06:24 <jforbes> contyk: +1
15:06:27 <bookwar> contyk: i agree, but i don't see the other way
15:06:39 <bookwar> we can not enable default stream, there are conflicts
15:06:59 <bookwar> and we can not keep old eclipse, as it can not be updated
15:07:17 <jforbes> I agree with the 2nd point
15:07:37 <nirik> can't we fix the conflicts?
15:08:01 <contyk> I think fixing the conflicts and then having a default stream would be the way to go
15:08:05 <sgallagh> +1
15:08:12 <sgallagh> (To fixing the conflicts, for clarity)
15:09:15 <bookwar> we are past all deadlines
15:09:33 <bookwar> let's split it into 2 parts
15:09:35 <jforbes> Well, things are broken
15:09:43 <bookwar> 1) retire old eclipse
15:09:58 <bookwar> 2) enable default module if conflict is resolved
15:10:09 <bookwar> can we agree on 1) ?
15:10:11 <jforbes> We shouldn't have gotten into this point to begin with, but now that we are here, deadlines don't mean we ship broken
15:10:20 <jforbes> I agree on 1
15:10:25 <nirik> bookwar: I can agree with 1 for sure.
15:10:26 <jforbes> I actually agree on both
15:10:28 <zbyszek> bookwar: +1 on 1
15:10:39 <sgallagh> Just to be clear, there's another alternative that mhroncok suggested on devel@
15:10:49 <nirik> the question on 2 is if we block waiting for it to get fixed or not. ie, when does it need resolved by?
15:10:50 <bookwar> for 2) i'd like to see a deadline
15:10:58 <sgallagh> But I think it's far too invasive at this point for F31
15:11:13 <sgallagh> 2) Doesn't need to happen for GA
15:11:21 <sgallagh> We can *add* a default stream post-GA with no issues
15:11:59 <sgallagh> Well, I suppose you wouldn't be able to install it from media without pointing to updates repos, but that doesn't feel unreasonable to me
15:12:55 <sgallagh> Proposal: Drop the unmaintained eclipse from the non-modular repositories and ship module streams of eclipse. Whenever the conflicts are resolved later, we can make a default stream available.
15:13:07 <jforbes> sgallagh: +1
15:13:16 <bookwar> sgallagh: +1
15:13:18 <nirik> would we accept changes to fix this during freeze?
15:13:25 <nirik> +1
15:13:29 <jforbes> nirik: I think it is FE worthy
15:13:30 <sgallagh> nirik: Which part?
15:13:30 <zbyszek> sgallagh: is this different from bookwar's proposal?
15:13:44 <sgallagh> zbyszek: Not really, but I was aiming for clarity.
15:13:58 <zbyszek> OK, +1
15:14:00 <contyk> it's more specific
15:14:03 <contyk> sgallagh: +1
15:14:17 <jforbes> bookwar's proposal implied that it wouldn't go into default during the F31 cycle. sgallagh clarified that it can go in when it is ready
15:14:30 <nirik> sgallagh: I agree to all of it, but just wanted to know if we would accept FE's to fix it before we turn off branched composes... but I guess we can let the normal process decide that
15:14:30 <bookwar> retirement part is urgent, who does it?
15:15:18 <sgallagh> nirik: I'd be willing to go on record treating this as a FESCo blocker, honestly.
15:15:23 <zbyszek> bookwar: I'll add stuff to fedora-obsolete-packages
15:15:42 <zbyszek> #agree Drop the unmaintained eclipse from the non-modular repositories and ship module streams of  eclipse. Whenever the conflicts are resolved later, we can make a default stream available.
15:15:47 <zbyszek> #undo
15:15:47 <zodbot> Removing item from minutes: AGREED by zbyszek at 15:15:42 : Drop the unmaintained eclipse from the non-modular repositories and ship module streams of  eclipse. Whenever the conflicts are resolved later, we can make a default stream available.
15:15:50 <nirik> I'm not sure... I'd like it fixed for sure...
15:15:58 <nirik> but if it was the last thing...
15:15:59 <zbyszek> #agree Drop the unmaintained eclipse from the non-modular repositories and ship module streams of  eclipse. Whenever the conflicts are resolved later, we can make a default stream available (+6, 0, 0)
15:16:21 <zbyszek> #action zbyszek to add eclipse to fedora-obsolet-packages
15:16:37 <zbyszek> Any volunteers to do the retirement? mbooth?
15:17:34 <mbooth> zbyszek: Sure, I can probably organise it. I don't remember if I am "main admin", but I sure am "defacto main admin"
15:17:55 <zbyszek> #action mbooth to drive the retirement of non-modular eclipse.
15:17:57 <nirik> mbooth: if you run into any perms issues ping me.
15:18:08 <mbooth> nirik: Will do thanks
15:18:10 <bookwar> sgallagh: is it fesco blocker as in "ignore feature freeze", or fesco blocker as "postpone release" ?
15:18:41 <nirik> block release
15:18:53 <mbooth> bookwar: sgallagh: I proposed it ad blocker, but feel free to switch to freeze exception if that is more appropriate
15:18:58 <sgallagh> bookwar: block release. But I'm only weakly there.
15:19:14 <jforbes> I would say FE for sure, on the fence about blocker status
15:19:14 <sgallagh> We should vote formally, at least
15:19:35 <zbyszek> sgallagh: can you make a proposal
15:19:36 <sgallagh> Proposal: Treat resolving the eclipse issue as a blocker
15:19:41 <sgallagh> I can
15:19:46 <zbyszek> thanks ;)
15:20:15 <contyk> what criterion is it breaking, btw?
15:20:18 <nirik> weak -1 I guess... I just don't think it's serious enough to block and we can fix it after go...
15:20:21 <sgallagh> As I said, I'm weakly +1 here (and the set of things that need to be done is fairly small)
15:20:24 <sgallagh> ok
15:20:36 <sgallagh> contyk: It's not, that's why FESCo is ruling, not the regular process.
15:20:52 <contyk> okay
15:20:55 <zbyszek> Yeah, I'm +0 too. Seems easy enough but not very serious.
15:20:57 <contyk> weak -1
15:21:13 <sgallagh> OK, that's sufficiently negative that it cannot pass, so let's move on.
15:21:25 <sgallagh> I think we clearly have the votes for FE at least
15:21:26 <jforbes> Yeah, I think I am -1 to blocker, though I would really like to see it fixed in time with an FE
15:22:03 <zbyszek> Proposal: Treat the eclipse not-being-installable issue as a freeze exception
15:22:13 <bookwar> +1
15:22:14 <jforbes> zbyszek: +1
15:22:15 <sgallagh> +1
15:22:31 <nirik> well, we can let the normal blocker meeting handle that?
15:22:42 <nirik> and/or vote in bug?
15:23:21 <zbyszek> nirik: wouldn't it be faster to just approve it here?
15:23:40 <zbyszek> Since we have a bunch of people who seem to agree that a FE is appropriate.
15:24:01 <nirik> sure I guess... just seems like it's missing all the qa folks and others who normally vote on em...
15:24:42 <nirik> anyhow, +1 FE from me too
15:25:08 <zbyszek> contyk?
15:25:16 <contyk> +1 to FE
15:25:40 <zbyszek> #agree The bug about eclipse not being installable is approved as FESCo FE (+6, 0, 0)
15:25:46 <zbyszek> #topic Next week's chair
15:26:00 <zbyszek> I can do it again, this one wasn't much of an effort.
15:26:01 <sgallagh> I will not be here next week
15:26:29 <zbyszek> #action zbyszek will chair next meeting
15:26:37 <zbyszek> #topic Open Floor
15:26:37 <sgallagh> Thanks, zbyszek
15:26:37 <jforbes> I will be out next week as well
15:26:44 <nirik> I have one quick item...
15:26:50 <zbyszek> The floor is yours
15:27:39 <nirik> releng has https://pagure.io/pungi-fedora/pull-request/767 pending... which is to enable a ppc64le version of live workstation in f31.
15:27:48 <nirik> we already enabled it in f32 I think
15:27:53 <nirik> but there's no change for it.
15:27:56 <nirik> (that I know of)
15:28:07 <nirik> on the other hand, it's just a new arch for an existing thing.
15:28:22 <nirik> should we enable f31? ask for a change? enable/disable f32?
15:29:18 <sgallagh> I'd ask for a Change for F32 and enable the arch in F31 with no fanfare.
15:29:29 <sgallagh> Rephrased as a proposal:
15:29:31 <mboddu> For f32, there was a change which was approved but not for f31
15:29:45 <nirik> mboddu: oh? must have missed the f32 one...
15:29:48 <sgallagh> Actually, one question
15:30:11 <sgallagh> Approving this would probably imply adding work on the websites team to link it, yes?
15:30:11 <jforbes> So F31 is a "tech preview"?
15:30:26 <zbyszek> That doesn't seem to make sense to me. If it is merged for F31, then let's advertise with a change page.
15:30:56 <nirik> sgallagh: if there were such a team... and I think a lot of getfedora is pretty automated now, so I am not sure if it would just pick it up or not...
15:30:59 <zbyszek> If necessary, have the chagne page say "F31 is tech preview, F32 will be the real thing."
15:31:37 <zbyszek> Hmm, there was some proposal to add another variant like this (for arm64?), but I can't find it.
15:31:49 <mboddu> sgallagh: Also, QA needs to be notified, since its a new delivery even though not release blocking
15:31:59 <sgallagh> OK, I'm going to switch to:
15:32:09 <sgallagh> Proposal: It's too late for F31
15:32:45 <nirik> I can't find the f32 change off hand. ;(
15:33:20 <mboddu> I remember seeing it somewhere
15:33:22 * mboddu digs
15:33:34 <nirik> sgallagh: +1.
15:33:45 <jforbes> sgallagh: +1
15:33:59 <zbyszek> .bug 1733673
15:34:01 <zodbot> zbyszek: 1733673 – [Feature Request] Add Desktop LiveCD images for ppc64le systems - https://bugzilla.redhat.com/1733673
15:34:44 <zbyszek> sgallagh: +1, though it is a bit sad to slip
15:35:00 <zbyszek> But we're at a freeze now, so it doesn't seem to be the time to add another deliverable.
15:35:41 <zbyszek> bookwar, contyk?
15:36:06 <bookwar> +1
15:36:10 <mboddu> zbyszek: Freeze starts tomorrow, but yeah, its close
15:36:11 <contyk> I abstain
15:36:50 <zbyszek> #agree Adding ppc64le desktop variant is rejected (+5, 1, 0)
15:37:06 <zbyszek> OK, anything else?
15:37:34 <zbyszek> If not, I'll close in a minute.
15:38:55 <zbyszek> Thanks all.
15:38:57 <zbyszek> #endmeeting