15:00:09 <zbyszek> #startmeeting FESCO (2019-10-14)
15:00:09 <zodbot> Meeting started Mon Oct 14 15:00:09 2019 UTC.
15:00:09 <zodbot> This meeting is logged and archived in a public location.
15:00:09 <zodbot> The chair is zbyszek. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:00:09 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
15:00:09 <zodbot> The meeting name has been set to 'fesco_(2019-10-14)'
15:00:09 <zbyszek> #meetingname fesco
15:00:09 <zodbot> The meeting name has been set to 'fesco'
15:00:09 <zbyszek> #chair nirik, ignatenkobrain, jforbes, zbyszek, bookwar, sgallagh, contyk, mhroncok, otaylor
15:00:10 <zodbot> Current chairs: bookwar contyk ignatenkobrain jforbes mhroncok nirik otaylor sgallagh zbyszek
15:00:12 <zbyszek> #topic init process
15:00:15 <mhroncok> hey
15:00:17 <contyk> .hello psabata
15:00:18 <zodbot> contyk: psabata 'Petr Šabata' <psabata@redhat.com>
15:00:24 <zbyszek> .hello2
15:00:25 <zodbot> zbyszek: zbyszek 'Zbigniew Jędrzejewski-Szmek' <zbyszek@in.waw.pl>
15:00:27 <nirik> .hello kevin
15:00:28 <zodbot> nirik: kevin 'Kevin Fenzi' <kevin@scrye.com>
15:00:54 <zbyszek> That's 4...
15:05:23 <zbyszek> So.. we have no quorum.
15:05:40 <zbyszek> #info Meeting is cancelled because of lack of quorum.
15:05:42 <zbyszek> #topic Next week's chair
15:05:52 <zbyszek> #action zbyszek will chair next meeting
15:06:00 <zbyszek> #topic Reminder: please vote in open tickets.
15:06:00 <zbyszek> .fesco 2242
15:06:00 <zbyszek> .fesco 2243
15:06:00 <zbyszek> .fesco 2244
15:06:00 <zbyszek> .fesco 2245
15:06:00 <nirik> bummer. :(
15:06:01 <zodbot> zbyszek: Issue #2242: Nonresponsive maintainer: Benjamin Pereto bpereto - fesco - Pagure.io - https://pagure.io/fesco/issue/2242
15:06:04 <zodbot> zbyszek: Issue #2243: Python 2 exception for mercurial (runtime and buildtime) - fesco - Pagure.io - https://pagure.io/fesco/issue/2243
15:06:07 <zodbot> zbyszek: Issue #2244: Update the FTBFS policy - fesco - Pagure.io - https://pagure.io/fesco/issue/2244
15:06:10 <zodbot> zbyszek: Issue #2245: F32 System-Wide Change: Binutils 2.33 - fesco - Pagure.io - https://pagure.io/fesco/issue/2245
15:06:17 <zbyszek> .fesco 2241
15:06:18 <zodbot> zbyszek: Issue #2241: F32 Self-Contained Change: Better Thermal Management for the Workstation - fesco - Pagure.io - https://pagure.io/fesco/issue/2241
15:06:21 <zbyszek> .fesco 2246
15:06:22 <zodbot> zbyszek: Issue #2246: Create a rule to get newly Fedora branched composes sooner - fesco - Pagure.io - https://pagure.io/fesco/issue/2246
15:06:27 <zbyszek> #topic Open Floor
15:06:42 <zbyszek> We could always discuss ongoing issues.
15:07:06 <mhroncok> I'd like to talk about https://bugzilla.redhat.com/show_bug.cgi?id=1747408
15:07:13 <zbyszek> Oh, me too.
15:07:20 <mhroncok> AFAIK We've voted that FESCo approves the workaround
15:07:47 * mhroncok doesn't agree the current thing is gonna be it. nobody seems to care
15:08:12 <nirik> it looks like dnf folks didn't get the message that that wasn't going to be a acceptable solution
15:08:59 <zbyszek> Yep.
15:09:06 <mhroncok> should I open a FESCo ticket to vote for "reset libgit2 exa bat" as aworkaround?
15:09:47 <zbyszek> Do you have a link to the previous discussion in fesco?
15:10:55 <mhroncok> https://pagure.io/fesco/issue/2230
15:11:01 <mhroncok> https://pagure.io/fesco/issue/2230#comment-599678
15:11:44 <zbyszek> So... the proposed solution actually satisifies the minimum state there.
15:11:59 <mhroncok> https://meetbot.fedoraproject.org/fedora-meeting-1/2019-09-23/fesco.2019-09-23-15.00.log.html
15:12:05 <zbyszek> But we also said "we will vote on the proposed solution".
15:12:18 <mhroncok> zbyszek: "the proposed solution actually satisifies the minimum state there" is arguable
15:12:27 <mhroncok> that's why we added the vote requirement
15:13:19 <zbyszek> Pfff, I screwed up the "pending announcement query".
15:13:46 <zbyszek> I filtered out closed bugs, and now I'm not sure if they were announced or not.
15:13:59 <zbyszek> I'll try to fix it in the summary email.
15:14:30 <zbyszek> mhroncok: so maybe let's just reopen #2230 and vote there?
15:14:39 <nirik> I wonder if we could have some kind of 'preupgrade command/script' in dnf that is part of fedora-release or the like that would do these kinds of things...
15:15:04 <zbyszek> nirik: that has been attempted before
15:15:18 <zbyszek> I don't think we want this.
15:15:37 <zbyszek> Issues like this one should be exceptional.
15:16:03 <nirik> well, I think the reluctance in dnf is that adding a hacky thing like this is not something they want to do, they want some more generic thing...
15:16:03 <zbyszek> We put a lot of effort in making the upgrade path seamless, and any issues should be solved in individual packages.
15:16:28 <nirik> well, we have had a lot of things in the past... like usr-move... had a bunch of special case in anaconda
15:16:38 <zbyszek> But even if we push this out to fedora-release, then dnf will
15:16:39 <contyk> it happens from time to time
15:16:55 <zbyszek> have to do the callout, and the callout will call back to dnf.
15:17:18 <zbyszek> Yeah, and in each case the mechanism needs to be different.
15:17:26 <mhroncok> I understand the desire of a general solution
15:17:56 <mhroncok> but a properly documented temporary hacks are sometimes unavoidable
15:18:22 <zbyszek> We are badly pressed for time, and we only need this once...
15:19:01 <nirik> yeah, but they will have to maintain it until f30 goes eol at least... ;(
15:19:06 <zbyszek> But if dnf folks would be willing to provide a more general solution, then that'd be OK too of course.
15:19:34 <nirik> I suspect there's really not time right now, but... we need something.
15:20:14 <zbyszek> Proposal: reopen 2230 and vote there if https://bugzilla.redhat.com/show_bug.cgi?id=1747408#c67 is a sufficient solution.
15:20:28 <mhroncok> works for me
15:20:44 <nirik> sure.
15:21:28 <zbyszek> OK, anything else?
15:21:33 <nirik> if anyone has time for a PR/patch to do the module resets that might be nice...
15:22:01 <mhroncok> I'm not doing that if they are not willing to take it
15:22:31 <zbyszek> It's not so simple, because one has to understand dnf internals pretty well to figure out the least-bad spot to do the call.
15:23:05 <zbyszek> I'll close in 1 minute.
15:23:18 <nirik> well, I think the alternative is a more generic script call or something, but I think that will take a lot more work...
15:23:58 <zbyszek> Yeah, esp. that the script might need to signal failure or negative reply from the user.
15:24:12 * nirik nods
15:25:05 <zbyszek> Thank you all. See you next week, hopefully in a bigger crowd.
15:25:07 <zbyszek> #endmeeting