15:00:03 <dcantrell> #startmeeting FESCO (2020-01-20)
15:00:03 <zodbot> Meeting started Mon Jan 20 15:00:03 2020 UTC.
15:00:03 <zodbot> This meeting is logged and archived in a public location.
15:00:03 <zodbot> The chair is dcantrell. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:00:03 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
15:00:03 <zodbot> The meeting name has been set to 'fesco_(2020-01-20)'
15:00:03 <dcantrell> #meetingname fesco
15:00:03 <zodbot> The meeting name has been set to 'fesco'
15:00:03 <dcantrell> #chair dcantrell
15:00:03 <zodbot> Current chairs: dcantrell
15:00:27 <dcantrell> #topic init process.hello dcantrel
15:00:41 <dcantrell> .hello dcantrel
15:00:42 <zodbot> dcantrell: dcantrel 'David Cantrell' <dcantrell@redhat.com>
15:00:43 <decathorpe> .hello2
15:00:45 <zodbot> decathorpe: decathorpe 'Fabio Valentini' <decathorpe@gmail.com>
15:00:50 <dcantrell> #topic init process
15:00:52 <contyk> .hello psabata
15:00:53 <zodbot> contyk: psabata 'Petr Šabata' <psabata@redhat.com>
15:00:59 <sgallagh> .hello2
15:01:00 <zodbot> sgallagh: sgallagh 'Stephen Gallagher' <sgallagh@redhat.com>
15:01:09 <mhroncok> .hello churchyard
15:01:10 <zodbot> mhroncok: churchyard 'Miro Hrončok' <mhroncok@redhat.com>
15:01:34 <sgallagh> I’m typing on a phone from a train which will be arriving in about 10 minutes, so I apologize if I’m slow to respond.
15:01:57 <contyk> Welcome to Brno.
15:02:02 <nirik> morning
15:02:09 <dcantrell> well, I don't know how to change the topic
15:02:15 <dcantrell> but it looks like we have enough people for the meeting
15:02:24 <dcantrell> #topic #2320 https://pagure.io/fesco/issue/2320 F32 System-Wide Change\
15:02:27 <dcantrell> : Enable EarlyOOM
15:02:29 <dcantrell> damn it
15:02:36 <contyk> :))
15:02:38 <dcantrell> this window manager is killing me
15:02:43 <dcantrell> hang on
15:03:01 <dcantrell> #topic #2320 https://pagure.io/fesco/issue/2320 F32 System-Wide Change: Enable EarlyOOM
15:03:10 <dcantrell> better?
15:03:18 <mhroncok> better
15:03:22 <dcantrell> sorry about that
15:03:40 <nirik> I'm +1 if the workstation working group wants to enable it there, but don't think we should enable it globally.
15:04:12 <sgallagh> This is enabled by a systemd preset, right?
15:04:51 <dcantrell> not sure, sounds right.  the devel list thread had discussion of other approaches to OOM killers
15:04:54 <dcantrell> such as oomd
15:04:57 <decathorpe> dcantrell: you can use #undo for that :)
15:05:10 <dcantrell> (hey, I learn something new in irc every day)
15:05:29 <sgallagh> Proposal: FESCo will permit Edition and Spin maintainers to enable EarlyOOM at their discretion but will not make it the default for all Fedora at this time.
15:05:53 <mhroncok> sgallagh: +1
15:05:53 <nirik> yeah, I am pretty sure it would be a preset.
15:05:55 <dcantrell> personally, I am a -1 on enabling this as a default for any edition
15:05:56 <contyk> +0
15:06:16 <decathorpe> sgallagh 's Proposal: +1
15:06:19 <contyk> I'd rather not see it enabled by default anywhere but meh.
15:06:20 <decathorpe> Change: -0
15:06:43 <nirik> sgallagh: +1
15:06:45 <sgallagh> contyk: if you feel that way, vote against.
15:06:49 <mhroncok> I personally think that we should just wait, but if the worksation maintainers want it, they shall have it
15:07:22 <contyk> sgallagh: It's not a very strong feeling :)
15:07:41 <dcantrell> I just feel like it's papering over the real problem.  A patch for the symptom.
15:08:27 <nirik> so, we could also punt...
15:08:42 <nirik> I note that the workstation working group is talking about this again tomorrow in their meeting? I think?
15:09:01 <nirik> https://lists.fedoraproject.org/archives/list/desktop@lists.fedoraproject.org/message/UZUCUJLV3AZREWJYF77JHEVUY6DWPAP6/
15:09:47 <mhroncok> in that case, it makes sense to punt
15:10:08 <sgallagh> Papering over a problem is a time-tested way of solving things in software :-)
15:10:37 <mhroncok> and if it isn't working, just add more paper
15:10:40 <dcantrell> in the case of Firefox, it's certainly easier than finding where it leaks memory
15:11:16 <sgallagh> “Everywhere” isn’t a sufficient answer? *ducks*
15:11:57 <dcantrell> I just think it's bad form to automate our workaround for a real problem.  That's not actually doing anything and likely to cause more issues.  But that's just me.
15:11:58 <dcantrell> So move this to next week?
15:12:09 <sgallagh> Is waiting for the Workstation WG to meet tomorrow fundamentally different from my proposal?
15:12:30 <sgallagh> Other than delaying the decision process
15:12:36 <contyk> Regarding next week, how many people will be around?
15:12:40 * nirik is fine approving sgallagh's or waiting
15:12:46 <sgallagh> (And by extension, potential testing time)
15:13:03 <sgallagh> I will not be. I’ll be flying home after DevConf
15:13:06 <dcantrell> sgallagh: if we're talking about early oom killers, how much testing do we actually do?  :)
15:13:32 * nirik will not be around for next weeks meeting. will be doing other meetings in brno
15:13:42 <dcantrell> based on the discussion, sgallagh's proposal looks like it has votes.  we can vote now
15:13:45 <dcantrell> on that proposal
15:14:11 <mhroncok> +1 for sgallagh's proposal FTR
15:14:16 <decathorpe> +1 as well
15:14:31 <dcantrell> I forgot a line from this template, let's see
15:14:34 <dcantrell> .fesco 2320
15:14:35 <zodbot> dcantrell: Issue #2320: F32 System-Wide Change: Enable EarlyOOM - fesco - Pagure.io - https://pagure.io/fesco/issue/2320
15:15:07 <mhroncok> that line justs makes zodbot post the link and title
15:15:17 <dcantrell> I'm learning!
15:15:39 <nirik> +1 to sgallagh's proposal
15:16:00 <dcantrell> I'm still a -1
15:16:26 <mhroncok> contyk: still 0?
15:16:28 <dcantrell> contyk?
15:16:30 <contyk> Still.
15:17:13 <dcantrell> ok, so (+3, 0, -1)   did I count everything
15:17:21 <mhroncok> +3, 1, -1
15:17:25 <dcantrell> whoops
15:18:02 <mhroncok> A majority of the committee (that is, five out of nine) is required to pass a proposal in a meeting.
15:18:24 <mhroncok> so we punt anyway, unless there is another proposal
15:18:37 <dcantrell> a majority voting?
15:18:46 <dcantrell> or majority +?
15:19:15 <mhroncok> I read that as majority +
15:19:37 <dcantrell> ah, I read it the other way.  a majority voting.
15:19:51 <dcantrell> is everyone ok punting on this for more people in the discussion?
15:20:03 <mhroncok> ack
15:20:10 <decathorpe> yeah
15:20:14 <contyk> Ack.
15:20:22 <dcantrell> alright, next question is what is that for the agree decision command here?  PUNT?
15:21:09 <mhroncok> dcantrell: (I recommend you put your -1 in the ticket to avoid autoapproval with one +1 in 4 days)
15:21:17 <dcantrell> ok, I will do that
15:21:24 <mhroncok> dcantrell: you can just #info We agreed to punt ...
15:21:51 <dcantrell> #info We agreed to punt 2320 to a future meeting and for more discussion
15:22:07 <dcantrell> #topic Next week's chair
15:22:17 <dcantrell> but do we want to have the meeting next week?
15:22:29 <dcantrell> I am ok with scheduling it and trying
15:22:35 <dcantrell> but we might not get a lot of people
15:22:44 <mhroncok> proposal
15:22:50 <contyk> I think many people will be traveling or be otherwise busy
15:22:53 <mhroncok> next FESCo meeting is in 14 days
15:22:58 <contyk> mhroncok: +1
15:23:03 <dcantrell> mhroncok: +1
15:23:13 <mhroncok> that is 2020-02-03 IIRC
15:23:28 <contyk> ...which I will not attend due to travel.
15:23:36 <contyk> But better than next week.
15:24:08 <dcantrell> anyone else opposed?
15:24:45 <decathorpe> nope
15:24:47 <decathorpe> next chair?
15:24:52 <decathorpe> I volunteer
15:24:57 <dcantrell> (I am taking silence here as agreement)
15:25:01 <dcantrell> ah, good, my next question
15:25:14 <dcantrell> decathorpe chair next meeting: +1
15:25:46 * dcantrell hears crickets
15:26:24 <mhroncok> technically, we cannot cancel the next meeting without +5, right?
15:26:52 <dcantrell> don't know
15:26:57 <mhroncok> don't knwo either
15:27:05 <contyk> Let's vote on whether we can cancel it with fewer votes.
15:27:11 <mhroncok> contyk: :D
15:27:13 <contyk> Requiring +5.
15:27:24 <dcantrell> contyk: file that as a proposal and we can vote in a meeting
15:27:42 <nirik> I'm fine canceling next week. I won't be around.
15:27:47 <contyk> I'd say we can cancel it anyway, for practical reasons.
15:28:06 <contyk> Or not but it's more or less sure we won't have quorum.
15:28:21 <mhroncok> ok, I suppose we can #info the decision and if any other fesco member feels betrayed by that, hey can send flowers
15:28:48 <dcantrell> that sounds reasonable, but it's probably also us voting on a policy for that
15:28:52 <dcantrell> at the next meeting
15:29:34 <dcantrell> #info next FESCo meeting scheduled for 2020-02-03 1500 UTC
15:29:54 <mhroncok> dcantrell: and decathorpe will chair it
15:30:06 <dcantrell> #action decathorpe will chair next meeting
15:30:21 <dcantrell> #topic Open Floor
15:30:25 <mhroncok> I get nothing
15:30:35 <contyk> Me neither.
15:31:04 <dcantrell> I want to know how fast sgallagh's train is moving
15:31:06 <dcantrell> and from where
15:31:28 <mhroncok> I suppose sgallagh has left the train
15:31:42 <sgallagh> Or the train has left sgallagh
15:32:03 <mhroncok> right, or both
15:32:05 <dcantrell> the only other thing I have now is a random point of trivia...it is currently colder in Boston than at McMurdo Station in Antarctica right now
15:32:09 <sgallagh> 🤔
15:32:30 <sgallagh> I’m in Brno now.
15:32:37 <dcantrell> (and that will likely change, but still, kinda fun)
15:32:49 <dcantrell> ok, thanks everyone.  enjoy Brno if you're there, enjoy elsewhere if you're there
15:32:54 <sgallagh> ... questioning my life choices
15:33:20 <dcantrell> #endmeeting