#fedora-meeting-1: FESCO (2020-02-24)
Meeting started by contyk at 15:00:04 UTC
(full logs).
Meeting summary
- init process (contyk, 15:00:10)
- #2341 maven and ant: sfl4j-jdk14 filtered (ticket includes proposal to ban default modular streams) (contyk, 15:01:53)
- https://pagure.io/fesco/issue/2341#comment-627466
(nirik,
15:03:42)
- AGREED: For Fedora 32
and onward, all default modular streams are banned. Existing
defaults are removed. (+8, 0, -0) (contyk,
15:25:24)
- #2339 Proposal to change ARM Release Blocking Criteria - Drop XFCE (32bit), Add Workstation(64bit) (contyk, 15:26:14)
- No change in last week's FESCo decision, the
ticket can be closed. (contyk,
15:27:52)
- #2328 F32 Self-Contained Change: Additional buildroot to test x86-64 micro-architecture update (contyk, 15:28:11)
- AGREED: Provided
releng agrees, the change proposal is approved. (+7, 0, -0)
(contyk,
15:52:12)
- #2342 F32 incomplete Changes (contyk, 15:52:40)
- https://pagure.io/fedora-infrastructure/issue/7677
(nirik,
16:01:43)
- DNF Better Counting: Non-blocking, client-side
done, let's give the server-side part more time. (contyk,
16:02:59)
- https://koji.fedoraproject.org/koji/buildinfo?buildID=1469799
(mhroncok,
16:05:02)
- Free Pascal Compiler 3.20: Appears to be done,
bug status should be updated. (contyk,
16:05:03)
- LLVM 10: Appears to be done, bug status should
be updated. (contyk,
16:06:02)
- https://src.fedoraproject.org/rpms/clang/blob/master/f/clang.spec
has -DBUILD_SHARED_LIBS=OFF, not yet sure if built or just committed
(mhroncok,
16:07:45)
- Restart services at end of rpm transaction:
Status unclear; if no action is taken before the deadline, let's
move this to F33. (contyk,
16:16:40)
- Stop shipping individual component libraries in
clang-libs package: Appears to be done, bug status should be
updated. (contyk,
16:18:28)
- Use update-alternatives for /usr/bin/cc and
/usr/bin/c++: Moved to F33, any changes should be reverted.
(contyk,
16:20:28)
- https://bodhi.fedoraproject.org/updates/FEDORA-2020-b0652e4f4b
(2 hours ago ;) (nirik,
16:22:08)
- Haskell package to Stackage LTS 14:
Done. (contyk,
16:22:12)
- Ship BerkeleyDB backend as a module: Moved to
F33. (contyk,
16:23:03)
- Limit scriptlet usage of core packages: An
ongoing change, status unknown. No action needed. (contyk,
16:25:18)
- #2343 Proposal: Block (stable release) bodhi updates when they fail dist.rpmdeplint (contyk, 16:25:36)
- AGREED: Close for
now; as soon as something is ready to enable, ask us again about
that specific thing (+6, 0, -0) (contyk,
16:42:31)
- #2340 Get a process established to remove branches (contyk, 16:42:44)
- https://pagure.io/fedora-infrastructure/issue/8390
(nirik,
16:47:40)
- AGREED: Branches
reachable from any other branch that are not used for building
anything can be removed (+6, 0, -0) (contyk,
16:51:52)
- #2344 Enable new fonts packaging guidelines in F31 (contyk, 16:52:19)
- FPC approval is sufficient in this case.
(contyk,
16:54:25)
- No explicit approval needed for backwards
compatible changes Close the ticket. (contyk,
16:59:56)
- Next week's chair (contyk, 17:00:08)
- ACTION: mhroncok will
chair the next meeting. (contyk,
17:01:29)
- Open Floor (contyk, 17:01:33)
- beta freeze/bodhi enablement is at 14UTC on
tuesday (2020-02-25). We moved it from 00:00, so 14 extra
hours... (contyk,
17:02:42)
Meeting ended at 17:03:13 UTC
(full logs).
Action items
- mhroncok will chair the next meeting.
Action items, by person
- mhroncok
- mhroncok will chair the next meeting.
People present (lines said)
- contyk (145)
- mhroncok (92)
- nirik (71)
- sgallagh (58)
- decathorpe (39)
- dcantrell (28)
- zodbot (24)
- bookwar (15)
- nim-nim (8)
- ignatenkobrain (5)
- tflink (4)
- smooge (3)
- zbyszek (0)
Generated by MeetBot 0.1.4.