#fedora-meeting-1: FESCO (2020-06-15)
Meeting started by contyk at 15:00:27 UTC
(full logs).
Meeting summary
- init process (contyk, 15:00:33)
- Welcome new FESCo members & Meeting time (contyk, 15:02:15)
- The new meeting time is Wednesday, 1400 UTC,
starting June 24. (contyk,
15:18:33)
- Council Engineering Representative (contyk, 15:21:17)
- https://docs.fedoraproject.org/en-US/fesco/Fedora_Council_Engineering_Rep/
(contyk,
15:21:33)
- contyk will step down from the Council
Engineering representative position; FESCo will process the
nominations in #2405 over the next week. (contyk,
15:24:20)
- #2400 F34 System-Wide Change: NSS CK_GCM_PARAMS change (contyk, 15:24:55)
- AGREED: FESCo asks
rrelyea to rephrase the request and add details about the expected
impact, particularly on rebuilds and revisit in a week (+8, 0,
-0) (contyk,
15:34:38)
- What is the scope of Modularity? (contyk, 15:35:03)
- AGREED: Modular-only
packages are not allowed and modular versions are only be allowed as
alternatives to non-modular packages. (+9, 0, -0) (contyk,
15:58:47)
- There is an exception to this rule: if the
package does not function in non-modular Fedora (with reasonable
amount of work), it is permitted to have it in module only. As an
example if non-modular Fedora has dnf 4, and there is module with
dnf 5, a package that only works with dnf 5 can remain modular only,
until dnf 5 is included in non-modular Fedora. For the time being,
such (contyk,
15:58:54)
- AGREED: Default
streams are not allowed in Fedora. This may be revised in the
future, especially if the functionality of default streams is
improved. (+9, 0, -0) (contyk,
16:00:26)
- AGREED: Encourage
compatibility packages rather than modules wherever reasonable
(e.g., libraries, language interpreters, …, and anything that can
benefit from parallel installability). (+9, 0, -0) (contyk,
16:02:07)
- AGREED: Make
*modular*.repo optional by splitting them into a separate package.
(+8, 1, -0) (contyk,
16:03:24)
- AGREED: Disable
*modular*.repo by default in new installations. (2, 0, -7)
(contyk,
16:04:58)
- Modular repo will remain enabled. (contyk,
16:05:05)
- AGREED: Defer to the
next meeting. Meanwhile sgallagh will work on improving policy for
those modules with feedback from FESCo members. (+9, 0, -0)
(contyk,
16:52:36)
- https://lists.fedoraproject.org/archives/list/devel@lists.fedoraproject.org/thread/EJD3V43ONMVE37DQO6RVQ5ZGN6PJXDBC/
is the case on fedora-devel today. (zbyszek,
16:52:38)
- Next week's chair (contyk, 16:52:56)
- ACTION: ignatenkobrain will chair the next meeting.
(contyk,
16:53:25)
- Open Floor (contyk, 16:53:32)
- https://docs.fedoraproject.org/en-US/fesco/
is not getting updated. (zbyszek,
16:55:06)
- https://pagure.io/fedora-infrastructure/issue/8964
(bcotton,
16:56:54)
Meeting ended at 16:59:24 UTC
(full logs).
Action items
- ignatenkobrain will chair the next meeting.
Action items, by person
- ignatenkobrain
- ignatenkobrain will chair the next meeting.
People present (lines said)
- mhroncok (153)
- sgallagh (120)
- contyk (107)
- zbyszek (70)
- nirik (57)
- King_InuYasha (54)
- ignatenkobrain (51)
- dcantrell (49)
- zodbot (34)
- cverna (30)
- decathorpe (28)
- bookwar (21)
- bcotton (9)
- Conan_Kudo (0)
- Eighth_Doctor (0)
- Sir_Gallantmon (0)
- Son_Goku (0)
- Pharaoh_Atem (0)
Generated by MeetBot 0.1.4.