14:01:00 <ignatenkobrain> #startmeeting FESCO (2020-07-22)
14:01:00 <zodbot> Meeting started Wed Jul 22 14:01:00 2020 UTC.
14:01:00 <zodbot> This meeting is logged and archived in a public location.
14:01:00 <zodbot> The chair is ignatenkobrain. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:01:00 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
14:01:00 <zodbot> The meeting name has been set to 'fesco_(2020-07-22)'
14:01:07 <ignatenkobrain> #meetingname fesco
14:01:07 <zodbot> The meeting name has been set to 'fesco'
14:01:13 <ignatenkobrain> #chair nirik, ignatenkobrain, decathorpe, zbyszek, sgallagh, mhroncok, dcantrell, cverna, Conan_Kudo, Pharaoh_Atem, Son_Goku, King_InuYasha, Sir_Gallantmon, Eighth_Doctor
14:01:13 <zodbot> Current chairs: Conan_Kudo Eighth_Doctor King_InuYasha Pharaoh_Atem Sir_Gallantmon Son_Goku cverna dcantrell decathorpe ignatenkobrain mhroncok nirik sgallagh zbyszek
14:01:13 <ignatenkobrain> #topic init process
14:01:16 <sgallagh> .hello2
14:01:17 <zodbot> sgallagh: sgallagh 'Stephen Gallagher' <sgallagh@redhat.com>
14:01:25 <King_InuYasha> .hello ngompa
14:01:26 <nirik> morning
14:01:26 <zodbot> King_InuYasha: ngompa 'Neal Gompa' <ngompa13@gmail.com>
14:01:27 <ignatenkobrain> dcantrel will not join us today and mhroncok / churchyard will possibly join us later if we stay long enough :)
14:01:29 <bcotton> .hello2
14:01:30 <zbyszek> .hello2
14:01:30 <zodbot> bcotton: bcotton 'Ben Cotton' <bcotton@redhat.com>
14:01:33 <zodbot> zbyszek: zbyszek 'Zbigniew Jędrzejewski-Szmek' <zbyszek@in.waw.pl>
14:01:53 <sgallagh> I'm juggling this meeting and dealing with a contractor at my house, so if I don't reply quickly on a vote, please ping me (I'll get the notification on my phone)
14:03:09 <decathorpe> .hello2
14:03:10 <zodbot> decathorpe: decathorpe 'Fabio Valentini' <decathorpe@gmail.com>
14:03:21 <decathorpe> sorry, Matrix went weird on my phone
14:04:02 <ignatenkobrain> ok, let's give Clement and Kevin few more minutes, we don't have much on the agenda today anyway :)
14:04:09 <ignatenkobrain> brb
14:04:11 <sgallagh> ignatenkobrain: nirik is here
14:04:16 <sgallagh> He said "morning" above
14:04:27 <King_InuYasha> just missing cverna
14:04:33 <nirik> I am
14:04:41 * nirik jumps up and down and waves hands
14:04:54 <King_InuYasha> nirik: he probably missed you due to lack of hello command
14:05:02 * pingou _ó/\o_ nirik
14:05:33 <nirik> .hello kevin
14:05:33 <zodbot> nirik: kevin 'Kevin Fenzi' <kevin@scrye.com>
14:05:35 <King_InuYasha> are pingou and nirik merging into pingonik?
14:05:36 <nirik> there happy?
14:05:37 <ignatenkobrain> oh, did not notice :0
14:05:51 <cverna> hello o/
14:06:06 <ignatenkobrain> #topic #2448 F33 Self-Contained Change: PostgreSQL 13
14:06:09 <ignatenkobrain> .fesco 2448
14:06:11 <zodbot> ignatenkobrain: Issue #2448: F33 Self-Contained Change: PostgreSQL 13 - fesco - Pagure.io - https://pagure.io/fesco/issue/2448
14:06:31 <King_InuYasha> so uhh, this change seems woefully underspecified?
14:06:40 <sgallagh> It's vacation season; I'm inclined to bump this out one more week before rejecting it.
14:06:45 <nirik> we need input from the change owners.
14:06:55 <nirik> sgallagh: +1
14:07:26 <King_InuYasha> I'm fine with that
14:07:35 <ignatenkobrain> sgallagh: +1
14:07:35 <cverna> sgallagh: +1
14:07:40 <King_InuYasha> sgallagh: +1
14:07:40 <decathorpe> +1
14:07:42 <bcotton> given the fire drill that postgresql 12 was, i'd like to see some assurance we won't repeat that
14:07:48 <King_InuYasha> indeed
14:07:57 <King_InuYasha> I missed all that because of my own fire drills that cycle :(
14:09:17 <ignatenkobrain> zbyszek: fine with deferring for the next week?
14:09:47 <zbyszek> sorry, I had a phone call
14:10:05 <zbyszek> Yeah, +1 to deffering. The contingency plan is inadequate right now.
14:10:27 <ignatenkobrain> #agree Give one more week for the change owners to respond (+7, 0, -0)
14:10:28 <zbyszek> (And it also sounds like waiting until F34 might be appropriate in any case).
14:10:35 <ignatenkobrain> #topic #2440 F33 System-Wide Change: Patches in Forge macros - Auto macros - Detached rpm changelogs
14:10:38 <ignatenkobrain> .fesco 2440
14:10:39 <zodbot> ignatenkobrain: Issue #2440: F33 System-Wide Change: Patches in Forge macros - Auto macros - Detached rpm changelogs - fesco - Pagure.io - https://pagure.io/fesco/issue/2440
14:10:44 <ignatenkobrain> this one is from the previous week
14:11:33 <King_InuYasha> :(
14:11:43 <ignatenkobrain> I'll keep my -1 on this
14:11:51 <zbyszek> I'm +1.
14:12:09 * nirik still hasn't really been able to sit down and figure this one out...
14:12:57 <King_InuYasha> I'm not happy with the flow being proposed as part of this change
14:13:10 <King_InuYasha> because these macros break mock and he has proposed no solution for that
14:13:18 <zbyszek> nirik: it may be summed up as: a bunch of helper lua code and an update to the forge macros and some additional new features on top of that.
14:13:20 <sgallagh> I really want to read up on this and make sure I understand it (I was on PTO last week). For right now, I'm 0.
14:13:38 <decathorpe> for now I am -1
14:13:46 <King_InuYasha> the detached changelog and the auto preamble stuff scare me, and for that alone I'm -1
14:13:50 <cverna> same I have really had time to look at it in depth
14:14:00 <decathorpe> the change owner is repeatedly unable to document anything which makes me sad
14:14:02 <cverna> have not*
14:14:03 <nirik> zbyszek: I think I am ok with the helper macros, but then there's things like detached changelogs...
14:14:05 <zbyszek> King_InuYasha: I think you must be thinking about the other ticket. This one is "just lua".
14:14:24 <King_InuYasha> zbyszek: maybe, I spent a few hours last weekend going over all of it, it's... a lot
14:14:35 <ignatenkobrain> zbyszek: no, it is also %auto_* framework with bunch of macro there
14:14:53 <ignatenkobrain> also it is about detached rpm changelogs
14:14:57 <ignatenkobrain> so it is not only about lua
14:14:58 <King_InuYasha> but it seemed like *this* change also intends to replace all the stages of a spec file with %auto_* macros
14:15:17 <ignatenkobrain> at least this is how title of the change is written
14:15:33 <decathorpe> it looks like creating another DSL on top of RPM .spec files
14:15:36 <King_InuYasha> the example in the change proposal also seems to confirm my recollection
14:15:46 <zbyszek> IIUC, it adds the infrastructure to do this, but it'll only be used by people who want to use it.
14:15:49 <King_InuYasha> https://fedoraproject.org/wiki/Changes/Patches_in_Forge_macros_-_Auto_macros_-_Detached_rpm_changelogs#Fully_automated_packaging
14:16:03 <King_InuYasha> zbyszek: one consequence of this change is that mock cannot produce SRPMs anymore
14:16:23 <zbyszek> King_InuYasha: hmm, are you sure? Where was this discussed?
14:16:23 <King_InuYasha> this is something nim has pointed out to us in Go SIG and devel@ when it was brought up
14:16:55 <King_InuYasha> nim says mock and Koji need to be changed to not produce a srpm from git before building the package on all arches
14:17:04 <King_InuYasha> this is, unfortunately, completely unacceptable
14:17:05 <zbyszek> King_InuYasha: that's the other change, not this one.
14:17:21 <King_InuYasha> are you sure?
14:17:36 <zbyszek> No.
14:17:44 <nirik> and thats not actually the case as I understand it... it can/does make a src.rpm, it's just wrong/different from the final src.rpm
14:18:23 <nirik> do we think another week will allow us to figure this out better? or not... ?
14:18:28 <King_InuYasha> I don't know
14:18:59 <ignatenkobrain> I don't think anything will change in one week
14:19:01 <King_InuYasha> I'm struggling to understand this, and I guess I'm just going to have to literally test it to see its behaviors, because it's very confusing
14:19:08 <decathorpe> It looks like it was a lot of work, but to me the approach looks ill-advised and I don't like it
14:19:09 <sgallagh> I'd really like for us not to vote -1 on the grounds that we don't understand it.
14:19:27 <sgallagh> If we're voting -1, let's make sure it's because we feel that it's *wrong*
14:19:43 <King_InuYasha> my grounds of saying it's wrong is the detached changelog stuff
14:19:52 <decathorpe> King_Inuyasha: well that is really the problem, that none of us really understand what's going on
14:19:55 <King_InuYasha> and I don't think a programmatically generated preamble is a good idea
14:20:12 <sgallagh> King_InuYasha: What about the changelog is wrong?
14:20:39 <King_InuYasha> sgallagh: to *use* the detached changelog flow, you need to commit *before* and *after* the build manually
14:20:56 <nirik> thats not this change.
14:20:58 <King_InuYasha> this differs from pingou's rpmautospec model which handles the post-build part automatically and properly
14:21:04 <nirik> thats the auto bump related one
14:21:07 <King_InuYasha> ugh
14:21:15 <King_InuYasha> okay
14:21:19 <nirik> but they are confusingly intertwined
14:21:20 <zbyszek> King_InuYasha: I think that in some specific case, like for example very repetitive font packaging, an automatically generated premable could be OK. It probably is *not* what I would do with my package, but I think it's OK to allow people to experiment with stuff like that as long as it's opt-in.
14:21:23 <ignatenkobrain> my -1 is based on the fact that upstream is working on better (proper) generation of the spec files based on the content. also based on the fact that change owners do not try work with upstream RPM, but rather work it around. I am very scared that once we allow this to go in, we will be stuck maintaining this forever ourselves.
14:21:58 <King_InuYasha> zbyszek: I'm comfortable with changing my vote to +0 for this, but I am not hot on the idea enough to do +1
14:22:14 <King_InuYasha> so for now, my -1 is now +0
14:22:44 <cverna> Igor Raits:  I think you have fair concerns
14:23:35 <cverna> the maintenance piece is a big part to consider
14:23:35 <zbyszek> So... the way I understand this is: it's a localized change, opt-in, and backwards compatible. If that's not the case, I'd like to be shown where exactly.
14:23:37 * nirik agrees
14:23:54 <King_InuYasha> and yeah, I think that the problems it is trying to solve are real, but I'd rather see rpm's efforts pushed forward to land those in Fedora
14:24:15 <King_InuYasha> ffesti, myself, and ignatenkobrain have been discussing this there for a while now
14:24:24 <King_InuYasha> and he does have a PR open for this
14:24:29 <King_InuYasha> err ffesti does
14:24:41 <nirik> zbyszek: well, it mentions "users of forge, fonts and go macros"
14:25:07 <King_InuYasha> the forge and go macros are broadly used, the fonts macros less so
14:25:23 <decathorpe> The way I remember it, this will require changes in most go and fonts packages
14:25:31 <King_InuYasha> yup
14:25:50 <decathorpe> particularly because some macros are renamed.
14:25:50 <zbyszek> FWIW, I don't think we should vote on this now. I'd like to get clarity on the various doubts that people have.
14:25:57 <King_InuYasha> iirc, this will also break all the go packages packaged the legacy way for compatibility for EPEL, too
14:26:16 <nirik> the change mentions a compatiblity layer...
14:26:20 <zbyszek> decathorpe: backwards compat was promised and seems to be implemented in the PR.
14:26:26 <nirik> but of course someday that would be dropped
14:26:28 <sgallagh> zbyszek: Actually, I'm coming down on the side of "-1 now, repropose for F34 after answering questions"
14:26:45 <decathorpe> and who is going to adapt 1000s of packages?
14:27:11 * King_InuYasha is already struggling to do all the adapting for the cmake change...
14:27:12 <nirik> who will bell the cat indeed. ;)
14:28:05 <King_InuYasha> changes like these suck because they are the hardest to implement at scale
14:28:12 <King_InuYasha> so I really want a plan for how to deal with that
14:28:50 <sgallagh> I think this would benefit from another cycle to resolve these issues.
14:29:27 <decathorpe> give it some time to cook in a copr
14:29:28 <sgallagh> Proposal: Reject this Change for Fedora 33. Change Owners can repropose it for Fedora 34 after addressing FESCo concerns.
14:29:37 <King_InuYasha> sgallagh: +1
14:29:39 <ignatenkobrain> sgallagh: +1
14:29:40 <zbyszek> sgallagh: that seems rather unfair. The change is essentially implemented, but the description is unclear.
14:30:11 <zbyszek> We should work with the change owner to add those missing points, and not bump the change 6 months down the road because *we* don't have time.
14:30:35 <King_InuYasha> zbyszek: I'm open to that idea if the proposal can be made clearer
14:30:52 <sgallagh> zbyszek: What I'm hearing from multiple FESCo members is that the Change is not just unclear but badly-implemented.
14:30:54 <ignatenkobrain> zbyszek: from my experience in Packaging Committee, somebody like Fabio Valentini (decathorpe) will have to write description for this change :)
14:31:00 <decathorpe> zbyszek: I'm dreading that we'll just receive another wall of cryptic text
14:31:17 <King_InuYasha> right, someone would have to work specifically with nim on cleaning this up
14:31:46 <zbyszek> sgallagh: I don't think it's "badly-implemented". King_InuYasha had some issues, but they were addressing the other change ;)
14:31:59 <King_InuYasha> zbyszek: at this point, I'm just really confused what is what
14:32:01 * sgallagh sighs
14:32:12 <King_InuYasha> and the way nim has explained to me has further muddled everything
14:32:41 <decathorpe> I won't say it is implemented badly, but it is probably only maintainable by one person
14:32:44 <sgallagh> OK, if someone from FESCo wants to volunteer to work with nim to rephrase the Change Proposal so we can evaluate it fairly, let's defer a week
14:33:06 <sgallagh> If no one is willing to do so, my original proposal stands.
14:33:35 <zbyszek> What does "rephrase" mean? Is there a list of questions that people have?
14:34:19 <zbyszek> Because right now we're asking for changes without any specifics.
14:35:11 <decathorpe> I think one of the problems is that the change proposal describes what it does, but not how, and only points people to read the code if they want to know details
14:35:11 <King_InuYasha> I want to know 1) what it does 2) the impact 3) adoption effort required 4) backwards-compatibility guarantees (if any)
14:35:24 <decathorpe> and the FAQ section is ... frequently asked questions, by whom?
14:35:44 <sgallagh> decathorpe: Right, I think an architecture design document is what we need here.
14:36:11 <decathorpe> sgallagh: exactly
14:36:23 <mhroncok> hello
14:36:31 <mhroncok> sorry for the delay
14:36:40 <decathorpe> mhroncok: hello! o/
14:36:40 <sgallagh> Not just "What macros should I use?" but "What are they doing under the hood so I can tweak them and/or what other macros and patterns are incompatible?"
14:36:41 <zbyszek> proposal: ask @nim to clarify the proposal on those questions, revisit when we have the answers.
14:36:53 <King_InuYasha> zbyszek: +1
14:37:02 <decathorpe> zbyszek: +1
14:37:08 <sgallagh> zbyszek: +1
14:37:16 <cverna> +1
14:37:22 <nirik> +1
14:37:28 <mhroncok> +1
14:37:40 <sgallagh> My big problem with pushing a lot of work into a few macros is that I then have *no idea* what the side-effects are.
14:37:51 <zbyszek> Thanks!
14:38:28 <King_InuYasha> what I *don't* want is another confusing public relations disaster like what happened to modularity
14:38:30 * nirik is a bit worried about rpm re-implementing all this and then we have to change things twice
14:38:58 <sgallagh> Yeah, that too.
14:39:07 <sgallagh> RPM really feels like the better place for such things to happen.
14:39:23 <sgallagh> But RPM changes can also take the better part of a decade to land, so...
14:39:43 <King_InuYasha> https://github.com/rpm-software-management/rpm/pull/1239
14:39:46 * RaphGro thought RPM is dead :P
14:40:00 <sgallagh> .fire RaphGro
14:40:00 <zodbot> adamw fires RaphGro
14:40:01 <King_InuYasha> we've gotten a lot better now at adopting rpm features now that we don't run our koji builders on rhel
14:40:04 <mhroncok> sgallagh: lately, this has not been true
14:40:22 <RaphGro> .moar sugar zodbot
14:40:22 <zodbot> here zodbot, have some more sugar
14:40:49 <RaphGro> sgallagh++
14:40:49 <zodbot> RaphGro: Karma for sgallagh changed to 8 (for the current release cycle):  https://badges.fedoraproject.org/tags/cookie/any
14:41:01 <King_InuYasha> we've beated openSUSE to adopting many features, when historically they did them long before we did
14:41:10 <King_InuYasha> s/beated/beaten/
14:41:25 <King_InuYasha> so in that regard, I think we are doing very well
14:42:09 <sgallagh> OK, that's fair.
14:42:18 <sgallagh> My experiences may be a bit out of date
14:42:34 <sgallagh> (I guess the `Requires(meta)` stuff only took around 18 months.
14:42:51 <ignatenkobrain> sorry, I had to disappear for a while
14:43:22 <King_InuYasha> sgallagh: the problem is that rpm doesn't release often enough
14:43:31 <zbyszek> sgallagh: I think there's generall will to have rpm move faster from everyone involved, so I think there's hope.
14:43:37 <King_InuYasha> fedora used to be the bottleneck, and now rpm is
14:43:49 <King_InuYasha> that's a much nicer problem to have
14:44:08 <ignatenkobrain> #agree Ask @nim to clarify the proposal on those questions, revisit when we have the answers (+6, 1, -0)
14:44:20 <ignatenkobrain> #topic Next week's chair
14:44:52 <ignatenkobrain> any volunteers?
14:45:24 <King_InuYasha> I can't do next week (I'm on-call) but I could do the week after
14:45:39 <King_InuYasha> (on-call at $DAYJOB, that is)
14:45:53 <ignatenkobrain> #action ngompa will chair next meeting
14:46:04 <ignatenkobrain> #topic Open Floor
14:46:09 <decathorpe> 🤔
14:46:11 <zbyszek> ignatenkobrain: no, next week
14:46:12 <sgallagh> uh
14:46:12 <King_InuYasha> uhhh
14:46:26 <ignatenkobrain> #undo
14:46:26 <zodbot> Removing item from minutes: <MeetBot.items.Topic object at 0x7fb1b9cbcd50>
14:46:27 <ignatenkobrain> #undo
14:46:27 <zodbot> Removing item from minutes: ACTION by ignatenkobrain at 14:45:53 : ngompa will chair next meeting
14:46:30 <ignatenkobrain> can't read it :)
14:46:43 <decathorpe> I can do next week
14:46:55 <ignatenkobrain> #action decathorpe will chair next meeting
14:46:59 <ignatenkobrain> #topic Open Floor
14:47:04 <bcotton> o/
14:47:10 <King_InuYasha> how's everyone feeling about Fedora 33 so far? :)
14:48:04 <nirik> fun times. ;)
14:49:12 <King_InuYasha> it seems like this will be the biggest release we've ever done :D
14:49:24 <King_InuYasha> makes me wonder what Fedora 34 is going to look like
14:49:36 <decathorpe> uuuh
14:49:53 <zbyszek> I'm feeling good actually. Lot's of very good changes happnening.
14:49:54 <decathorpe> somebody take over my Java packages now plz? :)
14:49:54 <sgallagh> Yeah, I'm more than a little startled at the amount of stuff targeted at F33.
14:50:18 <King_InuYasha> I have some theories as to why, but that's all they are :)
14:50:25 <mhroncok> :D
14:51:16 <King_InuYasha> 35 system wide changes, 15 self-contained so far on the changeset page
14:52:03 <King_InuYasha> and I expect the list of changes approved to rise a bit over the next two weeks
14:52:20 <bcotton> speaking of changes...
14:52:46 <bcotton> You should expect a very late system-wide change to promote IoT to an Edition, but it's okay because the critical work has actually been done for a while
14:53:08 <decathorpe> Why is that System-Wide?
14:53:10 <bcotton> and the policy that would require it to be a system-wide change hasn't actually been approved by council yet
14:53:25 <decathorpe> ah.
14:53:43 <bcotton> because it has siginifcant impact across the distro (releng, marketing, design, etc etc)
14:54:06 <bcotton> the idea is that new spins are a self-contained change, but to be an Edition is a Big Deal[tm] so it requires a lot more that goes into it
14:54:39 <King_InuYasha> I kind of wish we dropped that distinction
14:54:39 <bcotton> and using the system-wide change process prevents us from having to invent a new process from scratch that woudl end up looking a lot like the system-wide change process anyway :-)
14:54:45 <King_InuYasha> haha
14:55:09 <King_InuYasha> I just had a conversation about how Fedora's terminology for flavors is extremely confusing
14:55:09 <bcotton> King_InuYasha: there's been some discussion of that. if nothing else, we need to drop the spin/lab distinction, but i think there's some merit in editions
14:55:30 <nirik> I kinda liked spins/labs, but whatever...
14:55:32 <sgallagh> King_InuYasha: The distinction is important, though. It differentiates the things that are "cool community contributions" from "Fedora Project Deliverables"
14:55:33 * bcotton could opine at length on this topic (which should surprise no one)
14:55:55 <King_InuYasha> sgallagh: in practice, they're *all* deliverables because of our release engineering process
14:55:59 <zbyszek> FWIW, I find the new "Solution" name very very confusing.
14:56:18 <sgallagh> I'll confess, I had trouble picking a word there. "Deliverable" was the closest I could think of.
14:56:42 <sgallagh> I can't say "Product" because Red Hat doesn't like that word in relation to Fedora :)
14:56:51 <zbyszek> What about "variant"?
14:57:07 <cmurf> sometimes they don't get delivered since the big distinction is they aren't all release blocking
14:57:18 <zbyszek> "Fedora Workstation is a variant of Fedora that is ... "
14:58:00 <cmurf> times like this when English is less than helpful :D
14:58:24 <King_InuYasha> we should just use flavors
14:58:36 <King_InuYasha> people seem to understand that well
14:58:50 <decathorpe> what about Colors? ;)
14:58:52 <King_InuYasha> :D
14:58:58 <cmurf> sounds like an idea for codenames
14:59:00 <decathorpe> (like, for, differently colored hats?)
14:59:01 * cmurf runs
14:59:09 <King_InuYasha> man, I miss codenames :'(
14:59:30 <cmurf> you know, i really didn't like them, and now i really miss them
14:59:37 <zbyszek> "flavors" are good too.
14:59:40 <decathorpe> Fedora Blue (KDE), Fedora Green (Cinnamon) ...
14:59:45 <King_InuYasha> :D
14:59:51 <King_InuYasha> Fedora Black (GNOME) :P
14:59:54 <sgallagh> decathorpe: That would be problematic with Silverblue
15:00:06 <zbyszek> Fedora shimmery (Silverblue)
15:00:07 <sgallagh> And also potentially with cultural issues.
15:00:12 <decathorpe> Silverblue is a terrible name tbh
15:00:31 <zbyszek> BTW, bcotton's presence reminds me: what about the fast-track process change?
15:00:37 <King_InuYasha> well, Kinoite is thankfully better :)
15:00:56 <zbyszek> We have a bunch of thumbsups on the PR and a few votes in the ticket. Can we consider it approved?
15:01:12 <ignatenkobrain> I have feeling that we should finish FESCo meeting and continue this discussion on #fedora-devel :)
15:01:24 <ignatenkobrain> and zbyszek beats me
15:01:36 <mhroncok> well if we can, we can vote abotu the fast track proposal here
15:01:39 <sgallagh> I hadn't read it yet. Just did so.
15:01:41 <sgallagh> +1
15:02:12 <ignatenkobrain> #topic #2445 Proposal: Make the "shortcut" decision process require a specific request and assent
15:02:15 <ignatenkobrain> .fesco 2445
15:02:16 <zodbot> ignatenkobrain: Issue #2445: Proposal: Make the "shortcut" decision process require a specific request and assent - fesco - Pagure.io - https://pagure.io/fesco/issue/2445
15:02:28 <ignatenkobrain> +1 from me
15:02:31 <zbyszek> +1
15:02:58 <ignatenkobrain> I think cverna and Conan_Kudo voted +1 too
15:03:02 <ignatenkobrain> and Fabio Valentini (decathorpe)
15:03:03 <cverna> +1 too
15:03:08 <mhroncok> +1
15:03:25 <King_InuYasha> +1
15:03:29 <decathorpe> yup
15:04:33 <ignatenkobrain> nirik: would like to vote?
15:05:35 <nirik> sorry, in another meeting.
15:05:37 <nirik> sure, +1
15:06:01 <ignatenkobrain> #agree APPROVED (+8, 0, -0), bcotton will squash commits
15:06:08 <bcotton> hooray!
15:06:10 <ignatenkobrain> #topic Open Floor
15:06:12 <ignatenkobrain> anything else?
15:06:33 <cverna> nothing from me
15:06:44 <King_InuYasha> Flock CFP closes on the 27th
15:06:49 <King_InuYasha> people should submit talks!
15:07:11 <King_InuYasha> https://pagure.io/flock
15:07:26 * decathorpe whisphers "Would you like to talk about Java?"
15:07:39 <ignatenkobrain> shall we do online FESCo session? :)
15:07:45 <sgallagh> We do not utter that language here.
15:07:47 <zbyszek> ignatenkobrain: +1
15:08:11 <King_InuYasha> ignatenkobrain: +1
15:08:15 <ignatenkobrain> Fabio Valentini (decathorpe): soon it will be about nodejs (according to my FTI bug list)
15:08:18 <cverna> +1
15:08:22 <decathorpe> yeah :(
15:08:30 <ignatenkobrain> #action ignatenkobrain to submit FESCo session for Flock
15:08:30 <King_InuYasha> at least Python seems fine this cycle
15:08:54 <mhroncok> King_InuYasha: you are welcome ;)
15:08:59 <ignatenkobrain> mhroncok: and the Python guys are handling it well :)
15:09:05 <King_InuYasha> mhroncok: indeed, thank you!
15:09:21 <mhroncok> :bow:
15:09:29 <ignatenkobrain> mhroncok++ pviktori++ torsava++ not sure who else is on Python team these days
15:09:29 <zodbot> ignatenkobrain: Karma for pviktori changed to 2 (for the current release cycle):  https://badges.fedoraproject.org/tags/cookie/any
15:09:33 <zodbot> ignatenkobrain: Karma for torsava changed to 2 (for the current release cycle):  https://badges.fedoraproject.org/tags/cookie/any
15:09:38 <King_InuYasha> so far, GCC guys haven't proposed anything world breaking for GCC 11, so I'm hoping F34 won't suck like F32 did
15:10:34 <King_InuYasha> but it's going to be less fun if we need to factor LLVM into mass rebuilds...
15:10:38 <bcotton> "so far" :-)
15:10:50 <mhroncok> ignatenkobrain: cstratak and lbalhar helped with 3.9 as well
15:11:08 <ignatenkobrain> cstratak++ lbalhar++
15:11:08 <zodbot> ignatenkobrain: Karma for cstratak changed to 2 (for the current release cycle):  https://badges.fedoraproject.org/tags/cookie/any
15:11:11 <zodbot> ignatenkobrain: Karma for lbalhar changed to 2 (for the current release cycle):  https://badges.fedoraproject.org/tags/cookie/any
15:11:33 * mhroncok says endmeeting
15:11:52 <ignatenkobrain> #endmeeting